Что Вам потребуется

 Top Next

1.Операционная система Windows 10.

Поддерживаются только 64-х разрядные версии операционных систем!

Обязательно убедитесь, что у Вас установлены все обновления ОС на текущий момент времени!

2.ПЭС «Гражданин Полиция»;

3.Набор программного обеспечения ПЦН «Гражданин Полиция» в составе:

·GOAL-коммутатор. Состоит из VAC (Virtual Audio Cable) и модулей GOALcity для связи с ним.

·IP GOAL.

·Видеоретранслятор

·Язык многофункциональной логики SL++

·3D Plan

·Энигма

·Архивный сервер

·IP аудио

·Программа для воспроизведения аудио файлов AIMP или похожий бесплатный аналог (если Вы будете использовать другую программу, то некоторые моменты настройки будут отличаться);

4.Динамики, подключенные к линейному выходу на задней панели корпуса компьютера либо микрофон + наушники, подключенные в гнездо микрофона и выхода звука на передней панели корпуса компьютера;

5.Обязательно убедитесь, что Вы используете свежие версии драйверов на все оборудование. Необходимо установить драйверы на звуковую карту от производителя, и ни в коем случае не использовать драйверы, поставляемые вместе с Windows. Ссылки на загрузку последних версий драйверов Вы всегда можете найти на нашем сайте технической поддержки.

tipbulb Подробнее о компонентах:

· Аудиоплеер Aimp

· Видеоподсистема

· Virtual Audio Cable


Virtual Audio Cable

 Top Previous Next

1.Установите Virtual Audio Cable следуя указаниям мастера установки.

2.Запустите настройку виртуальных звуковых карт (Пуск – Все программы – Virtual Audio Cable – Control Panel)

3.Перед Вами откроется окно настройки. По умолчанию программа создает одну виртуальную звуковую карту, нам же понадобятся две. Одна для загрузки звука в IP сервер и вторая для разделения звука оповещения и голоса абонента.

4.Нажмите кнопку «Set» и установите количество карт равное двум. Две виртуальные звуковые карты могут понадобиться в дальнейшем, если мы захотим разделить звуки оповещения диспетчера и голос абонента.

5.В аудио устройствах Windows появятся 2 виртуальные звуковые карты. Первую используется для передачи звука ожидания ответа через IP сервер в вызывную панель. Вторая - может понадобиться для разделения каналов звука при оповещении, т.е. чтобы звук оповещения о новом событии выводился на динамики, а голос абонента в наушники.

В Вашем случае, здесь могут присутствовать и другие звуковые устройства, но главное – чтобы присутствовали представленные выше. Остальные устройства можно отключить, они Вам не потребуются.

6.Далее необходимо разделить каналы звука с задней и передней панели. Это делается через диспетчер звуковых устройств, устанавливаемый вместе с драйверами звуковой карты.

Пример для аудио карт SoundMax

·Запустите диспетчер звуковых устройств двойным кликом по иконке в трее, либо Пуск – Все программы – SoundMax – Панель управления.

·Откроется окно настройки звуковых устройств. Перейдите на вкладку «Расширенные настройки» и поставьте птичку «Разделить звуковые каналы». Сохраните изменения.

Пример для аудио карт Realtek

·Запустите диспетчер звуковых устройств двойным кликом по иконке в трее, либо Пуск – Все программы – Realtek – Диспетчер звуковых устройств Realtek.

·Перейдите к дополнительным настройкам, кликом по ссылке в правом верхнем углу диспетчера звуковых устройств.

·Поставьте птичку в поле «Разделить все входные гнезда в качестве независимых входных устройств» и сохраните все изменения.

7.Зайдите в настройку аудио параметров, установите устройство записи «Микрофон» по умолчанию, уровень громкости – подберите на слух, все остальные источники записи – выключите.

8.В настройках устройств воспроизведения - главную громкость поставьте на 80%, прослушивание микрофона выключите (если предусмотрено). В ОС Windows 7 прослушка микрофона отключается на вкладке «Прослушивать» в свойствах микрофона.


Аудиоплеер Aimp

Установите программу следуя указаниям мастера установки.

Она необходима для воспроизведения музыкального файла ожидания ответа через виртуальную звуковую карту. Дистрибутив можно найти в свободном распространении в сети Интернет, либо на приложенном к системе DVD диске. После установки откройте настройки программы и выполните следующее:

Вкладка «Воспроизведение»

Выберите устройство «DirectSound: Line 1 (Virtual Audio Cable)». Т.е. плеер будет передавать звук на только что созданную виртуальную звуковую карту, и уже с нее будет передаваться звук в IP сервер через созданный нами в дальнейшем «Uploader-Sound» (см. Создание исходящего аудио канала).

Вкладка «Автоматика»

Отключите переход на следующий трек; при запуске программы начинать воспроизведение и сворачивать программу в трей, при окончании плейлиста повторять его, поставьте птичку "Повторять плейлист, если в нем один файл".

Вкладка "Плеер"

Отключите показ логотипа программы при запуске и кнопку на панели задач.

Вкладка «Информационная лента»

Отключите ленту.

В итоге получиться что программа будет стартовать и начинать воспроизведение музыкального файла скрыто от пользователя. Сохраните все настройки и добавьте в плейлист плеера один музыкальный файл, который и будет служить звуком ожидания ответа.

Примеры звуков ожидания лежат в папке Domofon.


Видеоподсистема

1)Скопируйте папку «Domofon» со всем содержимым в любое место на компьютере, в примере будет использоваться путь: C:\Domofon

2)Подготовьте файл для закрытия программы Aimp. Создайте (если его нет) текстовый файл «kill.txt» в скопированной папке. Откройте его и напишите следующее: «taskkill /im aimp3.exe /f /t» (без кавычек). Сохраните файл и измените расширение с .txt на .bat. Позднее при создании событий этот файл пригодится.

3)Установите клиент, архивный сервер, мультимедиа сервер, (setupcc.exe, setupas.exe, setupvss.exe) с драйверами! Запустите клиент и на диаграмме подключений GOALcity добавьте все установленные сервера:

В мультимедиа сервере появятся четыре звуковые устройства: аппаратная звуковая карта («Первичный драйвер записи»), две виртуальные звуковые карты («Line 1» и «Line 2») и «Микрофон» (при использовании Windows 10, «Микрофон» может не появиться сразу. Необходимо подключить его к ПК и перезапустить программу и службу GOALcity).


Создание архива

В случае использования Архивного сервера, необходимо создать архив (если Вы уже создали Локальный архив ранее, то пропустите данный пункт):

Правым кликом по «телу» Сервера архива откройте контекстное меню и выберите пункт «Настроить…».

Откроется окно настроек Архивного сервера. Нажмите кнопку «Добавить» и затем «Создать» (либо «Подключить» если хотите использовать ранее созданный архив).

Укажите путь к папке, в которой будет храниться архив и выставьте либо ограничение размера, либо количество минимального свободное места на жестком диске, либо максимальную длительность записи. При достижении любого из этих порогов начнется автоматическая перезапись самых старых файлов. Чтобы правильно настроить эти параметры, ознакомьтесь с рекомендациями по настройке Архивного сервера.

Нажатием кнопки «Ок» сохраните все изменения и вернитесь на диаграмму подключений. Теперь Вы увидите созданный архив на диаграмме.


Создание видеоисточника

Все названия источников (Alarm, Video-In и т.д.) даны только для примера. Вы можете выбирать самостоятельные имена источников и настраивать систему используя их.

Данная настройка необходима для получения видео с вызывной панели. Зайдите в настройки мультимедиа сервера. Процесс аналогичен описанному выше, касательно Архивного сервера.

Выберите источник «RTPSource», откройте его настройки кликом по кнопке [image].

Найдите в источнике «RTP-Видео источник» пункт «Добавить видео источник».

Введите данные для подключения: имя - «Video-In», путь - «192.168.10.164» (далее, в примере будет использоваться именно этот адрес) пароль - «admin», логин - «admin». Сохраните настройки кнопкой «Ок».

Ваши IP адреса устройств могут (и, теоретически, должны) отличаться от представленных!


Создание датчика нажатия кнопки на вызывной панели

Данная настройка необходима, чтобы GOALcity реагировала на нажатие кнопки вызова на вызывной панели. Зайдите в настройки мультимедиа сервера, далее в «IPSource», выберите в источниках «Устройства» пункт «Beward Sensor».

Введите данные для подключения: имя - «Alarm», путь – «192.168.10.164» (далее, в примере будет использоваться именно этот адрес) пароль – «admin», логин – «admin». Нажмите на кнопку «Ок» и сохраните параметры мультимедиа сервера.


Создание исходящего аудио канала

Данная настройка необходима чтобы IP сервер мог отправлять звук на вызывную панель домофона. Зайдите в настройки мультимедиа сервера (так же как делали это ранее), далее в «IPSource», выберите в источниках «Передатчик» пункт «Добавить Beward-Upload». Имя - «Uploader-Sound», хост - 192.168.10.164, логин - admin, пароль - admin. В строке «Права доступа» укажите «Администратор», пароль оставьте пустым.

Важно! Если ваша учетная запись Администратора в GOALcity запаролена, то в поле «Пароль» необходимо вписывать пароль Администратора, а не оставлять его пустым.

Поле «Источник» пока тоже оставьте пустым. Нажмите на кнопку «Ок» и сохраните параметры мультимедиа сервера. Снова откройте настройки мультимедиа сервера, пункт IP Source - Передатчик – Uploader-Sound. Теперь в поле «Источник» Вы можете выбрать одно из устройств. Выберите «Line 1» и сохраните настройки. Нажмите на кнопку «Ок» и сохраните параметры мультимедиа сервера.

С помощью этого аплоадера будет передаваться звук ожидания ответа абоненту.

IP source upload set

По аналогии создаем еще один Uploader с такими же настройками, но называем его «Uploader-Talk» и в поле «Источник» выбираем «Микрофон».

С помощью этого аплоадера, будет передаваться голос диспетчера абоненту.


Создание входящего аудио канала

Данная настройка необходима чтобы получать звук с вызывной панели подключенной к IP серверу. Откройте настройки мультимедиа сервера, затем в «RTPSource» выберите настройки вашей камерыи напротив пункта «Аудио» поставьте галочку.

Обновите мультимедия сервер. Появится еще одна графа с названием видео источника, с которого будет поступать аудио.


Создание виртуального ключа

Данная настройка необходима чтобы прекращать поступивший вызов, выключать запись видео и аудио, закрывать фрейм. Зайдите в настройки мультимедиа сервера, далее в «DeviceSource» выберите в источниках «Датчики и ключи» пункт «Добавить виртуальный ключ». Подробнее о создании источников, Вы можете почитать здесь. Имя - «Close», остальные настройки оставьте по умолчанию. Нажмите на кнопку «Ок» и сохраните параметры мультимедиа сервера.

После выполнения всего выше изложенного мультимедиа сервер должен выглядеть так:

Если всё правильно, и мультимедиа сервер выглядит как на рисунке выше, продолжайте настройку, иначе – перепроверьте все пункты.


Создание фрейма

Теперь нужно создать фрейм, содержащий элементы управления и видео с вызывной панели.

a)Подключите к клиенту в одно окно (!): виртуальный ключ («Close»), аплоадер «Uploader-Talk», и видео сигнал с IP сервера, видео с вызывной панели («Video-In»). Важно подключать устройства именно в указанном порядке! Остальные устройства подключаем каждое к своему окну, они нам понадобятся для работоспособности событий SL++.

b)Примените настройки диаграммы нажав «Ок».

c)Окна появятся на мониторе. Выберите окно, в которое подключен видеосигнал. Остальные окна можно уменьшить и «отложить» в сторону.

d)В окне с видеосигналом выберите настройку «Не сохранять пропорции» чтобы можно было производить свободное масштабирование окна (по необходимости):

e)Включите ручную расстановку устройств в окне.

f)Перемещаем и масштабируем окна устройств для более удобного и наглядного вида.

Обратите внимание, что устройства в окне перемещаются по принципу «слоев», последнее подключенное будет самым нижним, поэтому и нужно было соблюдать последовательность подключения, описанную выше. Если её не соблюдать, то кнопки управления «спрятались» бы под видео изображением.

g)Затем откройте настройки виртуального ключа «Close» кликом по кнопке [image] . На вкладке «Запись» выберите созданный ранее архив. Во вкладке «Контроль» снимите галки: «Менять состояние по двойному щелчку» и «Отображать панель инструментов».

h)Настройте внешний вид кнопки. Перейдите к пункту «Визуальное представление» и укажите путь C:\Domofon\emf\close-5 для того чтобы стандартная картинка виртуального ключа ответственного за прерывание связи и закрытие фрейма, изменилась на ту что лежит в указанной папке (необязательно использовать именно эти изображения, вы можете создать картинку самостоятельно и использовать вместо предоставленных). Сохраните настройки нажатием кнопки «Ок».

i)Повторите процедуру для источника «Uploader-Talk». Делаем настройки аналогично виртуальному ключу «Close».

j)Настройка внешнего вида кнопки. Перейдите в пункт «Визуальное представление» и укажите путь C:\Domofon\emf\sound-3 для того чтобы стандартная картинка виртуального ключа ответственного за прерывание связи и закрытие фрейма, изменилась на ту что лежит в указанной папке (необязательно использовать именно эти изображения, вы можете создать картинку самостоятельно и использовать вместо предоставленных). Сохраните настройки нажатием кнопки «Ок».

k)Зайдите в настройки видео источника «Video-In» и на вкладке «Запись» выберите созданный ранее архив «Arch», настройте желаемую скорость записи видео в архив. Нажмите «Ок».

Примечание. Чтобы открыть «старый» вид настроек видеоисточника щелкните по кнопке [image] всплывающей панели с зажатой клавишей «Ctrl» на клавиатуре.

l) Включите запись в архив! (это необходимо сделать перед сохранением фрейма).

m)Откройте настройки видеоисточника «Video-In», перейдите на вкладку «Просмотр» и снимите птички «Отображать историю аналитики» и «Отображать всплывающую панель» чтобы ничего не отвлекало оператора от работы с системой.

n)Теперь можно сохранить готовый фрейм в файл назначив ему определённое имя, например, «street-01».

Выбранный путь сохранения фрейма НЕ должен соответствовать стандартному где установлена GOALcity, иначе после деинсталляции и установки новой версии – можно потерять все ресурсы.

Это касается не только фреймов, но и звуков, скриптов и прочих сопутствующих файлов, используемых в данной конфигурации.

Лучше всего, всё сохранять в скопированную ранее папку «Domofon», которая в данном примере размещена на диске C:\Domofon

o)Закройте окно из меню:

Итак, сервер настроен, фрейм подготовлен, осталось добавить план и создать события.


Создание плана

a)Нажмите на кнопку главного меню главной панели GOALcity

b)Выберите пункт «Настройка планов»

Примечание! В вашей системе должен быть установлен DirectX 9c и зарегистрирована библиотека gcplan.dll иначе строчки «Настройка планов…» у Вас не будет.

c)В появившемся окне нажмите на кнопку «Добавить» и выберите путь к Вашему изображению (изображение должно быть в форматах jpg, png или bmp). Нажмите «Ок».

d)В менеджере планов появится созданный план. Выберите его и нажмите кнопку «Ок». Откроется новое окно с планом.

e)Перейдите в режим настройки вида и подберите оптимальный вид для плана:

f)Сохраните понравившийся вид нажатием на «+» в панели справа. Откроется окно, задайте название и нажмите «Ок». Маленький эскиз появится справа в колонке.

Важно! Обязательно активируйте данный вид, щелкнув на него левой кнопкой мыши, чтобы он подкрасился красной рамкой!

g)Перейдите к «Режиму просмотра» и закройте панель видов, сняв птичку в меню окна:

h)Окно плана примет стандартный вид:

i)Перейдите в «Режим редактирования». Добавьте объект «pictogramma» из раздела «domophone» и задайте ему имя. Например, «pic-01». Имена объектам рекомендуем давать такие, чтобы Вы потом могли разобраться с вашей системой.

j)С помощью мыши масштабируйте пиктограмму и расположите ее в нужном месте плана и перейдите в «Режим просмотра».

Эта пиктограмма, в последствии, будет привязана к датчику «Alarm» вызывной панели.


Проверка настроек и подключений

a)Зайдите на Диаграмму подключений и проверьте подключение устройств к клиенту GOALcity от Мультимедиа сервера: «Alarm» (кнопка вызова), «Микрофон» (микрофон, подключенный в звуковую карту), «Audio-In» (микрофон в вызывной панели), «Uploader-Sound». Устройства должны быть обязательно подключены чтобы можно было работать с ними в менеджере событий SL++. Если окна мешаются на экране, их можно скрыть, но ни в коем случае не закрывать.

b)Откройте настройки «Микрофона» кликом по кнопке [image] и укажите в пункте запись ранее созданный архив «Arch»:

c)Аналогично настройте другой источник аудио - «Audio in».


Настройка событий

Перед тем как настроить события, связанные с объектами на фрейме – фрейм необходимо загрузить (иначе в настройках SL++ нужных элементов не окажется)!

Загрузить фрейм можно двойным кликом по его иконке в explorer’е или любом другом менеджере файлов под Windows:

tipbulb Подробнее о событиях:

· Событие "Оповещение"

· Событие" Загрузка фрейма"

· Событие "Включение двухсторонней связи"

· Событие "Выключение двухсторонней связи"

· Событие "Выгрузка фрейма"


"Оповещение"

Откройте из главного меню GOALcity «Менеджер событий SL++».

Добавьте новое событие «Оповещение».

Активатор

«Alarm» состояние «Сработал». Нажмите «Ок». Цепочка событий начинается с нажатия кнопки на вызывной панели.

Действие 1: Анимация пиктограммы.

Элемент «pic-01», действие «alarm» (т.е. при нажатии на кнопку вызывной панели, пиктограмма начнёт анимироваться и сменит свой цвет на красный) Заметьте, что к названию пиктограммы добавляется название плана (Popova.pic-01). Нажмите «Ок».

Действие 2: Передача звука ожидания в IP сервер (передача звука ожидания абоненту).

Добавьте еще одно действие. Элемент «Uploader-Sound», действие «Замкнуть». После этой команды, весь звук, проходящий через виртуальную звуковую карту «Line 1», будет передаваться в IP сервер и проигрываться в динамиках вызывной панели. Но еще нужно запустить проигрывание звука.

Действие 3: Воспроизведение звука ожидания для абонента.

Добавьте третье действие. Нам нужно запустить установленный ранее и настроенный Aimp3 и передать абоненту звук ожидания ответа. Стандартными средствами GOALcity этого сделать не получится, потому что звук будет выводится на аудио карту, назначенную по умолчанию и, соответственно, звук пойдет в колонки или наушники диспетчера (чтобы звук передавался корректно, мы и используем виртуальную звуковую карту «Line 1»).

Выберите элемент «GOALcity», и затем действие «Запустить программу». Приложение выберите приложение Aimp3 из места установки (По умолчанию «C:\Program Files(x86)\AIMP3\aimp.exe»).

Сохраните событие нажатием на кнопку «Ок» и переходите к созданию следующего.

Действие 4: Воспроизведения звука оповещения о вызове для диспетчера.

Добавьте четвертое действие. Элемент «GOALcity», действие «Проиграть звук», и нажмите на кнопку «Настройки…»

Выберите звук, который будет проигрываться диспетчеру для оповещения о поступившем вызове на подключенных к компьютеру динамиках (наушниках).

Тип сигнала: «Звуковой файл», путь «C:\Domofon\sounds\вызов.wav».

GOALcity поддерживает воспроизведение звука формата «.wav», поэтому перекодируйте звук заранее или используйте предложенный.

Все действия для события «Оповещение» созданы. Если у вас все правильно, то должно получиться так (поля «Выполняются условия» и «Не выполняются условия» не заполняются, поэтому их нет на скриншотах):


"Загрузка фрейма"

Добавьте еще одно событие с названием: «Загрузка фрейма»

Активатор

Элемент: «Popova.pic-01», событие: «Двойной щелчок мыши». Нажмите «Ок».

Действие 1: Анимация пиктограммы.

Элемент «Popova.pic-01», действие «dialog» (пиктограмма сменит своё состояние на зелёный цвет)

Действие 2: Загрузка фрейма

Элемент «GOALcity», действие «Загрузить окно» (укажите путь где лежит ранее сохранённый файл фрейма, в примере это «C:\Domofon\frames\street-01.gcfrm»)

Задайте уникальное имя загружаемого окна, в примере это «street-01». Сохраните действие нажатием на кнопку «Ок».

Действие 3: Выключение передачи звука ожидания абоненту

Элемент «Uploader-Sound», действие «Разомкнуть». Прекращается подача звукового сигнала на IP сервер из программы Aimp3, соответственно динамик вызывной панели должен замолчать.

Сохраните событие нажатием на кнопку «Ок» и переходите к созданию следующего.

Действие 4: Выключение программы Aimp

Диспетчер отреагировал на вызов и нажал на пиктограмму, звук в динамик вызывной панели больше не передается и программу Aimp необходимо закрыть. Если оставить ее во включенном состоянии, то следующее нажатие на кнопку вызова не запустит ее снова, и соответственно звука ожидания ответа не будет.

Элемент «GOALcity», действие «Запустить программу», выберите ранее созданный файл «kill.bat». Нажмите «Ок» и сохраните действие.

Действие 5: Запись голоса диспетчера

Элемент «Микрофон», действие «Включить запись», нажмите кнопку «Ок» и сохраните действие. Звук с микрофона начнет записываться в заранее созданный архив.

Действие 6: Запись голоса абонента

Элемент «Audio-In», действие «Включить запись», нажмите кнопку «Ок» и сохраните действие. Звук с микрофона начнет записываться в заранее созданный архив.

Сохраните событие нажатием кнопки «Ок».

Все действия для события «Загрузка фрейма» созданы. Если у вас все правильно, то должно получиться так:


"Включение двухсторонней связи"

Добавьте еще одно событие с названием: «Двухсторонняя связь. Включение»

Активатор

Элемент: «Uploader-Talk», событие: «Замкнут». Нажмите кнопку «Ок». При этом будет включаться настроенный ранее аплоадер, который будет переправлять весь звук с микрофона через IP сервер в динамики вызывной панели.

Действие 1: Включение прослушивания микрофона с IP сервера (прослушивания абонента)

Элемент «Audio-In», действие «Включить прослушивание». Т.е. включается прямая передача звука с микрофона вызывной панели в динамики (наушники) диспетчера.

Сохраните событие нажатием кнопки «Ок».

Все действия для события «Двухсторонняя связь» созданы. Если у вас все правильно, то должно получиться так:


"Выключение двухсторонней связи"

Добавьте следующее событие с названием: «Двухсторонняя связь. Выключение»

Активатор

Элемент: «Uploader-Talk», событие: «Разомкнут». Нажмите на кнопку «Ок». При этом будет выключаться настроенный ранее аплоадер, перенаправляющий весь звук с микрофона через IP сервер в динамики вызывной панели.

Действие 1: Выключение прослушивания микрофона с IP сервера (прослушивания абонента)

Элемент «Audio-In», действие «Выключить прослушивание». Т.е. мы выключаем прямую передачу звука с микрофона вызывной панели в динамики (наушники) диспетчера.

Сохраните событие нажатием кнопки «Ок».

Все действия для события «Двухсторонняя связь. Выключение» созданы. Если у вас все правильно, то должно получиться так:

Включите обработчик событий SL++ (кнопку [image] на главной панели GOALcity) и проверьте всё-ли работает?

Алгоритм следующий:

·По нажатию на кнопку вызова панели – иконка на плане должна замигать красным цветом, в динамике вызывной панели должен раздаться звук ожидания ответа (тот что передает Aimp3), в динамиках, подключенных к компьютеру диспетчера - звук оповещения (поступил новый вызов).

·Кликнув дважды по иконке - она должна стать зеленой и «поднять» фрейм с видео изображением и элементами управления, звуки оповещения - выключиться.

·Кликом по кнопке с изображением динамика включается\выключается двухстороннюю связь.

·Все разговоры и видео должны записываться в архив.

Если всё работает - переходите к последнему пункту, в противном случае - перепроверяйте настройки.


"Выгрузка фрейма"

Создайте последнее событие с называнием: «Выгрузка фрейма»

Активатор

Элемент «Close», состояние «Замкнут»

Действие 1: Размыкание ключа

Элемент «Close», действие «Размокнуть». Это действие разомкнет ключ, чтобы не «зациклить» события и при следующем «поднятии» фрейма ключ был разомкнут и фрейм сразу же не закрылся.

Сохраните действие нажатием на кнопку «Ок».

Действие 2: Анимация пиктограммы

Вызов окончен, и необходимо вернуть пиктограмме и системе состояние ожидания вызова.

Элемент «Popova.pic-01», действие «idle» (пиктограмма сменит своё состояние на серый, стандартный цвет)

Действие 3: Выключение прослушки микрофона вызывной панели (голоса абонента)

Этим действием выключается прослушка микрофона вызывной панели, если диспетчер забудет нажать на кнопку выключения двухсторонней связи (с изображением динамика).

Элемент «Audio-In», действие «Выключить прослушивание».

Действие 4: Выключение передачи голоса в вызывную панель (голос диспетчера)

Элемент «Uploader-Talk», действие «Разомкнуть». Т.е. мы выключаем прямую передачу звука с микрофона диспетчера в вызывную панель. Это действие, опять же, на всякий случай, если диспетчер забудет нажать на кнопку выключения двухсторонней связи.

Действие 5: Выключение записи голоса абонента

Элемент «Audio-In», действие «Выключить запись».

Действие 6: Выключение записи голоса диспетчера

Элемент «Микрофон», действие «Выключить запись».

Действие 7: Закрытие (выгрузка) фрейма

Элемент «GOALcity», действие «Выполнить команду меню».

В поле «Объект» выберите Ваше загруженное окно, в примере это «street-01». Это имя Вы задавали окну на стадии загрузки фрейма. Кликом по кнопке [image] поля «Пункт меню» выберите пункт «Закрыть». Иногда команда меню «Закрыть» не срабатывает с первого раза, рекомендуем повторить данную процедуру дважды.

Если все настроено верно, то событие должно выглядеть так:

Сохраните событие нажатием на кнопку «Ок».


Финальная проверка

Итого получается 5 событий и должно выглядеть так:

Если всё сделано правильно, IP сервер работает и введены параметры без опечаток – то можно считать, что настройка завершена и система полностью готова.

По вызову с панели: событие: «Оповещение»

a)В 3D плане должна анимироваться пиктограмма.

b)На вызывной панели должен звучать звук ожидания ответа.

c)На динамиках должен быть звук оповещения о вызове.

Даблклик по пиктограмме: событие: «Загрузка фрейма», оба события «Двухсторонняя связь»

a)Состояние пиктограммы меняется на зелёное.

b)Прекращается подача звуковых сигналов с обоих сторон.

c)Загружается фрейм содержащий – видео с вызываемой панели, кнопку включения двухсторонней связи и кнопку закрытия.

d)После клика по кнопке связи абонент должен слышать диспетчера и наоборот. При повторном клике связь прекращается.

e)Должна включаться запись видео и обоих аудио источников.

Клик по ключу, отвечающему за закрытие фрейма: событие: «Выгрузка фрейма»

a)Останавливается запись в архив с обоих аудиоканалов.

b)Изменяется состояние пиктограммы на пассивное.

c)Выключается двухсторонняя аудио связь.

d)Закрывает фрейм.


Приложение

Последние версии стоек системы «Гражданин полиция» оборудованы датчиком удара, подключенному к IP видеосерверу. Его можно так же привязать к системе и использовать для предотвращения антивандальных действий.

tipbulb Смотрите также:

· Разделение звука в наушниках и динамиках


Разделение звука

Разделение звука в наушники и динамики

 Top Previous

Назначьте через микшер Windows устройством воспроизведения по умолчанию наушники.

Настройка KM Player’а

Установите дополнительно еще один аудиоплеер, для примера взят KM Player (можно найти на предлагающемся к системе компакт диске). Рекомендуем использовать именно его, плеер бесплатный и отвечает всем необходимым требованиям для реализации разделения звука.

Выполните следующие настройки плеера:

Общие Настройки - Вкладка При запуске. Установите Действие – Продолжать воспроизведение, Состояние экрана – Сворачивать в область уведомлений.

Общие Настройки -> Повтор\Список. Установите порядок воспроизведения Аудио – Повторение одной записи, по завершении – Повторить все.

Вкладка Обработка Аудио. Выберите устройство, через которое будет воспроизводиться звук оповещения абонента (в примере это Динамики, у Вас, скорее всего будет так же) и нажмите кнопку «Задать».

После настройки добавьте любой звуковой файл, которым Вы хотите оповещать оператора о новом вызове.

Этими настройками Вы добьетесь того, что плеер будет стартовать скрыто от пользователя и воспроизводить звук в динамики вашего АРМ. Весь же остальной звук (голос абонента) будет идти в наушники, т.к. Вы назначили их устройством по умолчанию.

Для активации данного способа оповещения нужно немного изменить события SL++ настроенные ранее.

Начните с события "Оповещение"

Действие 4: Воспроизведения звука оповещения о вызове для диспетчера

Измените четвертое действие данного события. Элемент «GOALcity», действие «Запустить программу». Укажите путь к заранее установленному и настроенному KM Player’у.

Другими словами, вместо стандартного звукового сигнала «от GOALcity» которое проигрывается в устройстве по умолчанию (наушниках), Вы запустите заранее настроенный на воспроизведение через динамики KM Player.

Теперь необходимо выключить этот звук при приеме звонка оператором в событии "Загрузка фрейма".

Действие 4: Воспроизведения звука оповещения о вызове для диспетчера

Добавьте еще одно действие. Элемент «GOALcity», действие «Запустить программу». Укажите путь к файлу закрытия KM Player’а (входит в набор программного обеспечения АРМ).

На этом настройка разделения звука закончена.