Введение

Интернет-Видеорегистратор производства "Спецлаб"

Интернет-Видеорегистратор (Далее ИВР) – это объединение облачных технологий с вашей «железякой». ИВР имеет массу особенностей, отличающих его от простой «писалки-смотрелки». И прежде всего, сетевая логика, адаптированная к любым, даже самым слабым каналам. Чтобы по ним что-то прокачать, нужно умение сокращать информацию и выбирать важное. Поэтому самое главное достоинство ИВР - видеоаналитика, в ней производится преданализ событий, за счет чего убираются многие часы пустого видео. Интернет посылаются уже оформленные сюжеты - для более интеллектуального исследования более мощными серверами. При этом в тысячи раз сокращается трафик – теперь он больше не грузит домашнюю или офисную сеть. Появляется возможность установки в местах с очень слабым Интернетом. И в том числе, с неустойчивыми каналами. Если живое видео от камер безвозвратно теряется в момент сбоя, то каждый видеосюжет из ИВР будет пытаться отправиться по назначению до скончания вечности: как только появляется хоть какая-то связь, короткие видеоролики уходят в «Далекий свидетель».

Более подробно о ИВР Вы можете узнать здесь.


Подключение устройства

ИВР подключается к сети передачи данных, поддерживающей протокол TCP/IP, через встроенную розетку формата RJ-45 или Wi-Fi, а к монитору через кабель HDMI. Устройство имеет 3 USB порта, один выведен для легкого подключения устройств ввода-вывода, два других располагаются на плате и необходимы для подключения иных перефейрийных устройств, например внешних USB накопителей, для хранения архива. Электропитание происходит включением в розетку 220В, поставляемого в комплекте, блока питания. Ниже представлена схема подключения устройства для начала работы


Подключение камер в сеть

Интернет-Видеорегистратор (ИВР) -позволяет вести событийную запись "коротких роликов" на сам ИВР или внешний жесткий диск и отправку этих роликов в наш облачный сервис "Далекий свидетель": по Вашему усмотрению.

ИВР работает только с IP-камерами, позволяя подключить их до 4х штук. Осуществляет постоянную запись — пока есть видеодетекция. Если активности долго нет - запись останавливается до её появления.

ИВР выполняет первичный видеоанализ с формированием событийного ряда. В облачный сервис будут отправляться уже оформленные сюжеты для дальнейшей консолидации и анализа с выстраиванием логических цепочек на более мощных серверах.

Сеть камер ИВР


Главное меню

Основным элементом управления ИВР является Главное меню. По умолчанию оно выглядит так:

Условно главное меню можно поделить на 3 зоны.

Первая зона располагается в левой части экрана, размещая в себе архив событий. Кликнув по событию, Вы перейдете в меню просмотра архива с воспроизведением выбранного события.
Вторая зона, зона просмотра, в которой отображаются ваши камеры, подключенные к ИВР. Нажав на камеру, она раскроется на всю зона просмотра. Если нажать на номер камеры, то ИВР запишет 10 секундный ролик в архив.

Третья зона является технической зоной и несет в себе следующие функции:

"Спецлаб" - нажатие в этом месте перевед вас на сайт разработчика.

Главное меню разворачивание камер Данная кнопка позволяет переключать изображение в окнах выбирая между настоящим размером кадра и заполнением в окне. Это позволяет камеры с различными разрешениями вывода привести в единый вид.

"Поиск камеры" - нажатие данной кнопки переводит Вас в панель поиска камер по протоколу Onvif. Более подробно о настройках в этом пункте меню можно прочитать здесь.
"Старт"/"Стоп" - данная кнопка позволяет включать и отключать активную работу ИВР.

"Архив" - нажатие данной кнопки приведет Вас в меню просмотра архивных роликов. Более подробно о настройках в этом пункте меню можно прочитать здесь.

"Далекий свидетель" - нажатие в этом месте переведет Вас на сайт "Далекий свидетель".
"Настройки" - нажав данный пункт вы перейдете в меню расширенных настроек камеры. Более подробно о настройках в этом пункте меню можно прочитать здесь.


Поиск камер

Для начала, мы рекомендуем произвести поиск камер по протоколу ONVIF, потому что почти все современные камеры поддерживают этот протокол. На главной панели управления нажмите "Поиск камер" А уж если что-то не найдется, то можно будет добавить вручную. Найденные камеры будут отображены столбцом в левой части экрана. Если Ваша камера не была найдена, то в нижней части экрана нажмите на кнопку "Добавить камеру". В появившемся окне введите IP-адрес устройства, которое нужно добавить. Выберите из списка камеру, которую хотите подключить.
Пункт "Имя пользователя" здесь задается имя пользователя, которое установлено на видеокамере, которое было установлено с завода или изменено пользователем. Для доступа к камере.

Пункт "Пароль" в данном пункте задается пароль, для подключения к видеокамере, который был установлен с завода или изменен пользователем. Для доступа к камере.
Пункт "Потоки" в данном пункте выбирается поток, из группы потоков камеры, для сохранения на ИВР.
Пункт "Яркость" перемещение ползунка настраивает яркость отображения видеопотока в ИВР.
Пункт "Контраст" перемещение ползунка настраивает контраст отображения видеопотока в ИВР.
Во вкладке "Сохранить как" выбирается в какой пункт будет сохранен выбранный поток камеры.


Архив

Архив - это менеджер записи, хранения и просмотра истории событий системы.

Пункт "Очистить архив" удаляет все события из архива.
Пункт "Добавить лицо в базу данных" добавляет лицо в базу данных с текущего просматриваемого ролика в котором оно было определено.

Пункт "Лица" переводит Вас в базу лиц. Отмив справа "галочкой" лица нажмите удалить, для исключения лиц из базы.

Пункт "Автономера" переводит Вас в базу автомобильных номеров, в которой можно добавлять и удалять номера, для работы датчиков/ключей. Отмив справа "галочкой" номера, нажмите удалить, для исключения номеров из базы.

Пункт "Область детекции автономеров" позволяет настроить зону определения автомобильных номеров с текущего просматриваемого ролика. Как правило, в реальных условиях при проезде (остановке) транспортного средства в зоне охвата камеры номера находятся в ограниченной зоне кадра. Для ускорения обработки кадра желательно установить границы, в которых программа и будет пытаться обнаружить автомобильный номер. Делается это выделением границ рамки с помощью мыши при нажатой и удерживаемой её левой клавише.

Область поиска номера


Настройки камеры

Данная вкладка предназначена для изменений настроек подключения к камере. Смены потоков камеры (для много поточных камер), а также смены порта и настроек времени переподключения к камере. Также если в настройках камеры были изменены настройки пользователя, здесь их также можно изменить.

Пункт "URL потока для анализа (MJPEG или H264)" данная настройка аналогична с настройками камеры на диаграме подключений. Данный пункт отвечает за то, что будет отображаться в окне камеры.

Пункт "URL(для записи)" Данная настройка аналогична с настройками камеры на диаграме подключений. Данный пункт отвечает за то, что будет записываться в архив. Рекомендуем использовать поток на котором используется кодек h264 и максимальное разрешение.

Пункт "Имя пользователя" здесь задается имя пользователя, которое установлено на видеокамере, которое было установлено с завода или изменено пользователем.

Пункт "Пароль" в данном пункте задается пароль, для подключения к видеокамере, который был установлен с завода или изменен пользователем.

Пункт "Програмный декодер" задействует программный декодер вместо аппаратного. Рекомендуется использовать при нестандартных потоках видео.


Видеоаналитика

Данная вкладка предназначена для изменений настроек видеоаналитических алгоритмов камер. ИВР включает в себя четыре типа детектора: детектор движения, детектор людей, детектор лиц и детектор автомобильных номеров.

Модуль детектора движений имеет развитую систему индикации и предупреждений.

Пункт "Включить ДД" активирует работу детектора движения на текущей камере.
Пункт "Чувствительность ДД" отвечает за чувствительность детектора, к происходящему в кадре. Если ложные сработки идут часто, понизьте уровень чувствительности. Если полезные объекты не определяются, то повысьте.

Пункт "Вести запись пока есть детекция" При активации данного параметра ИВР будет записывать постоянно ролики длинной в 1 минуту, пока в окне есть движение. То есть, если, например, в окне камеры будет детекция в течении 10 минут 36 секунд, то Вы получите 10 роликов длинной в 1 минуту и 1 ролик длинной в 36 секунд.

Модуль детектора людей служит для распознавания в изображении силуэтов людей и классификации их действий, присущих людям. Детектор людей ресурсоемкий алгоритм, его не рекомендуется включать более чем на 3 камерах, при отсутствие работы других алгоритмов, за исключением детектора движения.
Пункт "Включить детектор людей" активирует работу детектора людей на текущей камере.
Пункт "Чувствительность детектор людей" отвечает за чувствительность детектора, к происходящему в кадре. Если ложные сработки идут часто, понизьте уровень чувствительности. Если полезные объекты не определяются, то повысьте.

Детектор лиц – выявляет в кадре появление человеческих лиц, оценивает их индивидуальные параметры, позволяя идентифицировать людей и сопоставлять их с базами данных. Благодаря встроенному аналитическому алгоритму ИВР «умеет» отследить из всей передаваемой камерой информации человеческие лица и инициировать соответствующую реакцию системы согласно произведенным вами настройкам. Детектор лиц ресурсоемкий алгоритм, его не рекомендуется включать более чем на 3 камерах, при отсутствие работы других алгоритмов, за исключением детектора движения.

Пункт "Включить детектор лиц" активирует работу детектора лиц на текущей камере.
Пункт "Размер лица" позволяет настроить размер лица, на которое будет проводится сработка
Пункт "Включить распознование лиц" включает рассчет метрики для сравнения лиц с лицами, находящимися в базе данных. Использовать распознование лиц рекомендуется не более чем на 2 камерах, так как это очень ресурсоемкий процесс.
Пункт "Процент достоверности для распознавания лиц" Если лица не находятся в базе, уменьшите значение. Если имена не совпадают с лицами, увеличьте! Нормальный уровень - 50%.
Пункт "Управлять ключом" в данном пункте указывается ключ ИВР который нужно замкнуть при определении лица из базы данных.
Пункт "Замыкать ключ на время (сек.) при распознавании лица из базы данных" в данном пункте задается время на которое будет замкнут ключ при определении лица из базы данных.

Данная вкладка предназначена для включения алгоритма по определению автомобильного номера в кадре камеры. Детектор автономеров ресурсоемкий алгоритм, его не рекомендуется включать более чем на 2 камерах, при условии, что другие камеры не будут задействованы вовсе.

Пункт "Включить распознавание автономеров" активирует работу детектора автомобильных номеров на текущей камере.

Пункт "Ключ открытия" в данном пункте указывается ключ ИВР который нужно замкнуть для открывания шлагбаума/ворот при определении номера из базы данных.
Пункт "Замыкать ключ открытия на время (сек.) при совпадении номера с номером из базы данных" в данном пункте задается время на которое будет замкнут ключ для открывания шлагбаума/ворот.

Пункт "Ключ закрытия" в данном пункте указывается ключ ИВР который нужно замкнуть для закрывания шлагбаума/ворот при истечении времени открытия.

Пункт "Замыкать ключ закрытия на время (сек.)"в данном пункте задается время на которое будет замкнут ключ для закрывания шлагбаума/ворот.

Пункт "Время открытия (сек.)" в данном пункте задается время, через которое программа попробует закрыть ворота. Если датчики перекрытия не будут воздейств

Пункт "Датчик открытия" в данном пункте указывается датчик ИВР с которого будет приходить информация о том, что ворота открыты.
Пункт "Датчик закрытия" в данном пункте указывается датчик ИВР с которого будет приходить информация о том, что ворота закрыты.
Пункт "Проверять на совпадение первые символы номера в количестве (0-все)" в данном поле указывается сколько символов в номере должны совпадать с номером из базы данных, для работы с ключами.

Алгоритм Опасное начало

Алгоритм "Опасное начало" предупреждает, что в зоне видимости какой-то из камер, для которых он включен, после отсутствия движения в течение некоторого времени, появился движущийся объект. Применение его особенно эффективно в тех случаях, когда ведется наблюдение за объектами, на которых нет постоянно движущихся предметов (автомобилей, людей, подвижного оборудования). Идеален для ночной охраны. Но, как правило, и в дневное время несанкционированные действия производятся при более-менее продолжительном отсутствии людей, которые могут стать свидетелями.

Пункт "Начальная задержка в кадрах" устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенямии и прочим.

Пункт "Учитывать период отсутствия движения" при этой настройке в течении установленного времени сработка по алгоритму произойдет даже если событие будет продолжительным.

Пункт "Период отсутствия движения в секундах" в данном пункте задается время отсутствия движения после которого произойдет сработка алгоритма.

Как правило, на любой камере есть зоны, детекция движения в которых не нужна или не желательна. Чтобы настроить маску детекции, перейдите на вкладку "Маска". Данная настройка применима только к "Детектору движения". После активации работы маски, перейдите на главное меню и нажмите в окне камере на те места, где необходимо "нарисовать" маску. Переключение стирания и нанесения маски изменяется в левом нижнем углу камеры. Знак плюс соответсвует нанесению маски, знак минус соответствует ее стиранию.

Пункт "Использовать маску" позволяет исключить из зоны детекции место (места), где присутствуют объекты, на которые детектор не должен реагировать.
Пункт "Показывать маску" включает отображение маски в окне просмотра камеры.


Далекий свидетель

Farwit (или "Далекий свидетель") является дополнительным "помощником" в обеспечении Вашей безопасности, но, в отличии от Вашего ИВР, он может быть всегда с Вами, в вашем смартфоне.

Пункт "Включить" поставьте галочку в данном пункте, чтобы включить отправку событий на "далекий свидетель"

Пункт "Адрес облака "Далекий свидетель"" в данном меню лучше оставить значения по умолчанию. Функция изменения предоставлена для технических специалистов

Пункт "Пользователь" в данном пункте вводите логин, указанный при регистрации на cloud.farwit.com

Пункт "Пароль" в данном пункте вводите логин, указанный при регистрации на cloud.farwit.com

Пункт "Максимальное количество событий" в данном пункте указывается количество событий готовящиеся к отправке на далекий свидетель. При привышении этого параметра, самое старое событие будет заменяться самым новым.


Архив

Данная вкладка предназначена для изменений настроек событийного архива. В нем представлено всего 2 пункта.

Пункт "Максимальное количество событий" в данном пункте указывается максимальное количество событий, которое будет хранится в архиве. По достижению предела самые старые будут перезаписаны самыми новыми.

Пункт "Место хранения архива" в данном пункте выбирается хранилище между внутренним и внешним хранилищем. Важно! Внешним хранилищем является устройство хранения данных подключенное через USB интерфейс


Датчики

Данная вкладка предназначена для изменений настроек записи при срабатывании датчиков . Позволяет выбрать на какой камере вести запись, после срабатывания датчика.


Разное

Данная вкладка предназначена для различных сторонних настроек в работе ИВР.

Пункт "Аппаратный перезагрузчик" позволяет включить аппаратный модуль перезагрузки, в случае сбоя в работе программы или устройства. Для применения данного пункта настройки требуется перезагрузка устройства.


Подключение датчиков и ключей

В ИВР предусмотрена работа с датчиками и ключами, с возможностью удаленного контроля срабатывания датчиков. На плате установлены колодки подключения внешних устройств, колодки подключения датчиков и технический разъем предназначенный для сотрудников "Спецлаб"

Схема датчиков ключей

Панель ключей. Каждый канал пронумерован и имеет три контакта, для обеспечения возможности смены активного состояния линии с замкнутого на разомкнутое. Если необходимо замыкание контактов управляемого устройства по команде пользователя, то его необходимо подключить на 2 и 3 контакт колодки, если необходим обратный эффект (размыкание контактов по команде пользователя), то на 1 и 3.

Справа колодки для подключения линий датчиков. Контакт c обозначением "<-" обозначает положительный контакт, "—|" обозначает землю, каждый датчик обладает своим собственным контактом земли.

Технический разъем предназначет только для специалистов "СпецЛаб"