Введение

Снимок экрана 2020-10-23 152622

Стрим-сервер представляет из себя высоконадежную систему просмотра видеокамер и их записи.

Он почти не потребляет вычислительных ресурсов, поэтому может быть установлен даже на слабом ПК. Как на Windows, так и на Linux. Он может работать с большим количеством дисков, обеспечивая длительное хранение видеоконтента.

Стрим-сервер работает и как DVR, складывая видео без распаковки в потоковых кодеках типа H.264. Каждый участок архива, каждый его кадр может быть ассоциирован с любым событием и запрошен на просмотр любым сетевым клиентом.

Сами камеры в реальном времени могут просматриваться любым количеством сетевых клиентов как через обычный браузер, так и в специализированных программах. Тем самым Стрим-сервер является расширителем доступа к камерам, которые способны выдавать только несколько каналов.

Если IP-камера, как правило, позволяет выдать только два потока видео в разных форматах или только один поток в нужном формате, то Стрим-сервер обеспечивает размножение любых типов потоков на большое количество.

Такая автономная задача, обрабатываемая на отдельном дешевом компьютере, позволяет высвободить ресурсы видеосерверов и АРМ-ов, многократно повысить эффективность видеоаналитики и уменьшить затраты на её ресурсы.


Запуск стрим сервера

Для запуска стрим-сервера:

1. Откройте командную строку.

2. Перейдите в папку, где располагаются файлы стрим-сервера (сервер с расширением .exe и файл конфигурации с расширением .json)

3. Запустите файл «server.exe» с конфигурацией «sample.json» (может быть другое название) Пример: server.exe sample.json

Если результат будет как на скриншоте №1, то все сделано правильно и стрим-сервер запущен. Зайти на него можно с любого браузера по адресу, указанному в файле конфигурации.

скриншот №1

Не закрывайте окно командной строки после запуска стрим-сервера, иначе он не будет работать.


Вызов справки

Для вызова дополнительных параметров запуска стрим-сервера запустите стрим-сервер с параметрами «-h». Пример: server.exe -h.

Ответом будет:

Stream Server 3.4.2

Usage: server.exe [OPTIONS] config

Positionals:

config TEXT Configuration file

Options:

-h,--help вызовет данное сообщение

-v,--version отобразит версию программы

-l,--log TEXT после запуска стрим-сервера создаст файл с логами

-e,--example TEXT сформирует пример файла конфигурации


Получение лицензии

После запуска стрим-сервера, может возникнуть сообщение как на скриншоте №2, это будет означать, что в файле конфигурации прописан неправильный ключ лицензии (см. описание файла конфигурации). В этом случае нужно обратиться в компанию разработчика за ключом лицензии. Для этого скопируйте ключ, указанный в строке «Get license. Key:», и отошлите на почту компании, в ответ вы получите ключ лицензии для данного компьютера. Его нужно вписать в файл конфигурации в соответствующее поле (см. описание файла конфигурации)

скриншот №2


Возможные ошибки при запуске сервера

Если после запуска стрим-сервера вы видите сообщение как на скриншоте №3, это значит, что была допущена ошибка при изменении файла конфигурации (json).

скриншот №3

Если после запуска стрим-сервера вы видите сообщение как на скриншоте №4, это значит, что ключ лицензии, указанный в файле конфигурации, неверен.

скриншот №4


Вкладка веб-интерфейса Си-норд

Включает/выключает взаимодействие с оборудованием Си-Норд. Дублирует настройки сервера «surgard» в файле конфигурации за одним исключением, в веб интерфейсе данная настройка будет действовать до первой перезагрузки. После перезагрузки или обновления страницы, настройка примет состояние, указанное в файле конфигурации.

Блок - «surgard» строка «enable»: true(включить), либо false(выключить)

Снимок экрана 2020-10-20 122734


Вкладка веб-интерфейса Настройки

Во вкладке «Настройки» можно скачать либо поменять файл конфигурации, а также перезагрузить стрим-сервер.

«Скачать файл конфигурации» - сохранить файл конфигурации на компьютер.

«Перезагрузить сервер» - перезагружает стрим-сервер

Снимок экрана 2020-10-20 122746

Замена файла конфигурации из веб-интерфейса

Для замены файла конфигурации:

1. Нажмите кнопку «Выберите файл»

2. Укажите файл конфигурации который необходимо загрузить

3. Нажмите кнопку «Закачать»

4. Перезапустите сервер.


Описание файла конфигурации

Для редактирования файла конфигурации лучше пользоваться программой «notepad++», либо любым онлайн редактором. Пример: https://jsonformatter.org/json-editor

Файл конфигурации json с описанием параметров:

{

"version": 1, - версия программного обеспечения

"license": "CC2F8157A20375FDE743FC3385FC601787DCD7AF", - ключ лицензии

"client": {

Блок настройки камер

"cameras": [

{

"id": "cam1", - внутренний идентификатор камеры

"name": "Камера1", - имя камеры отображаемое в веб-интерфейс

"streams": [

{

"url": "rtsp:// ", - ссылка на 1й поток с камеры

Блок настройки архива

"archive": {

"path": "D:/archive/camera1", - путь до архива камеры

"hours": 1, - глубина архива в часах

},

{

"url": "rtsp:// ", - ссылка на 2й поток с камеры

}

],

"surgard_events" : [ - параметры в этом блоке берутся из программного обеспечения «Центр охраны»

{

"objnum" : "0001", - объект

"event" : "E130", - событие( если событий несколько то их можно прописать через запчтую(например «E130», «E320»)

"section" : "00", - раздел

"cable" : "001" - шлейф

}

]

},

]

},

"server": { - раздел настройки параметров серверов

"rtsp": { - RTSP сервер ретрансляции в стороннее ПО

"ip": "192.168.10.124", - ip адрес RTSP сервера. IP компьютера на котором работает стрим-сервер

"port": 554 - порт RTSP сервера

},

"surgard": {

"ip": "192.168.10.124", - ip адрес, используемый протоколом «surgard» для взаимосвязи с ПО «Центр охраны». Настраивается в ПО «Центр охраны». IP адрес компьютера на котором установлено ПО «Центр охраны».

"port": 11111, - порт, используемый протоколом «surgard» для взаимосвязи с ПО «Центр охраны». Настраивается в ПО «Центр охраны».

"enable": true - включает/отключает взаимодействие с протоколом «surgard»

},

"http": { - необходим для взаимодействия со стрим-сервером через интернет браузер.

"ip": "192.168.10.124", - ip адрес http сервера. IP компьютера на котором работает стрим-сервер

"port": 8888, - порт http сервера

Раздел настройки отображения камер в браузере.

"layouts": [

{

"id": "layout1", - идентификатор раскладки камер

"name": "1x1", - отображаемое имя раскладки в браузере

"popup": {

"left": 10,

"top": 10,

"right": 90,

"bottom": 90

},

"monitors": [ - настройки расположения раскладок камер

{

Координаты расположения окна камеры. В данном случае одно окно на экране. Отсчет координат производится от верхнего левого края.

"left": 0, - координата левого края окна в процентах

"top": 0, - координата верхнего края окна в процентах

"right": 100, - координата правого края окна в процентах

"bottom": 100- координата нижнего края окна в процентах

}

]

},

{

"id": "layout2",

"name": "2x2",

"popup": {

"left": 10,

"top": 10,

"right": 90,

"bottom": 90

},

"monitors": [

{

"left": 0,

"top": 0,

"right": 50,

"bottom": 50

},

{

"left": 50,

"top": 0,

"right": 100,

"bottom": 50

},

{

"left": 0,

"top": 50,

"right": 50,

"bottom": 100

},

{

"left": 50,

"top": 50,

"right": 100,

"bottom": 100

}

]

}

]

},

"ws-discovery": { - сервер для взаимодействия со стрим-сервером по средствам ONVIF

"ip": "192.168.10.124"

},

Настройка прав доступа стрим-сервера

"users": [

{

"login": "admin", - логин пользователя

"password": "admin", - пароль пользователя

"admin": true, - права администратора (принимает два параметра: true- права предоставлены, false - права не предоставлены)

"ids": [ - id камер и раскладок видов, доступ к которым необходимо предоставить

"*" - знак "*" означает, что доступ предоставлен без ограничений

]

},

{

Пример ограниченной учетной записи.

"login": "user",

"password": "pass",

"admin": false,

"ids": [

"cam1",

"layout1x1"

]

}

]

}

}