Введение

»«

Введение

Система событийного видеонаблюдения

Уникальный набор средств и функций для безопасности с аналитическим видеонаблюдением для любого типа объекта: дома, квартиры, дачи, офиса, магазина, многоэтажного здания и комплекса зданий, банка, завода, фабрики, стоянки автотранспорта, служб ГИБДД, МВД, ФСБ, уличного контроля, комплекса «Безопасный город».

Подробнее о системе GOALcity Вы можете узнать здесь.

Если у вас возникли проблемы с переходом по ссылке, рекомендуем ознакомиться с дополнительной информацией.


Базовые функции ПО событийного видеонаблюдения

»«

Базовые функции ПО событийного видеонаблюдения

GOALcity

базовые функции
программного обеспечения
СОБЫТИЙНОГО ВИДЕОНАБЛЮДЕНИЯ

Назначение: Уникальный набор средств и функций для безопасности с аналитическим видеонаблюдением на базе нейронных сетей для любого типа объекта.

Полезная особенность: Устраняется человеческий фактор за счет конвертации «длинных» потоков видео в «короткие» события на базе технологии «Видеосемантика».

Качество событий дополняется нейронными сетями, которые распознают полезные цели: людей, авто, оружие, дроны, деньги, положение тела и проч.

Распределенно-сетевая архитектура: Программное обеспечение (в дальнейшем ПО) состоит из множества сетевых модулей клиент-серверной структуры, которые могут располагаться как локально на одном ПК, так и на других ПК, объединенных общей, в том числе и многоранговой, сетью.

Мобильность и облака: Использование кросплатформенных модулей позволяет выходить за рамки собственной сети и передавать данные как на индивидуальные устройства, например, мобильные телефоны, так и в Глобальные облака с ГИС-навигацией по огромному количеству объектов.

Интерфейс: Гибкий, на 94% изменяемый с возможностью выбора индивидуальных размеров независимых окон и мест их расположения на экране.

Операционные системы: В зависимости от задач, ПО включает модули для ПК, планшетов и смартфонов с поддержкой операционных систем: Windows, Linux и Android.
Примечание: ПО под урезанные ОС типа Astra Linux содержит значительно меньше возможностей в виду ограничений самих ОС. Но их численность постоянно увеличивается с развитием этих ОС.

Поддерживаемые видеокамеры: Все модули ПО работают с любыми видами IP-камер, имеющими стандартный протокол ONVIF, с поддержкой кодеков: MJPEG, H-264/265. При наличии плат оцифровки поддерживаются камеры реального времени CCTV и HD-SDI.

Видеоаналитика автоматизирует основные функции средств охраны: обнаружение, слежение, распознавание, прогнозирование, предупреждение. Эти функции выполняются многократно, обеспечивая непрерывное уточнение гипотез о количестве, местоположении и типах объектов в контролируемой зоне, а так же устранение избыточности в результатах.

Основные конкурентные возможности:

Акцентирование происшествий: Вывод в реальном времени на отдельную панель коротких ключевых сюжетов всего происходящего на объекте видеонаблюдения.

Последовательное видеонаблюдение (вместо параллельного): Хронологическая последовательность ключевых моментов со всех камер при возможности систематизации по каждой камере в отдельности. Таким образом, в груде сотен камер всегда есть логическая связь, что за чем следует и для чего, - все видно по Панели последовательности действий.

Человеческий фактор с учетом отвлечения внимания: Удержание на экране серии последних событий, произошедших на объекте видеонаблюдения. Даже, если оператор отвлекся или его отвлекли, он не пропустит произошедшее в это время преступление.

Постинформирование: Быстрый доступ к просмотру более старых ключевых событий в случае длительного отвлечения оператора от монитора.

Мобильность: Передача видеосюжетов с ключевыми событиями на мобильные устройства (телефоны, планшетники).

Доклад руководству: Моментальная отсылка видеосюжетов о происшествии вышестоящему руководству на их рабочие компьютеры или телефоны.

Распространение поисковой информации: Быстрая рассылка видеосюжетов о происшествиях, видеозаписей лиц, фотографий документов на мобильные устройства смежных служб, других постов, ППС и дежурных частей.

Быстрый просмотр архива: моментальные переходы между ключевыми событиями. Быстрый охват информации по первым секундам сюжетов.

Режим фотогалереи: Вывод первых кадров ключевых событий в виде большого числа картинок – начальных моментов. При выборе любой картинки – проигрывание видео с момента записи этого кадра.

Активное видеонаблюдение: Возможность текстового комментирования видеоинформации с целью дальнейшего поиска текстовых метаданных в архиве. Например, секретарь может записывать данные визиток, охранник – потенциальных нарушителей и т.д. Потом эти моменты быстро находятся в видеопотоке, и краткий комментарий становится более чем понятен за счет просмотра видеосюжета по нему.

Целенаправленный архивный поиск: Фильтрация по лицам, автономерам, ключевым событиям, месту детекции, цвету, текстовым комментариям и другим метаданным.

Многоканальный просмотр архива: проигрывание большого числа видеокамер одновременно и вместе со звуковыми каналами, что ускорят процесс просмотра и создает общую картину происходящего на всём объекте.

Охват архивной информации: Синхронный просмотр не только видео, но вообще всех типов архивных записей: видеокамер, микрофонов, сработок датчиков, ключей, положений шлагбаумов, состояний электронных замков, показаний устройств измерения температуры, давления, влажности, качества воздуха, паров спирта, радиации, записей мониторов ПК и т.д.

Синхронизация: Четкая синхронизация любых потоков видеоканалов с любыми потоками аудиоканалов, а также между собой, что часто отсутствует у других в виду разной скорости прохождения по сети.

Перенос данных: Экспорт аудио- видеоданных в переносимый формат многоканального синхронного просмотра на других компьютерах. Удобный и многофункциональный плеер, специализированный под «разбор полетов». На обычном плеере трудно подбирать нужный кадр, да и нет возможности смотреть сразу множество видеоканалов.

Секретность: Надежная защита экспортированных файлов от просмотра посторонними лицами. Перенос данных на «флэшке» или CD-диске надежно защищен.

Доказательная база: Запись без алгоритмов математического предсказания, использование электронной цифровой подписи (ЭЦП) для безусловного доказательства в суде.

Устойчивость к сбоям: сохранность базы и восстановление последних кадров, которые, как правило, самые важные, если произошло ЧП.

Разборчивость аудиозаписи: Полный формат, пригодный для шумоочистки. Используемые повсеместно аудио кодеки хороши только для музыки - стерильно бесшумных звукозаписывающих студий. Чтобы разобрать человеческую речь в бытовых шумах, требуется специализированный кодек, который и разработал Спецлаб.

Слабозаметные действия: Страховочная запись на случай, если криминальный момент попадает на ту часть кадра, где он почти не виден, или события происходят так, что видеотдетектор не реагирует, или он не замечает полезную информацию в груде помех. Запись в этом случае всё равно производится, она не видна в архиве обычным способом, но может быть выведена в случае поиска ЧП.

Качество видео последовательности: стабилизация рывков и тайм-аутов вывода кадров на монитор.

Мощность: Параллельный код, реально оптимизированный под многопроцессорность. Большинство программистов до сих пор использует метод последовательного исполнения кода.

Надежность ОС: Специальная система контроля жизнеспособности операционной среды и оборудования, защищающая от зависаний и сбоев.

Интеграция: Поддержка всех распространенных протоколов, постоянная реинтеграция при внесении изменений производителями. Индивидуальна работа с неизвестными производителями устройств.

Оптимальное использование ресурсов: Оптимизация кода под видеоадаптеры, мультимедийные расширения процессоров, разновидности компьютерных комплектующих.

Отказоустойчивость сети: Резервирование каналов и сетевых элементов, перераспределение ресурсов в случае отказа какого-либо элемента или канала.

Охранная логика: гибкая многофункциональная логика, охватывающая все происходящие события в комплексе, а не просто «сработал датчик – взвыла сирена». Индивидуальная и неповторимая логика для каждого объекта, что гарантирует защиту от наличия опыта у криминала по вскрытию уже известных технологий.

Статистика и анализ: Видеоподсистема и ОПС GOALcity могут подсчитывать количество прошедших людей (по детектору лиц), проехавших автомобилей (по детектору автономеров), отдельных объектов (по видеоаналитике). А также точное количество транзакций: выполнения отслеживаемых комбинаций действий теми или иными объектами (логика SL++).

Всё это отображается как в реальном времени, так и выгружается в Exel-формат для дальнейшего анализа. Например, можно сравнить, соответствует ли число людей, прошедших контроль в кинотеатре, числу купленных билетов.

Кроме того, контроллеры всеразличных датчиков и измерительных устройств также могут вносить свою лепту. В реальном времени отображается статистика изменения температуры, давления, влажности, радиационной среды, качества воздуха и т.д.

Визуализация объекта: Плоские и объемные планы зданий с многоуровневой архитектурой, анимацией событий, видеовставками, интерактивным управлением. Любые виды 2D и 3D устройств в различных состояниях на вкус дизайнера.

GIS-навигация: Работа с масштабными территориями на картах местности. Интерактивное управление подвижными объектами GPS/GLONASS. Вывод видеокамер поверх слоев карт. Подгрузка информационных баз данных для интересующих объектов: планы зданий БТИ, список жителей, сведения о зарегистрированном оружии, наличие лиц с непогашенным сроком судимости, все базы ГИБДД о любом интересуемом автотранспорте, админпрактика водителей.

Автоматический поиск видеокамер: Всё ПО имеет возможность находить все доступные ему модули ПО и IP-камеры автоматически – собственным программным поиском в сети.

Мультимонитор: Поддержка большого числа мониторов, подключенных к одному ПК с независимым расположением окон ПО на каждом.

Ретрансляция: Возможность размножать потоки любой из камер для совместного её использования большим числом пользователей. При этом обеспечиваются режимы:

а) без персжатия – для экономии ресурсов ПК,

б) с пересжатием в нужный размер и формат.

в) с пересжатием и объединением нескольких камер в одно окно как отдельный экран.

с) путем ретрансляции RTSP.

Два типа оборудования для нейросетей: Нейронные сети для ПК работают как на центральном процессоре CPU, так и на процессорных мощностях видеоадаптеров GPU nVidia. А совместное их использование увеличивает общий эффект в скорости обработки нейронных сетей.

Логика: Специальный модуль для настройки сценариев поведения всех датчиков и оконечных устройств в совокупности всех сработок со всех доступных устройств – SL++. Создание сценариев поведения, на которые требуется сработка, и многоходовые виды сработок – в постоянном отслеживании дальнейших действий и вариантов реакции для них.

Статистика действий: Все действия всех устройств отображаются как в реальном времени (в журнале), так и выгружаться в Exel-формат для дальнейшего анализа.

Визуализация объекта: Плоские и объемные планы зданий с многоуровневой архитектурой, анимацией событий, видеовставками, интерактивным управлением. Любые виды 2D и 3D устройств в различных состояниях на вкус дизайнера.


Системные требования

»«

Системные требования

Системные требования - это описание примерных характеристик, которым должен соответствовать компьютер для того, чтобы на нём можно было использовать программу GOALcity.

ОС: Windows 10, Windows 11, Windows Server 2016, Windows Server 2019 с последними обновлениями.

Процессор:

§Intel Core i5, i7, i9 последних поколений и intel Xeon последних поколений, с частотой не ниже 3 ГГц

§AMD Ryzen r5, r7, r9 последних поколений и AMD Threadripper последних поколений, с частотой не ниже 3 ГГц.

Оперативная память: от 16 Гб.

Выбор оперативной памяти и мощности процессора будет зависеть от конфигурации системы и количества камер.

Видеокарта: Для работы с нейросетью необходима видеокарта NVIDIA GTX 1050 Ti и выше.

SSD рекомендуется использовать для ОС (250 Гб).

HDD рекомендуется использовать для хранения данных. Лучше всего подойдут специализированные диски для видеонаблюдения, например, WD Red Pro.

Для 3D плана требуется DirectX версии 9.0с выпуска июня 2010 года

Более подробно о системных требованиях можно прочитать здесь.

Поддерживаемые языки

В настоящее время в дистрибутив включены языки: русский, английский (США), французский (Франция), испанский (традиционная сортировка), азербайджанский (латиница).

По запросу в дистрибутив можно добавить любой другой язык.


Быстрый старт

»«

Быстрый старт

Для того, чтобы начать пользоваться программой GOALcity, необходимо выполнить несколько простых шагов:

1. Запустите файл "GOALcity_Medina_Free_x64.exe" и инсталлируйте софт, нажимая кнопку "Далее". Подробнее об установке бесплатной версии программы GOALcity вы можете прочитать здесь.

2. Запустите программу GOALcity, используя ярлык [image] .

3. После запуска программы на Диаграмме подключений откроется окно Подключение IP камер.

Если вы случайно закрыли Диаграмму подключений, открыть ее можно с помощью кнопки diagramma-03 на Главной панели управления.

4. Подключите камеры с помощью автоматического или ручного поиска.

5. Создайте архив в настройках Сервера архива.

6. Для того, чтобы настроить архив и запись перейдите в Настройки камеры. Для этого наведите мышку на окно камеры и нажмите кнопку button-settings .

Затем откройте вкладку Архив.

7. Перейдите во вкладку Запись.

8. Не выходя из Настроек камеры, перейдите во вкладку Нейросеть.

Вы можете выбрать Онлайн или Офлайн нейросеть.

Онлайн - вариант с постоянным анализом каждого кадра, который работает на видеосервере. В качестве аппаратной части используются аппаратные процессоры видеокарт.

Для работы нейросети рекомендуем установить видеокарту NVIDIA, соответствующую минимальным требованиям (память видеокарты минимум 4ГБ).

Обратите внимание, после установки нейросети необходимо перезагрузить программу и службу. Без этого шага нейросеть работать не будет!

После перезагрузки программы и службы снова зайдите в Настройки камеры, как это было описано выше и перейдите во вкладку Нейросеть.

Сейчас необходимо установить нейрокомпоненты. Вы можете активировать их по отдельности или комбинировать в зависимости от задач.

Снова перезагрузите программу и службу.

Обратите внимание, что для работы нейросети необходимо активировать ее на видеосервере и выбрать вычислительно устройство. Сделать это можно опять же в Настройках камеры, во вкладке Нейросеть.

По умолчанию, в качестве вычислительного устройства будет выбран процессор (CPU). Однако, для улучшения работоспособности нейросети, рекомендуем выбрать вычислительное устройство CUDA.

Подробнее об онлайн нейросети вы можете прочитать здесь.

Так же вы можете активировать Оффлайн нейросеть. Офлайн вариант не требует видеокарт и работает на обычном ЦПУ клиентской части приложения. Анализируются кадры только события, а не весь поток данных с видеокамер. Для Офлайн нейросети можно использовать даже слабые ноутбуки или планшеты.

Для того, чтобы активировать Офлайн нейросеть, перейдите в Настройки панели Внимание. Затем откройте вкладку Помехи, пункт Нейросеть. Установите переключатель в положение ACTIVATED.

Подробнее об оффлайн нейросети вы можете прочитать здесь.

9. Активируйте камеры в панели "Внимание!".

Если у Вас остались вопросы, Вы можете обратиться в нашу техническую поддержку.


Установка программы

»«

Установка программы

Для ознакомления с программой отлично подойдет Бесплатная версия аналитической системы видеонаблюдения GOALcity. Чтобы получить ссылку на страницу для скачивания, необходимо заполнить форму запроса бесплатной версии на сайте.

На указанный Вами электронный адрес будет выслано письмо с ссылкой для скачивания программы, а также логин и пароль для доступа к ней.

Для начала работы с программой GOALcity необходимо открыть установочный файл GOALcity_Medina_Free_x64.exe

Перед вами откроется окно с возможностью выбора языка. Выбрав нужный Вам язык, нажмите "ОК" для продолжения установки.

Затем появится окно с информацией о возможностях бесплатной версии GOALcity. Для продолжения нажмите кнопку "Далее"

Далее мастер установки предложит ознакомиться с лицензионным соглашением. Для того, чтобы согласиться с лицензионным соглашением, необходимо нажать кнопку "Принимаю". При нажатии кнопки "Отмена" установка программы будет прервана.

В появившемся окне необходимо выбрать папку, в которую программа GOALcity будет установлена. По умолчанию это папка C:\Program Files\Speclab\GOALcity. Для выбора другой папки нажмите кнопку "Обзор". Затем нажмите кнопку "Далее".

Затем перед Вами откроется окно с возможностью создания и настройки архива. Здесь Вы можете выбрать папку, куда будет записываться архив, а также указать ограничение объема архива. Максимальный размер локального архива будет равен установленному значению в поле "Ограничение размера архива". Если размер архива достигнет максимального значения, то старые записи будут удалены.

Если необходимости в создании архива нет, уберите "птичку" в пункте "Создать архив для записи камер" и нажмите кнопку "Далее".

Далее мастер уведомит Вас о том, что на Ваш компьютер будет установлена программа "Сбор технической информации GOALcity". В случае обнаружении проблем эта программа позволит собрать и отправить разработчику технические данные, необходимые для решения проблемы. Затем нажмите кнопку "Далее".

В открывшемся окне Вы можете выбрать папку для хранения базы данных лиц. По умолчанию это папка C:\Users\AppData\Local\Temp\ATT\FACEDB. Для выбора другой папки нажмите кнопку "Обзор", укажите необходимую Вам папку и нажмите "ОК", а затем нажмите кнопку "Далее".

Для установки системы передачи видео от видеокамер на Ваш мобильный телефон отметьте "птичкой" пункт "GOALmobile2" в открывшемся окне.

Если Вы отметите "птичкой" пункт "GOALmobile-2" перед Вами откроется окно Конфигуратора GOALmobile-2. Подробнее о настройке Конфигуратора Вы можете здесь.

Далее, в случае, если у Вас есть видеокарта NVIDIA GTX 1050 Ti и выше, откроется окно с возможностью установки нейронной сети и Базового набора классов, которая необходима для распознавания человека, автомобиля, багажа и животного. Отметьте "птичкой" пункт "Установить нейронную сеть и Базовый набор классов", а затем нажмите кнопку "Далее".

Перед Вами откроется окно с дополнительной информацией о настройках камер видеонаблюдения, с которой Вы можете ознакомиться нажав на фразу "Настройка камер видеонаблюдения".

После нажатия кнопки "Далее" появится окно с предложением посмотреть ознакомительный ролик, который откроется автоматически после нажатия кнопки "Установить".

Далее начнется установка. Это может занять некоторое время, пожалуйста, подождите.

По окончании установки программы Вам будет предложено запустить GOALcity и ознакомиться с настройками и быстрым стартом. Для продолжения нажмите кнопку "Готово".

Стоит еще раз отметить, что бесплатная версия программы GOALcity имеет ряд ограничений, подробнее о которых вы можете узнать здесь.

Для получения лицензии необходимо обратиться в SpecLab и наши специалисты с удовольствием ответят на Ваши вопросы!


Установка компонентов

Установка программы >

Установка компонентов

GOALcity – сетевая система, основная её особенность заключается в том, что различные ее составные части (программно-аппаратные компоненты) могут работать на разных компьютерах, объединенных в сеть. Так компьютер оператора (клиент) может находиться в одном месте, а ПК с платой или платами видеозахвата – в другом, удаленном от первого.

Дистрибутив GOALcity состоит из нескольких исполняемых файлов:

1. GOALcity_Client_x64.exe - Клиент GOALcity.

2. IP_Server_x64.exe - Мультимедиа сервер GOALcity

3. Archive_Server_x64.exe - Архивный сервер GOALcity

4. Analog_Video_Server_x64.exe – Видео сервер GOALcity

5. GOALcity_Analog_Audio_Server_x64.exe - Аудио сервер GOALcity

Далее подробно рассмотрим установку каждого компонента GOALcity.


Клиент_2

Клиент

Установка программы > Установка компонентов >

Клиент

Запустите исполняемый файл 1_GOALcity_Client_x64.exe. Мастер установки предложит выбрать используемый язык программы. Если Вы ошиблись с выбором языка, его можно будет изменить позже, используя Tweaker GOALcity.

На мониторе Вы увидите окно "Рабочее место оператора"

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена".

На следующем этапе установки Вам нужно выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции "Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск".

Далее мастер уведомит Вас о том, что на Ваш компьютер будет установлена программа "Сбор технической информации GOALcity". В случае обнаружении проблем эта программа позволит собрать и отправить разработчику технические данные, необходимые для решения проблемы. Отметьте "птичкой" необходимые Вам пункты, а затем нажмите кнопку "Далее".

В открывшемся окне Вы можете выбрать папку для хранения базы данных лиц. По умолчанию это папка C:\Users\AppData\Local\Temp\ATT\FACEDB. Для выбора другой папки нажмите кнопку "Обзор", укажите необходимую Вам папку и нажмите "ОК", затем нажмите кнопку "Далее".

Для установки системы передачи видео от видеокамер на Ваш мобильный телефон отметьте "птичкой" пункт "GOALmobile2" в открывшемся окне.

В случае, если Вы отметите "птичкой" пункт "GOALmobile-2" перед Вами откроется окно Конфигуратора GOALmobile-2. Подробнее о настройке Конфигуратора Вы можете здесь.

В случае, если у Вас есть видеокарта NVIDIA GTX 1050 Ti и выше, откроется окно с возможностью установки нейронной сети и Базового набора классов, которая необходима для распознавания человека, автомобиля, багажа и животного.

Затем нажмите кнопку "Далее".

После нажатия кнопки "Далее" откроется окно с предложением посмотреть ознакомительный ролик, который откроется автоматически после нажатия кнопки "Установить".

Далее начнется установка. Это может занять некоторое время, пожалуйста, подождите.

По окончании установки программы Вам будет предложено перезапустить компьютер. Выберите нужный Вам пункт и нажмите кнопку "Готово".


Мультимедиа сервер_2

Мультимедиа сервер

Установка программы > Установка компонентов >

Мультимедиа сервер

Запустите исполняемый файл 2_GOALcity_IP_Server_x64.exe. На мониторе Вы увидите окно "Установка Сервера поддержки сетевых устройств".

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена".

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции"Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск". Затем нажмите кнопку "Далее".

Перед Вами откроется окно с дополнительной информацией о настройках камер видеонаблюдения, с которой Вы можете ознакомиться нажав на фразу "Настройка камер видеонаблюдения".

После нажатия кнопки "Далее" откроется окно с предложением посмотреть ознакомительный ролик, который откроется автоматически после нажатия кнопки "Установить".

Далее начнется установка. Это может занять некоторое время, пожалуйста, подождите.

По окончании установки программы Вам будет предложено перезапустить компьютер. Выберите нужный Вам пункт и нажмите кнопку "Готово".


Архивный сервер_2

Архивный сервер

Установка программы > Установка компонентов >

Архивный сервер

Запустите исполняемый файл 3_GOALcity_Archive_Server_x64.exe На мониторе Вы увидите окно "Установка Сервера архивов"

Важно! Если Вы устанавливаете бесплатную версию ПО (GOALcity_Medina_Free_x64.exe) или общий сетап (GOALcity_MedinaBox_x64.exe), то отдельно архивый сервер ставить не нужно.

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена".

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции "Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск".

После нажатия кнопки "Далее" откроется окно с предложением посмотреть ознакомительный ролик, который откроется автоматически после нажатия кнопки "Установить".

Далее начнется установка. Это может занять некоторое время, пожалуйста, подождите.

По окончании установки программы Вам будет предложено перезапустить компьютер. Выберите нужный Вам пункт и нажмите кнопку "Готово".


Видео сервер_2

Видео сервер

Установка программы > Установка компонентов >

Видео сервер

Запустите исполняемый файл 4_GOALcity_Analog_Video_Server_x64.exe. Перед вами откроется окно "Сервер аналоговых видеокамер".

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена".

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции"Обзор". Затем нажмите кнопку "Далее".

Следующий шаг – выбор размещения папки программы в меню "Пуск"

Затем, мастер откроет окно "Опции установки", предлагающее три варианта инсталляции. К каждому из них даны достаточно подробные пояснения, поэтому выбрать нужный вариант не трудно.

Далее мастер уведомит Вас о том, что на Ваш компьютер будет установлена программа "Сбор технической информации GOALcity". В случае обнаружении проблем эта программа позволит собрать и отправить разработчику технические данные, необходимые для решения проблемы. Затем нажмите кнопку "Далее".

В открывшемся окне Вы можете выбрать папку для хранения базы данных лиц. По умолчанию это папка C:\Users\AppData\Local\Temp\ATT\FACEDB. Для выбора другой папки нажмите кнопку "Обзор", укажите необходимую Вам папку и нажмите "ОК", затем нажмите кнопку "Далее".

Для установки системы передачи видео от видеокамер на Ваш мобильный телефон отметьте "птичкой" пункт "GOALmobile2" в открывшемся окне.

В случае, если Вы отметите "птичкой" пункт "GOALmobile-2" перед Вами откроется окно Конфигуратора GOALmobile-2. Подробнее о настройке Конфигуратора Вы можете здесь.

После нажатия кнопки "ОК", в случае, если у Вас есть видеокарта NVIDIA GTX 1050 Ti и выше, откроется окно с возможностью установки нейронной сети и Базового набора классов, которая необходима для распознавания человека, автомобиля, багажа и животного.

Затем нажмите кнопку "Далее".

Следующий шаг, предложит выбрать какие из плат используются в системе - тип B, C или D. Все платы промаркированы необходимой буквой в верхней части, рядом с креплением в системный блок. Выберите нужные и нажмите кнопку "Далее".

После нажатия кнопки "Далее" откроется окно с предложением посмотреть ознакомительный ролик, который откроется автоматически после нажатия кнопки "Установить".

Далее начнется установка. Это может занять некоторое время, пожалуйста, подождите.

По окончании установки программы Вам будет предложено перезапустить компьютер. Выберите нужный Вам пункт и нажмите кнопку "Готово".


Аудио сервер_2

Аудио сервер

Установка программы > Установка компонентов >

Аудио сервер

Запустите исполняемый файл 5_GOALcity_Analog_Audio_Server_x64.exe. На мониторе Вы увидите окно "Сервер аналоговых микрофонов", в котором отображается версия программы и номер сборки.

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена".

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции"Обзор". Затем нажмите кнопку "Далее".

Следующий шаг – выбор размещения папки программы в меню "Пуск". Затем нажмите "Далее".

После этого мастер предложит выбрать какие из плат используются в системе - тип B, C или D. Все платы промаркированы необходимой буквой в верхней части, рядом с креплением в системный блок. Выберите нужные и нажмите кнопку "Далее".

После нажатия кнопки "Далее" откроется окно с предложением посмотреть ознакомительный ролик, который откроется автоматически после нажатия кнопки "Установить".

Далее начнется установка. Это может занять некоторое время, пожалуйста, подождите.

По окончании установки программы Вам будет предложено перезапустить компьютер. Выберите нужный Вам пункт и нажмите кнопку "Готово".


Подключение и настройка IP-камер

Типы питания для IP-камер видеонаблюдения

»«

Типы питания для IP-камер видеонаблюдения

Большинство современных ip камер видеонаблюдения поддерживают два стандарта питания:

1. Стабилизированное напряжение (5 В, 12 В или 24 В DC). В данном случае используется блок питания со соответствующими характеристиками (Примечание! Зачастую не входит в комплект поставки!)

2. Технология PoE (стандарт 802.3af) - питание и данные по сетевому кабелю витая пара. К примеру может быть использован PoE инжектор или сетевой HUB с данной технологией.

Схему подключения POE инжектора можно увидеть ниже на рисунке.

Примечание! Существует уже большое количество разновидностей стандартов POE поэтому учтите это при подборе данного оборудования и сопоставьте характеристики POE камеры и сетевого хаба для нее.

Так же бывают HUB устройства с различными вариантами Lan портов с POE и без, обычно POE порты на них выделены соответствующим образом.

Самым оптимальным является второй вариант подключения. Почти все современные камеры имеют данную технологию на борту что позволяет легко и без лишних проводов подключить камеру в сеть.


Подключение IP-камер к сетевому роутеру

Подключение и настройка IP-камер >

Подключение IP-камер к сетевому роутеру

Схема подключения IP-камеры с блоком питания к сетевому роутеру

Схема подключения ip камеры с PoE инжектором

Иногда помимо Lan порта камера может подключаться по средствам беспроводной связи Wi-Fi, но при этом, в любом случае, питание камеры будет осуществлено по одному из 2х вариантов выше.


Изменение IP адресса камеры

Подключение и настройка IP-камер >

Изменение IP адресса камеры

КАМЕРА И ВАШ КОМПЬЮТЕР ДОЛЖНЫ НАХОДИТЬСЯ В ОДНОЙ ПОДСЕТИ!

IP адрес состоит из двух частей: номера подсети и номера устройства. Первые три числа IP адреса - это номер сети, а последнее - номер устройства, подключенного к сети.

Рисунок 1

Таким образом, исходя из примера (Рисунок 1), все устройства, IP адрес которых начинается с номера 192.168.5, находятся в одной подсети.

Рисунок 2

Перед началом настройки камеры Вам необходимо узнать ее IP адрес, который можно найти на коробке от устройства. В случае, если IP адрес камеры найти не удалось, Вы можете сделать это с помощью утилиты, которую можно скачать на сайте производителя устройства. Так, например, для камер Hikvision это программа SADP. Достаточно просто скачать утилиту, запустить ее и программа сама найдет камеры своего производителя. Здесь же Вы можете изменить IP адрес камеры.

В случае, если возникли какие-то сложности, можно использовать другой способ. После того, как Вы узнали IP адрес камеры, необходимо сделать так, чтобы камера и Ваш компьютер находились в одной подсети. Это надо для того, чтобы Ваш компьютер и камера могли обмениваться данными.

Чтобы Ваш компьютер и камера были в одной подсети, необходимо сначала узнать подсеть своего компьютера. Это можно сделать двумя способами: через Свойства сети и с помощью командной строки.

Для того, чтобы узнать подсеть своего компьютера через Свойства сети, необходимо:

1. Зайти в "Пуск"
2. Открыть "Параметры"
3. Перейти во вкладку "Сеть и Интернет"

4. Выбрать пункт "Настройка параметров адаптера"

Рисунок 3

5. Выбрать свое сетевое подключение и, щелкнув ПКМ, открыть "Свойства"

6. В открывшемся окне выбрать пункт "IP версии 4 (TCP/IPv4)" и нажать на кнопку "Свойства"

7. Перед Вами откроется окно, где Вы сможете посмотреть свою подсеть и IP адрес компьютера

Рисунок 4

Для того, чтобы узнать подсеть своего компьютера с помощью командной строки, необходимо:

1. Открыть командную строку, нажав клавиши Win+R, затем ввести команду cmd и нажать ОК.

2. Перед Вами откроется окно командной строки, где необходимо ввести команду ipconfig и нажать enter

3. В строке IPv4-адрес будет указан IP адрес Вашего компьютера.

Рисунок 5

После того, как Вы узнали IP адрес камеры и свою подсеть, Вам необходимо изменить подсеть Вашего компьютера на подсеть камеры. Это надо для того, чтобы Вы могли зайти в настройки камеры и поменять ее IP адрес.

Чтобы изменить подсеть своего компьютера необходимо:

1. Открыть Свойства сети. Как это сделать было описано выше (Рисунок 3 и 4)

2. В поле "Использовать следующий IP адрес" прописать IP с подсетью, в которой находится камера (Рисунок 6)

Рисунок 6

После того, как Вы добавили Ваш компьютер и камеру в одну подсеть, Вы можете изменить IP адрес камеры для дальнейшего обмена данными между камерой и Вашем компьютером. Поменять IP адрес камеры можно двумя способами:

1. Зайти в настройки камеры с помощью Web браузера.

Пропишите IP Adress камеры в поисковой строке браузе. Перед Вами откроются настройки камеры, где Вы сможете вручную поменять IP камеры.

2. С помощью утилиты производителя

Обычно такие утилиты доступны на официальном сайте. Например, для камер Hikvision сущетсвует утилита SADP, которую можно скачать на сайте производителя.

После запуска утилиты перед Вами октроется окно со списком утройств Hikvision. Выберите Ваше устройство и в поле IP Adress укажите новый IP для камеры.

Рисунок 7

Обратите внимание, что после того, как Вы поменяли IP адрес камеры, необходимо вернуть компьютер в Вашу подсеть для того, чтобы компьютер и камера вновь оказались в одной подсети (Рисунок 6)!

Если у Вас возникли дополнительные вопросы, Вы можете обратиться в техническую поддержку.

Подробнее о дальнейшей настройке камеры Вы можете прочитать здесь.


Настройка и активация ONVIF на камерах

Подключение и настройка IP-камер >

Настройка и активация ONVIF на камерах

Работоспособность как нашей, так и других программ видеонаблюдения, зависит от правильной настройки IP-камер. А если еще точнее, то от активации функции ONVIF.

Сейчас для поиска и подключения всех камер в сети достаточно нажать одну кнопку, однако, в IP-камерах должен быть активизирован ONVIF. В противном случае ничего не найдется, камеры не подключатся, а пользователь, вместо видеопотоков с анимированной видеоаналитикой, увидит пустую панель управления.

Одна часть производителей продает свои камеры с уже активированной функцией ONVIF, а другая оставляет эту настройку на усмотрение пользователя. К сожалению, в России преобладают поставщики из второй группы и клиент вынужден сам настраивать свои камеры до начала настройки системы видеонаблюдения.

Наиболее известный поставщик - Hikvision, однако, нужная настройка спрятана здесь так далеко, что даже специалист не найдет ее за полчаса.

В разных камерах одной и той же фирмы (опять же говорим о Hikvision) эта настройка может быть спрятана в разных местах.

Кроме того, мало просто поставить галочку в нужном месте. Требуется еще завести пользователей и именно их пароли должны вбиваться в программу видеонаблюдения.

Такая система неудобна, потому что существует паралллельно другим пользователям, которые вбиваются для управления WEB-интерфейсом. Если вы зашли в настройки или в просмотр IP-камеры с помощью браузера, то это еще не значит, что с помощью этого же пароля подключите данную видеокамеру к программе видеонаблюдения.

В нашем случае действуют имена и пароли из списка пользователей именно ONVIF.

Ниже мы привели скриншоты данных настроек наиболее популярных видеокамер.

Еще раз отметим, что некоторые производители требуют создание нового пользователя для работы с ONVIF!

Acumen

Acumen

Axis

Axis

Base-IP

BasIp

Beward

ComOnyX

Dahua

Dahua

Evidence

Evidence

Hikvision

HiWatch

Hiwatch

Huawei

Huawei

NoName

Omny

Omny


Подключение IP-камер к системе GOALcity

Подключение и настройка IP-камер >

Подключение IP-камер к системе GOALcity

Самый распространенный способ подключения камеры в GOALcity по ONVIF протоколу осуществляется через "Настройки подключений", которые доступны через основное меню программы, либо через соответствующую кнопку на главной панели.

Далее выбираем "Мультимедиа сервер" и нажимаем на знак "+"

Перед вами появится мастер подключения Ip камер, выбираем «Автоматический поиск» или «Ручной».

1)При «Автоматическом поиске» находятся и выводятся все камеры по Onvif в текущей сети. Необходимо выбрать нужную камеру и нажать «Авторизоваться». Далее требуется ввести логин-пароль, камера становится «Выбранной». «Добавить в общий список» и «Применить» - камера подключится в новое окно GOALcity и будет готова для дальнейших настроек и использования в системе.

2)При «Ручном поиске» необходимо выбрать «Я знаю Ip адрес (URL) камеры», затем ввести IP и нажать «Проверить», далее появится выбор нашей камеры где необходимо произвести «Авторизацию» ввести логин-пароль, после чего нажать кнопку «Добавить в общий список» и «Применить», камера подключится в новое окно GOALcity и готова будет для дальнейших настроек и использования в системе.


Архивный сервер

»«

Архивный сервер

Архивный сервер - менеджер записи, хранения и просмотра видео-, аудиоданных, а также истории событий системы в комплексе или индивидуально по каждому элементу безопасности.

Он разграничивает доступ большого числа пользователей как локально, так и по сети, обеспечивая контроль прав, перераспределение ресурсов, защиту данных.

Для хранения видео используются полные кадры покадровой компресии, что ускоряют доступ к любому из них.

Архив GOALcity очищен от конфиденциальной информации и всех служебных данных, поступающих от источников видео.


Создание или подключение архива

Архивный сервер >

Создание или подключение архива

Для того, чтобы создать или подключить архив, необходимо:

1. Установить дистрибутив архивного сервера. Как это сделать, вы можете прочитать здесь.

Если Вы устанавливаете бесплатную версию ПО (Medina_Free_x64.exe) или общий сетап (MedinaBox_x64.exe), то отдельно архивый сервер ставить не нужно.

2. Запустить программу GOALcity, используя ярлык [image] .

3. Перейти на Диграмму подключений, нажав на кнопку diagramma-03 на Главной панели.

4. На Диаграмме подключений зайти в настройки Сервера архива и создать новый архив.

При создании архива вы можете выбрать ограничения архива

Ограничение размера архива - максимальный размер локального архива будет равен установленному в данном поле значению. Если размер архива достигнет максимального значения, то старые записи будут удалены.

Минимальное свободное место на диске - количество свободного места, которое будет игнорироваться программой при записи и всегда оставаться свободным. Минимальное значение не должно быть ниже 10% от общей емкости жесткого диска. Данный объем необходим для нормальной работы механизма "самостирания".

Максимальная длительность записи - по истечении указанного количества дней записи будут удалены.

5. Так же вы можете подключить ранее созданный архив

6. Настроить архив и запись. Как это сделать, вы можете прочитать здесь.


Настройка архива и записи

Архивный сервер >

Настройка архива и записи

Для того, чтобы настроить архив и запись, необходимо:

1. Перейти в Настройки камеры, нажав на кнопку button-settings на всплывающей панели в окне камеры

2. Открыть вкладку Архив

Писать в архив - выбор архива, в который данная камера будет записывать видео. В выпавшем окне будет выбор из архивов, подключенных к текущей сессии GOALcity.

Просматривать из окна камеры - выбор записи для просмотра в окне. Можно выбрать между записью с текущей камеры и записью из архива с удаленного сервера. Если оставить параметр Записываемый, то в окне будет воспроизводиться видео из архива, в который ведется запись.

3. Выбрать, какая запись будет выведена на просмотр при нажатии на кнопку button-play - Архив - на всплывающей панели в окне камеры.

Выводить на просмотр только основную запись этой камеры - в окне требуется просматривать только основную запись с камеры, расположенной в текущем окне.

Выводить на просмотр автономную записи этой камеры - в окне требуется просматривать только резервную запись с камеры, расположенной в текущем окне.

Выводить на просмотр основную и автономную записи этой камеры - в окне требуется просматривать как резервную, так и основную запись с камеры, расположенной в текущем окне.

Выводить на просмотр все записи выбранного архива - в окне требуется просматривать все записи, находящиеся в выбранном для просмотра архиве.

Для того, чтобы настроить запись, необходимо:

1. Перейти во вкладку Запись в Настройках камеры и активировать пункт Включить основную запись

Запись по детекции - запись будет производиться при наличии движения в кадре.

Минимальная избыточность - система будет записывать только те кадры, в которых присутствует детекция движения. Это сэкономит место на диске, однако, т.к. будут записываться не все кадры и не постоянно, есть возможность упустить что-то важное.

Средняя избыточность - оптимальный вариант для записи. Если не настроена страховочная запись (об этом чуть ниже), то в случае, когда детектор движения не активен, система вести запись не будет. Однако, если в кадре появится какое-либо действие, сразу же включится запись со скоростью, указанной в поле Скорость записи на время или определенное количество кадров.

2. Перейти во вкладку Страховка и настроить страховочную запись

3. Перейти во вкладку Контент и активировать нужный вам пункт

Записывать все кадры - если для записи требуются все кадры с текущей записи.

Записывать кадры, где есть движение - применяется там, где движение происходит редко, для экономии ресурсов жетских дисков.

Записывать кадры, где есть лица - если нужно записывать только те кадры, в которых система идентифицирует лица.

Записывать кадры, где есть автономера - если нужно записывать только те кадры, в которых система определяет автомобильный номер.

4. Перейти во вкладку Сервер и активировать Автономную запись.

Писать в архив - выбрать архив, в которые данная камера будет записывать видео. В выпавшем окне будут указаны все архивы, которые подключены к текущей сессии GOALcity.

Режим записи - режим записи, по которому будет вестись резервная запись:

-простой - запись будет производиться со скоростью, указанной в пункте Скорость записи, к/с.

-полный - запись будет производиться со скоростью, указанной в пункте Скорость записи, к/с, а при детекции движения ускорится до показателя, указанного в пункте Скорость записи по детекции, к/с.

-только по детекции - запись будет вестись только по детекции, со скоростью, указанной в пункте Скорость записи по детекци, к/с. Если движение в кадре отсутствует, то запись прекращается.

-сквозной - скорость записи будет равна скорости просмотра самого быстрого источника клиента (сервера). Если у источника (сервера) нет клиентов, скорость записи будет равна базовой скорости, установленной в пункте Скорость записи.

Таймаут записи по детекции - задержка записи после детекции движения.

5. Сохраните все изменения, нажав кнопку ОК.


Просмотр и фильтрация записей

Архивный сервер >

Просмотр и фильтрация записей

Чтобы посмотреть записанную информацию в GOALcity существует несколько способов:

СПОСОБ №1

Открыть архив непосредственно из окна камеры, кликнув по всплывающей кнопке button-play , получив записи именно этого источника.

Зачастую используется именно этот способ, но второй способ пригодится для одновременного синхронного просмотра нескольких камер в одном окне.

СПОСОБ №2

1. Кликнуть ЛКМ на значок archsrv-06 на Главной панели управления

2. Перед Вами откроется окно с возможностью выбора камеры, архив которой мы хотим просмотреть

Рассмотрим подробнее настройки данного окна

Выбор камеры и избыточности просмотра

Выберите записи для просмотра с интересующих вас камер, отметив соответствующие строчки флажками. Если в списке камер отсутствуют данные о дате записи, нажмите кнопку Получить диапазон.

Если необходимо выбрать другие камеры для просмотра записей - нажмите кнопку Снять выделение и произведите выбор снова. Для каждой из камер можно настроить Избыточность просмотра.

Избыточность просмотра

Минимальная – выводятся только те кадры, в которых произошла сработка детекторов (движения, лиц, автономеров и т.д.) и алгоритмов Панели "Внимание!". Это может быть дерганый просмотр, т.к. видеодетекция неоднородна и не всегда отражает полную картину. Но это минимальная информация, которая передает сюжеты перед камерой, как видит их машина. Рекомендуется использовать при недостатке времени на просмотр.

Средняя – выводятся все кадры, в которых произошла сработка алгоритмов и детекторов, а также те, которые были записаны до и после сработки. Проигрывание идет в однородной скорости. На просмотр выводятся даже те кадры, которые могли быть "не отмечены" детектором в силу незаметности движения (эмоции лица, движения глаз, разговорных мышц, легкие покачивания головой, конечностями и проч.) Выводятся также и промежутки между продетектированными движениями, например, тот период, пока человек стоял неподвижно. Кроме того, выдается некоторый период записи, предшествующей началу движения. Рекомендуется использовать при стандартном просмотре.

Максимальная – самая большая плотность кадров, в которую входит вся записанная информация. Как правило, это страховочная запись, которая делается на случай, если видеодетекцию по каким-либо причинам удалось обойти, например, при сильных атмосферных помехах. Рекомендуется использовать в случае рассмотрения происшествия и выводить только ограниченный период самого происшествия, т.к. постоянный просмотр такого объема записи требует крайне много времени.

Аналитика

Если отмечена опция Аналитика, то сюжеты, на которые среагировали алгоритмы аналитической системы "Внимание!" (Панель "Внимание!"), будут автоматически воспроизводиться плеером с максимальной избыточностью. Как правило, это новые события, нестандартное поведение или изменение обстановки в зоне обзора камеры.

На просмотр выводятся начальные моменты записанных сюжетов, а в окошке Аналитика выставляется интервал времени, который добавится при воспроизведении этих сюжетов. В полученных таким образом интервалах будут показаны все кадры без фильтрации. Рекомендуется использовать как основной тип просмотра в стандартном режиме постоянного контроля за объектом.

Завершив настройку, нажмите кнопку Готово. Перед вами откроется окно архивного плеера.

Окно архивного плеера

Окно плеера архива визуально разделено на 2 части: верхняя – окно просмотра, нижняя – элементы управления плеером и панели с информацией.

Воспроизводит записи архива программный многофункциональный видео плеер, который может:

-одновременно и синхронно демонстрировать записи с нескольких камер (каждую в отдельном окне);

-отключать/подключать просмотр одной или нескольких камер "на ходу" без остановки воспроизведения;

-переключать масштаб диапазона времени от 1 секунды до 4-х лет;

-производить поиск и отображение информации по разным признакам (детекция движения, оставленные, унесённые предметы, номера автомобилей, лица);

-графически отображать плотность записи;

-графически отображать запись сработок детекторов, как в общем потоке информации, так и отдельно по каждой из подключенных камер;

-переподключаться к архиву по команде оператора;

-производить экспорт информации в другой раздел ПК, на другие компьютеры, на другие носители: CD, DVD-диски и т.п.;

-сохранять отдельные кадры в формате *.jpg;

-изменять скорость воспроизведения в диапазоне от х0,10 (десятикратное замедление) до х64 (ускорение в 64 раза)

Раскраска интервалов записей на шкале времени плеера является неточным, исключительно оценочным инструментом. Алгоритм раскраски, при некоторых условиях, при наличии даже одного кадра с движением может привести к изменению цвета участка записи длительностью до нескольких минут и даже больше.

В верхней части отображается картинка, поступающая с архива записей камер. Наличие подписи под окном камеры и вид этой подписи переключается кнопкой . Каждый очередной клик по ней переключает вид подписи или совсем выключает её.

Следующая кнопка arch-prosmotr-05 служит для переключения соотношения сторон кадра. В нажатом состоянии кадр в окне воспроизводится с реальным соотношением сторон. Если кнопка неактивна, кадр заполняет окно камеры полностью и может воспроизводиться с искажением размера кадра в зависимости от размера окна.

Кнопка arch-prosmotr-06 переворачивает изображение на 180 градусов.

Кнопка arch-prosmotr-07 позволяет установить фильтры для отбора плеером соответствующей информации из архива. Подключив желаемые фильтры, нажмите кнопку "Ок".

Левее располагаются кнопки, отвечающие за включение/отключение от просмотра архива определённых камер. Например , – окно архива камеры 2 включено.

В нижней части окна плеера находится Панель управления. Линия, отделяющая эту область окна, может перемещаться, изменяя зону просмотра и зону управления плеером.

Ниже этой линии – кнопки выбора диапазона: крайняя справа позволяет выбрать диапазон непосредственно по датам, при этом можно воспользоваться встроенным календарём, открывающимся при клике по треугольнику в окошке "Годы".

Сама кнопка "Диапазон" является частью Селектора масштабирования диаграммы архива. Под селектором находится диаграмма архива, показывающая наличие записи и её плотность.

Кнопки Селектора позволяют выбрать наиболее удобный масштаб диаграммы. Нажатие кнопки с названием соответствующего периода времени означает, что масштаб диаграммы будет соответствовать этому периоду.

Панель управления плеером видеоархива

Большинство кнопок Панели управления плеером снабжены всплывающими подсказками, которые помогают быстро разобраться с их назначением. Тем не менее несколько пояснений не помешают.

Итак, слева направо. Кнопка "Переподключение" – ей удобно воспользоваться, когда необходимо просмотреть записи с тех камер, которых сейчас в окне просмотра нет. Кликнув по ней, вы попадёте в меню выбора записей для просмотра, здесь, отметив соответствующие флажки, можно сменить просматриваемые камеры.

Далее – кнопка "Настройки". При нажатии на нее открывается окно "Плеер – настройки", в котором можно установить некоторые опции плеера архивов.

Следующая кнопка позволяет сохранить фрагменты архивных видеозаписей как на жестком диске компьютера, так и на внешних носителях информации. После нажатия на неё откроется окно "Экспорт видео", в котором надо произвести соответствующие настройки: выбрать формат экспорта (SSDF или AVI), путь сохранения (раздел, каталог и название файла) и ввести, если необходимо, краткое описание.

С помощью следующей кнопки производится экспорт отдельного кадра. При нажатии её доступны следующие опции: сохранить в файле, скопировать в буфер обмена и печать. В случае выбора первой из них вы попадете в окно "Сохранение текущего кадра". Здесь нужно указать программе, куда записать снимок, и настроить с помощью ползунка качество записи изображения в формат *.jpeg. Чем более высокий процент вы выберете, тем лучше будет качество, но тем больше будет размер файла. Копирование в буфер обмена позволяет переместить кадр в другую программу или в документ, например, в MS Word при написании рапорта или объяснительной. Выбор опции "Печать" откроет диалог принтера, подключенного к компьютеру.

Чтобы автоматически перейти к следующему диапазону, после окончания воспроизведения текущего нажмите на Панели управления плеером видео архива кнопку arch-prosmotr-15 записи по текущей камере нажмите кнопку arch-prosmotr-16

Следующие две кнопки при воспроизведении архивных записей не активны. Воспользоваться ими можно только когда воспроизведение оставлено. Их назначение: помочь Вам в поиске нужных записей и их фрагментов.

arch-prosmotr-20 - Кнопки управления воспроизведением. Функции их разъясняются всплывающими подсказками. Далее на Панели управления плеером видео архива следуют две кнопки arch-prosmotr-21 с окошком между ними. Это регуляторы и индикатор скорости воспроизведения. С помощью стрелки влево можно замедлить воспроизведение до х0,10, т.е. в 10 раз, а стрелка вправо позволит ускорить его до х64, т.е. в 64 раза.

Поиск объектов и движения

Кнопка arch-prosmotr-18 откроет окно "Поиск объектов" в текущем диапазоне просмотра и в выбранной (или не выбранной) зоне. Если зона поиска не указана, то поиск будет производиться по всем кадру. Чтобы настроить фильтр объектов, нажмите кнопку "Настройки", Вы попадёте в таблицу, где расстановкой флажков-галочек в соответствующих клетках и установите цифровые значения нужных критериев поиска и нажмите кнопку "Готово", после чего, нажмите кнопку "Старт" и запустите поиск. Результаты поиска отобразятся в окне в виде кадров.

По умолчанию все категории открыты и активны. Вы можете отключить и свернуть "не нужные".

Контекстное меню окна управляет способом открытия-закрытия вкладок. Если активировать пункт "Раскрывать только один элемент", то на просмотр будет выводиться только один активный элемент, все остальные будут "спрятаны".

Поиск объектов можно производить и в определенной области видео. Для этого "наведите" курсор мыши на видео и в правом верхнем меню появится всплывающее меню, кликните по кнопке "Зоны поиска".

Выделите с помощью мыши необходимую зону для поиска.

Количество зон поиска не ограничено и Вы можете выделить сразу несколько. Чтобы удалить "ненужную" зону, "схватите" её левой кнопкой мыши и "утащите" за пределы окна архивного плеера.


Архив событий

Архивный сервер >

Архив событий

Архив событий необходим для того, чтобы сохранять короткие ролики с панели "Внимание!" . Такие ролики не занимают много места на жестком диске и если с панели "Внимание!" они регулярно удаляются, то в архив событий они сохраняются до тех пор, пока есть свободное место на жестком диске. Если запись с архива начнет перезаписываться через месяц или два, ролики событий Вы можете посмотреть даже через год.

Для того, чтобы подключить и настроить архив событий необходимо:

1. Зайти на Диаграмму подключений и, нажав ПКМ на "Сервер архива", выбрать вкладку "Настройки".

2. Затем выбрать пункт "Архив событий" и поставить галку напротив пункта "Разрешить архив событий"

3. Нажав в этом же окне кнопку "Настроить" вы сможете выбрать папку, в которую будут сохраняться ролики, а также количество потоков записи, длительность архива, и свободное место на диске.

4. Далее закройте Диаграмму подключений.

После того, как вы произведете настройки, описаные выше, видеоролики с Панели "Внимание!" будут сохраняться в указанную вами папку.


Нейронная сеть

»«

Нейронная сеть

Нейронные сети способны идентифицировать силуэты людей, автомобилей, животных, переносимых объектов и прочие полезные цели, которые действительно интересны пользователю. Нейросеть распознает необходимый объект в любой освещенности, с любых сторон, со всеми углами подвеса камеры, в разных масштабах как на дальнем плане, так и на переднем, исключая помехи (веточки, блики, тени и т.д.).

Пользователь нашего софта может выбрать Онлайн или Оффлайн нейросеть.

Посмотреть, как нейронные сети работают на практике, вы можете здесь.


Онлайн нейросеть

Нейронная сеть >

Онлайн нейросеть

Онлайн нейросеть - это вариант с постоянным анализом каждого кадра, который работает на видеосервере с установленными мощными картами nVidia. В качестве аппаратной части здесь используются процессоры видеокарт.

Для того, чтобы установить нейросеть, необходимо:

1. Перейти в "Настройки камеры", нажав на кнопку button-settings на всплывающей панели выбранной вами камеры.

2. Перейти во вкладку "Нейросеть" и нажать на кнопку "Установить полную версию нейронной сети".

3. Перезапустить программу и службу. Для этого необходимо выйти из настроек камеры, нажать кнопку [image] на Главной панели и выбрать в открывшемся окне "Перезапустить программу и службу".

4. После того, как нейросеть будет установлена, необходимо активировать ее и выбрать вычислительное устройство CUDA, на котором нейронная сеть будет работать. Сделать это можно в Настройках камеры.

5. Для того, чтобы использовать нейросеть, необходимо установить компоненты фильтра нейронной сети, которые используются для решения нестандартных задач на основе классификации объектов. Чтобы их установить, откройте вкладку Компоненты, выберите нужный вам набор классов и нажмите Установить.

6. После этого необходимо снова перезапустить программу и службу.

7. Далее переходим в Настройки камеры -- Нейросеть и выбираем вкладку "Компоненты". Здесь необходимо выбрать нужный вам компонент фильтра нейронной сети и нажать "Подключить", а затем "ОК".

Обратите внимание, что программа GOALcity позволяет установить сразу несколько компонентов фильтра нейронной сети.

Посмотреть, как нейросети работают на практике, вы можете здесь.


Оффлайн нейросеть

Нейронная сеть >

Оффлайн нейросеть

Офлайн вариант нейросети не требует видеокарт и работает на обычном ЦПУ клиентской части приложения. Анализируются кадры только события, а не весь поток данных с видеокамер. В случае ее активации любой событийный ролик перед тем, как выйти на панель "Внимание!", проверяется на наличие в нем объектов указанных классов. При отсутствии объектов во всех кадрах этого ролика или отсутствии их заданного типа активности, событийный ролик сбрасывается в "урну". Для Офлайн нейросети можно использовать даже слабые ноутбуки или планшеты.

Для того, чтобы активировать Офлайн нейросеть, необходимо:

1. Перейти в "Настройки панели "Внимание!".

2. В открывшемся окне выбрать необходимую камеру и перейти в ее "Настройки".

3. Далее перейти во вкладку "Помехи", выбрать пункт "Нейронная сеть" и активировать алгоритм.

С помощью настроек можно выбрать, какие объекты вас интересуют. По умолчанию установлено два условия: Наличие в кадре человека или движующегося транспортного средства. Логично, что просто стоящий автомобиль не содержит событийной информации.

Вы можете настроить алгоритм таким образом, чтобы на панель "Внимание!" были выведены только события, где объекты классов:

- присутствуют (Программа будет выводить только те ролики, на которых присутствуют объекты указанных классов);

- отсутствуют (Программа будет выводить только те ролики, на которых отсутствуют объекты указанных классов);

- появляются (Программа покадрово проверяет ролик и, если на начало проверки объектов указанных классов не было, а в последующих кадрах они есть, это и будет считаься повлением. Т.о., на панель "Внимание!" будут выведены только те алгоритмы, во время сработки которых появятся объекты указанных классов);

- исчезают (Программа покадрово проверяет присутствие объектов указанных классов в ролике и, если на начало проверки объекты были, а в последующих кадрых их не будет, это и будет считаться исчезновением объектов. Такой ролик будет выведен на панель);

- двигаются (Будут выводиться все ролики, на которых двигаются объекты указанных классов. Для таких объектов как автомобили чаще всего необходимо отслеживать не их присутствие в кадре, а только движение. В отличие от человека, автомобиль может находиться в кадре вечно, что не добавляет информативности, а только увеличивает бесполезные сработки).

Настройка объектов классов.

Для добавления объектов:

1. Отметьте "птичкой" необходимый пункт и после того, как кнопка "Настроить..." станет активной, нажмите на нее.

2. Перед вами откроется окно "Настройка параметров фильтра". Нажмите кнопку "Добавить".

3. В окне "Настройка параметров класса" укажите:

Класс - выберите в соответствии с установленной нейросетью.

Минимальная вероятность - отвечает за точность сравнения детектируемых объектов с базой данных нейросети. Если полезные объекты не определяются, этот показатель необходимо понизить. Если полезные объекты определяются как помехи - повысить.

Минимальная ширина объекта детекции. Устанавливается в процентном соотношении от размера кадра. Данный показатель требуется для отсеивания особо мелких (по ширине) предметов.

Минимальная высота объекта детекции. Устанавливается в процентном соотношении от размера кадра и требуется для отсеивания особо мелких (по высоте) предметов.

Максимальная ширина объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных (по ширине) предметов.

Максимальная высота объекта детекции. Устанавливается в процентном соотношении от размера кадра. Данный показатель требуется для отсеивания особо крупных (по высоте) предметов.

4. После настройки всех параметров нажмите "ОК" и в окне "Настройка параметров фильтра" появится выбранный вами класс. Снова нажмите "ОК".


Панель "Внимание!"

»«

Панель "Внимание!"

Назначение панели "Внимание!"- активизировать группу аналитических алгоритмов, предназначенных для того, чтобы обратить внимание оператора на события, представляющие определённую опасность для объекта наблюдения.


Основные настройки панели

Панель "Внимание!" >

Основные настройки панели

При первой установке программы Панель "Внимание!" включится по умолчанию. Если же вы устанавливаете новую версию программы и при этом сохранили прежние её настройки, то потребуется включить и настроить Панель.

Для того, чтобы включить и настроить панель "Внимание!", необходимо:

1. Открыть Главное меню программы и перейти в пункт Настройки панели "Внимание!"

В открывшемся окне отобразится список подключенных к системе панелей "Внимание!". Можно удалить уже подключенные или добавить новые панели.

Чтобы удалить ненужную панель, необходимо отметить ее флажком и нажать кнопку Удалить. Если просто снять галочку и нажать кнопку pакрыть, то выбранная панель пропадет с монитора, но не удалится из системы.

Кнопка Добавить добавляет новую панель сразу на монитор. Все действия с ней аналогичны ранее описанным.

2. Указать папки, куда будут сохраняться данные.

Папка базы данных - укажите путь , куда будут сохраняться ролики с панели "Внимание!".

Папка базы данных лиц - укажите путь, где будут храниться добавленные лица для идентификации.

Корневая папка для обмена видеороликами - укажите путь, по которому панель будет хранить ролики для последующей их передачи в GOALmobile 2.

3. Настроить панели "Внимание!".

Здесь перечислены все камеры по которым панель "Внимание!" может вести аналитический анализ.

Клик ЛКМ по строчке камеры включает\выключает обработку камеры панелью, а клик ПКМ - открывает параметры текущей камеры.

В строке Статус мобильного оповещения задайте важность событий с текущей панели. Этот параметр будет влиять на настройки оповещений при связке GOALcity с GOALmobile 2.

Кнопка "Дополнительно" открывает расширенные настройки панели "Внимание!".

Настройка отображения событий:

Чтобы переименовать панель, введите необходимое имя в строку Наименование. Следующие два поля отвечают за расположение роликов на панели и соотношение сторон. Подстройте параметры под Ваши нужды.

Расположение – Устанавливает способ расположения кадров на панели «Внимание!». Например, если задать способ отображения Сверху-Вниз, то новые события будут отображаться наверху панели, а старые будут смещаться вниз.

Соотношение сторон – Устанавливает соотношение сторон роликов на панели «Внимание!».

Показывать полный кадр – Выбирается способ отображения нового события, т.е. если данная опция включена, то при появлении нового события на панель будет выведен полный кадр с событием, а если выключена - то только область кадра, в которой данное событие произошло.

Максимальное число событий на панели - Устанавливается максимальное количество одновременно отображаемых на панели «Внимание!» роликов с событиями.

Количество строк (столбцов) – устанавливается внешний вид отображения кадров на панели по количеству строк (если панель "Внимание" расположена горизонтально) или столбцов (если панель "Внимание!" расположена вертикально.

Корректировать высоту (ширину) - позволяет вручную корректировать размер ролика на панели "Внимание!" .

Границы кадров – Устанавливается ширина и цвет полосы, разделяющей кадры на панели "Внимание!".

Цвет каймы линейки истории – Устанавливается цвет выделения границ окна истории при его открытии.

Показывать тень линейки истории – При активации, граница линейки истории будет отбрасывать тень.

Проигрывать ролики на панели – устанавливается способ отображения событий на панели «Внимание!», либо статическая картинка, либо последовательность кадров.

Задержка перед повторным проигрыванием – Временной интервал между последним кадром в ролике и повторным воспроизведением ролика на панели «Внимание!».

Показывать всплывающую кнопку включения прокрутки – Включает отображение кнопки прокрутки. Кнопка прокрутки включает\отключает режим перехода к новому ролику.

Например, вы прокрутили панель с роликами вниз и не видите последних (самых свежих) событий, если данная опция включена, то при появлении новых событий, панель будет автоматически прокручиваться к появившемуся событию. Соответственно при отключении, мы сможем "листать" панель свободно, перехода к новому событию не произойдет.

Прокручивать на самое старое – Меняет очередность попадания роликов на панель «Внимание!». Старые ролики всегда будут в начале.

Проигрывать звук при добавлении ролика – Будет проигрывать звуковой сигнал при попадании ролика на панель «Внимание!». Нажмите кнопку «Настроить» и выберите звуковой сигнал который будет проигрываться. Можно выбрать предустановленный сигнал, либо установить свой в формате *.wav.

Включать экран при новом событиии - Эта опция позволяет включать экранпри появлении нового события. Для корректной работы отключите экран блокировки в настройках операционной системы.

Не очищать панель при завершении программы – При завершении или перезагрузки программы на панели "Внимание!" сохранятся все события. Она поможет в том случае, если необходимо не потерять текущие ролики при перезапуске программы или внезапной перезагрузке ПК.

Работа с подтверждениями:

Опция Режим работы с подтверждением активирует таймер панели "Внимание!" и "заставляет" охранников следить за тем, чтобы панель "Внимание!" оставалась чистой, иначе тревожные события будут автоматически передаваться в настроенный заранее центр мониторинга. Проще говоря, если охранник не отреагирует на событие (закроет его или закомментирует) то это событие автоматически будет отправлено по определенному, заранее настроенному адресу.

Показывать кнопку Очистить панель - Добавляет кнопку Очистить панель на таймер работы с подтверждениями.

Трансляция:

Транслировать событие – включение трансляции панели - панель, как отдельная камера, появится в списке Мультимедиа сервера.

Добавлять комментарий – Опция актуальна при использовании нескольких панелей «Внимание!». Если она активна, то при перетаскивании событий с одной панели на другую, Вам будет обязательно предложено создать комментарий.

Публиковать на сервере архивов, Загружать с удаленных серверов архивов – Данные функции позволяют получать события на панель "Внимание!" не подключив ни одной камеры. Активируйте функцию Публиковать на сервере архивов на "сервере". Добавьте архив с сервера на диаграму подключений и активируйте функцию.

Загружать с удаленных серверов архивов на "клиенте". Нажмите кнопку настроить и унажите с какого сервера необходимо получать события.

На панель "Внимание!" клиента будут приходить ролики с панели "Внимание!" с выбранного сервера.

Время работы - Можно указать время работы панели "Внимание!".

Экспорт и импорт:

Экспортировать только ролики в формате mp4 – При активации, события с панели "Внимание!" будут сохранятся в отдельную папку в формате mp4. Так же необходимо активировать работу GM2 в настройках панели "Внимание!". После этого, по указаному на скриншоте пути, для каждой панели "Внимание!" создастся папка с инемем в формате ГГ-ММ-ЧЧ в которую и будут сохранятся ролика с панели "Внимание!".

Импортировать ролики в формате mp4 – Импортировать ролики с других панелей "Внимание!" в формате mp4.

Путь к папке импорта – Укажите путь к папке для импортируемых роликов с других панелей "Внимание!".

Важно! Не рекомендуется создавать папку импорта на системном и архивных дисках.

Импортированные ролики необходимо – Выберите действие которое необходимо произвести с роликоми после импорта их на панель "Внимание!"(удалять, переименовывать или переносить в подпапку).

Технические настройки (только для специалистов СпецЛаб):

Общая очередь кадров – Технологическая настройка - только для специалистов.

Кешировать ролики в памяти – При проигрывании на панели "Внимание!" ролики постоянно обращаются к жесткому диску. При активации, видимые ролики на панели "Внимание!" будут задействовать ресурсы опреативной памяти, а не жесткого диска.

Переупаковывать кадры – Данная настройка применяется в случае, когда на компьютере мало оперативной памяти и присутствует притормаживание интерфейса GOALcity при работе с панелью "Внимание!". Стоит учесть что переупаковка кадров разгрузит оперативную память, но повлечет за собой дополнительную нагрузку на процессор.

Распаковывать кадры асинхронно – Технологическая настройка - только для специалистов.

Использовать внешний конвертер – Технологическая настройка - только для специалистов.

Контекстное меню событий на панели "Внимание!"

Нажав правой кнопкой мыши по одному из "кадров" Панели "Внимание!" Вы вызовете контекстное меню.

•Комментировать - написать комментарий по данному событию.

•Показать камеру - разворачивает окно камеры с актуальным изображением, по которой сработал алгоритм.

•Показать запись - позволяет оперативно просмотреть фрагмент записи, выполненной по отображенному на Панели событию.

•Показать историю - отображает в выпадающей панели историю событий панели "Внимание!" по выбранной камере.

•Настройки панели - открывает настройки панели "Внимание!"


Настройка отображения алгоритмов

Панель "Внимание!" >

Настройка отображения алгоритмов

Доступ к настройкам

Параметры отображения алгоритмов индивидуальны для каждой камеры на панели "Внимание!" и настраиваются исходя из требуемых задач.

Для того, чтобы открыть настройки необходимой вам камеры, кликните правой кнопкой мыши по "шапке" панели "Внимание!".

Вкладка Общие

Перед Вами откроется окно с основными настройками отображения алгоритмов панели.

В левой части окна расположены основные параметры, в правой части окно с "живым" видео с текущей камеры.

Отображать дату - отображение даты на ролике с панели «Внимание!». Если данная функция выключена, то на ролике будет отображаться только время события. Рекомендуется использовать там, где события происходят редко.

Отображать название алгоритма - отображение названия алгоритма на панели «Внимание!». Рекомендуется применять, когда на панель приходят данные с разными алгоритмами, для облегченного понимания произошедшего.

Отображать номер автомобиля - активирует отображение автомобильного номера, в ролике с автомобилем, что упрощает прочтение номеров, появившихся в кадре.

Мигание рамки вокруг камеры - при возникновении события, вокруг окна камеры будет мигать рамка.

Проигрывать только при наведении указателя - отключает постоянное проигрывание роликов на панели «Внимание!». События будут появляться в виде фотографий, а воспроизводиться только при наведении указателя мыши.

Отрисовывать состояние алгоритмов -включает или отключает индикаторы, которые дают информацию о состоянии алгоритмов. Они имеют вид разноцветных прямоугольников и расположены в нижней части окна камеры.

Показывать окно просмотра при добавлении события - активирует окно с событием (оно "всплывает" и в увеличенном размере располагается в центре экрана) при сработке алгоритма на Панели "Внимание!".

Включение экрана при новом событии - позволяет включать экран при появлении нового события, если настроено автоматическое выключение экрана.

Отображать надписи - позволяет задать произвольные надписи поверх видео у всех видеороликов для текущей камеры и текущей панели "Внимание!".

Так же, вместо обычного текста Вы можете использовать переменные:

%t - выведет текущее время поверх видеоизображения в формате Ч:М

%T - вермя в формате Ч:М:С

%d - выведет текущую дату, а %D текущую дату с указанием дня недели.

Вкладка Параметры

Увеличение области события - регулирует, насколько сильно увеличивать область, в которой произошло какое-либо событие (область, в которой сработал какой-либо алгоритм). По умолчанию, установлена единица, т.е. область события не увеличивается. Установка "2" увеличит область события в 2 раза и т.д.

От начала события проигрывать - устанавливает, какой промежуток времени выводить на панель "Внимание!" до сработки какого-либо из алгоритмов. Значение по умолчанию в 3 секунды позволяет выводить сам момент сработки алгоритма и 3 секунды после этой сработки. Эта настройка определяет лишь максимальное значение длительности ролика, а сам ролик формируется исходя из собственных алгоритмов, задача которых передать смысл изменений.

Коэффициент замедления - позволяет регулировать скорость отображения ролика на панели "Внимание!". Значение по умолчанию 2 - замедляет воспроизведение в 2 раза от оригинального. Таки образом, можно рассмотреть событие более детально.

Интервал смежности - говорит о том, что сколько бы событий не обрабатывала панель "Внимание!" по текущей камере, периодичность их появления будет не менее, чем, например, 15 секунд. То есть, после сработки любого алгоритма должно пройти минимум 15 секунд до сработки следующего.

События на панели "Внимание!" можно увеличивать двойным кликом для более детального просмотра. При этом они "разворачиваются" на всю область рабочего стола и автоматически закрываются через период времени, указанный в поле Закрывать окно просмотра через.

Избыточность:

Минимальная – выводятся только те кадры, в которых произошла сработка детекторов (движения, лиц, автономеров и т.д.) и алгоритмов Панели "Внимание!". Это может быть дерганый просмотр, т.к. видеодетекция неоднородна и не всегда отражает полную картину. Но это минимальная информация, которая передает сюжеты перед камерой, как видит их машина. Рекомендуется использовать при недостатке времени на просмотр.

Максимальная – самая большая плотность кадров, в которую входит вся записанная информация. Как правило, это страховочная запись, которая делается на случай, если видеодетекцию по каким-либо причинам удалось обойти, например, при сильных атмосферных помехах. Рекомендуется использовать в случае рассмотрения происшествия и выводить только ограниченный период самого происшествия, т.к. постоянный просмотр такого объема записи требует крайне много времени.


Алгоритм "Авария"

Панель "Внимание!" >

Алгоритм "Авария"

Алгоритм панели "Внимание!" Авария служит для оперативного оповещения оператора о том, что с одной из видеокамер пропал видеосигнал. Даже если оператор отвлекся, он всегда увидит это оповещение на одной из панелей.

Чтобы настроить алгоритм, откройте настройки панели "Внимание!" и перейдите на вкладку Авария. Настраивается алгоритм отдельно для каждой камеры.

Чтобы включить алгоритм, установите переключатель в положение ACTIVATED.

Начальная задержка - устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и прочим.

Допустимое время отсутствия видео - устанавливает период, после которого будет выводиться оповещение на панель "Внимание!". По умолчанию данное значение всегда 30. То есть, если видео "пропало" на 29 секунд и появилось на 30-ой - оповещения не будет.

Длительность ролика последних записанных в архив кадров - устанавливает длительность ролика, который будет выведен на панель "Внимание!".

Реагировать на отсутствие записи - поможет вам отслеживать моменты пропадания видеозаписи с текущей камеры в случае повреждения жесткого диска или каких-либо других проблем. На панель внимание так же будет выведен ролик с последними секундами записи и иконкой перечеркнутого жесткого диска.

Реагировать на перекрытие и расфокусировку камеры - для отслеживания моментов перекрытия и расфокусировки камеры. На панель так же будет выведен ролик с последними секундами записи и иконкой перечеркнутого жесткого диска.

Транслировать тестовый ролик и записывать его для GM2 каждые... - позволяет установить время (в минутах), как часто будет выводиться и записываться тестовый ролик.

Выводить тестовый ролик на панель - на панель "Внимание!" выводится тестовый ролик.

Обратите внимание! Для работы алгоритма необходимо, чтобы у камеры была настроена и включена запись в архив, т.к. ролики формируются именно из текущего архива камеры.

Кнопка [image] откроет неполные настройки архива на выбранной вами камере. Как настроить архив вы можете посмотреть здесь.

Кнопка [image] откроет окно, в котором можно настроить действия с камерой в случае, если она будет перекрыта.

Активировать детектор тамперинга - включает детектор перекрытия и видеодетектор объектов. Данные настройки являются серверными и затронут все клиенты, которые подключаются к нему.

Задержка сработки - задержка выдачи сигнала о появлении темперинга. Т.е. может определить наличие нарушения, но сообщит о нём только спустя указанное время, при условии, что в течение этого времени тамперинг сохранится. Это позволяет отстроиться от кратковременных нарушений или непредвиденных помех, которые могут нарушить работу алгоритма.

Задержка восстановления - работает аналогично пункту Задержка сработки, но уже на этапе снятия сигнала о наличии тамперинга.

Период сброса состояния детектора - время, по истечению которого, выполнит сброс до состояния идентичному началу работы детектора при старте программы.

Подавать звуковой сигнал - позволяет включить и выбрать подачу звукового сигнала, если камера перекрыта.

Записывать события в Журнал - записывает сообщения о потери связи в системный журнал GOALcity, который можно открыть из главного меню, пункт Просмотр журнала.

Вкладка Дополнительные предназначена для технических специалистов и не требует изменений.


Алгоритм "Лица"

Панель "Внимание!" >

Алгоритм "Лица"

Алгоритм панели "Внимание!" Лица – выявляет в кадре появление человеческих лиц, оценивает их индивидуальные параметры, позволяя идентифицировать людей и сопоставлять их с базами данных.

Для того, чтобы активировать алгоритм Лица, необходимо:

1. Зайти в Настройки панели "Внимание!". Как это сделать, вы можете посмотреть здесь. И перейти во вкладку Лица.

2. Перевести ползунок активации алгоритма Лица в положение ACTIVATED и активировать Идентификацию лиц на сервере. Подробнее об Идентификации лиц вы можете прочитать здесь.

Стоит отметить, что для того, чтобы идентифицированные лица попадали на панель "Внимание!", необходимо активировать работу алгоритмов панели для данной камеры. Если это не сделать, лица на панель "Внимание!" попадать не будут. Для этого кликните по имени камеры в окне настройки панели «Внимание!». При этом пункты Настроить, Имя камеры и Имя сервера должны поменять цвет на зеленый.

Описание настроек

Вкладка "Эта панель" служит для активации и настройки алгоритма Лица, а также для создания списка имен для данной панели.

Деактивировать – Включить-выключить отображение алгоритма «Лица» на «панели Внимание!».

Время отслеживания - Время прохождения перед камерой. Если одно и то же лицо повторяется, увеличьте значение!

Живое лицо (защита от картинок) – опция предназначена для защиты от картинок (фотографий). С отключенной функцией лицо будет определяться с одного ракурса. При активации опции "2 ракурса" лицо определится, только если человек покажет в камеру не менее двух ракурсов (анфас и профиль). При активации опции "3 ракурса" лицо определится, только если покажет в камеру не менее трех ракурсов (анфас, профиль левый, профиль правый).

Точность сравнения - Если лица не находятся в базе, уменьшите значение. Если имена не совпадают с лицами, увеличьте! Нормальный уровень - 50%.

Выводить всех - При активации данной функции на панель "Внимание!" будут попадать все обнаруженные лица.

Добавить - Добавить лицо в список имен из общей базы.

Удалить - Удалить лицо из списка имен.

Удалить все - Удалить все лица из списка имен.

Искать имена - может быть активирована только при включенной опции "выводить всех". При активации, попавшие на панель "Внимание!" известные лица, будут подписаны согласно списку имен.

Выводить только имена из списка – При активации данной функции на панель "Внимание!" будут попадать только те лица, которые есть в списке имен.

Выводить только неизвестных - При активации данной функции на панель "Внимание!" будут попадать только те лица, которых нет в списке имен.

Настроить - Открывает окно настроек Идентификации, о которых было сказано выше.

Каждая камера имеет свою индивидуальную базу лиц. Чтобы добавить базу лиц, необходимо нажать кнопку Добавить на данной вкладке.

Изначально список имен будет пуст и вы можете добавить туда определенных людей или всех сразу. При этом панель «Внимание!» может работать в трех режимах - выводить только людей из списка, выводить только людей не из списка или выводить всех.

Перед вами откроется окно со списком добавленных ранее лиц. Выберите нужные имена и нажмите кнопку ОК. Для выделения нескольких имен просто выделите их по очереди. Чтобы снять выделение - кликните по имени еще раз. Нажмите кнопку Выбрать все чтобы выбрать все имена.

Если в список имен не добавить ни одного имени, то панель "Внимание!" будет выводить все лица, которые обнаружит.

Расположение папки с общей базой лиц можно задать в Настройках панелей «Внимание!».

Вход в настройки производится через главное меню программы.

Чтобы открыть главное меню, нажмите кнопку главной панели управления [image] .

В открывшемся списке выберите пункт Настройка панелей "Внимание!".

Вкладка "Общая база"служит для создания базы имен из файлов пользователя.

В программе GOALcity есть два вида базы лиц: общая база лиц и база лиц (список имен) для конкретной панели «Внимание!». Общая база лиц распространяется на всю программу, а список лиц только на определенную камеру.

Общая база формируется путем добавления лиц из уже имеющихся у вас фотографий и новых лиц из панели «Внимание!», которые попадают туда с камер видеонаблюдения с включенным алгоритмом Лица.

Добавить - добавляет файл с изображением лица в общую базу лиц.

Добавить папку - добавляет папку с изображениями лиц в общую базу лиц.

Удалить - удаляет один или несколько файлов с лицами из общей базы лиц.

Список имен для конкретной панели "Внимание!" формируется путем добавления лиц из общей базы.

Вкладка "Управление" служит для активации и управления IP контроллером Телепатия.

Деактивировать – Включить-выключить отображение алгоритма «Лица» на «панели Внимание!».

Задержка - задержка замыкания ключа после сработки алгоритма.

Таймаут - задержка замыкания ключа между сработками алгоритма.

Адрес, порт - ip адрес и порт по которому находится контроллер.

Логин, пароль - учетные данные для доступа к контроллеру.

Номер ключа - ключ, который будет замыкатся при сработки алгоритма.

Замкнуть на - время на которое замкнется выбраный ключ.

Проверить - проверяет доступность контроллера и выводит соответствующее сообщение.

Важно! Время в пункте Таймаут должно быть больше чем время в пункте Замкнуть на, это необходимо для корректной связи контроллера и GOALcity, ввиду сетевых задержек.

Например, когда мы ставим Таймаут 2 секунды, мы, также говорим GOALcity ждать ответа от контроллера 2 секунды, если при это в пункте Замкнуть на указаны 2 секунды, то ответ от Телепатии, что она все выполнила, не успевает придти, ввиду сетевых задержек. Потому рекомендуется указывать значение Таймаут, хотя бы на 1 пункт больше, чем в Замкнуть на.

Вкладка "Статистика" служит для активации автоматического заполнения общей базы лиц и отслеживания статистики.

Автоматически добавлять неизвестные лица - неизвестные лица будут автоматически добавляться в общую базу. Неизветному лицу присвоится цифровой идентификатор, который может быть изменен.

Вести статистику - отображает сколько раз определенное лицо попало на камеру.

Выводить ролик только если количество посещений больше - минимальное количество раз, которое одно и тоже лицо должно определится, прежде чем ролик с ним попадет на панель "Внимание!".

Детектирование лиц в камерах на входе дает возможность посчитать количество людей, зашедших в здание или пришедших на мероприятие.

Для включения данной функции кликните правой кнопкой мыши по «шапке» панели «Внимание!» и в появившемся окне поставьте галку на против пункта «Окно статистики».

Окно статистики будет вести подсчет всех событий для данной панели «Внимание!»

Для сброса счетчика нажмите [image] . Для закрытия


Алгоритм "Авто"

Панель "Внимание!" >

Алгоритм "Авто"

Алгоритм Авто служит для оперативного оповещения оператора о том, что в обзоре одной из видеокамер появился автомобильный номер. Даже если оператор отвлекся, он всегда увидит это оповещение на одной из панелей "Внимание!".

Для того, чтобы активировать алгоритм Авто, необходимо:

1. Зайти в Настройки панели "Внимание!". Как это сделать, вы можете посмотреть здесь. И перейти во вкладку Авто.

2. Перевести ползунок активации алгоритма Авто в положение ACTIVATED и активировать Детектор автономеров. Подробнее о Детекторе автономеров вы можете прочитать здесь.

Стоит отметить, что для того, чтобы идентифицированные автономера попадали на панель "Внимание!", необходимо активировать работу алгоритмов панели для данной камеры. Если это не сделать, автономера на панель "Внимание!" попадать не будут. Для этого кликните по имени камеры в окне настройки панели «Внимание!». При этом пункты Настроить, Имя камеры и Имя сервера должны поменять цвет на зеленый.

Описание настроек

Продолжительность отслеживания - Время проезда автомобиля перед камерой. Если один и то же номер повторяется, увеличьте значение!

Реагировать только на номера из списка - При активации данной функции на панель "Внимание!" будут попадать только те номера, которые есть в списке номеров.

Не реагировать на номера из списка - При активации данной функции на панель "Внимание!" будут попадать только те номера, которых нет в списке номеров.

Список номеров:

Для добавления номера в список номеров нажмите кнопку Добавить и напечатайте нужный номер в формате "А111АА37". Если один из символов неизвестен, замените его вопросительным знаком (?). Например: "А11?А?37".


Алгоритм "Помехи"

Панель "Внимание!" >

Алгоритм "Помехи"

Бесполезные записи помех, которых бывает очень много при наружном видеонаблюдении, отнимают массу дорогого времени при просмотре архивов. Поэтому алгоритмы Растения, Атмосфера, Нейронная сеть, Движение фильтруют помехи так, чтобы у пользователя оставалась только полезная информация.

Для того, чтобы активировать фильтр помех, необходимо:

1. Зайти в Настройки панели "Внимание!". Как это сделать, вы можете посмотреть здесь. И перейти во вкладку Помехи.

2. Перевести ползунок активации фильтра Помехи в положение ACTIVATED.

Для того, чтобы необходимые вам алгоритмы попадали на панель "Внимание!", необходимо активировать их для данной камеры. Если этого не сделать, объекты на панель "Внимание!" попадать не будут.

Кликните по имени камеры в окне настройки панели «Внимание!», чтобы активировать ее. При этом пункты Настроить, Имя камеры и Имя сервера должны поменять цвет на зеленый.

Кнопка [image] активирует алгоритм Помехи для всех камер, а кнопка [image] только для конкретной камеры и дублирует ползунок act132 в пункте Параметры.


Растения

Панель "Внимание!" > Алгоритм "Помехи" >

Растения

Алгоритм Растения позволяет выявлять устойчивые помехи и сразу исключать ее из алгоритмов видеоаналитики. Как правило, это помехи, создаваемые движением веток деревьев, кустов, травы и теней от них.

Данный алгоритм наиболее эффективный способ защиты от помех, за исключением нейросетей. Но нейросети требуют наличия видеокарт nVidia, которые не входят по габаритам в мини-компьютеры и планшетные домофоны. Кроме того, даже на полноценных ПК нейросети ухудшают свою работу в условиях почти полной темноты, поэтому в ночное время без освещения рекомендуется активизировать этот алгоритм с помощью расписания времени.

Для того, чтобы активировать алгоритм Растения, необходимо:

1. Зайти в Настройки панели "Внимание!". Как это сделать, вы можете посмотреть здесь. И перейти во вкладку Помехи.

2. Перевести ползунок активации фильтра Помехи в положение ACTIVATED.

3. Перейти во вкладку Растения и перевести ползунок активации алгоритма в положение ACTIVATED.

Описание настроек

Уровень помех – Если ложные сработки идут часто, повысьте уровень помех. Если полезные объекты не определяются, то понизьте.

По умолчанию – Сбрасывает настройку уровня помех до состояния по умолчанию.

Проводить настройку при загрузке программы – Позволит проводить подстройку алгоритма при каждом запуске в автоматическом режиме. Система сама проанализирует видеопоток и "вычленит" проблемные места.

Отображать карту уровня опасности в окне камеры – Позволяет включить цветовое наложение на видеопоток, на котором будут отмечены красным цветом зоны исключенные из внимания. Данную опцию можете включить, если вам интересно, в каком месте кадра система определила помехи.

Толщина каймы опасной зоны – система пытается предугадать начальную стадию развития помехи. Например, ветер только начинается и качает лишь незначительно ветку. Следующий порыв ветра с более сильным колебанием ветки будет компенсирован этой каймой.

Время нарастания уровня движения – Время непрерывной детекции движения, спустя которое, в окне камеры будет отображаться карта уровня опасности.

Время снижения уровня движения – В течении установленного времени, при отсутствии детекции движения, карта уровня опасности будет постепенно уменьшаться, а по истечению установленного времени, исчезнет.

Настройка зоны особого внимания – Еще один инструмент повышения качества обнаружения полезных целей, позволяет обозначить зону в кадре, где видеодетекция наиболее вероятна: чаще, чем в других местах кадра, ходят люди или проезжают автомобили. Это фирменный алгоритм Спецлаб, имеющий закрытую информацию типа работы. Для пользователя важно лишь то, что помех будет меньше, правильных сработок – больше.

Такую маску следует накладывать только в те места, где исключаются естественные помехи. Эта маска не должна превышать 50% площади кадра, иначе алгоритм потеряет свой смысл.

Настройка времени:

Как правило, характер помех сильно отличается в светлое и темное время суток, особенно на улице. Поэтому каждому алгоритму можно задать свой период действия.

Например, ночью эффективнее работает Атмосфера, а днем - Нейросеть.

Включен постоянно – При активации алгоритм будет выполняться всегда.

Включен в указанное время - При активации появляется возможность включения и отключения алгоритма в заданное время.

Включен ночью - Позволяет указать географические координаты места установки камеры. Для автоматического определения координат требуется подключение к сети Интернет.

Настройка зоны особого внимания:

Кисть – Позволяет выбрать размер кисти.

Маскировать/Стирать – С установленной галкой кисть будет рисовать, без галки стирать.

Получить кадр – Обновляет кадр в окне настройки зон особого внимания.

Очистить – Очищает кадр от нарисованной зоны.


Атмосфера

Панель "Внимание!" > Алгоритм "Помехи" >

Атмосфера

Алгоритм Атмосфера фильтрует помехи, проявлющиеся на большой площади кадра. Как правило, это блики прожекторов или ИК-подсветок во время дождя и снега. А также резкая смена освещенности, в том числе включение света.

Чтобы активировать алгоритм Атмосфера необходимо:

1. Зайти в Настройки панели "Внимание!". Как это сделать, вы можете посмотреть здесь. И перейти во вкладку Помехи.

2. Перевести ползунок активации фильтра Помехи в положение ACTIVATED.

3. Перейти во вкладку Атмосфера и перевести ползунок активации алгоритма в положение ACTIVATED.

Описание настроек

Объединять помехи по всем кадрам ролика – Оценивает площади детекции всех кадров ролика события, объединяя их в одну общую площадь.

На отдельных кадрах может не быть превышения детекции по площади, но по другим кадрам идет много ложных сработок в разных частях кадра. В этом случае рекомендуется активировать эту настройку.

Атмосферные помехи – постарайтесь, с помощью двух «ползунков», визуально «подогнать» площадь нарисованных на видеоизображении помех к тому, что Вы реально видите в кадре. Другими словами, выберите максимальную площадь детекции с помощью этого прямоугольника, если детекция будет больше указанной площади, то сработок алгоритмов не будет.

Настройка времени - как правило, характер помех сильно отличается в светлое и темное время суток, особенно на улице. Поэтому каждому алгоритму можно задать свой период действия. Подробнее о настройке времени вы можете прочитать здесь.


Нейронная сеть

Панель "Внимание!" > Алгоритм "Помехи" >

Нейронная сеть

Нейросеть позволяет избирательно реагировать на те или иные действия именно человека или машины.

Нейросеть в данном случае не определяет сработку алгоритмов, а только дополняет их своими фильтрами.

В случае её активации в этом разделе, любой событийный ролик перед тем, как выйти на панель «Внимание!», проверяется на наличие в нем объектов указанных классов. При их отсутствии во всех кадрах ролика или отсутствии их заданного типа активности, событийный ролик сбрасывается в «корзину».

Для того, чтобы активировать алгоритм Нейронная сеть, необходимо:

1. Зайти в Настройки панели "Внимание!". Как это сделать, вы можете посмотреть здесь. И перейти во вкладку Помехи.

2. Перевести ползунок активации фильтра Помехи в положение ACTIVATED.

3. Перейти во вкладку Нейронная сеть и перевести ползунок активации алгоритма в положение ACTIVATED.

Обратите внимание, что для работы алгоритма необходимо установить нейросеть и активировать фильтр нейронной сети на видеосервере! Как это сделать, вы можете прочитать здесь.

Описание настроек

Выводить только события, где объекты классов:

- присутствуют – Программа будет выводить только те ролики на панель «Внимание!», на которых присутствуют объекты указанных классов.

- отсутствуют – Программа будет выводить только те ролики на панель «Внимание!», на которых отсутствуют объекты указанных классов.

- появляются – На панель «Внимание!» будут выводится только те алгоритмы, во время сработки которых появятся указанные объекты классов. Программа покадрово проверяет ролик и если на начало проверки объекта не было, а в последующих кадрах он есть, это и будет считаться появлением.

- исчезают – На панель «Внимание!» будут выводится только те алгоритмы, во время сработки которых исчезнут указанные объекты классов. Программа покадрово проверяет присутствие объекта в ролике, и если на начало проверки объект был, а в последующих кадрах его не будет, это и будет считаться исчезновением.

- двигаются – Будут выводится все указанные, двигающиеся объекты. Для таких объектов как автомобили чаще нужно отслеживать не их присутствие в кадре, а только движение. В отличие от человека, автомобиль может находиться в кадре вечно, что не добавляет информативности, а только увеличивает бесполезные сработки.

Тестовые функции:

Не рекомендуется включать без указания службы технической поддержки.

Добавлять информацию о работе фильтра – Данная функция включает вывод служебной информации в ролике на панели «Внимание!».

Выводить все ролики – При включении на панель «Внимание!» будут попадать все ролики.

Настройка объектов классов

Для того, чтобы добавить объекты, необходимо:

1. Выбрать типы событий, которые будут попадать на панель "Внимание!".

2. Добавить необходимые вам классы в окне Настройка параметров фильтров.

3. Настроить параметры класса в окне Настройка параметров класса.

Задайте класс – Выберите из предустановленных или впишите сами в соответствии с установленной нейронной сетью.

Минимальная вероятность - Отвечает за точность сравнения детектируемых объектов с базой данных нейросети. Если полезные объекты не определяются, то понизить. Если определяются помехи как полезные объекты – повысить.

Минимальная ширина – Минимальная ширина объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких по ширине предметов.

Минимальная высота – Минимальная высота объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких по высоте предметов.

Максимальная ширина – Максимальная ширина объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных по ширине предметов.

Максимальная высота – Максимальная высота объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных по высоте предметов.

Также вы можете настроить время работы алгоритма. Как это сделать вы можете прочитать здесь.


Движение

Панель "Внимание!" > Алгоритм "Помехи" >

Движение

Данный фильтр исключает сработку видеоаналитики на статических сюжетах при отсутствии активности.

Если видеоаналитика регистрирует событие, например «новое лицо», «новый госномер», «новая гамма» и т,д., и при этом отсутствует сработка обычного видеодетектора движения (обычно синие рамки), то данное событие не выводится на панель «Внимание!».

Генеральная активация исключает реакцию при отсутствии любого движения в кадре. Если вы поставите галочку в «Отслеживать только область события», наличие видеодетекции будет проверяться только в зоне события. Например, в районе номера автомобиля.

Если в кадре периодически обнаруживается гос.номер стоящего автомобиля, то сработка на это явление может производиться какждый раз, когда проезжающий транспорт освещает его фарами. Данный фильтр проверяет реагировать лишь на движение самого автомобиля с определившимся номером или активности в его зоне нахождения.

Для того, чтобы активировать алгоритм Движение, необходимо:

1. Зайти в Настройки панели "Внимание!". Как это сделать, вы можете посмотреть здесь. И перейти во вкладку Помехи.

2. Перевести ползунок активации фильтра Помехи в положение ACTIVATED.

3. Перейти во вкладку Движение и перевести ползунок активации алгоритма в положение ACTIVATED.

Обратите внимание, что для работы алгоритма необходимо настроить детектор движения. Как это сделать, вы можете прочитать здесь.

Отслеживать только область события – При активации будет выводить ролики на панель "Внимание!" только при детекции движения в области события.

Также вы можете настроить время работы алгоритма. Как это сделать вы можете прочитать здесь.


Настройка времени

Панель "Внимание!" > Алгоритм "Помехи" >

Настройка времени

Как правило, характер помех сильно отличается в светлое и темное время суток, особенно на улице. Поэтому каждому алгоритму можно задать свой период действия.

Например, ночью эффективнее работает Атмосфера, а днем - Нейросеть.

Включен постоянно – При активации алгоритм будет выполняться всегда.

Включен в указанное время - При активации появляется возможность включения и отключения алгоритма в заданное время.

Включен ночью - Позволяет указать географические координаты места установки камеры. Для автоматического определения координат требуется подключение к сети Интернет.


Видеосемантика

Панель "Внимание!" >

Видеосемантика

Видеосемантика — краткое логическое изложение видеоинформации путём разложения ее на семантические единицы (видеосюжеты), каждый из которых имеет свой законченный смысл, отличающийся от предыдущего и последующего видеосегмента. Это особое направление видеоаналитики — так называемая гибкая видеоаналитика, не имеющая жестких параметров и точной формализации.

Видеосемантика отслеживает характерные черты видеоконтента в результате анализа статистических изменений, таким образом, осуществляется селекция видео-событий по их смысловому отличию. Семантика в языкознании изучает смысл единиц языка, а в видеоаналитике изучает смысл единиц видеособытий. И там, и там — это набор знаний, объединенных между собой определенными соотношениями.

Видеосемантика базируется на большом наборе различных типов видеодетекторов, изучающих свойства объекта (его размеры, соотношения сторон, цветовую гамму, направление движения, скорость, частоту движений, параметры изменений…). Все эти характеристики связаны между собой математическими соотношениями, основанными на закономерностях поведения различных типов объектов.

Отсутствие жестко заданных параметров и точной формализации защищает от помех, так как они включаются в общий анализ и вычитаются сами из себя в результате разности статистических изменений.

Видеосемантика позволяет разграничивать события по их отличительным признакам, что дает возможность автоматизировать многие процессы, связанные с поиском видеоконтента в длительных записях или в режиме реального видеонаблюдения.

Видеосемантика раскладывает видеопоследовательность на смысловые единицы. Дополнительные программы могут выделять ту часть смысловой единицы, который полностью характеризует весь фрагмент. И, в итоге, вместо монотонной видеозаписи получается разделенный на короткие фрагменты видеоряд, вмещающий в себе смысл всей записи в удобном для восприятия любым, даже неподготовленным человеком, виде.

Для того, чтобы активировать алгоритм Видеосемантика, необходимо:

1. Зайти в Настройки панели "Внимание!". Как это сделать, вы можете посмотреть здесь. И перейти во вкладку Видеосемантика.

2. Перевести ползунок активации алгоритма Видеосемантика в положение ACTIVATED.


Новизна

Панель "Внимание!" > Видеосемантика >

Новизна

Алгоритм Новизна является наиболее часто используемым из всего набора видеосематических алгоритмов. Принцип работы основан на сравнивании ключевых моментов видеоряда. Особенно хорошо алгоритм себя проявляет на "статических" камерах, другими словами, в том случае, когда движение в кадре не постоянно. Например, задний двор вашего дома. Как правило там редко кто-то появляется, но, если появится, вы получите мгновенное оповещение хоть на компьютер, хоть на мобильный телефон. Алгоритм работает по принципу "Ничего нет - что-то появилось".

Алгоритм не требует особых настроек и сам "подстроится" под реалии вашего объекта.


Поступательность

Панель "Внимание!" > Видеосемантика >

Поступательность

Алгоритм Поступательность основан на анализе поступательного движения человека, машины, и т.д.

Для примера возьмем проходную с одним входом и выходом расположенными в одном направлении. Алгоритм Новизна в этом случае нам особо не поможет, потому что движение в проходной практически постоянное, но вот Поступательность будет более чем кстати.

Алгоритм анализирует траекторию движения людей по коридору и подстраивается под обстановку. Если большинство людей идет прямо к выходу, алгоритм запомнит это и не будет обращать Ваше внимание, но вот если один из них вдруг решит изменить свое направление и, например, зайти в подсобку справа, вы тут же увидите об этом на панели "Внимание!", мобильном телефоне или планшете.

Или другой пример - автомобильная дорога. Установлен знак "Только прямо", но есть возможность повернуть в ту или иную сторону. Алгоритм подстроится под прямолинейное движение автомобилей, а Вы увидите на панели "Внимание!" только злостных нарушителей.

Настроек алгоритм так же практически не требует и сам подстроится под вашу ситуацию на объекте.


Количество

Панель "Внимание!" > Видеосемантика >

Количество

В отличии от алгоритма Количество, применяемого в жесткой видеоаналитике, в "гибкой" видеосемантике алгоритм ведет себе совсем иначе. При использовании "жесткого" алгоритма, нам необходимо указывать количество объектов, их размер и прочую служебную информацию для отработки алгоритма. Здесь же ничего этого не требуется. Необходимо только указать, насколько широкий угол обзора у Вашей камеры, все остальные параметры алгоритм подберет "сам". Работа основана на "долгосрочном" анализе, другими словами алгоритм накапливает статистику по размещению объектов в поле зрения камеры. Например, мимо вашей камеры постоянно ходят люди, по 1-му, вдвоем. Алгоритм "привыкнет" к таким группам и не будет заострять Ваше внимание на эти события, но, если пойдет более большая группа людей Вы сразу же получите об этом сигнал.

Или, например, перекресток и стоп линия. Ширина проезжей части может "вместить" один автомобиль перед стоп линией. Алгоритм "привыкнет" что автомобиль там должен быть только один. И если кто-то захочет нарушить и "вылезет" вторым рядом, система мгновенно оповестит вас об этом.

Из настроек мы предлагаем Вам указать только насколько широкий угол обзора у Вашей камеры, остальное алгоритм все сделает "сам".


Площадь

Панель "Внимание!" > Видеосемантика >

Площадь

Расширяет сферу применения жесткого видеоаналитического алгоритма Площадь. Принцип работы схож с алгоритмом Количество, и работают они, как правило, в паре. Опять же, вся разница в том, что нам не нужно задавать конкретных параметров. Сработка алгоритма основана на накоплении видеостатистики. Например, мы смотрим на место для курения. Обычно покурить выходят 1-2 человека одновременно. Алгоритм "привыкнет" к этому. Если "курильщиков" выйдет больше, дружно сядут на лавочку и начнут мило беседовать, Вы получите об этом оповещение.

Настройка алгоритма так же сведена к минимуму, необходимо только указать насколько "широко" смотрит Ваша камера и примерное время сравнения изменений в видеоряде


Гамма

Панель "Внимание!" > Видеосемантика >

Гамма

Алгоритму Гамма можно найти огромное количество применений начиная от прямого назначения "Свет есть - свет погас" и заканчивая более изощренными, например, нахождение в темном потоке машин светлой или наоборот. Так же алгоритм мгновенно предупредит о перекрытии камеры, о сильной засветке или прочих "нештатных" ситуациях. Будет полезен практически в любой ситуации, и может обратить Ваше внимание на то, о чем Вы бы и не подумали. Прекрасно сигнализирует о возгораниях, задымлениях и т.д.

Настройка не прихотлива. Укажите только примерную разницу в освещении, которую Вам необходимо отслеживать. Остальную работу алгоритм сделает за Вас.

Для работы алгоритма "Температура" необходимо установить GOALTHERMO для выбранной камеры.


Нейронные сети

Панель "Внимание!" >

Нейронные сети

Нейронная сеть способна в хаосе помех находить силуэты людей, автомобилей, животных, переносимых предметов, атрибутов одежды и прочие полезные цели, которые действительно интересны пользователю. Она распознает необходимый объект в любой освещенности, с любых сторон, со всеми углами подвеса камеры, в разных масштабах как на дальнем плане, так и на переднем.

Информация в нижней части рамки детекции отображаются в формате "Х:ХХХ" и означают:

Х: - порядковый номер анализируемого кадра;

:ХХХ - время, затраченное на анализ одного кадра в миллисекундах.


Нейро-Б

Панель "Внимание!" > Нейронные сети >

Нейро-Б

Базовый набор нейросетей

Люди, автомобили, животные - появление, движение, остановка, начало движения, изменение характера активности, багаж (классификация на сумки, рюкзаки, коробки, чемоданы) - оставленные-унесенные предметы с показом хозяина.

Для того, чтобы активировать алгоритм Нейро-Б, необходимо:

1. Зайти в Настройки панели "Внимание!". Как это сделать, вы можете посмотреть здесь. И перейти во вкладку Нейро-Б.

2. Перевести ползунок активации алгоритма Нейро-Б в положение ACTIVATED.

Обратите внимание, что для того, чтобы активировать алгоритм, необходимо установить и настроить нейросеть. Как это сделать, вы можете прочитать здесь.

Описание настроек

Деактивировать - Включить-выключить отображение алгоритмов нейросети на «панели Внимание!».

Максимальное количество кадров в ролике – Определяет количество кадров в ролике, которые попадают на панель «Внимание!».

Добавлять в ролик - Укажите, что будет отображаться в ролике на панели "Внимание!", все кадры, кадры с движением или объектами нейросети.

Учитывать интервал смежности роликов – Активирует использование интервала смежности для нейронной сети.

Интервал смежности отвечает за частоту попадания роликов с детекцией на панель «Внимание!».

Обратите внимание, что устанавливается интервал смежности в настройках панели «Внимание!», на вкладке Общие.


Детектор людей

Панель "Внимание!" > Нейронные сети > Нейро-Б >

Детектор людей

Детектор людей - служит для распознавания в изображении силуэтов людей и классификации их действий, присущих людям

Для работы алгоритма необходимо установить нейросеть и активировать фильтр нейронной сети на видеосервере!

Для того, чтобы активировать детектор людей, необходимо:

1. Зайти в Настройки панели "Внимание!". Как это сделать, вы можете посмотреть здесь. И перейти во вкладку Нейро-Б.

2. Перевести ползунок активации алгоритма Нейро-Б в положение ACTIVATED.

3. Перейти во вкладку Человек и перевести ползунок активации алгоритма в положение ACTIVATED.

Обратите внимание, что для того, чтобы необходимые Вам алгоритмы попадали на панель "Внимание!", необходимо активировать их для данной камеры. Если это не сделать, объекты на панель "Внимание!" попадать не будут, но будет работать нейросеть и визуализация.

Для этого кликните по имени камеры в окне настройки панели «Внимание!». При этом пункты Настроить, Имя камеры и Имя сервера должны поменять цвет на зеленый.

Описание настроек

Объект

Минимальная вероятность – Отвечает за точность сравнения детектируемых объектов с базой данных нейросети. Если люди не определяются, то понизить. Если определяются помехи как человек – повысить.

Минимальная ширина объекта детекции - устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких по ширине предметов.

Минимальная высота объекта детекции - устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких по высоте предметов.

Максимальная ширина объекта детекции - устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных по ширине предметов.

Максимальная высота объекта детекции - устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных по высоте предметов.

Отображать объекты – При активации данного пункта вокруг объекта будет отображаться цветная рамка со служебной информацией. (название объекта, вероятность совпадения и т.д.)

Параметры

Время допустимого отсутствия – Время на которое детектируемый объект может быть перекрыт до повторного обнаружения. Если объект был перекрыт на превышающее установленное время, то программа определит его как новый объект.

Количество кадров истории - Количество кадров, которые программа хранит в своей памяти для анализа и вывода алгоритмов на панель "Внимание!".

Точность сравнения – Допустимое изменение площади неподвижного объекта. Если программа находит одного и того же неподвижного человека несколько раз - под разными ID, уменьшите значение. Если из двух рядом стоящих людей определяется только один, увеличьте значение.

Разрешенное смещение в процентах от ширины кадра - Если неподвижный объект производит движения не превышающие установленный параметр, то для программы он останется неподвижным.

Время определения неподвижности - Устанавливает время неподвижности объекта для определения алгоритма "Остановка". Если движущийся объект остановится, то только после истечения установленного времени он будет считаться неподвижным.

Время определения движения - Устанавливает время движения объекта для определения алгоритма "Начало движения". Если неподвижный объект начнет движение, то только после истечения установленного времени программа определит начало движения.

Действия

Движение - Включает/выключает определение движения объекта. Если объект попал в кадр во время движения, то ему будет присвоен алгоритм "Движение"

Остановка - Включает/выключает определение остановки объекта. Если объект попал в кадр во время движения, но затем остановился, то по истечению времени, установленному в параметре.

Начало движения - Включает/выключает определение начало движения объекта. Если объект был в кадре в неподвижном состоянии, но затем начал движение, то по истечению времени, установленному в параметре.


Детектор автомобилей

Панель "Внимание!" > Нейронные сети > Нейро-Б >

Детектор автомобилей

Детектор автомобилей - служит для распознавания в изображении силуэтов автомобилей и классификации их действий.

Для работы алгоритма необходимо установить нейросеть и активировать фильтр нейронной сети на видеосервере!

Чтобы включить детектор автомобилей, активируйте нейронную сеть на панели "Внимание!".

Перейдите в пункт «Автомобиль» и активируйте детектор людей, переведя ползунок из положения [image] в положение act1

Для того чтобы необходимые Вам алгоритмы попадали на панель "Внимание!", необходимо активировать их для данной камеры. Если это не сделать, объекты на панель "Внимание!" попадать не будут, но будет работать нейросеть и визуализация.

Для этого кликните по имени камеры в окне настройки панели «Внимание!». При этом пункты "Настроить", "Имя камеры" и "Имя сервера" должны поменять цвет на зеленый.

Описание настроек

Объект

Минимальная вероятность – Отвечает за точность сравнения детектируемых объектов с базой данных нейросети. Если автомобили не определяются, то понизить. Если определяются помехи как автомобили – повысить.

Минимальная ширина – Минимальная ширина объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких по ширине предметов.

Минимальная высота – Минимальная высота объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких по высоте предметов.

Максимальная ширина – Максимальная ширина объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных по ширине предметов.

Максимальная высота – Максимальная высота объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных по высоте предметов.

Отображать объекты – При активации данного пункта вокруг объекта будет отображаться цветная рамка со служебной информацией. (название объекта, вероятность совпадения и т.д.)

Параметры

Время допустимого отсутствия – Время на которое детектируемый объект может быть перекрыт до повторного обнаружения. Если объект был перекрыт на превышающее установленное время, то программа определит его как новый объект.

Количество кадров истории - Количество кадров, которые программа хранит в своей памяти для анализа и вывода алгоритмов на панель "Внимание!".

Точность сравнения – Допустимое изменение площади неподвижного объекта. Если программа находит один и тот же неподвижный объект несколько раз - под разными ID, уменьшите значение. Если из двух рядом стоящих предметов определяется только один, увеличьте значение.

Разрешенное смещение в процентах от ширины кадра - Если неподвижный объект производит движения не превышающие установленный параметр, то для программы он останется неподвижным.

Время определения неподвижности - Устанавливает время неподвижности объекта для определения алгоритма "Остановка". Если движущийся объект остановится, то только после истечения установленного времени он будет считаться неподвижным.

Время определения движения - Устанавливает время движения объекта для определения алгоритма "Начало движения". Если неподвижный объект начнет движение, то только после истечения установленного времени программа определит начало движения.

Действия

Движение - Включает/выключает определение движения объекта. Если объект попал в кадр во время движения, то ему будет присвоен алгоритм "Движение"

Остановка - Включает/выключает определение остановки объекта. Если объект попал в кадр во время движения, но затем остановился, то по истечению времени, установленному в параметре

Начало движения - Включает/выключает определение начало движения объекта. Если объект был в кадре в неподвижном состоянии, но затем начал движение, то по истечению времени, установленному в параметре


Детектор животных

Панель "Внимание!" > Нейронные сети > Нейро-Б >

Детектор животных

Детектор животных - служит для распознавания в изображении силуэтов животных и классификации их действий, присущих животным.

Для работы алгоритма необходимо установить нейросеть и активировать фильтр нейронной сети на видеосервере!

Чтобы включить детектор животных, активируйте нейронную сеть на панели "Внимание!".

Перейдите в пункт «Животное» и активируйте детектор людей, переведя ползунок из положения [image] в положение act1

Для того чтобы необходимые Вам алгоритмы попадали на панель "Внимание!", необходимо активировать их для данной камеры. Если это не сделать, объекты на панель "Внимание!" попадать не будут, но будет работать нейросеть и визуализация.

Для этого кликните по имени камеры в окне настройки панели «Внимание!». При этом пункты "Настроить", "Имя камеры" и "Имя сервера" должны поменять цвет на зеленый.

Описание настроек

Объект

Минимальная вероятность – Отвечает за точность сравнения детектируемых объектов с базой данных нейросети. Если животные не определяются, то понизить. Если определяются помехи как животные – повысить.

Минимальная ширина – Минимальная ширина объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких по ширине предметов.

Минимальная высота – Минимальная высота объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких по высоте предметов.

Максимальная ширина – Максимальная ширина объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных по ширине предметов.

Максимальная высота – Максимальная высота объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных по высоте предметов.

Отображать объекты – При активации данного пункта вокруг объекта будет отображаться цветная рамка со служебной информацией. (название объекта, вероятность совпадения и т.д.)

Параметры

Время допустимого отсутствия – Время на которое детектируемый объект может быть перекрыт до повторного обнаружения. Если объект был перекрыт на превышающее установленное время, то программа определит его как новый объект.

Количество кадров истории - Количество кадров, которые программа хранит в своей памяти для анализа и вывода алгоритмов на панель "Внимание!".

Точность сравнения – Допустимое изменение площади неподвижного объекта. Если программа находит один и тот же неподвижный объект несколько раз - под разными ID, уменьшите значение. Если из двух рядом стоящих предметов определяется только один, увеличьте значение.

Разрешенное смещение в процентах от ширины кадра - Если неподвижный объект производит движения не превышающие установленный параметр, то для программы он останется неподвижным.

Время определения неподвижности - Устанавливает время неподвижности объекта для определения алгоритма "Остановка". Если движущийся объект остановится, то только после истечения установленного времени он будет считаться неподвижным.

Время определения движения -Устанавливает время движения объекта для определения алгоритма "Начало движения". Если неподвижный объект начнет движение, то только после истечения установленного времени программа определит начало движения.

Действия

Движение - Включает/выключает определение движения объекта. Если объект попал в кадр во время движения, то ему будет присвоен алгоритм "Движение"

Остановка - Включает/выключает определение остановки объекта. Если объект попал в кадр во время движения, но затем остановился, то по истечению времени, установленному в параметре

Начало движения - Включает/выключает определение начало движения объекта. Если объект был в кадре в неподвижном состоянии, но затем начал движение, то по истечению времени, установленному в параметре


Багаж

Панель "Внимание!" > Нейронные сети > Нейро-Б >

Багаж

Настройка оставленных предметов

Для работы алгоритма необходимо установить нейросеть и активировать фильтр нейронной сети на видеосервере!

Чтобы включить детектор оставленных предметов, активируйте нейронную сеть на панели "Внимание!".

Перейдите в пункт «Багаж» и активируйте детектор людей, переведя ползунок из положения [image] в положение act1

Для того чтобы необходимые Вам алгоритмы попадали на панель "Внимание!", необходимо активировать их для данной камеры. Если это не сделать, объекты на панель "Внимание!" попадать не будут, но будет работать нейросеть и визуализация.

Для этого кликните по имени камеры в окне настройки панели «Внимание!». При этом пункты "Настроить", "Имя камеры" и "Имя сервера" должны поменять цвет на зеленый.

Описание настроек

Параметры

Минимальная вероятность – Отвечает за точность сравнения детектируемых объектов с базой данных нейросети. Если полезные объекты не определяются, то понизить. Если определяются помехи как полезные объекты – повысить.

Минимальная ширина – Минимальная ширина объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких по ширине предметов.

Минимальная высота – Минимальная высота объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких по высоте предметов.

Максимальная ширина – Максимальная ширина объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных по ширине предметов.

Максимальная высота – Максимальная высота объекта детекции. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо крупных по высоте предметов.

Количество кадров до обнаружения – Устанавливает количество выводимых кадров в ролике до обнаружения объекта детекции.

Отображать объекты – При активации данного пункта вокруг объекта будет отображаться цветная рамка со служебной информацией. (название объекта, вероятность совпадения и т.д.)

Алгоритм

Время допустимого отсутствия – Время на которое детектируемый объект может быть перекрыт до повторного обнаружения. Если объект был перекрыт на превышающее установленное время, то программа определит его как новый объект.

Реагирование на исчезновение - исчезание детектируемого объекта сразу выводится на панель "Внимание!".

Время неподвижности – Устанавливает время неподвижности детектируемого объекта до вывода его на панель «Внимание!». Имеет прямую взаимосвязь с пунктом Количество кадров неподвижности. Если не будет выполнено условие обоих пунктов, то ролик не выведется на панель «Внимание!».

Количество кадров неподвижности – Устанавливает количество кадров неподвижности детектируемого объекта до вывода его на панель «Внимание!». Имеет прямую взаимосвязь с пунктом Время неподвижности. Если не будет выполнено условие обоих пунктов, то ролик не выведется на панель «Внимание!».

Точность сравнения – Допустимое изменение площади неподвижного объекта. Если программа находит один и тот же неподвижный объект несколько раз - под разными ID, уменьшите значение. Если из двух рядом стоящих предметов определяется только один, увеличьте значение.

Человек

Минимальная вероятность человека – Отвечает за точность сравнения объекта человек с базой данных нейросети. Имеет прямую взаимосвязь с пунктом Допустимое пересечение с человеком. Если человек не определяется, то понизить. Если объекты, которые не являются человеком определяются как человек – повысить.

Допустимое пересечение с человеком – Данная настройка позволяет отфильтровать багаж который находится в руках людей. При максимальном значении, багаж будет определяться даже в руках человека, при минимальном, детекция произойдет только при отсутствии пересечения с человеком.

Реагировать только на оставленное человеком - Настройка позволяет реагировать только на те объекты, которые оставил человек.

Расстояние до человека не более - Данная настройка позволяет задать то расстояние до человека, на котором объект будет считаться оставленным.

Человек должен появиться не позднее - Время, через которое объект будет считаться оставленным


Нейро-Р

Параметры

Панель "Внимание!" > Нейронные сети >

Параметры

Расширенный набор нейросетей

Опасное направление, опасное пересечение, пасный поворот, опасная зона, опасная скорость авто, опасное время активности, опасный покой, опасное изменение площади, опасное изменение пропорций, опасное изменение цветовой гаммы объекта, Появление или исчезновение объекта заданного цвета.

Чтобы активировать "Нейро-Р" для выбранной камеры, кликните правой кнопкой мыши по «шапке» «панели «Внимание!» и в появившемся окне нажмите пункт «Настройки…»

В окне Настройки панели «Внимание!» кликните по пункту «Настроить»

Перейдите на вкладку «Нейро-Р» и в пункте «Параметры» активируйте нейросеть, переведя ползунок из положения [image] в положение act1


Направление

Панель "Внимание!" > Нейронные сети > Нейро-Р >

Направление

Алгоритм "Направление" предупреждает, что какой-либо объект движется в сторону, запрещенную правилами. Представим себе парковочную станцию. И вот, один нарушитель, или неопытный водитель решил выехать через въезд, тем самым создавая потенциально аварийную ситуацию. Но сработавший вовремя алгоритм разбудит задремавшего охранника, включит сирену, активирует шлагбаум и т.д.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения. На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении.

Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Направление» предусмотрены следующие установки.

"Активировать" - активирует/деактивирует алгоритм.

По нажатию кнопки "Добавить" откроется окно "Настройка зоны".

Здесь задаются разрешенные и запрещенные направления.

Область, ограниченная периметром ABCD - зона. Все, что вне зоны - внешняя область.

Зону можно располагать как необходимо. Для этого указатель мыши подводим к краю с буквенным обозначением, зажимаем левую кнопку и перетаскиваем край, меняя положение границы.

Далее следуют настройки всех четырех границ (A-B, B-C, C-D, D-A).

"Состояние" - может быть открыто - разрешено пересечение границы в любом направлении, закрыто - пересечение запрещено, только выход - пересечение границы при движении со стороны внешней области по направлению к зоне запрещено, только вход - пересечение границы при движении со стороны зоны по направлению к внешней области запрещено.

"Длина в метрах" - здесь необходимо указать реальную длину границы, иначе алгоритм функционировать не будет.

"Движение в сторону границы разрешено" - если убрать галочку из данного пункта, то любое движение в сторону границы, даже без ее пересечения, запрещено.

"Начальная задержка" – устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и проч.

"Длительность усреднения" - суть данного параметра заключается в следующем. В реальности объект движется неравномерно. Для математического анализа необходима некая усредненная траектория движения, в рамках которой будут производиться расчеты. В данном пункте устанавливается, на протяжении скольких кадров будет производиться усреднение. Значение влияет на чувствительность алгоритма.

"Продолжительность отслеживания" - здесь устанавливается время, в течении которого программа, не прекращая отслеживание, будет ожидать движения объекта при его исчезновении. Для индикации сработки этого алгоритма можно назначить звуковой сигнал.


Пересечение

Панель "Внимание!" > Нейронные сети > Нейро-Р >

Пересечение

Алгоритм "Пересечение" предупреждает, что какой-либо объект пересек черту которую пересекать, по тем или иным причинам, пересекать нельзя.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения.

На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении.

Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись".

А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

Важно! Для работы алгоритма необходимо активировать детектор объектов на сервере.

Продолжительность отслеживания – время отслеживание объекта после сработки алгоритма.

Использовать данные нейронной сети – при активации в окне настройки линий можно будет использовать данные об объектах нейронной сети.

Настроить нейронную сеть – Перенаправляет в настройки нейронной сети.

Добавить – открывает окно настройки линий.

Настройка линий

Название – введите название линии.

Слева – если поставить «галку» проход слева на право будет запрещен и при пересечении ее объектом сработает алгоритм.

Справа - если поставить «галку» проход справа на лево будет запрещен и при пересечении ее объектом сработает алгоритм.

До/после – чем больше число, тем больше траектория которую должен преодолеть объект пересекая линию. Если в зоне опасного пересечения есть помехи, например в виде качающихся веток, увеличив эти параметры Вы избавитесь от назойливых помех.

Класс – При использовании нейросети, в этом пункте указывается класс нейросети на который будет срабатывать алгоритм.(человек, автомобиль, животное)

Чтобы перетащить линию пересечиния, наведите курсор мыши на один из краев линии (А или В) и с зажатой левой кнопкой мыши перетащите ее в нужное место.


Поворот

Панель "Внимание!" > Нейронные сети > Нейро-Р >

Поворот

Опасный поворот

Алгоритм "Поворот" выявляет резкие повороты. Как ни странно, большинство выбираемых людьми направлений основывается на совершенно конкретном математическом законе: из точки А в точку Б мы направляемся кратчайшим путем – по прямой. Согласитесь, довольно странно выглядит человек, идущий змейкой по просторной дороге. Еще более странным может быть резкий разворот назад.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения.

На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении.

Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Опасный поворот» предусмотрены следующие установки.

"Активировать" - активирует/деактивирует алгоритм.

"Разрешенный левый поворот", "Разрешенный правый поворот" - позволяют установить, в градусах, значение максимального угла поворота объекта налево и направо соответственно, ниже которого сработка алгоритма не произойдет.

"Начальная задержка" – устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и проч.

"Длительность усреднения" - суть данного параметра заключается в следующем. В реальности объект движется неравномерно. Для математического анализа необходима некая усредненная траектория движения, в рамках которой будут производиться расчеты. В данном пункте устанавливается, на протяжении скольких кадров будет производиться усреднение. Значение влияет на чувствительность алгоритма.

"Продолжительность отслеживания" - здесь устанавливается время, в течении которого программа, не прекращая отслеживание, будет ожидать движения объекта при его исчезновении.

"Отставание базового вектора" - суть этого параметра заключается в том, что аналитический аппарат в каждом новом кадре к траектории движущегося объекта строит касательную-вектор. Между последним таким вектором и предпоследним, который называется "базовым", рассчитывается угол, по которому и определяется на сколько "опасен" поворот. Значение, выставленное в данном пункте задает в каком кадре, относительно последнего, будет строиться базовый вектор. Меняя этот параметр, меняем чувствительность алгоритма.

Для индикации сработки можно назначить звуковой сигнал.

Для работы алгоритма "Опасный поворот" необходимо активировать Детектор объектов (меню "Объекты" в настройках камеры).

Пример: Если человек не сразу выбрал кратчайший путь до входа в ваш офис, а, пытаясь не привлекать внимание, шел параллельно дороги, то резкий разворот у самого окна или двери можно считать опасным.


Зона

Панель "Внимание!" > Нейронные сети > Нейро-Р >

Зона

Алгоритм «Зона» – предупреждает, что в зонах контролируемых какой-то из камер, для которых он включен, и где не должно происходить никакого движения, неожиданно появились движущиеся объекты. С помощью его можно установить маршруты санкционированного движения и такие, где движение запрещено. Злоумышленник волей-неволей вынужден проникать туда, где обычно людей не бывает или они там появляются чрезвычайно редко.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения.

На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении.

Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Зона» предусмотрены следующие установки.

"Начальная задержка" – устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и проч.

Для индикации сработки этого алгоритма можно назначить звуковой сигнал.

Кликнув мышью по кнопке «Настройка зон», Вы попадете в окно, в котором можно выделить маску зон/зоны действия этого алгоритма.

В верхней части окна выбирается размер "кисти" и выполняемое действие (маскирование или стирание маски). Удерживая левую кнопку мыши и перемещая курсор по кадру Вы наносите или стираете маску. Сразу очистить замаскированную площадь можно, нажав кнопку «Очистить». Кнопка «Получить кадр» позволит Вам обновить картинку, отображаемую в окне.

Завершив маскирование зоны детекции, кликните по кнопке «Ок»


Предмет

Панель "Внимание!" > Нейронные сети > Нейро-Р >

Предмет

Алгоритм «Предметы» – осуществляет контроль за появлением/исчезновением предметов в поле наблюдения камеры.

Если предмет исчез, то можно предположить, что он похищен, просмотр записи, предшествующей моменту сработки алгоритма поможет уточнить обстоятельства исчезновения. Внезапное появление нового предмета может представлять в наше время существенную опасность. Им может оказаться какое-либо "шпионское" устройство, либо даже взрывоопасный предмет.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются моменты появления или исчезновения в поле зрения камеры нового предмета. На панели крупным планом выводится сам предмет, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении.

Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Предметы» предусмотрены всего две установки:

"Время предпросмотра" - укажите, какой период времени должен анализироваться для сработки алгоритма. Другими словами, сколько должен находится предмет в кадре до сработки.

"Продолжительность отслеживания после обнаружения" - укажите задержку на сработку алгоритма после обнаружения предмета в кадре за время, установленное в предыдущем поле.

Для индикации сработки этого алгоритма можно назначить звуковой сигнал. Также можно указать место в компьютере, куда программа будет сохранять записываемые кадры.

Чтобы алгоритм работал необходимо активировать фоновый детектор (детектор объектов в настройках камеры)!

Фильтрация с использованием нейронной сети:

"Не реагировать на человека на время" - время, на которое камера не будет реагировать на человека

"Реагировать только на багаж за время" - время, за которое камера будет реагировать только на багаж.


Время

Панель "Внимание!" > Нейронные сети > Нейро-Р >

Время

Алгоритм «Время» предупреждает, что в зоне видимости какой-то из камер, для которых он включен, где, как правило люди долго не задерживаются, движущийся объект находится слишком долго. Применение его особенно эффективно, например, для камер, установленных в подъездах, перед входными дверями квартир и домов. Позволяет отследить деятельность лиц, готовящих несанкционированное проникновение.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения. На панели крупным планом выводится сам объект, по периметру окна камеры, передающей изображение с места события мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении.

Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Время» предусмотрены следующие установки.

"Активировать" - активирует/деактивирует данный алгоритм.

"Период превышения" – рассчитывается исходя из того, сколько времени по максимуму требуется обычно, чтобы покинуть зону видимости камеры. Как правило, на проход по лестничной площадке требуется около 10 сек. Но для подготовки ограбления этого мало: нужно изучить замки, глазки, взломоустойчивость двери. Именно эта разница во времени нахождения в зоне наблюдения камеры и используется для распознавания "хороших" и "плохих".

"Макс. время отсутствия движения" - задается время, по истечении которого, если не произошло ни одного движения, то алгоритм сработает.

Если, например, хозяин выйдет покурить на площадку, или кто-то из "своих", явившись навеселе, слишком долго добирается от лифта до двери, система обратит внимание оператора лишь на начало события, после чего все виды оповещения заблокируются до следующего события, определённого в настройках алгоритма Интервалом между событиями.


Покой

Панель "Внимание!" > Нейронные сети > Нейро-Р >

Покой

Алгоритм "Покой" очень похож на алгоритм "Время", только работает в "обратную сторону" Настройки аналогичны.

Разница заключается в том, что "Покой" срабатывает тогда, когда какое-либо движение в поле обзора камеры прекращается совсем. Это полезно, например, в случае с конвеером, когда он останавливается.


Площадь

Панель "Внимание!" > Нейронные сети > Нейро-Р >

Площадь

Алгоритм «Площадь» – комплексный. Он предупреждает сразу о нескольких признаках опасных проявлений. Например, если в большой аудитории среди сидящих кто-нибудь встанет, то алгоритм распознает это как новое событие, так как существенно изменится площадь детекции. Толпа людей тоже представляет собой по площади детекции один большой объект, потому любая его трансформация вызовет сработку. Это может быть поднятая рука, подобравшийся близко к камере злоумышленник и многое другое.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения.

На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении.

Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Площадь» предусмотрены следующие установки.

"Начальная задержка" – устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и проч.

"Время усреднения" - период, на протяжение которого допускается кратковременное изменение площади с возвращением её в прежние пределы. Это время необходимо для того, чтобы избежать ложных сработок в случае кратковременного попадания в зону обзора посторонних предметов, не представляющих опасности, например, флагов, развеваемых порывом ветра.

"Соотношение" – вычисляется инсценированием событий перед камерой. "Актёрами" воспроизводятся сцены возможных несанкционированных действий и по результатам их анализа устанавливаются параметры изменения площади детекции.

Настройка "Реагировать на уменьшение площади движения" указывает алгоритму на необходимость сработки не только в случае увеличения площади движущихся объектов, но и в обратной ситуации – при ее уменьшении.

Для индикации сработки этого алгоритма можно назначить звуковой сигнал.

Алгоритм может вступать в коллизии с другими и дополнять их, потому рекомендуется применять для каждого конкретного объекта разные комбинации алгоритмов. Кроме того, имеется возможность настроить любую из камер на выдачу только одного сообщения при наступлении одновременно нескольких рассчётных событий.

Правильно установленный Интервал между событиями отсечёт ложные срабатывания при постоянно совершающемся движении. Так, если по объективу камеры ползает насекомое, то его движение вызовет только одну сработку алгоритма.


Пропорция

Панель "Внимание!" > Нейронные сети > Нейро-Р >

Пропорция

Алгоритм панели "Пропорция" отслеживает объекты по заданным параметрам и оповещает о том, что в кадре появился объект не отвечающий этим параметрам.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения.

На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении.

Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

Важно! Для работы алгоритма необходимо активировать детектор объектов на сервере.

Время усреднения – суть данного параметра заключается в следующем. В реальности объект движется неравномерно. Для математического анализа необходима некая усредненная траектория движения, в рамках которой будут производиться расчеты. В данном пункте устанавливается, на протяжении скольких кадров будет производиться усреднение. Значение влияет на чувствительность алгоритма.

Минимальное допустимое соотношение ширины к высоте, максимальное допустимое соотношение ширины к высоте – определяет пропорции объекта, появление в кадре объекта с отличными от установленных пропорций, вызовет сработку алгоритма.

Подавление помех – активирует фильтр сложных помех.

Настроить детектор объектов - перенаправляет в настройки детектора объектов.


Скорость

Панель "Внимание!" > Нейронные сети > Нейро-Р >

Скорость

Алгоритм "Скорость" служит для оповещения о превышении допустимых пределов скорости перемещения. Операторы автопогрузчиков, чтобы работа была увлекательной, любят выжимать максимальные скорости из автопогрузчиков на прямых участках складских помещений, даже в груженом состоянии. Опасные игрища приводят к серьезному ущербу и даже человеческим увечьям в результате постоянных аварий.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения. На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении.

Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

Важно! Для работы данного алгоритма необходимо активировать детектор объектов.

Добавить – открывает окно настройки областей измерения скорости.

Добавление области

Название – введите название области.

Мин.время – минимальное время за которое объект должен преодолеть указанную область.

Макс.время – максимальное время за которое объект должен преодолеть указанную область. Чтобы сформировать область скорости, наведите курсор мыши на одну из вершин и с зажатой левой кнопкой мыши перетащите ее в нужное место.

Подавление помех – активирует фильтр сложных помех.

Отслеживание автономеров – исследует изменение размеров номера во времени, что без лишних радаров или других специфических устройств позволяет достаточно точно определять скорость движения любых средств передвижения, на которых нанесен номерной знак.

Настроить детектор объектов – перенаправляет в настройки детектора объектов.


Нейро-С

Параметры

Панель "Внимание!" > Нейронные сети >

Параметры

Нейро-С является набором различных социальных алгоритмов, которые помогают выявлять нарушение социальных норм на объекте. Тем самым, приучая людей соблюдать установленные нормы, а так же контролируя нарушения, оповещая оператора о нарушении. Таким образом, в любой момент суток, можно увидеть начавшуюся драку, либо стаю животных, которая может предоставлять угрозу для человека.

Чтобы активировать социальную нейросеть для выбранной камеры, кликните правой кнопкой мыши по «шапке» «панели «Внимание!» и в появившемся окне нажмите пункт «Настройки…».

В окне Настройки панели «Внимание!» кликните по пункту «Настроить»

Перейдите на вкладку «Нейро-С» и в пункте «Параметры» активируйте нейросеть, переведя ползунок из положения [image] в положение act1


Толпа

Панель "Внимание!" > Нейронные сети > Нейро-С >

Толпа

Алгоритм «Толпа» предупреждает, что в зоне контролируемой какой-то из камер, для которых он включен, неожиданно скопилось слишком много или слишком мало движущихся объектов: людей, автотранспорта и т.п., большая часть которых находятся на расстоянии друг от друга.

Применение его особенно эффективно для камер с широким углом обзора, способных зафиксировать одновременно большое количество самостоятельных объектов. Так неожиданное появление толпы на или возле охраняемого объекта может оказаться началом опасного события.

Если сработка системы по алгоритму «Опасное начало» предупреждает о том, что в зоне контроля камеры появился первый движущийся объект (объекты), то включение алгоритма «Толпа» означает, что количество таких объектов изменилось (увеличилось или уменьшилось).

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность(и) и оценить намерения.

На панели крупным планом выводится сам движущийся объект(ы), по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении.

Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Толпа» предусмотрены следующие установки.

"Разрешенное количество" - здесь выбирается какое число объектов одновременно может появиться в поле зрения камеры без сработки алгоритма (если количество объектов больше, то алгоритм сработает).

"Начальная задержка" – устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и проч.

"Минимальное расстояние между объектами" - позволяет установить предельное расстояние между детектируемыми объектами, до которого они могут сблизиться.

"Использовать данные нейронной сети" – при активации в окне настройки линий можно будет использовать данные об объектах нейронной сети.

Непрерывное изменение количества объектов в кадре вследствие их неупорядоченного движения компенсируется Интервалом между событиями, алгоритм которого постоянно вычисляет среднее число объектов в зоне видимости. Если в поле зрения камеры появились, например, два человека, идущие навстречу друг другу, в тот момент, когда траектории их движения пересекутся, то, если этот момент не превысит время, установленное для Интервала между событиями, сработки не произойдёт. Если же они задержатся, чтобы побеседовать друг с другом, то сработает оповещение и событие будет зафиксировано. Что, в общем, и правильно: регистрация факта такой встречи может оказаться небесполезной с позиции безопасности охраняемого объекта.


Стая

Панель "Внимание!" > Нейронные сети > Нейро-С >

Стая

Нейросети, обученные распознавать животных, покажут на карте города, где обитают стаи бродячих собак, их количество и опасную близость к людям.

"Разрешенное количество" - здесь выбирается какое число объектов одновременно может появиться в поле зрения камеры без сработки алгоритма (если количество объектов больше, то алгоритм сработает).

"Время наблюдения" - длительность ролика на панели "Внимание!".

"Классы (через запятую)" - классы нейронной сети, на которые будет срабатывать алгоритм.


Дистанция

Панель "Внимание!" > Нейронные сети > Нейро-С >

Дистанция

C помощью видео аналитического алгоритма "Дистанция", можно установить контроль за нарушением социальных дистанций. Он позволяет выявить места частого пересечения людей, перестроить архитектуру зданий и маршруты передвижения, выставить в нужных местах специальные предупреждающие устройства, нарисовать отметки для остановки, стрелки или заградительные разграничители потоков.

"Время наполнения ролика" - длительность ролика на панели "Внимание!".

"Минимальная дистанция" - минимальная допустимая дистанция сближения, если дистанция между объектами будет меньше установленного значения, сработает алгоритм.

"Время блокировки повторной сработки" - после нарушения минимальной дистанции, алгоритм блокирует повторный вывод ролика на панель "Внимание!" на заданное время до тех пор, пока не будет превышена "Дистанция блокировки повторной сработки". Этот параметр блокирует бесконечный вывод видеороликов на панель "Внимание!" если два человека остановились поговорить в зоне действия алгоритма.

"Дистанция блокировки повторной сработки" - Минимальное расстояние между сблизившимися объектами, при котором не произойдет повторная сработка.

"Отображать работу алгоритма в окне камеры" - отображает дистанцию между объектами в окне камеры.

"Классы нейросети" - классы нейронной сети, на которые будет срабатывать алгоритм.


Мед. маска

Панель "Внимание!" > Нейронные сети > Нейро-С >

Мед. маска

В условиях пандемии появляется требование обязательного ношения масок. С помощью алгоритма "Мед.маска" можно распознавать людей, у которых на лице их нет.

"Срабатывать на лицо без маски/лицо в маске" - настройка позволяет выбрать режим распознавания лиц в медицинской маске или без.

"Время отслеживания" - в течение какого времени камера будет отслеживать человека в маске или без.

"Минимальное количество детекций" - минимальное количество движений, которое требуется для распознавания маски.

"Отображать работу алгоритма в окне камеры" - визуальное отображение алгоритма в окне камеры.

"Чувствительность детекции маски" - значение, которое показывает, насколько нейронная сеть "уверенна", что на лице человека именно маска


Утопающие

Панель "Внимание!" > Нейронные сети > Нейро-С >

Утопающие

Алгоритм "Утопающие", распознает плавающих людей на воде и способен предупредить, если кто-то двигается в опасном направлении – пропал из виду на опасное для жизни время, ведет себя неестественно – захлебывается. На экране сразу указывается место бедствия и производится предупреждение оператора.

"Время наполнения ролика" - длительность ролика на панели "Внимание!".

"Отображать работу алгоритма в окне камеры" - визуальное отображение алгоритма в окне камеры.

"Классы нейросети" - классы нейронной сети, на которые будет срабатывать алгоритм.


Нейро-К

Параметры

Панель "Внимание!" > Нейронные сети >

Параметры

Нейро-К представляет набор алгоритмов поведенческой логики для выявления криминальных ситуаций. Множество криминальных преступлений, как правило, требуют нестандартных действий.

Набор криминальных алгоритмов - это эффективное средство для проверки адекватности посетителей и выявления у них криминальных намерений. Комбинация данных алгоритмов с детектором лиц выдаёт очень полезные результаты, помогая предупредить многие противоправные действия.

Чтобы активировать криминальный набор нейросетей для выбранной камеры, кликните правой кнопкой мыши по «шапке» «панели «Внимание!» и в появившемся окне нажмите пункт «Настройки…».

В окне Настройки панели «Внимание!» кликните по пункту «Настроить»

Перейдите на вкладку «Нейро-Р» и в пункте «Параметры» активируйте нейросеть, переведя ползунок из положения [image] в положение act1


Бегущий человек

Панель "Внимание!" > Нейронные сети > Нейро-К >

Бегущий человек

"Время наполнения ролика" - длительность ролика на панели "Внимание!".

"Отображать работу алгоритма в окне камеры" - визуальное отображение алгоритма в окне камеры.

"Классы нейросети" - классы нейронной сети, на которые будет срабатывать алгоритм.


Оружие

Панель "Внимание!" > Нейронные сети > Нейро-К >

Оружие

Алгоритм "Оружие" способна распознавать угрожающие людям предметы, в том числе различные типы как холодного, так и огнестрельного оружия. Он способен моментально сигнализировать о появлении в зоне видимости таких видов оружия как: пистолеты, винтовки, автоматические винтовки, автоматы, пулеметы, гранатометы, ножи и кинжалы.

"Время наполнения ролика" - длительность ролика на панели "Внимание!".

"Отображать работу алгоритма в окне камеры" - визуальное отображение алгоритма в окне камеры.

"Классы нейросети" - классы нейронной сети, на которые будет срабатывать алгоритм.


Маска грабителя

Панель "Внимание!" > Нейронные сети > Нейро-К >

Маска грабителя

"Время наполнения ролика" - длительность ролика на панели "Внимание!".

"Отображать работу алгоритма в окне камеры" - визуальное отображение алгоритма в окне камеры.

"Классы нейросети" - классы нейронной сети, на которые будет срабатывать алгоритм.


Положение головы

Панель "Внимание!" > Нейронные сети > Нейро-К >

Положение головы

Алгоритм "Положение головы" позволяет разпознавать намерения. Нейросеть просигнализирует оператору видеонаблюдения о страном поведении человека

"Время наполнения ролика" - длительность ролика на панели "Внимание!".

"Отображать работу алгоритма в окне камеры" - визуальное отображение алгоритма в окне камеры.

"Классы нейросети" - классы нейронной сети, на которые будет срабатывать алгоритм.


Фото-видео съемка

Панель "Внимание!" > Нейронные сети > Нейро-К >

Фото-видео съемка

Данный алгоритм срабатывает, как только в зоне видимости камеры появляется средство фото-видеозаписи. Такая нейросеть будет полезна на объектах, где фото-видеосъемка запрещена.

"Время наполнения ролика" - длительность ролика на панели "Внимание!".

"Отображать работу алгоритма в окне камеры" - визуальное отображение алгоритма в окне камеры.

"Классы нейросети" - классы нейронной сети, на которые будет срабатывать алгоритм.


Дроны

Панель "Внимание!" > Нейронные сети > Нейро-К >

Дроны

Нейросетевой модуль распознавания дронов сигнализирует о том, что в зоне видимости камер появился непрошенный летательный объект.

"Время наполнения ролика" - длительность ролика на панели "Внимание!".

"Отображать работу алгоритма в окне камеры" - визуальное отображение алгоритма в окне камеры.

"Классы нейросети" - классы нейронной сети, на которые будет срабатывать алгоритм.


Farwit и GOALmobile-2

Панель "Внимание!" >

Farwit и GOALmobile-2

Farwit ("Далекий свидетель") - облачный Интернет-сервис Спецлаб, способный надежно хранить информацию в удаленном от объекта месте, исключая любой несанкционированный доступ. "Короткие данные" с ключевыми моментами заводятся в удобную поисковую систему для анализа событий и оповещения в случае экстренного характера.

GM2 (GOALmobile2) - мобильный сервис для работы с приложением для смартфонов и планшетов, который позволяет использовать мобильное устройство как видео-пульт охраны с системой видеонаблюдения и средством оповещения. Посмотреть, как GM2 выглядит на мобильном устройстве, вы можете здесь.

Оба сервиса настраиваются с помощью специального конфигуратора (GoalOBserver), который устанавливается вместе с GOALcity. Как это сделать, вы можете посмотреть здесь.


<?xml version="1.0" encoding="UTF-8"?><topicref type="topic" id="448047992803755" build="ALL" modified="2023-05-11T14:29:14.498Z" icon="0" href="topic100"><caption translate="true">РќР°СЃС‚СЂРѕР№РєР° СЃРµСЂРІРёСЃРѕРІ Рё РјРѕР±РёР»СЊРЅРѕРіРѕ РїСЂРёР»РѕР¶РµРЅРёСЏ</caption><topic><![CDATA[РїВ»С—<?xml v

Настройка сервисов и мобильного устройства

Панель "Внимание!" > Farwit и GOALmobile-2 >

Настройка сервисов и мобильного устройства

Для того, чтобы начать использовать GOALmobile-2, необходимо:

1. Установить программу SpecLab GOALcity:

- если у вас ранее была установлена программа SpecLab GOALcity, необходимо перейти по ссылке и скачать установочный файл GOALcity_Client_x64.exe

- в случае, если вы в первый раз используете программу SpecLab GOALcity, перейдите по ссылке и заполните форму для запроса Бесплатной версии аналитической системы видеонаблюдения.

2. На этапе установки необходимо отметить галкой пункт "GOALmobile-2", а затем нажать кнопку "Далее".

3. После того, как вы установите и настроите программу (как это сделать, можно посмотреть здесь) необходимо настроить экспорт видеороликов.

Для этого откройте Главное меню программы и выберите пункт "Настройка панелей Внимание!".

4. Активировать GOALmobile-2 в Настройках панели Внимание, нажав на иконку [image] возле необходимой камеры.

5. Установить мобильное приложение. Для этого необходимо здесь же, не закрывая Настройки панели Внимание, перейти в настройки камеры во вкладку Оповещение.

6. Для настройки Farwit необходимо активировать кнопку "Сохранять события в облачном сервисе "Далекий свидетель"" во вкладке Оповещение, а так же зарегистрироваться на сайте облачного видео-сервиса.

7. В настройках панели Внимание, во вкладке Оповещение необходимо настроить Сервер событий.

Вкладка "Основные"

Адрес сервера событий - IP адрес сервера, с которого мобильное устройство будет получать видеоролики.

Дополнительный адрес сервера событий/второй дополнительный адрес сервера - эти IP адреса вводятся опционально и используются только в случае, когда к серверу необходим доступ как из локальной сети, так и через интернет. Либо в случае, когда вы пользуетесь услугами двух интернет провайдеров, и в случае аварии у одного провайдера, GOALcity автоматически переключится на второго.

Порт сервера событий - порт используемый сервером событий для отправки роликов на мобильное приложение.

Адрес брокера событий ведет учет подключенных мобильных устройств и сообщает им о том, что на одном из серверов событий появился новый ролик (новое событие) и видеоинформацию можно скачать. Может быть установлен как на одном компьютере с сервером событий, так и отдельно.

Порт брокера событий - порт используемый брокером событий для отправки сообщений мобильному приложению о том, что на сервере событий появился новый ролик.

Идентификатор устройства Андроид - уникальный идентификатор (id) мобильного устройства на базе Андроид.

Вкладка "Панели"

На данной вкладке отображаются активные панели "Внимание!" и камеры, ролики с которых будут отправляться на мобильное приложение и/или в Farwit. Заполняется автоматически, исходя из настроек клиентской части GOALcity.

С помощью кнопкии Изменить можно установить максимальное количество событий, которое будет отображаться на мобильном устройстве с определенной панели "Внимание!". Выделите панель "Внимание!" в списке и нажмите кнопку Изменить. Установите необходимое значение (по умолчанию 20)

Вкладка "Д.Свидетель"

Используется для настройки параметров отправки роликов на облачный видео-сервис Farwit.

Включить - активирует отправку роликов в Farwit.

Адрес архива - адрес и порт далекого свидетеля (cloud.farwit.com:80).

Максимальное количество событий в очереди для передачи в облако.

Адрес дополнительного - второй IP адрес вводится опционально и используется в случае, когда нужно, чтобы ролики передавались в дополнительное облачное хранилище для резервного хранения.

Пользователь/пароль - укажите пользователя/пароль созданного при регистрации в облачном сервисе. В этой строке можно указать как имя пользователя, так и адрес электронной почты, указанной при регистрации.

Передавать события:

без реакции оператора - в облачное хранилище будут передаваться ролики только без реакции оператора;

с низкой/высокой важностью - в облачное хранилище будут передаваться ролики только с низкой/высокой важностью. Устанавливается в настройках панели «Внимание!» GOALcity.

Вкладка "Сервер GOALcity"

Здесь необходимо указать данные для авторизации на сервере GOALcity, чтобы конфигуратор мог подключиться к нему и собрать данные о панелях "Внимание!", пользователях и камерах.

Пользователь/Пароль GOALcity, который имеет право отправлять события.

Контроль состояния датчиков используется для передачи состояния датчиков и ключей на мобильное приложение.

64-разрядный - установите флаг, если клиент GOALcity имеет разрядность 64 бита.

Удаленная перезагрузка разрешает перезагрузить компьютер с мобильного устройства.

Контроль параметров GOALcity используется для отображения параметров, которые задаются в клиенте GOALcity.

8. Запустите программу GOALmobile с помощью ярлыка [image] на рабочем столе вашего мобильного устройства и перейдите в настройки.

9. Настроить основные параметры.

10. Настроить "живое" видео и выключатели.

Если события должны приходить как по локальной сети, так и через интернет, то эту операцию с добавлением сервера необходимо повторить дважды: первый раз вы вводите локальный IP адрес, а во второй - внешний. IP адреса должны совпадать с введенными в Конфигураторе!

Подробнее о сервисах Farwit и GM2 вы можете прочитать здесь, а также увидеть GM2 в действии.

Если у Вас остались вопросы, Вы можете обратиться в нашу техническую поддержку.


Пользователи GOALmobile-2

Панель "Внимание!" > Farwit и GOALmobile-2 >

Пользователи GOALmobile-2

GOALmobile-2 многопользовательское приложение, таким образом Вы можете предоставить доступ к определенным камерам определенной группе лиц. Например, чтобы жена могла смотреть только камеры из детской, но "не залезала" к Вам в гараж. Все права настраиваются на базе клиента GOALcity, GOALmobile-2 же подхватывает их автоматически.

Настройка прав для "живого" просмотра камер и архива

Первое что нужно сделать, это создать необходимого Вам пользователя в системе GOALcity. Откройте основные настройки программы и перейдите на вкладку "Пользователи".

Нажмите кнопку "Добавить" внизу окна и введите необходимые данные нового пользователя. Сохраните все нажатием кнопки "Ок".

Новый пользователь отобразится в общем списке. Теперь нужно разрешить или запретить ему определенные функции работы с GOALcity. Выделите созданного пользователя в общем списке и нажмите кнопку "Изменить". Чтобы данный пользователь не мог вносить никакие изменения в GOALcity ему хватит прав только на "Просмотр записей". Сохраните все настройки нажатием кнопки "Ок".

Теперь нужно указать что пользователь может просматривать, а что нет. Откройте диаграмму подключений GOALcity, перейдите к настройкам необходимого сервера (Мультимедиа, Архивного или Видеосервера) и перейдите на вкладку "Пользователи". Как и в прошлый раз, выделите необходимого пользователя и нажмите кнопку "Изменить". Для примера рассмотрим Видеосервер.

Во первых, нужно разрешить пользователю подключаться к данному серверу GOALcity. Поставьте галочку в разделе "Видеосервер - Подключение". Затем, выберите те камеры, к которым хотите разрешить доступ пользователю. Разрешайте (отмечайте "птичками") попарно к какой плате и какой камере дать доступ. Сохраните все изменения нажатием кнопки "Ок". На примере "Жене" разрешен доступ только к камере 1 видеосервера GOALcity. Все остальные камеры она не увидит.

Для других серверов GOALcity доступ выставляется аналогично. На мультмедиа сервере вместо плат видеозахвата будут источники (IPSource, RTPSource и т.д.), а на архивном сервере, соответственно - архивы.

После этих действий необходимо включить Оповещение для выбранных камер в настройках панели "Внимание!". Откройте настройки панели "Внимание!", и активируйте оповещение для выбранных камер, щелкнув левой кнопкой мыши по значку мобильного телефона справа от необходимой камеры. Не забудьте также активировать и саму камеру, чтобы она отрабатывала алгоритмы панели "Внимание!" иначе показывать Вам будет просто нечего.

Если Вы все сделали правильно, то в настройках конфигуратора GM2 отобразятся все созданные Вами пользователи.

На вкладке "Камеры" Вы сможете проверить верно ли Вы "выдали" права пользователям.


Telegram

Панель "Внимание!" >

Telegram

Для того, чтобы настроить отправку событий из Панели Внимание в ваш Telegram, необходимо:

1. Открыть Telegram на вашем устройстве и ввести в поисковую строку "BotFather"

2. Открыть чат с "BotFather" и нажать кнопку "Запустить".

3. В появившемся сообщении выбрать команду /newbot - create a new bot (создать нового бота).

4. Далее вам необходимо придумать название вашего бота и имя пользователя для вашего бота.

5. В следующем сообщении вы получите ссылку на созданный вами бот, а также токен.

6. После того, как вы создали бота и получили токен, необходимо зайти в настройки Панели Внимание в программе GOALcity.

7. Открыть вкладку "Дополнительно".

8. В пункте "Публиковать в Telegram" поставить галку и открыть "Настройки".

9. Скопировать полученный вами в боте "BotFather" токен и вставить в поле "Токен доступа для робота" в программе GOALcity. Затем нажать кнопку "Подключить".

10. Затем необходимо зайти в бот "BotFather" в вашем Telegram и перейти по ссылке в созданный вами бот. В открывшемся чате с вашим ботом необходимо прописать команду /add

11. Снова перейти в окно "Настройка робота Telegram" в программе GOALcity и нажать кнопку "Обновить". В "Списке чатов для отправки сообщений" появится название чата с вашим ботом. Для выхода из настроек необходимо нажать кнопку "ОК".

12. Для того, чтобы выбрать камеру, события с которой будут приходить в ваш Telegram, необходимо зайти в настройки выбранной камеры в Настройках панели Внимание. Перейти во вкладку "Оповещения" и выбрать вкладку "Telegram". Далее необходимо перевести ползунок в положение "Activated" и выбрать чат, в который будут направлены события (чат с ботом, которого вы создали).

13. После того, как вы произведете необходимые настройки, в ваш Telegram будут приходить события с выбранной камеры.


Настройки

»«

Настройки

В данном разделе находится описание различных настроек GOALcity.


Настройки в окне камеры

Настройки >

Настройки в окне камеры

Для того, чтобы перейти к Настройкам камеры, необходимо навести курсор на окно камеры и нажать на кнопку


Имя камеры

Настройки > Настройки в окне камеры >

Имя камеры

Данная вкладка позволяет в любой момент изменить название камеры, отображаемое в окне и на диаграмме подключений GOALcity. Можно выбрать один из вариантов: отображать лишь краткое название, либо отображать полностью, с названием источника и расположением на сервере.


Подключение

Настройки > Настройки в окне камеры >

Подключение

Данная вкладка предназначена для изменений настроек подключения к камере. Смены потоков камеры (для много поточных камер), а также смены порта и настроек времени переподключения к камере.

Если в настройках камеры были изменены настройки пользователя, здесь их также можно изменить. Эти настройки являются серверными и затрагивают все клиенты, подключенные к данной камере.

Пункт «URL(для просмотра)» - данная настройка аналогична с настройками камеры на диаграме подключений. Данный пункт отвечает за то, что будет отображаться в маленьком окне GOALcity. Рекомендуем использовать кодек jpeg и разрешение 640х480 или меньше в зависимости от размера окна.

Пункт «URL(для записи)» - данная настройка аналогична с настройками камеры на диаграме подключений. Данный пункт отвечает за то, что будет отображаться при распахивании окна GOALcity и постоянно записываться. Рекомендуем использовать поток на котором используется кодек h264 и максимальное разрешение.

Пункт «Имя пользователя» - здесь задается имя пользователя, которое установлено на видеокамере, которое было установлено с завода или изменено пользователем.

Пункт «Пароль» - в данном пункте задается пароль, для подключения к видеокамере, который был установлен с завода или изменен пользователем.

Пункт «Время ожидания ответа (сек.)» - здесь указывается на протяжении какого времени будет ожидаться ответ от камеры при попытке подключения.

Пункт «Порт ONVIFF» требуется для изменения номера порта камеры, при использовании различных протоколов подключения.

Пункт «Количество переподключений» - в данном пункте задается количество переподключений по истечении времени ожидания ответа. 0 – отключено. После всех попыток камеру нужно будет переподключить вручную.

Пункт «Таймаут переподключений, сек» - здесь настраивается, через какой временной период программа будет пытаться переподключиться к камере, если не получает сигнал. Если выбрать 30 секунд, то через каждые 30 секунд будет происходить попытка переподключения

Пункт «Время получения кадра, сек» - здесь настраивается минимальное время для получения кадра с камеры, по истечении которого, система будет считать, что сигнал пропал.


Потоки

Настройки > Настройки в окне камеры >

Потоки

Данная вкладка предназначена для настройки потоков, которые поступают с камеры. Для многопоточных камер, в данной вкладке настраиваются те потоки, которые подключены в текущий момент к клиенту.

Каждый поток настраивается по разрешению, частоте кадров и типу передаваемых данных (H.264, MJPEG). Также здесь устанавливаются общие настройки для всех потоков камеры. Данные настройки являются серверными.

Пункт «Аудио» включает получение аудио потока с камеры, если в ней предоставлена такая функция. Зайдя на диаграмму подключений и обновив мультимедиа сервер, появится еще одна графа с названием видео источника, с которого будет поступать аудио.

Пункт «Показывать предупреждение при остановке потока» выводит предупреждение в окне транслируемой камеры о том, что поток передачи остановился, но связь с камерой сохранилась.

Пункт «Использовать время потока» - данный пункт позволяет получать информацию о времени с камеры, если в ней есть данная функция.

Пункт «Включить проверку на пустой кадр» активирует проверку на пустые кадры в данном окне. Если в потоке камеры появится пустой кадр, то программа не выведет его на просмотр , а покажет цельный, который был ранее.

Пункт «Включить проверку на одинаковые кадры» активирует проверку на одинаковые кадры в данном окне. Если в потоке камеры появится повторяющийся кадр, то программа не выведет на просмотр этот кадр, а покажет тот, который был ранее.

Пункт «Безопасный кодек» включает внутреннюю конвертацию в отдельном процессе GOALcity. Данный параметр позволяет избавиться от ошибок перекодирования камер и избавить изображение от подергиваний и прерываний.

Пункт «Поправка времени кадра(мс)» - в данном меню задается время в милисекундах, на которое будет изменятся время кадра. Данная настройка нужна для того, чтобы избавиться от разрывов изображений на высокочастотных камерах.

Пункт «Нестандартный JPEG» - данная настройка предназначена если ваша камера использует нестандартное разрешение, отличные от 16:9, 4:3, 16:10, для избегания ошибок в работе.


Обработка

Настройки > Настройки в окне камеры >

Обработка

Данная вкладка предназначена для внесения изменений при включенном использовании VSS-Ретранслятора в данном окне. В данном меню происходит настройка трансляции, в которой можно указать и изменять разрешение и частоту кадров для данного транслируемого окна.

Пункт «Изменять размер кадра» - если активирован этот пункт, то кадр с источника передаётся с изменененными, до указанных ниже, значениями.

Пункт «Ширина и Высота» - здесь задается ширина и высота в пикселях, транслируемых (выходных) кадров.


Архив

Настройки > Настройки в окне камеры >

Архив

Обратите внимание, что для начала вам необходимо создать и подключить архив. Как это сделать вы можете посмотреть здесь.

Для того, чтобы настроить архив и запись, необходимо:

1. Перейти в Настройки камеры, нажав на кнопку button-settings на всплывающей панели в окне камеры

2. Открыть вкладку Архив

Писать в архив - выбор архива, в который данная камера будет записывать видео. В выпавшем окне будет выбор из архивов, подключенных к текущей сессии GOALcity.

Просматривать из окна камеры - выбор записи для просмотра в окне. Можно выбрать между записью с текущей камеры и записью из архива с удаленного сервера. Если оставить параметр Записываемый, то в окне будет воспроизводиться видео из архива, в который ведется запись.

3. Выбрать, какая запись будет выведена на просмотр при нажатии на кнопку button-play - Архив - на всплывающей панели в окне камеры.

Выводить на просмотр только основную запись этой камеры - в окне требуется просматривать только основную запись с камеры, расположенной в текущем окне.

Выводить на просмотр автономную записи этой камеры - в окне требуется просматривать только резервную запись с камеры, расположенной в текущем окне.

Выводить на просмотр основную и автономную записи этой камеры - в окне требуется просматривать как резервную, так и основную запись с камеры, расположенной в текущем окне.

Выводить на просмотр все записи выбранного архива - в окне требуется просматривать все записи, находящиеся в выбранном для просмотра архиве.


Запись

Настройки > Настройки в окне камеры >

Запись

Для того, чтобы настроить запись, необходимо:

1. Перейти во вкладку Запись в Настройках камеры и активировать пункт Включить основную запись

Запись по детекции - запись будет производиться при наличии движения в кадре.

Минимальная избыточность - система будет записывать только те кадры, в которых присутствует детекция движения. Это сэкономит место на диске, однако, т.к. будут записываться не все кадры и не постоянно, есть возможность упустить что-то важное.

Средняя избыточность - оптимальный вариант для записи. Если не настроена страховочная запись (об этом чуть ниже), то в случае, когда детектор движения не активен, система вести запись не будет. Однако, если в кадре появится какое-либо действие, сразу же включится запись со скоростью, указанной в поле Скорость записи на время или определенное количество кадров.

2. Перейти во вкладку Страховка и настроить страховочную запись

3. Перейти во вкладку Контент и активировать нужный вам пункт

Записывать все кадры - если для записи требуются все кадры с текущей записи.

Записывать кадры, где есть движение - применяется там, где движение происходит редко, для экономии ресурсов жетских дисков.

Записывать кадры, где есть лица - если нужно записывать только те кадры, в которых система идентифицирует лица.

Записывать кадры, где есть автономера - если нужно записывать только те кадры, в которых система определяет автомобильный номер.

4. Перейти во вкладку Сервер и активировать Автономную запись.

Писать в архив - выбрать архив, в которые данная камера будет записывать видео. В выпавшем окне будут указаны все архивы, которые подключены к текущей сессии GOALcity.

Режим записи - режим записи, по которому будет вестись резервная запись:

-простой - запись будет производиться со скоростью, указанной в пункте Скорость записи, к/с.

-полный - запись будет производиться со скоростью, указанной в пункте Скорость записи, к/с, а при детекции движения ускорится до показателя, указанного в пункте Скорость записи по детекции, к/с.

-только по детекции - запись будет вестись только по детекции, со скоростью, указанной в пункте Скорость записи по детекци, к/с. Если движение в кадре отсутствует, то запись прекращается.

-сквозной - скорость записи будет равна скорости просмотра самого быстрого источника клиента (сервера). Если у источника (сервера) нет клиентов, скорость записи будет равна базовой скорости, установленной в пункте Скорость записи.

Таймаут записи по детекции - задержка записи после детекции движения.

5. Сохраните все изменения, нажав кнопку ОК.


Лица

Настройки > Настройки в окне камеры >

Лица

Для активации алгоритма "Лица" необходимо перейти во вкладку "Идентификация" и поставить галку напротив пункта "Детектор лиц/распознавание"

Для начала другие настройки можете не изменять, они настраиваются "опытным" путем в зависимости от расположения камеры, размера лица в кадре и других параметров, в большинстве случаев, значения "по умолчанию" должны подходить.

Идентификация лиц / расчет метрики - Необходима для работы базы лиц и списка имен панели "Внимание!".

Искать лица только в областях "человек" (с нейросетью) - При включенной нейросети исследует только те области, где есть люди. Уменьшает загрузку процессора.

Минимальный размер лица - Позволяет отфильтровать лица на заднем плане, а также исключить ложные сработки на очень малые размеры лиц, в которых мало биометрики.

Время отслеживания, Точность отслеживания и Точность сравнения метрик лиц - Параметр только для текущего просмотра оператором, не влияет на поиск в базах.

Количество потоков ЦП - если камера не успевает идентифицировать лица, то следует увеличить количество потоков, но при этом может не хватить ресурсов для других камер, которые идентифицируют лица, а также для других задач программы.

Например: для камер, где скорость прохождения людей выше, это значение должно быть больше (камера на входе). А для камер, где скорость прохождения людей ниже, это значение должно быть меньше (длинный коридор).

Это высоконагрузочный алгоритм для процессора компьютера. Активируйте только в случае использования!

Для более наглядного обзора процессов рекомендуется активировать визуализатор трекера лиц на вкладке "Клиент" в настройках камеры.

Далее переходите к активации и настройки алгоритма "Лица" на панели "Внимание!".


Нейросеть

Настройки > Настройки в окне камеры >

Нейросеть

Нейронные сети способны идентифицировать силуэты людей, автомобилей, животных, переносимых объектов и прочие полезные цели, которые действительно интересны пользователю. Нейросеть распознает необходимый объект в любой освещенности, с любых сторон, со всеми углами подвеса камеры, в разных масштабах как на дальнем плане, так и на переднем, исключая помехи (веточки, блики, тени и т.д.).

Онлайн нейросеть - это вариант с постоянным анализом каждого кадра, который работает на видеосервере с установленными мощными картами nVidia. В качестве аппаратной части здесь используются процессоры видеокарт.

Для того, чтобы установить нейросеть, откройте "Настройки камеры", нажав на кнопку button-settings на всплывающей панели выбранной вами камеры.

В открывшемся окне перейдите в пункт "Нейросеть". Затем нажмите на кнопку "Установить полную версию нейронной сети".

Перед вами откроется окно "Менеджер компонентов". Нажимаем на кнопку "Установить".

После того, как нейронная сеть будет установлена, вам будет предложено перезапустить программу и службу.

Для этого необходимо выйти из настроек камеры, нажать кнопку [image] на Главной панели и выбрать в открывшемся окне "Перезапустить программу и службу".

После перезагрузки программы и службы снова откройте "Настройки камеры" и перейдите во вкладку "Нейросеть", как это было описано выше. Здесь необходимо отметить "птичкой" пункт "Активировать фильтр нейронной сети на видеосервере" и выбрать CUDA устройство nVidia.

Для того, чтобы использовать нейросеть, необходимо установить компоненты фильтра нейронной сети, которые используются для решения нестандартных задач на основе классификации объектов. Чтобы их установить, откройте вкладку "Компоненты", выберите нужный вам набор классов и нажмите "Установить".

После этого необходимо снова перезапустить программу и службу.

Далее, открываем "Настройки камеры" - "Нейросеть" и переходим во вкладку "Компоненты". Здесь необходимо выбрать нужный вам компонент фильтра нейронной сети и нажать "Подключить", а затем "ОК".

Обратите внимание, что программа GOALcity позволяет установить сразу несколько компонентов фильтра нейронной сети.


Области просмотра

Настройки > Настройки в окне камеры >

Области просмотра

Данная настройка предназначена для убирания черных полос в области кадра, появляющихся при оцифровке сигнала с аналоговых камер. Также в этом окне Вы можете выбрать область кадра, в которой нужно уделить особое внимание. При этом детекция и запись будет идти по всему кадру, который видит камера.


Надписи

Настройки > Настройки в окне камеры >

Надписи

Данная настройка позволяет настроить надписи, которые будут отображаться в текущем окне.

Пункт «Отображать информационную строку»: данный пункт отвечает за вывод технической информации на панель. Таких как «Разрешение кадра», «Автоконтраст», «Детектор движения», «Индикатор записи» и другие.

Пункт «Выводить предупреждения поверх кадра»: данный пункт настроек отвечает за отображения предупреждений о проблемах с камерой. Например, если связь с камерой будет потеряна, в окне будет отображаться последний полученный кадр, а поверх нее будет полупрозрачное изображение камеры в перечеркивающем круге.

Следующие настройки отвечают за действия в окне, которые будут происходить, при наведения на них курсором:

Пункт «Отображать всплывающую панель»: Данный параметр отвечает за появление панели настроек окна, в которой можно производить различные действия с камерой.

Пункт «Показывать план размещения камеры»: Включает отображение расположения камеры на миниплане, в правом нижнем углу окна.

Пункт «Показывать фотографию камеры»: Включает отображение фотографии камеры, в левом верхнем углу окна. Настройка выбора изображения активируется при выборе данного пункта и представлена в графе ниже.


Поворот

Настройки > Настройки в окне камеры >

Поворот

Данная вкладка позволяет повернуть изображение с камеры, если оно приходит в неправильном положении.

Пункт «Не поворачивать»: при выборе данного пункта настроек, изображение на камере не будет изменено, относительно исходного.

Пункты «Повернуть влево на 90 гр.» и «Повернуть вправо на 90 гр.»: при выборе одного из данных пунктов камера будет повернута на 90 градусов. Данная настройка нужна, если камера посылает изображение повернутым, чтобы привести в единый вид.

Важно! На аналоговых камерах, ввиду особенностей работы оцифровщиков, данная настройка отсутствует.

Пункт «Отразить по вертикали»: данная настройка переворачивает изображение на 180 градусов, относительно текущего. Данная настройка нужна, если изображение с камеры поступает перевернутым, для приведения их в единый вид.


Видеодетектор

Настройки > Настройки в окне камеры >

Видеодетектор

Детектор движения

Система GOALcity получила следующую версию видеодетектора «Snake-II» - это комбинированный координатный помехозащищенный видеодетектор с автоматической адаптацией к окружению.

Всепогодность обеспечивает алгоритм автоматической подстройки чувствительности, а также алгоритмы защиты от помех. В условиях сильных помех, кроме того, при наличии модуля видео аналитики, может включаться фильтр-детектор поступательного движения. Защиту от выпадения данных обеспечивает технология избыточной записи.

GOALcity включает в себя четыре основных типа детектора: контрастный, фоновый детектор (ДОП-детектор), детектор объектов и фильтр-детектор поступательного движения.

Кроме того, в модуле видео аналитики содержится большое число статистических видеодетекторов. Также существуют специализированные видеодетекторы: детектор лиц, видеодетектор автомобильного номера, видеодетектор скорости движения, видеодетектор направления, объема объектов и прочее.

Модуль видеодетекции имеет развитую систему индикации и предупреждений, а также собственную запись, независимую от основного архива. В кадре разными цветами могут отображаться области контрастного движения, области перекрытия фона, оставленные и (или) унесенные предметы. По сработке любого типа видеодетекции может выдаваться звуковой сигнал через встроенный динамик компьютера или с выхода звуковой карты.

Включение и настройка

По умолчанию видеодектор всегда включен для любой вновь созданной камеры. Чтобы его выключить, или перейти к настройкам, выполните следующие действия:

Откройте настройки видеоисточника кликом по кнопке button-settings на всплывающей панели в окне камеры. Перед Вами откроется окно настроек окна и видеоисточника.

По умолчанию открываются абсолютно все настройки окна и видеоисточника, сгруппированные по важности. В данный момент нас интересуют настройки только видеодетектора, поэтому перейдите на вкладку "Сервер". На данной вкладке можно включить\выключить основные компоненты GOALcity и отдельно их настроить. Видеодетектор является серверным компонентом, т.е. изменение его настроек затронет всех клиентов GOALcity подключенных к данному серверу.

Как Вы можете видеть, по умолчанию Видеодетектор включен. Чтобы его выключить, щелкните левой кнопкой мыши по надписи "Видеодетектор" или в любом другом месте "красного прямоугольника".

В выключенном состоянии кнопка окрасится в серый цвет. Чтобы перейти к настройками детектора, щелкните по кнопке dd-nastroiki-03 . Откроется окно с настройками, касающихся работы видеодетектора GOALcity.

У всех настроек есть детальное описание, настроить детектор "под себя" очень просто. Каждая вкладка отвечает за свою группу параметров и все настройки выполнены в стиле "больше-меньше".

"Отмечать область движения как" - Включает визуализацию в окне, для данной группы камер. Здесь можно выбрать цвет и тип рамки для области движения.

"Детализация области движения" - позволяет настроить "размер минимального элемента" в области движения.

"Активировать окно камеры при обнаружении движения" - окно камеры активируется в том случае, если обнаружено какое-то движение в кадре.

"Выдавать звуковой сигнал по детекции" - срабатывание звукового сигнала при обнаружении движения.

"Сохранять кадры с движением в папку" - выбор папки, куда будут сохранены кадры с движением.

"Записывать в Журнал информацию по детекции" - настройка позволяет записывать всю информацию о движении в Журнал.

Маска детекции

Как правило, на любой камере есть зоны, детекция движения в которых не нужна или не желательна. Чтобы настроить маску детекции, перейдите на вкладку "Маска" и отметьте птичкой поле "Есть". Перед Вами откроется "живое" изображение с текущей камеры. "Нарисуйте" с помощью мыши область, детекция движения в которой Вам не нужна.

Маска "рисуется" левой кнопкой мыши, правой - стирается. Масштаб "кисти" изменяется с помощью скрола. Клик средней кнопкой мыши (колесиком) полностью очищает текущую маску.

Чувствительность

Данная вкладка относится к настройкам видеодетектора. Отвечает за чувствительность детектора, к происходящему в кадре. Если ложные сработки идут часто, понизьте уровень чувствительности. Если полезные объекты не определяются, то повысьте.

Точность

Данная вкладка используется для настройки точности детекций. Чем выше точность детекции, тем больше процессорных ресурсов будет использоваться. Если видеодетекция используется лишь для начала записи, то не имеет смысла ставить высокую точность и нагружать компьютер. Максимальный нужен при использовании видеоаналитики и фильтрации сложных помех.

Размер

Данная вкладка используется для настройки точности работы видеодетектора, относительно размеров. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких и крупных объектов. Выбор из пунктов «Максимальный» и «Минимальный» позволяют визуализировать, в отображаемом ниже окне, максимальный и минимальный объект, на который будет срабатывать детекция.

Расположение

В данной вкладке располагается выбор местоположения камеры, в помещении или на улице. При выборе «В помещении» настройки чувствительности будут статическими и не будут изменяться, от происходящих событий в кадре. При выборе «На улице» будет включена автоматическая регулировка чувствительности, которая сама будет подстраиваться под изменяющиеся события в кадре, это немного ухудшает видеоанализ, но избавляет от множеств помех и ложных срабатываний детекции.

Скорость

Данная вкладка используется для настройки точности работы видеодетектора, относительно скорости. В первой шкале, напротив «Минимальная» устанавливается время, которое система может потратить на обработку кадра. Во второй шкале, напротив «Максимальная» устанавливается скорость обработки видеопотока.

Блики

В данной вкладке включается программный фильтр, который позволяет защититься от мельканий света от бликующих поверхностей, частой смены цветности (например, шелеста листьев) и прочих мелких помех. Данный фильтр увеличивает нагрузку на процессор.

При включении будет доступен ползунок, с настройкой чувствительности фильтра. Если ложные сработки идут часто, повысьте уровень чувствительности. Если полезные объекты не определяются, то понизьте.


Сеть и кодек

Настройки > Настройки в окне камеры >

Сеть и кодек

Во вкладке «Сеть» настраивает метод сжатия передаваемых данных, по типу пропускной способности сети. Выбирая тип вашей сети, в следующей вкладке , которая будет называться «Кодек X» находятся настройки и метод сжатия для передаваемых файлов с настройками. При выборе локальной сети следующая вкладка будет называться «Кодек LOC», при выборе более 100мбит/с – «Кодек LAN», при выборе менее 100мбит/с – «Кодек Internet». При LOC и LAN будет использоваться метод сжатия SpecLab MJPEG Light. При выборе Internet будет использоваться метод сжатия SpecLab MJPEG Hard

«Кодек Internet» имеет в себе дополнительные настройки

«Интервал между ключевыми кадрами» - Позволяет настроить интервал между ключевыми кадрами, это число кадров, после обработки которых кодек создает ключевой кадр при экспорте видео. Значение интервала ключевых кадров указывает кодировщику частоту проведения повторной оценки видеоизображения и записи полного кадра, или ключевого кадра, в файл. Если в кадре происходит частая смена сцен, присутствуют быстро движущиеся объекты, то общее качество изображения можно повысить сокращением интервала ключевых кадров. Уменьшение интервала между ключевыми кадрами приводит к увеличению размера выходного файла. Для ключевого файла устанавливается 2 значения. Временной, в милисекундах, и кадровый. Выдача нового ключевого кадра будет происходить по первому сработавшему алгоритму.

«Постобработка» - данный пункт улучшает качество изображения, но увеличивает нагрузку на процессор.


Просмотр

Настройки > Настройки в окне камеры >

Просмотр

В данной вкладке Вы можете настроить то, с какой скоростью воспроизведения будут выводиться видео в окнах GOALcity.

Пункт «Не экономить, получать все кадры и выводить с максимально возможной скоростью»: включая данную настройку, отображаться в текущем окне, будут передаваться данные в наилучшем разрешении и наибольшей частотой кадров, для данного потока. Для данного пункта настроек требуется высокопроизводительный процессор и «широкая» пропускная способность сети.

Пункт «При статике получать все кадры со скоростью не более»: в данной графе выбирается скорость воспроизведения видео с камеры, в которой не происходит ни одна из настроенных детекций.

Пункт «При видеодетекции ускоряться до»: здесь устанавливается скорость кадров, с которой будет воспроизводиться видео в окне, если одна из включенных детекций сработает.

Пункт «Ускоряться на любое движение»: данный пункт выбирается, если требуется увеличивать скорость воспроизведения видео, когда в кадре появляется любое движение. Для работы данной настройки требуется включенный «Видеодетектор» в настройках сервера.

Пункт «Ускоряться на лица»: данный пункт выбирается, если требуется увеличивать скорость воспроизведения видео, когда в кадре детектируется лицо. Для работы данной функции требуется включенный «Детектор лиц» в настройках сервера.

Пункт «Ускоряться на номера автомобилей»: данный пункт выбирается, если требуется увеличивать скорость воспроизведения видео, когда в кадре детектируется автомобильный номер. Для работы данной функции требуется включенный «Детектор номера» в настройках сервера.

Пункт «Не получать видео, принимать только метаданные»: отключает вывод видео в окне, но сохраняет вывод включенных детекций. В окне дальше будут отображаться данные с аналитики камеры, а также место их расположения.

Пункт «Режим ретранслятора»: Данный пункт выбирается, если данный клиент ретранслирует из данного окна видео на другие клиенты GOALcity, с изменением выходного кадра.

Пункт «Клиент ретранслятора»: Данный пункт выбирается, если данный клиент принимает в данное окна видео с другого клиента GOALcity. Настройка «Таймаут подключения» отвечает за время, в течении которого окно будет пытаться переподключиться к «Ретранслятору».


Буфер

Настройки > Настройки в окне камеры >

Буфер

В данной вкладке задается, сколько кадров будет хранится в буфере на сервере и клиенте.

Пункт «Буферизация на клиенте»: здесь задается количество кадров, которое будет сохраняться в памяти для временного хранения на компьютере клиенте.

Пункт «Буферизация на сервере»: здесь задается количество кадров, которое будет сохраняться в памяти для временного хранения, на компьютере, где расположен сервер.


Скрытность

Настройки > Настройки в окне камеры >

Скрытность

Данное окно позволяет включать и отключать анализ кадра, если окно скрыто. Если Вам нужно получать данные, со скрытого окна камеры, оставьте пункт «Да», тогда, даже будучи скрытой, на камере будет продолжаться обработка информации. Если выбрать пункт «Нет», то аналитика и запись на скрытом окне камере прекратится, что сэкономит ресурсы процессора.


Контроль

Настройки > Настройки в окне камеры >

Контроль

В данной вкладке настраиваются действия с камерой, если пропадает связь или видео сигнал.

Пункт «Переподключаться через»: отметив данный пункт программа будет сама пытаться подключиться к камере, с которой пропала связь. Также настраивается, через какой временной период программа будет пытаться это делать. Если выбрать 1 минуту, то через каждую минуту времени будет происходить попытка переподключения.

Пункт «Время на подключение – не более»: устанавливается время, в течение которого программа будет пытаться подключиться к серверу. По истечении его, если ответа от сервера нет, эти попытки будут прекращены.

Пункт «Время на получение кадра – не более»: настраивается минимальное время для получения кадра с камеры, по истечении его система будет считать, что пропал сигнал.

Пункт «Звуковой сигнал при пропадании видео»: позволяет включить и выбрать подачу звукового сигнала, если сообщение с камерой пропадает.

Пункт «Записывать события в Журнал»: записывает сообщения о потери связи в системный журнал GOALcity, который можно открыть из главного меню, пункт «Просмотр журнала».


Тамперинг

Настройки > Настройки в окне камеры >

Тамперинг

В данной вкладке настраиваются действия с камерой, если она была перекрыта.

Пункт «Активировать детектор тамперинга»: включает детектор перекрытия. Включает видеодетектор объектов. Данные настройки являются серверными и затронут все клиенты, которые подключаются к нему.

Пункт «Задержка сработки» - задержка выдачи сигнала о появлении тамперинга. Т.е. детектор может определить наличие нарушения, но сообщит о нём только спустя указанное время, при условии, что в течение этого времени тамперинг сохранится. Это позволяет отстроиться от кратковременных нарушений или непредвиденных помех, которые могут нарушить работу алгоритма.

Пункт «Задержка восстановления» - работает аналогично пункту «Задержка сработки», но уже на этапе снятия сигнала о наличии тамперинга.

Пункт «Период сброса состояния детектора» - время, по истечению которого, детектор выполнит сброс до состояния идентичному началу работы детектора при старте программы.

Пункт «Подавать звуковой сигнал»: позволяет включить и выбрать подачу звукового сигнала, если камера перекрыта.

Пункт «Записывать события в Журнал»: записывает сообщения о потери связи в системный журнал GOALcity, который можно открыть из главного меню, пункт «Просмотр журнала».

Вкладка «Дополнительные» - предназначена для технических специалистов и не требует изменений.


Автономер

Настройки > Настройки в окне камеры >

Автономер

Данная вкладка предназначена для включения алгоритма по определению автомобильного номера в кадре камеры. Выбор одной из настроек является серверной и включается для всех, кто подключается к данному серверу. Если детектор включен, появляются дополнительные настройки работы алгоритма по определению автомобильных номеров.

Внимание! При разрешениях кадра 768x288 и 640x240 алгоритм определения автономеров работать не будет.

Также Вы более подробно можете узнать от чего зависит вероятность распознавания и высокоскоростном детекторе номеров.

Устаревший детектор номеров

«Основные настройки»

Пункт «Страна»: в данном пункте выбираются автомобильные номера страны, которые будет искать алгоритм в кадре. Для российских номеров также можно выбрать код региона.

Пункт «Определять номера только выбранной страны»: выбрав данный пункт алгоритм будет искать и выводить автомобильные номера, выбранные в пункте «Страна». Если данный параметр не выбран, алгоритм будет искать номера всех стран, которые он может определить.

Пункт «Скорость детекции»: данный параметр отвечает за то, сколько кадров в каждой секунде будет анализироваться алгоритмом. Чем выше параметр, тем больше ресурсов процессора будет использоваться.

Пункт «Отмечать номера как»: при включении данного параметра в окне просмотра камеры будут отображаться автомобильные номера, которые определил алгоритм. Также в данном пункте можно выбрать цвет отображения номера в окне.

Пункт «Выдавать звуковой сигнал по детекции»: позволяет выбрать и настроить подачу звукового сигнала при сработке данного алгоритма.

Пункт «Сохранять кадры с номерами в папку»: данный пункт настрое выбирается, если нужно сохранять кадры, в которых алгоритм нашел автомобильный номер. Также можно указать место на компьютере, куда программа будет сохранять записываемые кадры

Пункт «Записывать в Журнал информацию о детекции»: записывает в журнал номер, который определил алгоритм, в системный журнал GOALcity, который можно открыть из главного меню, пункт «Просмотр журнала».

«Дополнительные настройки»

«Минимальная достоверность номера» - в данном пункте задается процент соответствия рамки номера относительно от параметров, указанных в ГОСТ Р 50577-93 , чем выше, тем точнее определение номера.

«Минимальная достоверность символа» - в данном пункте задается процент соответствия рамки символов в рамке относительно от параметров, указанных в ГОСТ Р 50577-93, чем выше, тем точнее определение номера.

«Порог распознавания символа» - в данном пункте указывается процент соответствия отдельного символа в автомобильном номере от эталонного, чем выше, тем точнее определение номера.

«Угол установки камеры по горизонтали» - в данной настройке задается угол отклонения камеры от горизонтальной плоскости в градусах.

«Угол установки камеры по вертикали» - в данной настройке задается угол отклонения камеры от вертикальной плоскости в градусах.

«Использовать адаптивную нормализацию» - данный пункт необходимо включать в том случае, если в номерах используются цветные символы (цифры или буквы). Эта обработка преобразует их в черно-белые в зависимости от интенсивности окраски. Более интенсивные цвета отображаются чёрным, менее – белым. Включение этой опции в данном случае повышает точность распознавания таких номеров.

«Искать номера только при наличии движения» - при активации данной настройки, номера будут определятся, только если в кадре есть движение.

«Искать номера в областях движения» - при активации данной настройки, алгоритм будет искать номера только в тех районах, где есть движение.

«Зона поиска» - как правило, в реальных условиях при проезде (остановке) транспортного средства в зоне охвата камеры номера находятся в ограниченной зоне кадра. Для ускорения обработки кадра желательно установить границы, в которых программа и будет пытаться обнаружить автомобильный номер. Делается это перемещением границ рамки с помощью мыши при нажатой и удерживаемой её левой клавише.

Новый детектор автономеров

Вкладка «Основные» - здесь представлены основные настройки, связанные с высокоскоростными автономерами.

«Скорость работы (к/с)» - данный параметр отвечает за то, сколько кадров в каждой секунде будет анализироваться алгоритмом. Чем выше параметр, тем больше ресурсов процессора будет использоваться.

«Минимальная ширина пластины» - здесь задается какое минимальное количество пикселей может занимать автомобильный номер в ширину.

«Максимальная ширина пластины» - здесь задается какое максимальное количество пикселей может занимать автомобильный номер в ширину.

«Количество потоков обработки» отвечает за то, сколько потоков процессора будет использовать камера. Если камера не успевает идентифицировать номера, то следует увеличить количество потоков, но при этом может не хватить ресурсов для других камер, которые идентифицируют номера, а также для других задач программы. Например: для камер, где скорость проезда автомобилей выше, это значение должно быть больше (камера на автомагистрали). А для камер, где скорость проезда автомобилей ниже, это значение должно быть меньше (камера на небольшой улице).

«Масштабирование» - в данном меню задается параметр масштабирования

«Порог бинаризации» - порог бинаризации цветных пикселей в черно-белые. Используется для внутренних потребностей. Значение по умолчанию 40 (рекомендуется). Менять ТОЛЬКО после анализа изображения специалистами Спецлаб.

Пункт «Углубленный анализ изображения» повышает качество распознавания в неблагоприятных условиях (например, если характеристики/настройки камеры не полностью соответствуют требованиям, либо при плохой погоде). Увеличивает время обработки кадра на 20-30% в зависимости от его размера. В нормальных условиях данный̆ параметр не влияет на качество распознавания.

Пункт «Учет перспективы изображения» - рекомендуется включать, когда номера имеют предельный наклон. Однако при этом увеличивается загрузка процессора

Пункт «Тест производительности» включает отображение того, сколько времени было затрачено на анализ кадра. Если более 500 мс, необходимо уменьшить скорость работы.

Пункт «Страны» отвечает за включение автомобильных номеров различных стран. Раскрыв номер, появляется еще три пункта. Рассмотрим их на примере России.

Пункт «Разрешен» включает поиск номеров выбранной страны.

Пункт «Минимальная достоверность распознавания(%)» в данном пункте задается процент соответствия рамки номера относительно от параметров, указанных в стандарте для номеров выбранной страны, чем выше, тем точнее определение номера.

Пункт «Использовать шаблоны (через , и/или -)» позволяет выбирать шаблоны для сравнивания. Например, 1,4,10,15-20 будут использовать шаблоны, с такими же названиями, из папки Templates в директории установки AutoNum.

«Зона поиска» - как правило, в реальных условиях при проезде (остановке) транспортного средства в зоне охвата камеры номера находятся в ограниченной зоне кадра. Для ускорения обработки кадра желательно установить границы, в которых программа и будет пытаться обнаружить автомобильный номер. Делается это перемещением границ рамки с помощью мыши при нажатой и удерживаемой её левой клавише.

Стандартный детектор номеров

Данный алгоритм использует нейронные сети с расчетом на центральном процессоре. Его стоит включать только для тех камер, где отслеживаются автомобильные номера.

Вкладка "Основные"

"Обновлять данные детектора движений" - заменяет работу детектора движений на работу нейросети. Все настройки, ориентированные на видеодетектор, например, запись видео на диск, будут работать по данным сработок нейросети. При активации необходимо выключить детектор движений, чтобы исключить конфликты модулей программы.

"Определять модель/цвет автомобиля" - с помощью этой настройки можно точно зафиксировать модель или цвет проезжающего автомобиля.

"Многопоточный режим" - настройка позволяет выбрать количество потоков.

"Отмечать номера как" - при включении данного параметра в окне просмотра камеры будут отображаться автомобильные номера, которые определил алгоритм. Также в данном пункте можно выбрать цвет отображения номера в окне.

"Выдавать звуковой сигнал по детекции" - позволяет выбрать и настроить подачу звукового сигнала при сработке данного алгоритма.

"Сохранять кадры с номерами в папку" -данный пункт настрое выбирается, если нужно сохранять кадры, в которых алгоритм нашел автомобильный номер. Также можно указать место на компьютере, куда программа будет сохранять записываемые кадры.

"Записывать в Журнал информацию о детекции" - записывает номер, который определил алгоритм, в системный журнал GOALcity, который можно открыть из главного меню, пункт «Просмотр журнала».

Вкладка "Дополнительные"

"Обрабатывать негоризонтальные номера" - возможность обрабатывать не только горизонтальные, но и вертикальные номера.

"Искать номера в областях движения" - поиск номера в кадрах с движением.

"Распознавать светлый текст номера" - распознавание текста номера на светлом фоне.

"Количество ошибок в номере" -количество ошибок, которые присутствуют в номере.

"Зона поиска" - как правило, в реальных условиях при проезде (остановке) транспортного средства в зоне охвата камеры номера находятся в ограниченной зоне кадра. Для ускорения обработки кадра желательно установить границы, в которых программа и будет пытаться обнаружить автомобильный номер. Делается это перемещением границ рамки с помощью мыши при нажатой и удерживаемой её левой клавише.


Фондетектор

Настройки > Настройки в окне камеры >

Фондетектор

Если стандартный видеодетектер показывает любые изменения в кадре по сравнению с предыдущим, то детектор фона дает статическую информацию, показывая лишь изменения относительно фона.

Пункт «Активировать детектор фона на видеосервере» - включает детектор фона для камеры, расположенной в текущем окне. Данные настройки являются серверными и затронут все клиенты, которые подключаются к нему.

Пункт «Отмечать область перекрытия фона как» - включает в текущем окне графическое отображение мест, где фон был перекрыт. В данном пункте также можно выбрать цвет, которым будет отмечаться перекрытие.

Пункт «Отмечать оставленные и унесенные предметы как» - включает в текущем окне графическое отображение мест, где детектором был выявлен оставленный или унесенный предмет. В данном пункте также можно выбрать цвет, которым будет отмечаться оставленный или унесенный предмет.

Пункт «Активировать окно камеры при обнаружении предмета» - максимизирует окно и помещает его в центр экрана, если алгоритм обнаружил оставленный или пропавший предмет.

Пункт «Выдавать звуковой сигнал по детекции» - позволяет выбрать и настроить подачу звукового сигнала при сработке данного алгоритма.

Пункт «Сохранять кадры с предметами в папку» - данный пункт настроек выбирается, если нужно сохранять кадры, в которых алгоритм обнаружил оставленный или унесенный предметы. Также можно указать место на компьютере, куда программа будет сохранять записываемые кадры.

Пункт «Записывать в журнал информацию о детекции» - записывает в журнал событие, который определил алгоритм, в системный журнал GOALcity, который можно открыть из главного меню, пункт «Просмотр журнала».

«Дополнительные настройки» в данных настройках указываются параметры, от которых зависят параметры сработки алгоритма.

Пункт «Минимальный размер» - в данном параметре задается минимальный размер объекта в процентах, от общей площади кадра.

Пункт «Чувствительность» - Отвечает за чувствительность детектора, к происходящему в кадре. Если ложные сработки идут часто, понизьте уровень чувствительности. Если полезные объекты не определяются, то повысьте.

Пункт «Определять только неподвижный оставленный объект» - данная настройка отвечает за сработку алгоритма на предметы, которые полностью остановили свое движение.

Пункт «Время определения оставленного объекта» - в данном пункте устанавливается временной период, за который алгоритм будет определять, что объект привнесен или унесен.

Пункт «История движения» - обычно во всех видеосистемах детекция движения осуществляется анализом изменений в соседних кадрах друг относительно друга. Но в случае высокой скорости показа и маленькой скорости движения это приведет к тому, что детекция не сработает. "История движения" анализирует изменения в кадрах за весь указанный период времени, тем самым снимая подобную проблему. Её значение по умолчанию – тоже оптимально для большинства объектов, и лучше всего определяется опытным путём.

Пункт «Быстрая адаптация» - минимальное время, затрачиваемое алгоритмом на автоматическое изменение параметров фильтров в зависимости от изменившихся условий.

Пункт «Медленная адаптация» - максимальное время, затрачиваемое алгоритмом на автоматическое изменение параметров фильтров в зависимости от изменившихся условий.


Цветдетектор

Настройки > Настройки в окне камеры >

Цветдетектор

Включает режим детекции по цвету объекта. При активации данного пункта программа начнет замечать движение объектов только определенного цвета либо, наоборот, объекты определенного цвета останутся без внимания системы.

«Отсутствует» - если выбран данный пункт, детекция по цвету производиться не будет.

Пункт «Только указанный цвет» - включает режим детекции по цвету объекта, при активации данного пункта программа начнет замечать движение объектов только определенного цвета. Цвет, на который алгоритм должен срабатывать, выбирается в поле кадра левой кнопкой мыши, находящемся под пунктами меню.

Пункт «Любой цвет, кроме указанного» - включает режим детекции по цвету объекта, при активации данного пункта программа начнет замечать движение объектов любого цвета, кроме определенного цвета. Цвет, на который алгоритм не должен срабатывать, выбирается в поле кадра левой кнопкой мыши, находящемся под пунктами меню.

«Искать только в областях общего движения» - поставив «галочку» в соответствующем окошке, алгоритм будет искать цвет, только если в этом же районе есть общее движение.


Интеллект

Настройки > Настройки в окне камеры >

Интеллект

В данной вкладке представлены настройки для высоконагрузочного алгоритма, необходимого для работы видеоаналитики СпецЛаб.

Пункт «Активировать ‘интеллектуальный’ детектор объектов на сервере» - включает видеодетектор объектов. Данные настройки являются серверными и затронут все клиенты, которые подключаются к нему.

«Скорость детекции» - данный параметр отвечает за то, сколько кадров за секунду будет анализироваться алгоритмом. Чем выше параметр, тем больше ресурсов процессора будет использоваться.

Параметр «Минимальный/максимальный размер» - устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких объектов.

Пункт «Чувствительность» отвечает за чувствительность детектора, к происходящему в кадре. Если ложные сработки идут часто, понизьте уровень чувствительности. Если полезные объекты не определяются, то повысьте.

«Искать объекты только при наличии движения» - алгоритм будет срабатывать и искать в кадре объекты, только при условии, что в нем находится движение. Для работы данной настройки требуется включенный «Видеодетектор», в настройках сервера.

Пункт «Отмечать объекты как» включает в текущем окне графическое отображение мест, где был обнаружен объект. В данном пункте также можно выбрать цвет, которым будет отмечаться объект.

Пункт «Показывать идентификатор объекта» включает отображение числового идентификатора, для каждого отдельного объекта, находящегося в кадре.

Пункт «Отображать траекторию движения»: включает в текущем окне графическое отображение траектории движения объекта. В данном пункте также можно выбрать цвет, которым будет отмечаться траектория движения.

Пункт «Использовать маску» включает настройки маски для данного алгоритма. В подменю откроется область кадра, в которой при нажатии левой кнопкой мыши будет закрашиваться область, на которой не нужна детекция, а правой кнопкой мыши эти области можно стирать. Чтобы увеличить или уменьшить кисть для закрашивания или стирания области, используйте колесико мыши с зажатой левой клавишой "Сtrl".


Помехи

Настройки > Настройки в окне камеры >

Помехи

Если в кадре камеры находятся очень сложные помехи, например, когда сработки идут на движение деревьев, тени веток или другие процессы, не поддающиеся фильтрации обычными способами, можно реагировать исключительно на поступательное движение. Фильтр сложных помех доступен только при активации детектора объектов на вкладе "Интеллект".

«Использовать фильтр сложных помех» - данная функция позволяет включить фильтр, при включенном детекторе объектов.

«Минимальная длина траектории» - в данном параметре задается процент от площади кадра, в котором должно будет произойти движение, чтобы алгоритм сработал и определил объект. Если много ложных сработок, надо повысить процент, если полезные объекты не определяются, то понизить.

«Время падения чувствительности» - в данном параметре указывается на какой промежуток времени будет понижена чувствительность в области, где алгоритм обнаруживает помеху.

«Время повышения чувствительности» - в данном параметре указывается через какой промежуток времени будет повышена чувствительность к изначальной, если в области пониженной чувствительности не было помех.


Миниплан

Настройки > Настройки в окне камеры >

Миниплан

Данная вкладка становится активной если во вкладке "Надписи" активировать «Показывать план размещения камеры». Вам будет представлена область, в которой можно начертить план, закрашивая квадраты левой кнопкой мыши, стирая правой, двойной клик выбирает расположение камеры и загружает план из списка сохраненных. Клик по списку планов слева устанавливает логическую связь данной камеры с выбранной.


Маскирование

Настройки > Настройки в окне камеры >

Маскирование

Предназначением данной вкладки является маскирование определенного участка зоны обзора камеры. Для этого в окне с видео кадром закрасьте область, которую нужно скрыть от просмотра, и нажмите кнопку "ОК". Например, нужно видеть человека, стоящего у банкомата, но требуется скрыть, какой код он вводит на панели. Причем, уровень неразборчивости можно регулировать. Например, сделать доступным просмотр силуэтов, дабы контролировать события, которые можно понять по движениям. Во всех случаях этот вариант в архиве не оставляет реального изображения под ретушью.

Итоговый результат маскирования Вы можете увидеть ниже.


Фильтры

Настройки > Настройки в окне камеры >

Фильтры

В данном меню собраны различные специализированные настройки.

Вкладки "Брокер кадров - предварительный" и "Брокер кадров терминальный"

Брокер используется для совместной обработки данных от нескольких источников, тогда как обычный фильтр работает только с данными от одного источника. Главным отличием предварительного брокера кадров от терминального является тот факт, что предварительный брокер получает данные ДО их обработки фильтрами, а терминальный - ПОСЛЕ.

Настройки для обоих брокеров идентичны.

"Режим рассылки кадров" - данная настрой позволяет выбрать сквозной, с постоянной базовой скоростью, с ускорением по детекции или только по детекции, режим рассылки кадров.

"Базовая скорость рассылки кадров, к/с" - скорость, с которой будет производиться основная рассылка кадров.

"Скорость рассылки кадров при детекции, к/с" - с помощью этой настройки можно установить скорость рассылки кадров при детекции.

"Таймаут рассылки кадров по детекции, к/с" - задержка рассылки кадров после детекции движения.

"Обработчики" - на данный момент для брокера есть только один обработчик - анализатор метаданных.

Вкладка «История Детекций»

Суть «истории детекции» заключается в том, что в поле зрения камеры где-то чаще, а где-то реже, детектируется движение, лица или автомобильные номера. На мониторе это может отображаться в виде цветной, монохромной или суммарной карты. В случае цветной карты, области, в которых чаще детектируется или было совсем недавно зафиксировано, например, движение, окрашиваются в определенный цвет (по умолчанию в красный), и называются «горячим следом», а те области, где движения не было давно или же нет совсем, в другой цвет, и называются «холодным следом». Там, где движение детектировалось недавно, остается «теплый след», который в свою очередь окрашивается в свой цвет. Таким образом, можно проконтролировать, где чаще всего детектируются движение, лица или автономера.

Пункт «Включить» задействует историю детекций. Чтобы отображать в окне историю детекций, нужно включить визуализатор в настройках клиента.

«Время хранения истории» - настройка отвечает за время хранения истории (в секундах).

Вкладка «Оставленный предмет» отвечает за специализированный детектор оставленных предметов, предназначающийся для особых условий.

Вкладка "События ONVIF" - используется для интеграции с сервером по протоколу ONVIF


ЖД вагоны

Настройки > Настройки в окне камеры > Фильтры >

ЖД вагоны

Данный фильтр используется для распознавания номеров железнодорожных вагонов, имеющих однострочный восьмизначный номер. Обеспечивает распознавание номеров для всех типов локомотивов, грузовых вагонов и цистерн.

Для работы необходимо:

1. Установить сетап GOALcity_WagonNum_x64.exe

2. Открыть «Настройки камеры» (как это сделать, вы можете прочитать здесь) вкладку «Фильтры», пункт «ЖД вагоны». Отметить «галкой» пункт «Разрешен».

«Скорость работы (к/с)» - скорость кадров, с которой будет воспроизводиться видео в окне камеры.

«Точность (%)» – точность определения номеров.

«Средняя высота символов (пикс.)» - наиболее часто встречающаяся усредненная высота символов.

«Соотношение ширины и высоты символа» - наиболее часто встречающееся, усредненное

соотношение ширины/высоты символов номера.

«Минимальная ширина символов» - минимальная ширина символов номера. Символы с меньшей

шириной будут отброшены.

«Минимальная высота символов» - минимальная высота символов номера. Символы с меньшей

высотой будут отброшены.

«Максимальная ширина символов» - максимальная ширина символов номера. Символы с большей

шириной будут отброшены.

«Максимальная высота символов» - максимальная высота символов номера. Символы с большей

высотой будут отброшены.

«Поворот по Х в градусах» - угол поворота камеры вокруг горизонтальной оси.

«Поворот по Y в градусах» - угол поворота камеры вокруг вертикальной оси.

«Поворот по Z в градусах» - угол поворота камеры вокруг оси.

Выводить частично распознанный номер – при включении данного параметра в окне просмотра

камеры будут выводиться даже те номера, которые распознаны не в полной мере.

Регион интереса – зона поиска номеров ЖД вагонов. Для ускорения обработки кадра желательно

установить границы, в которых детектор и будет пытаться обнаружить номер

Примеры выделения зоны поиска:

Пример неправильно выделенной области

Пример правильно выделенной области

Для отображения работы детектора необходимо включить "Визуализатор номеров ЖД вагонов" в "Настройках камеры".

При условии правильной настройки детекция номеров ЖД вагонов будет выглядеть так:


Дополнительно

Настройки > Настройки в окне камеры >

Дополнительно

"Корректировка аудио потока (Гц)" - если расходится звук с видео(при опережении звука можно понизить частоту воспроизведения задав отрицательное значение и наоборот.

"Оптимизация для мультипроцессорных систем" -данный пункт надо отмечать, когда в системе установлено 2 или более процессоров, для оптимизации работы GOALcity.

"Использовать системное время" - при активации этой настройки время берется не из потока, а присваивается текущее системное время.

"Количество буферов оптимизации" -в данном пункте указывается количество буферов, которые будут оптимизировать работу GOALcity в многопроцессорных системах.

"Отключить потоковую оптимизацию" - отключать потоковую оптимизацию можно только в особых случаях, в основном, по рекомендации тех.подержки.

«Разрешить алгоритмы» - если отметить данный пункт галочкой, то видеосервер будет преобразовывать формат источника в формат необходимый для обработки алгоритмами. По умолчанию включено. Если данную настройку выключить, то декомпрессия будет происходить на локальном клиенте.

«Аппаратное ускорение декомпрессии видеопотока при использовании алгоритмов» - данная настройка позволяет выбрать алгоритм аппаратного ускорения, который будет помогать в распаковке сжатых файлов на видеосервере, если в пункте «Разрешить алгоритмы» стоит галочка. С практической точки зрения данный режим стоит задействовать только на сервере GOALcity, не поддерживающем режим NVIDIA CUVID, но поддерживающем DirectX 11.2. В остальных случаях наилучшим режимом будет NVIDIA CUVID, либо, если он недоступен - DXVA2, который можно использовать на удалённых клиентах с самым разным оборудованием, вплоть до встроенных ГП Intel и AMD. Автоматический выбор метода декомпрессии работает именно по такому алгоритму: сначала выполняется проверка доступности NVIDIA CUVID, затем DXVA2 и D3D11VA. Если ни один из них недоступен используется программная декомпрессия.

«Индекс ускорителя декомпрессии видеопотока» - позволяет выбрать устройство, на котором будет производиться декомпрессия. Данная настройка нужна, если в системе установлено несколько устройств, которые могут выполнять декомпрессию. Например, несколько видеокарт. Так, первая видеокарта будет 0, вторая 1. Если у вас отключено аппаратное ускорение декомпрессии, данную настройку лучше не использовать и оставить по умолчанию.

«Отладочный режим» - технологическая настройка, только для специалистов.

"Авто выбор JPEG кодека" - в данном пункте задается, чтобы GOALcity автоматически выбирал JPEG кодеки видео камеры, при наличии нескольких различных кодеков. Тогда в архив пишутся только полные кадры JPEG.


Настройки видеоисточников

Настройки > Настройки в окне камеры >

Настройки видеоисточников

Общее описание

Настройки всех видеоисточников подразделяются на 2 главные категории - серверные и клиентские. Серверные настройки едины для всех клиентов, подключенных к данному источнику, клиентские же, могут быть заданы для каждого из подключенных клиентов индивидуально.

Чтобы открыть настройки видеоисточника, кликните левой кнопкой мыши по кнопке button-settings всплывающей панели в окне камеры. Интерфейс настроек "притерпел" большие изменения, стал более понятен "рядовому" пользователю. Все опции снабжены подробными подсказками и пояснениями. Окно настроек разделено на 3 группы: "Все настройки", "Клиент" и "Сервер".

Соответственно вкладка "Клиент" отвечает за настройки только текущего клиентского места, и не затронет больше никого.

Вкладка "Сервер" позволяет менять параметры сразу для всех подключенных к данному видеоисточнику клиентов GOALcity.

Вкладка "Все настройки" рекомендуется для "продвинутых" пользователей, в ней собраны абсолютно все настройки без разграничений сервер-клиент.

Другими словами, изменяя настройки через вкладку "Все настройки", Вы можете, сами того не зная, поменять параметры сразу для всех подключенных клиентов. Осторожнее с этим!

Основные параметры сгруппированы на соответствующих вкладках и их можно включать\выключать одним нажатием. Напротив каждого пункта есть кнопка, позволяющая открыть расширенные параметры.


Мультимедиа сервер

Настройки >

Мультимедиа сервер

Мультимедиа сервер представляет из себя комбайн источников для работы с различным оборудованием. В зависимости от установленных компонентов комплекса и компонентов в прошивке ключа защиты GOALcity в настройках мультимедиа сервера будут присутствовать следующие источники:

DeviceSource - приемник для работы с виртуальными устройствами. Позволяет создавать виртуальные ключи. Требуется наличие в прошивке ключа защиты возможности работы с компонентом "Сервер устройств". Устанавливается вместе с мультимедиа сервером. Также через этот источник подключаются интегрированные датчики и ключи с системы ОПС "Багульник".

DirectShowSource - приемник для работы с устойствами DirectShow, такими как USB Web камеры и т. д. Является экпериментальной разработкой и присутствует только в аппаратном ключе защиты с прошивкой "Мастер ключ". Устанавливается вместе с мультимедиа сервером.

ExternalExtensionsSource - источник внешних расширений, используется для работы со специализированным оборудованием, например, для подключения IP оборудования производства Dallmeier. Требуется установка компонента ExternalExtensionsSource и наличие в прошивке ключа защиты возможности работы с данным компонентом. Устанавливается из файла ExtExSourceSetup.exe из комплекта ПО GOALcity.

FlirSource - источник для работы с тепловизорами от фирмы Flir. Термодетектор, разрабатываемый компанией СпецЛаб, на сегодняшний день идеальное средство для точного диагностирования целей и помех. Он, как и обычная видеокамера, может видеть на большие расстояния, и, в отличие от обычной, в густых кустах и лесных массивах. Пожалуй, это самый зоркий видеодетектор, а главное, самый точный помехоустойчивый. Ему не надо объяснять, что есть качающаяся ветка или крупный снег, он работает только по температурным объектам. Устанавливается из файла flirsource.exe комплекта ПО GOALcity.

CoxSource - источник для работы с тепловизорами немецкой фирмы Cox. Устанавливается из файла coxsource.exe комплекта ПО GOALcity.

EvsSource - источник для работы с камерами фирмы EVS отечественной разработки. Данные камеры работают по протоколу UDP и показывают довольно неплохие показатели, особенно по соотношению цена-качество. Устанавливается из файла evssource.exe комплекта ПО GOALcity.

Ретранслятор. GOALcity - приемник для работы с ретранслируемыми окнами видеоклиента GOALcity. Устанавливается вместе с мультимедиа сервером. Для работы с данным источником требуется прошивка компонента Ретранслятор.

IpSource - приемник для работы с различным IP оборудованием (видеокамеры, видеосервера, мегапиксельные камеры). Для некоторых моделей оборудования дополнительно поддерживается работа со встроенными каналами звука (аудио), датчиками и реле. Устанавливается вместе с мультимедиа сервером. Для работы с данным источником требуется наличие в прошивке ключа защиты компонента "Сервер поддержки IP устройств". Список интегрированного оборудования Вы можете посмотреть на сайте технической поддержки.

RTPSource - приемник для работы с IP видеокамерами или серверами по RTP или RTSP протоколу передачи мультимедийных данных. Устанавливается вместе с мультимедиа сервером. Поддерживается работа и по протоколу ONVIF, имеется автоматический поиск поддерживаемых камер.

FFSource - новая версия источника для работы с IP видео камерами через GOALcity и RTSP протокол передачи мультимедийных данных. В работе используются программные библиотеки ffdshow. Устанавливается вместе с Мультимедиа сервером GOALcity. Является заменой устаревшего источника VLCSource.

SLDASource - источник работы с устройствами, подключаемыми по протоколу RS-485 производства Спецлаб и ряда сторонних производителей. Также в этом источнике осуществляется подключение IP контроллера Телепатия производства Спецлаб. Требуется установка бесплатного драйвера SLDA и наличии в прошивке ключа защиты возможности работы с компонентом Сервер устройств. Устанавливается вместе с мультимедиа сервером. Последнюю версию бесплатного драйвера можно скачать из раздела бесплатного ПО с сайта технической поддержки.

Также через SLDASource подключаются устройства из интегрированных систем ОПС, таких как "Болид" и "Стрелец".

SLSource - источник для работы с IP-видеосерверами и IP-Видеоблейзерами производства Спецлаб. Позволяет использовать все источники указанного оборудования (видео, датчики, реле и сигнализацию). Устанавливается вместе с мультимедиа сервером. Для работы с данным источником требуется наличие в прошивке ключа защиты компонента "Сервер поддержки IP устройств".

VlcSource - источник для внутренних (технологических) нужд. В большинстве случаев Вам он не понадобится, кроме как по рекомендации службы технической поддержки. Устанавливается из файла VlcSourceSetup.exe из комплекта дистрибутивов GOALcity.

С помощью этого источника можно проигрывать ролики в окнах GOALcity вместо "живого" видео с камер видеонаблюдения.

Amalgama - приемник для контроля действий оператора. Осуществляет захват и запись видео изображения рабочего стола ОС и всех действий оператора, включая захват нажимаемых клавиш, логирование запускаемых программ и открываемых файлов. Требуется установка компонента Amalgama и наличие в прошивке ключа защиты возможности работы с данным компонентом. Устанавливается из файла amalgama.exe из комплекта ПО GOALcity.


Установка мультимедиа сервера

Настройки > Мультимедиа сервер >

Установка мультимедиа сервера

Запустите исполняемый файл 2_IP_Server_x64.exe (ранее файл назывался setupvss_x64.exe). На мониторе Вы увидите окно "Установка Сервера поддержки сетевых устройств".

Важно! Программа использует электронный аппаратный ключ защиты Guardant Sign или Guardant Stealth-II. Убедитесь, что Вы скопировали файл license.txt в корневой каталог диска, на который установлена операционная система перед запуском программы. Без файла-лицензии программа будет работать в демо-режиме. Если в системе используется ключ Stealth-II, то необходимо дополнительно вручную установить драйвера на ключ защиты!

•Инсталляцию системы нужно проводить, загрузив ОС под именем пользователя, обладающего правами администратора этого ПК;

•Система GOALcity должна работать в сеансе того пользователя ОС, который производил инсталляцию системы;

•Категорически запрещается работать одновременно под разными пользователями ОС, каждый из которых запускает свой сеанс GOALcity.

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена" (текст лицензионного соглашения будет показан только при "чистой" установке программы, если любой из компонентов уже установлен, то мастер автоматически пропустит этот шаг).

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции "Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск".

После этого мастер откроет окно "Опции повторной установки". Отметьте "птичками" необходимые действия: если нужно удалить все предыдущие настройки GOALcity - "Удалить файлы настроек".

Начнется процесс записи файлов программы на ПК, ход которой отображается в окне "Копирование файлов", пожалуйста, немного подождите.

Завершите установку Мультимедиа сервера нажатием кнопки "Готово".


Интерфейс и настройки

Настройки > Мультимедиа сервер >

Интерфейс и настройки

Установите все необходимые компоненты GOALcity, откройте "Диаграмму подключений", добавьте на неё установленные сервера GOALcity и кликните правой кнопкой мыши по "шапке" "Мультимедиа сервера". Откроется контекстное меню.

GOALcity поддерживает захват звука с встроенной звуковой карты, если это разрешено прошивкой. Речь идет о источниках "Микрофон@ваша звуковая карта", "Первичный драйвер звука" и т.д. Количество может меняться в зависимости от особенностей звуковой карты.

Вкладка "Настройки"

Выберите пункт "Настроить...". Откроется окно "Настройки мультимедиа сервера". Также попасть в настройки можно двойным кликом левой кнопкой мыши в любом месте на пиктограмме мультимедиа сервера.

Окно настроек мультимедиа севера, условно разделено на две части - слева располагаются основные пункты меню, а справа их подпункты.

Мультимедиа сервер представляет из себя комбайн источников для работы с различным оборудованием. В зависимости от установленных компонентов комплекса GOALcity в настройках мультимедиа сервера будут присутствовать различные источники.

Чтобы перейти к конфигурации одного из источников, нажмите кнопку button-04 напротив необходимого источника.

Клик правой кнопкой мыши в правой части окна настроек раскроет контекстное меню.

•Пункт "Раскрывать элементы, имеющие возможность редактирования в отдельном окне" - активирует режим редактирования настроек источника в текущем окне. При задействовании перед источниками появится элемент "+", нажатие на который приведет к раскрытию списка элементов доступных для редактирования в данном источнике.

•Пункт "Раскрывать только один элемент" - при активации данного режима, возможно редактирование только одного источника в текущем окне. При раскрытии нового источника на редактирование, ранее редактируемый источник автоматически закроется.

Вкладка "Пользователи"

GOALcity многопользовательская система и каждому из пользователей можно разрешить определенные действия, например жена может смотреть только камеры установленные в детской, а муж имеет полный доступ ко всем камерам. Чтобы разршить\запретить доступ к определенным камерам мультимедиа сервера выполните следующие действия:

•Перейдите на вкладку "Пользователи" мультимедиа сервера, выберите пользователя, которому хотите изменить права и нажмите кнопку "Изменить". Создание новых пользователей производится через Основные настройки GOALcity на вкладке "Пользователи". Важно! Для изменения прав доступа пользователям необходимо обладать правами администратора GOALcity.

•Отметьте "птичками" необходимые разрешения пользователю.

Например, на рисунке выше, пользователю "Оператор 1" разрешено подключение к источнику "IP Source" и просмотр одной камеры "Улица".

Аналогично настраиваются права пользователей на просмотр архива, подключение к камерам видеосервера, аудиосерверу и т.д.

Вкладка "Фаервол"

GOALcity имеет встроенный внутренний фаервол, который может препятствовать несанкционированным подключениям "из вне" к вашей системе видеонаблюдения, ограничивать количество одновременных подключений и т.д.

В строке "Текущие подключения" отображается количество и IP адреса всех клиентов GOALcity, которые в данный момент подключены в Вашему Мультимедиа серверу.

•Строка "Фаервол" позволяет задать ограничения на подключения. Политикой предусмотрено 2 состояния "Разрешить все кроме" и "Запретить все кроме".

•В строке "Максимальное количество" задается максимальное одновременное количество разрешенных подключений.

•Чтобы задать новую маску IP адресов, которым Вы запрещаете или, наоборот, разрешаете подключение, нажмите на кнопку vss-22 . Символом * обозначается целый диапазон адресов. В примере выше, к мультимедиа серверу разрешено 3 одновременных подключений с любых IP адресов кроме 192.168.10.* ("звездочка" обозначает диапазон от 1 до 225).

Аналогично настраиваются права пользователей на просмотр архива, подключение к камерам видеосервера, аудиосерверу и т.д.


Амальгама

Настройки > Мультимедиа сервер > Настройка компонентов >

Амальгама

В мире, где на каждого человека приходится по несколько компьютеров, когда электроника стала неотделима от замысла личности, гораздо больше информации можно почерпнуть, контролируя компьютеры, а не только людей.

•"Амальгама" – это профессиональная многоканальная видеозапись изображения экрана мониторов.

•"Амальгама" – это распределенный сетевой комплекс, способный собирать всю информацию с удаленных компьютеров, полностью документируя (как видеопоток) все действия пользователя.

•"Амальгама" – это многомерное зеркало, способное отображать экраны сотен компьютеров на мониторе хозяина как в реальном масштабе времени, так и в записи.

•"Амальгама" полностью поддерживает все протоколы видеозаписи GOALcity и по технологии почти ничем не отличается от обычной видеозаписи, только вместо видеокамер используется программа перехвата изображения с экрана.

•"Амальгама" имеет все сервисные функции обычной видеозаписи - от видеодетекции до видеоаналитики, что значительно сокращает поток лишней информации. Учитывая то, что на мониторе нет помех, эти технологии работают идеально - в прямом смысле данного слова.

Видеоаналитика помогает вычислять отличительные особенности той или иной деятельности: игры, финансовые документы, Интернет-браузеры, текстовые комбинации клавиш, даже направление перемещения курсора "мышки".

Установка

Модуль "Амальгама" является дополнительным модулем Мультимедиа сервера и требует дополнительной установки. Инсталляция начинается с запуска исполняемого файла "amalgama_x64.exe".

Важно! "Амальгама" является отдельным продуктом, и, в случае деинсталляции, удалять её нужно так же отдельно! Если запускать общую деинсталляцию GOALcity, то все данные "Амальгамы"

Запустите исполняемый файл amalgama_x64.exe из комплекта дистрибутивов системы GOALcity. Выберите язык установки.

•Инсталляцию "Амальгамы" нужно проводить, загрузив ОС под именем пользователя, обладающего правами администратора этого ПК;

•Система GOALcity должна работать в сеансе того пользователя ОС, который производил инсталляцию системы

•Категорически запрещается работать одновременно под разными пользователями ОС, каждый из которых запускает свой сеанс GOALcity.

Откроется окно мастер установки "Амальгамы" в котором указана версия и сборка программного обеспечения

В настоящее время "Амальгама" работает только совместно со службой терминалов операционной системы. Поэтому служба терминалов должна быть активна. В связи с тем, что система GOALcity продолжает активно развиваться, её компоненты постоянно дорабатываются и модифицируются. Не рекомендуется устанавливать на один ПК компоненты из сборок разных версий, если иное не оговорено разработчиком. Рекомендуем использовать последнюю релизную версию сборки.

Затем откроется окно с текстом лицензионного соглашения. Примите условия соглашения нажатием кнопки "Принимаю".

Если инсталляция выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции "Обзор".

Укажите расположение ярлыков программы в меню "Пуск" и снова нажмите кнопку "Далее".

Затем мастер установки предложит ввести адрес сервера (верхняя строчка), с которого необходимо получать информацию и название окна (нижняя строчка).

Например: "Амальгама" устанавливается на компьютер с IP адресом 192.168.10.22, а видео нам нужно получать на сервере с адресом 192.168.10.23. Значит, при установке в верхнее поле нужно вписать адрес сервера (192.168.10.23:3107), а в нижнее можно вписать любую информацию, по которой Вы затем поймете на каком компьютере установлена "Амальгама" и чей "рабочий стол" Вы "смотрите". То есть, на клиентском ПК (с которого нужно получать видео рабочего стола) и нужно устанавливать "Амальгаму", прописывая в настройках "куда вещать".

Таким образом, на контролируемом компьютере должен быть установлен только дистрибутив "Амальгамы", ни ключа защиты, ни какого либо дополнительного ПО устанавливать не нужно! На серверной же стороне минимально должен быть установлен Мультимедиа сервер и Клиент GOALcity.

Важно! При вводе IP адреса сервера (верхняя строчка) обязательно указывайте порт подключения (по умолчанию 3107).

"Амальгама" начнет копирование файлов на жесткий диск. Закончив инсталляцию программы нажмите кнопку "Готово" и перезагрузите ПК.

Настройка

Откройте "Диаграмму подключений", правым кликом по шапке сервера откройте контекстное меню и выберите пункт "Обновить". Появятся новые окна "Амальгамы". Можете подключить их к окну GOALcity и начать контроль.

Расширенная настройка

Перейдите к настройкам Мультимедиа сервера и найдите в списке источников найдите Вашу "Амальгаму" Название источника будет вида "Amalgama (имя, которое Вы задавали в настройках при установке в нижней строке)".

Кликните по кнопке button-04 справа от Вашей "Амальгамы" чтобы открыть её настройки. По умолчанию, все источники захвата, кроме видео, отключены.

Настройки отображения так же можно изменить на вкладке "Трансляция" настроек Амальгамы, вызываемых по клику на кнопку button-settings

Важно! Если на контролируемом ПК используется несколько мониторов, то и видеоисточников "Амальгамы" будет такое же количество (DISPLAY1, DISPLAY2 и т.д.)! Каждый из них имеет индивидуальные настройки!

Захват видеопотока

Настройки видеопотока находятся на вкладке "Трансляция" каждого из "мониторов"

•С помощью опции "Масштаб" - выберите разрешение транслируемого по сети рабочего стола в процентах от оригинального. Необходимо отметить, что чем больше разрешение, тем больший объем информации пойдет по сети и соответственно увеличится ее загрузка.

•"Скорость к/с" -укажите скорость просмотра транслируемого видеосигнала. Чем больше это значение - тем больше загрузка сети.

•"Захватывать курсор" - если Вам необходимо захватывать вместе с рабочим столом и курсор мыши, отметьте эту опцию.

•"Режим совместимости для интегрированных видео карт" - включите, если на контролируемом ПК установлена интегрированная в материнскую плату видеокарта.

Захват клавиатуры

Отметьте птичкой данную опцию, если необходимо использовать захват клавиатуры на контролируемом ПК. Укажите, после нажатия каких "горячих" клавиш клавиатуры отправлять информацию. Нажмите клавишу "Ок" и сохраните настройки. На Мультимедиа сервере появится еще один источник типа датчик с именем вида: "Keyboard@Amalgama(имя, которое Вы задавали в настройках при установке в нижней строке).

Подключите его к окну GOALcity. Теперь Вы будете видеть все что пользователь нажимает на клавиатуре в режиме реального времени. Отправка информации осуществляется после нажатия на одну из ранее настроенных горячих клавиш.


Аппаратные источники

Настройки > Мультимедиа сервер > Настройка компонентов >

Аппаратные источники

GOALcity поддерживает захват звука с встроенной звуковой карты, если это разрешено прошивкой. Речь идет о источниках "Микрофон@ваша звуковая карта", "Первичный драйвер звука", "Линейный вход" и т.д. Количество может меняться в зависимости от особенностей звуковой карты.

Обратите внимание! Особенность Windows 10 заключается в том, что если устройство физически не подключено к аудио входу звуковой карты, то ОС не использует этот вход (отключает) и соответственно на Мультимедиа сервере Вы ничего не увидите. Для активизации необходимо физически подключить устройство к аудио входу и перезапустить программу и службу GOALcity.


Источник RTPSource и FFSource

Настройки > Мультимедиа сервер > Настройка компонентов >

Источник RTPSource и FFSource

Источник RTPSource и FFSource. Подключение IP камер с использованием кодека h264

RTPSource - приемник для работы с IP видеокамерами или серверами по RTP или RTSP протоколу передачи мультимедийных данных. Устанавливается вместе с мультимедиа сервером. Поддерживается работа и по протоколу ONVIF, имеется автоматический поиск поддерживаемых камер.

FFSource - другая версия источника для работы с IP видео камерами через GOALcity и RTSP протокол передачи мультимедийных данных. В работе используются программные библиотеки ffdshow. Устанавливается вместе с Мультимедиа сервером GOALcity. Является заменой устаревшего источника VLCSource.

Разница между источниками

•RTSPSource получает и пишет видео кодеком H.264. Так как для записи используется потоковый кодек, то трафик и размер архива будет на порядок меньше, чем при использовании покадрового кодека. Однако при просмотре будет тратиться много процессорных ресурсов. Просмотреть синхронно несколько камер в полном формате практически невозможно. Из-за структуры потока проблематичен и покадровый просмотр назад.

•FFSource также получает видео в формате H.264, но запись на жесткий диск производится с использованием нашего собственного покадрового кодека mjpeg, т. е. записывается каждый кадр. Размер архива будет больше, чем при использовании потокового кодека, но ресурсов при просмотре будет тратиться намного меньше и просмотреть несколько камер синхронно не составит никакого труда. Покадровый просмотр назад также идет без проблем.

Рекомендации по подключению IP камер

Современные IP камеры могут "отдавать" сразу несколько видео потоков в разном разрешении и с использованием разных кодеков. Используя эту функцию камер, мы доработали наш RTSP источник тем самым, позволяя существенно снизить нагрузку на ЦП, путем вывода на просмотр в маленьком окне "небольшого" потока, но при "распахивании" окна GOALcity автоматически переключаться на "полный" поток. Другими словами, в маленьком окне Вы будете видеть "маленькую" картинку, но так как размер окна мал, то отличий от изображения в полном разрешении практически не будет. При максимизации окна Вы будете видеть изображение в полном разрешении.

Запись при этом ведется всегда "полного" потока в максимальном разрешении

Чтобы настроить такой алгоритм работы, выполните следующие действия:

•Используйте RTSP источник для создания камер или мастер добавления IP камер GOALcity.

•"раскройте" созданный RTSP источник и введите необходимые данные в поля "URL для просмотра" и "URL для записи"

В поле "URL для просмотра" необходимо вводить ссылку на "маленький" видео поток с IP камеры, он будет отображаться в маленьком окне GOALcity. Рекомендуем использовать кодек jpeg и разрешение 640х480 или меньше в зависимости от размера окна. Рекомендуем устанавливать разрешение камеры с сохранением пропорций изображения!

В поле "URL для записи" необходимо вводить ссылку на "полный" видео поток с этой же IP камеры, он будет отображаться при распахивании окна GOALcity и постоянно записываться. Рекомендуем использовать кодек h264 и максимальное разрешение.

Создание источников

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке button-04 напротив пункта "RTPSource" или "FFSource" и выберите строчку "Редактировать".

Принцип создания источника очень похож на выше рассмотренный, только вместо IP адреса камеры используется rtsp ссылка на поток. Большое количество RTP ссылок для IP камер различных производителей Вы можете найти в интернете.

Нажатием кнопки button-04 вызовите всплывающее меню и выберите "Добавить видео источник". Откроется окно добавления нового источника.

Укажите все необходимые параметры и сохраните изменения. Аналогично прошлому примеру, созданный источник появиться в Мультимедиа сервере и останется только подключить его к окну GOALcity.

Чтобы повторно открыть настройки видео источника, достаточно щелкнуть по пиктограмме напротив необходимого источника. Удаление ненужных источников производится кликом по кнопке . Так же настройки подключения можно поменять непосредственно из окна камеры, зайдя в её настройки и перейдя на вкладку "Подключение". Настройки полностью аналогичны и могут быть изменены любым из доступных методов.

Клонирование источников

Функция клонирования используется для создания нескольких копий выбранного элемента (камера, микрофон, датчик, ключ). Копия может отличаться от оригинала несколькими параметрами (название, ip-адрес, и т. д.).

При клонировании можно автоматически изменить числовые элементы в параметрах "Имя" и "Host" в сторону возрастания. Для этого надо сразу после числа, которое необходимо изменить, поставить два знака "+". Например, пусть элемент называется "video 1". Тогда, добавив в параметр "Название" два знака "+", получим "video 1++". При клонировании, к числу "1" будет добавлен порядковый номер создаваемой копии, и в результате будут созданы элементы с названиями "video 2", "video 3" и т. д.


Источник IPSource

Настройки > Мультимедиа сервер > Настройка компонентов >

Источник IPSource

Источник IPSource. Подключение IP камеры с использованием кодека mjpeg

IpSource - приемник для работы с различным IP оборудованием (видеокамеры, видеосервера, мегапиксельные камеры). Для некоторых моделей оборудования дополнительно поддерживается работа со встроенными каналами звука (аудио), датчиками и реле. Устанавливается вместе с мультимедиа сервером. Для работы с данным источником требуется наличие в прошивке ключа защиты компонента "Сервер поддержки IP устройств". Список интегрированного оборудования Вы можете посмотреть на сайте технической поддержки.

Создание источников

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке button-04 напротив пункта "IP Source" и выберите строчку "Редактировать". Через этот источник можно подключить к GOALcity различные IP устройства: камеры, микрофоны, передатчики и т.д. Полный список интегрированных камер Вы всегда можете найти на нашем сайте технической поддержки.

Кликните по кнопке button-04 справа от пункта "Камеры", перед Вами откроется список всего оборудования, прошедшего расширенную интеграцию. Выберите источник "Axis-Video".

В окне настроек заполните необходимые поля соответсвующими данными:

•"Название" - введите название видео источника.

•"Хост" -введите IP адрес видео источника.

•"Пользователь" и "Пароль" - введите данные для аутентификации на устройстве.

•"Использовать прокси" - если Ваша сеть использует прокси-сервер, введите его параметры.

•"Время ожидания ответа" - укажите интервал времени в секундах, за которое должен быть получен ответ от камеры, если за это время камера не ответит, в окне вместо видео появится надпись "Нет сигнала".

•"Камера" - номер камеры (видео канала), укажите необходимый канал, при условии что подключаемся к видео серверу с несколькими каналами. Если это одиночная камера, оставьте значение "1".

•"Разрешение" - укажите разрешение камеры. Важно! Разрешение при подключении камеры в GOALcity и в веб интерфейсе камеры должны совпадать!

Нажмите кнопку "Ок" сохраните изменения и закройте настройки "Мультимедиа сервера".

Обратите внимание! Для каждого из источников набор параметров может отличаться: для каких-то камер можно указать разрешение, для каких-то - скорость просмотра и другие параметры. Но, зачастую, все необходимые настройки разрешения и скорость отображения видео нужно производить в веб интерфейсе IP камеры.

Теперь на Диаграмме подключений в "Мультимедиа сервере" Вы увидите созданную IP-камеру. Осталось только ее подключить к окну GOALcity

Подключение микрофонов, датчиков, ключей и прочего оборудования выполняется идентично. Вся разница в выборе источника - Микрофоны, Устройства и прочее.

Как это работает, вы можете посмотреть в видеоролике:

Клонирование источников

Функция клонирования используется для создания нескольких копий выбранного элемента (камера, микрофон, датчик, ключ). Копия может отличаться от оригинала несколькими параметрами (название, ip-адрес, и т. д.). При клонировании можно автоматически изменить числовые элементы в параметрах "Имя" и "Host" в сторону возрастания. Для этого надо сразу после числа, которое необходимо изменить, поставить два знака "+". Например, пусть элемент называется "video 1". Тогда, добавив в параметр "Название" два знака "+", получим "video 1++". При клонировании, к числу "1" будет добавлен порядковый номер создаваемой копии, и в результате будут созданы элементы с названиями "video 2", "video 3" и т. д.


Источник SLSource

Настройки > Мультимедиа сервер > Настройка компонентов >

Источник SLSource

Источник SLSource. Подключение устройств нашего производства

SLSource - источник для работы с IP-видеосерверами и IP-Видеоблейзерами производства Спецлаб. Позволяет использовать все источники указанного оборудования (видео, датчики, реле и сигнализацию). Устанавливается вместе с мультимедиа сервером, но для работы с данным источником требуется наличие в прошивке ключа защиты компонента "Сервер поддержки IP устройств".

Создание источников

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке button-04 напротив пункта "SL Source" и выберите строчку "Редактировать". Для примера добавим видео с второго Блейзера.

Кликните по кнопке button-04 справа от пункта "Камеры" и выберите источник "SL-Blazer-II Video".

В окне настроек заполните необходимые поля соответсвующими данными:

•"Название" - введите название видеоисточника.

•"Хост" -введите IP адрес видеоисточника.

•"Пользователь" и "Пароль" - введите данные для аутентификации на устройстве.

•"Использовать прокси" - если Ваша сеть использует прокси-сервер, введите его параметры.

•"Время ожидания ответа" - укажите интервал времени в секундах, за которое должен быть получен ответ от видеоблейзера, если за это время блейзер не ответит, в окне вместо видео появится надпись "Нет сигнала".

•"Камера" - устройство может поддерживать несколько каналов вывода видео, укажите необходимый.

Нажмите кнопку "Ок" сохраните изменения и закройте настройки "Мультимедиа сервера".

Создание и настройка параметров датчиков, ключей, передатчиков и прочего оборудования нашего производства выполняется аналогично. Вся разница в выбранном устройстве и источнике.

Обратите внимание! Параметры для настройки могут отличаться в зависимости от используемого источника!

Клонирование источников

Функция клонирования используется для создания нескольких копий выбранного элемента (камера, микрофон, датчик, ключ). Копия может отличаться от оригинала несколькими параметрами (название, ip-адрес, и т. д.). При клонировании можно автоматически изменить числовые элементы в параметрах "Имя" и "Host" в сторону возрастания. Для этого надо сразу после числа, которое необходимо изменить, поставить два знака "+". Например, пусть элемент называется "video 1". Тогда, добавив в параметр "Название" два знака "+", получим "video 1++". При клонировании, к числу "1" будет добавлен порядковый номер создаваемой копии, и в результате будут созданы элементы с названиями "video 2", "video 3" и т. д.


Источник SLDASource

Настройки > Мультимедиа сервер > Настройка компонентов >

Источник SLDASource

Источник SLDASource. Установка и настройка

SLDASource - источник работы с устройствами, подключаемыми по протоколу RS-485 производства Спецлаб и ряда сторонних производителей. Также в этом источнике осуществляется подключение IP контроллера "Телепатия" производства Спецлаб и других устройств нашего и не нашего производства. Требуется установка бесплатного драйвера SLDA и наличии в прошивке ключа защиты возможности работы с компонентом "Сервер устройств". Устанавливается вместе с мультимедиа сервером. Последнюю версию бесплатного драйвера можно скачать из раздела бесплатного ПО с сайта технической поддержки.

Также через SLDASource подключаются устройства из интегрированных систем ОПС, таких как "Болид" и "Стрелец".

Установка драйвера SLDA

Обязательно убедитесь в том, что клиент (GOALcity.exe) и служба (slssh.exe) GOALcity выключены. Также необходимо отключить Rotor-Net.

Запустите дистрибутив SLDAsetup.exe. Откроется окно мастера с выбором языка установки:

Выберите необходимый язык и нажмите кнопку "Ок".

Запустится мастер установки, в котором отображается версия драйвера.

Нажмите кнопку "Далее" и примите условия лицензионного соглашения с конечным пользователем.

После нажатия кнопки "Принимаю", выберите папку установки программы. По умолчанию это "Х:\Program Files (x86)\Speclab\SLDA" (где Х - диск, на котором установлена ОС Windows). Нажмите кнопку "Далее".

Выберите размещение папки программы в меню "Пуск". Нажмите кнопку "Далее".

Проверьте все данные установки и нажмите кнопку "Установить".

Драйвер SLDA установлен. На этом же этапе можно выполнить инсталляцию драйверов для USB HUB RS-485, к которому подключаются контроллеры датчиков - КД -16/485, контроллеры устройств - КВУ -8/485, блок приборов "Климат-контроль". Инсталляция необходима в случае, когда сервер устройств SLDA будет работать с данными контроллерами, в противном случае снимите "галку" и нажмите "Завершить".

Создание устройств

Рассмотрим добавление устройств на примере IP контроллера "Телепатия" нашего производства. Отметим, что устройства добавляются практически аналогично виртуальным, вся разница в параметрах этих устройств.

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке button-04 напротив пункта "SLDASource" и выберите строчку "Редактировать".

Кликните по кнопке button-04 справа от пункта "Датчики и ключи", перед Вами откроется список всего доступного для подключения оборудования. Выберите источник "Добавить Телепатия".

•"Название" - укажите имя создаваемого датчика/ключа.

•"Адрес" - укажите IP адрес контроллера "Телепатия".

•"Тип" - укажите, какой из элементов контроллера "Телепатия" создается - ключ или датчик.

•"Номер" - укажите номер элемента (датчика/ключа) на контроллере.

•"Пользователь" и "Пароль" - укажите данные для авторизации на IP контроллере.

Нажмите кнопку "Ок" и сохраните изменения. Теперь на Диаграмме подключений в "Мультимедиа сервере" Вы увидите созданный ключ. Подключите его к окну GOALcity.

Все параметры физических устройств практически полностью идентичны рассмотренным ранее виртуальных.


Источник VLCSource

Настройки > Мультимедиа сервер > Настройка компонентов >

Источник VLCSource

Источник VLCSource. Установка

VlcSource - программный модуль для работы с IP видеокамерами и видеофайлами. С помощью VlcSource можно проигрывать ролики практически любого формата, поддерживаемого VLC media player'ом. (avi, asf, mp4, итд), а так же для подключения IP видеокамер по протоколу RTSP не поддерживаемых стандартными источниками GOALcity (RTSPSource FFSource). К таким камерам, как правило, относятся камеры без поддержки ONVIF.

Установка компонентов

Перед началом работы, необходимо установить VLC media player и VlcSource.

VLC media player - бесплатный медиа плеер. Скачать его можно с сайта производителя.

Важно! Для GOALcity Medina необходимо использовать 64-х разрядную версию плеера!

VlcSource устанавливается из файла 8_VLC_Source_x64.exe комплекта дистрибутивов GOALcity.

1. Запустите исполняемый файл 8_VLC_Source_x64.exe. Откроется окно выбора языка. Выберите необходимый язык и нажмите кнопку "OK".

2. Откроется окно мастера установки "GOALcity VLC Source" с информацией о версии программы и номере сборки. Нажмите кнопку “Далее” и примите лицензионное соглашение.

3. После принятия лицензионного соглашения, откроется окно “Выбора папки установки". По умолчанию это "Х:\Program Files\Speclab\VlcSource" (где Х - диск, на котором установлена ОС Windows). Нажмите кнопку "Установить".

4. Начнется процесс инсталляции программы на компьютер.

5. По завершению инсталляции программы, “Мастер установки” предложит запустить службу. Запускайте.


Источник DeviceSource

Настройки > Мультимедиа сервер > Настройка компонентов >

Источник DeviceSource

Источник DeviceSource. Работа с виртуальными устройствами

DeviceSource - источник работы с виртуальными устройствами. Позволяет создавать виртуальные ключи. Требуется наличии в прошивке ключа защиты возможности работы с компонентом "Сервер устройств". Устанавливается вместе с мультимедиа сервером. Также через этот источник подключаются интегрированные датчики и ключи с системы ОПС "Багульник".

Создание виртуальных устройств

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке button-04 напротив пункта "DeviceSource" и выберите строчку "Редактировать".

Для примера, рассмотрим процесс создания виртуального ключа.

Кликните по кнопке button-04 справа от пункта "Датчики и Ключи", перед Вами откроется список всех доступных для создания устройств.

Основные используемые элементы это виртуальный ключ, ключ с таймером. Разница между ними в том, что при использовании второго, пользователь может задать определенный промежуток времени через который нужно сменить состояние ключа. Параметры обоих ключей практически идентичны.

Выберите пункт "Добавить виртуальный ключ".

Укажите все необходимые данные:

•"Имя" - укажите имя создаваемого виртуального ключа.

•"Замкнут" - укажите состояние ключа, нормально замкнутый или нормально разомкнутый.

•"Поврежден" - если установить параметр в "Да", то ключ будет имитировать КЗ в сети.

Нажмите кнопку "Ок" и сохраните изменения. Теперь на Диаграмме подключений в "Мультимедиа сервере" Вы увидите созданный виртуальный ключ. Подключите его к окну GOALcity.

Каждому состоянию ключа соответствует своя пиктограмма в окне:

Настройка виртуальных устройств

Откройте настройки виртуального ключа нажатием на кнопку button-02 :

Вкладка "Запись"

•На вкладке "Запись" настраивается архив, в который будут сохранятся данные о сработке данного ключа.

Вкладка "Контроль"

•"Ограничение времени подключения" - установите время, в течении которого GOALcity будет пытаться подключиться к ключу.

•"Интервал проверки связи" -установите периодичность проверки связи с ключом.

•Опция "Менять состояние по двойному щелчку" - регулирует каким способом производить переключение ключа с разомкнутого на замкнутое состояние и обратно. Если "галка" снята, то переключение будет происходить по "Одному щелчку мыши".

•"Активизировать окно при сработке" - если ключ участвует в каком либо из алгоритмов и окно ключа скрыто с экрана, то установив данную птичку можно показывать окно в случае сработки ключа.

•"Звуковой сигнал при сработке" - если Вам требуется звуковое оповещение при сработке ключа, активизируйте данную опцию.

•"Отображать:" - выберите, какие элементы интерфейса отображать в окне ключа.

•"Журнал" - укажите, записывать ли в архив моменты сработки и время подключения и отключения ключа.

Вкладка "Визуальное представление"

Является одинаковой для датчиков и ключей и позволяет установить пользовательские изображения на любые из состояний виртуального устройства.

Укажите в поле "Путь к каталогу с файлами..." путь к каталогу, в котором должно лежать 5 файлов в формате EMF+. Файлы будут иллюстрировать состояния ключа/датчика в программе и должны иметь определенные названия:

•unknown.emf - неопределенное состояние;

•open.emf - разомкнут;

•close.emf - замкнут;

•short.emf - короткое замыкание;

•broken.emf - обрыв.

В окне "Изображение" Вы можете увидеть предпросмотр изображения.


Ретранслятор VSS-Retr

Настройки > Мультимедиа сервер > Настройка компонентов >

Ретранслятор VSS-Retr

Схема работы ретранслятора

В ранее рассмотренных вариантах каждый клиент GOALcity должен был подключаться к каждому серверу. Т. е. к первому серверу три подключения (согласно схеме), ко второму три подключения и к третьему тоже три подключения. Если много клиентов, то каждое такое подключение значительно увеличивает нагрузку на сервер. Чтобы избежать этого, можно выполнить подключение всего одним клиентом GOALcity, на котором установлен VSS-Retr. Теперь все клиенты могут искать не сервера, а VSS-Retr и получать с него видео со всех серверов GOALcity.

Еще одна возможность VSS-Retr – это транслирование видео на клиентские ПК с меньшим разрешением.

К примеру, есть два офиса, объединенных по каналу Интернет. Схематично толстыми линиями показан широкий канал локальной сети, а тонкими линиями – сеть Интернет. Клиентские машины одного из офисов все так же подключаются в VSS-Retr, на котором выставлено меньшее разрешение для того, чтобы можно было передать весь необходимый видео трафик по каналу с ограниченной пропускной способностью.

Ретранслятор можно разместить и со стороны клиентских ПК. В этом случае видео передается с серверов на VSS-Retr. Пропускная способность канала Интернет подобрана соответствующим образом, а все клиенты, чтобы не загружать сервера и главное - чтобы не забивать Интернет канал - подключаются к VSS-Retr.

Схем реализации большое количество, что делает систему очень гибкой и распределено-сетевой.

Настройка трансляции

Кликните правой кнопкой мыши в окне любой камеры и вызовите контекстное меню. Выберите пункт "Транслировать" и активируйте ретранслятор (отметка напротив данного пункта указывает на то, что трансляция источника включена).

После активации ретранслятора станет доступен пункт "Настройки трансляции". Активируйте его.

•"Без изменений" - если активирован этот пункт, то кадр с источника передаётся без изменений: "каким пришёл - таким и ушёл". Этот пункт по техническим причинам не будет верно работать, если включена группировка нескольких источников в одно окно.

•"Размеры выходного кадра" - задайте ширину и высоту в пикселах транслируемых (выходных) кадров.

•"Режим градации серого" - если активировать данную опцию, то транслируемый видеосигнал будет черно-белым.

После включения трансляции данного окна зайдите на Диаграмму подключений, кликните правой кнопкой мыши по Мультимедиа серверу, выберите опцию "Обновить" - появится еще один источник - "Окно1@GOALcity". Это и есть новое транслируемое окно с заданными выше параметрами.

Получение транслируемых данных

Подключитесь клиентом по IP адресу к серверу, на котором стоит VSS-ретранслятор источника и подключите с него транслируемый источник. Имя у транслируемого источника будет вида "Имя камеры"@GOALcity.


Настройки программы

Настройки >

Настройки программы

Чтобы попасть в настройки программы SpecLab GOALcity, откройте главное меню и выберите строчку "Настройка программы"


Вкладка "Вид"

Настройки > Настройки программы >

Вкладка "Вид"

На вкладке "Вид" собраны настройки, отвечающие за внешний вид программы, пропорции окон при автоматическом выстраивании и прочие "косметические" настройки.

"Размер окна при выстраивании" - здесь Вы указываете и высоту каждого окна (пропорции), которые установятся при автоматическом выстраивании на "текущий" или "виртуальный рабочий стол". По умолчанию - 640*480.

"Размер окна при максимизации в процентах от размера экрана" - если дважды щелкнуть по окну нему левой кнопкой мыши, то оно увеличится в размерах и всплывет по середине монитора. Этим параметром Вы регулируете масштаб увеличения. Таким образом, если выставить здесь "100%" и "максимизировать" любое окно, то оно "развернется" на весь монитор.

"Задержка на переключение при автоматической смене расположения окон" - данный параметр отвечает за периодичность смены сохраненных схем расположения окон.

Чтобы отключить отображение часов на Главной панели GOALcity, снимите галочку "Отображать часы в главной панели", и наоборот, если Вы хотите отображать регулятор нагрузки на ЦП, то поставьте "птичку" в поле "Отображать регулятор нагрузки в главной панели".

"Максимизировать окно по двойному щелчку мыши" - при двойном щелчке мыши окно полностью откроется.

"Отображать значок приложения на панели задачи" - значок приложения "Вид" будет отображен на панели задач.

Если поставить галочку в окно "Всплытие с авторасположением окон", то будут доступны настройки, с помощью которых можно установить минимальное и максимальное время всплытия окна, например, по детекции движения или по какому-либо событию. Зафиксировать положение и размер окна при всплытии можно следующим образом: выбрать необходимое окно, вручную изменить его размер, местоположение, как Вам нужно, нажать на правую кнопку мыши в данном окне и в появившемся меню выбрать "Зафиксировать позицию всплытия".

•Опция "Отображать кнопку закрытия окна" добавляет на панели управления окном еще одну кнопку, с помощью которой можно быстро закрыть текущее окно. По умолчанию эта возможность отключена чтобы пользователь случайно "непозакрывал" окна и прервал запись и обработку видео.

Режим восстановления вида требуется для восстановления одного из сохраненных в GOALcity видов, чтобы избежать перемещения окон GOALcity и вернуть все в исходный заранее настроенный вид. Выберите необходимый вид в поле "Вид" и установите необходимый интервал времени для его загрузки.


Вкладка "Загрузка"

Настройки > Настройки программы >

Вкладка "Загрузка"

В данном разделе настраиваются опции загрузки клиентской программы.

GOALcity может загружаться автоматически при старте Windows, свернутой в маленький значок (иконку) в системном трее или загружаться скрытой (для активации опций необходимо поставить флажки в соответствующие клетки). Здесь же можно сменить комбинацию клавиш для выхода из скрытого режима. Скрытый режим полностью убирает с монитора весь интерфейс программы, оставляя работать его скрыто для пользователя. Чтобы вернуть интерфейс на место, необходимо нажать комбинацию клавиш, указанную в поле "Комбинация клавиш для выхода из скрытого режима". Очень важно помнить эту комбинацию.

•Поле "Загружать основную конфигурацию" активизирует постоянную загрузку ранее сохраненной основной конфигурации программы.

Обратите внимание, что для корректной работы автозагрузки программы под ОС Windows 10 необходимо запускать программу именно с правами администратора, поставив следующие "птички" у ярлыка программы:

•В поле "Пользователь" - задается, под каким пользователем будет выполняться вход в программу.

Если требуется, чтобы после загрузки все окна GOALcity были заблокированы от перетаскивания, то отметьте птичкой поле - "С заблокированным рабочим столом".


Вкладка "Горячие клавиши"

Настройки > Настройки программы >

Вкладка "Горячие клавиши"

На вкладке "Горячие клавиши" можно задать сочетание клавиш для быстрого доступа к различным функциям GOALcity.


Вкладка "Пользователи"

Настройки > Настройки программы >

Вкладка "Пользователи"

В разделе "Пользователи" можно добавлять, убирать, изменять права пользователей клиентской части программы. Чтобы добавить пользователя, нажмите кнопку "Добавить", и в открывшемся окне "Добавление пользователя" заполните соответствующие поля.

Чтобы настроить права вновь созданного пользователя, или изменить существующего, выделите его, и нажмите кнопку "Изменить". В открывшемся окне можно сменить пароль пользователя и добавить/убрать предоставляемые права по настройке клиентской программы и доступу к сетевым ресурсам.

Чтобы предоставить или отменить предоставленное право необходимо поставить или убрать галочку в соответствующем поле. Имеется возможность "Разрешить все" и "Запретить все" нажатием соответствующих кнопок в нижней части окна "Настройки пользователя".

Для быстрого переключения между пользователями используется кнопка "Смена пользователя" на Главной панели управления.


Вкладка "Доступ"

Настройки > Настройки программы >

Вкладка "Доступ"

По умолчанию, GOALcity подключает одного Пользователя – Администратора с правом автоматического входа (т.е. без пароля). Чтобы установить ему пароль, нажмите кнопку "Сменить", и введите необходимый пароль в соответствующее поле. Если снять флажок "Скрыть пароль" при вводе, то пароль будет виден в окне ввода.

Далее следуют настройки режима закрепленных окон, который активируется нажатием кнопки "Закрепить размещение окон" main-panel-05 на Главной панели управления. На выход из режима "Закрепления окон" можно установить пароль, чтобы пресечь несанкционированный доступ к настройкам GOALcity. Если такая функция требуется - ведите его в поле "Пароль".

Когда режим "Закрепления окон" активен, на Главной панели управления блокируются все элементы управления кроме тех, что вы отметите в блоке опций "Разрешить кнопку".

"Разрешить автоматический вход" позволяет входить в систему, не вводя пароль каждый раз.

"Запись по детекции" - при активации этого режима запись будет производиться при наличии движения.

"Страховочная запись" - При активации этой настройки система начнет непрерывную запись. Даже если вы выключите запись по детекции и основную запись, страховочная запись все равно будет будет продолжаться.


Вкладка "Видео"

Настройки > Настройки программы >

Вкладка "Видео"

Раздел "Видео" содержит настройки аппаратного ускорения и видеобуфера GOALcity.

•"Аппаратное ускорение" - это обработка видеосигнала средствами DirectX (DirectShow и Direct3D). Другими словами, аппаратное ускорение позволит часть работы по обработке видео переложить на видеокарту ПК. Рекомендуем оставлять параметр в положении "Выбирать автоматически". GOALcity "поймет" какая у Вас установлена видеокарта и подберет лучший режим. Но можете и поэкспериментировать с параметром, например, при активации OpenGl картинка будет более приятная на глаз. При отключении аппаратного ускорения обработка информации видеокартой прекращается и полностью "возлагается на плечи" процессора, в результате чего загрузка последнего возрастает.

Включение GDI-режима по умолчанию приведёт к тому, что в абсолютном большинстве случаев будет использоваться только он. В результате существенно увеличится нагрузка на ЦП, особенно, в случае использования камер высокого разрешения (1 МП и выше).

В GOALcity режим вывода видео на основе OpenGL был существенно оптимизирован.

Однако, при определённых условиях загрузка процессора в GDI-режиме по-прежнему может быть ниже, чем в OpenGL-режиме, особенно при работе с большим количеством камер низкого разрешения. Причина - дополнительные накладные расходы в исполняющей подсистеме OpenGL, связанные с невозможностью загрузки данных кадра в видеопамять без дополнительной стадии копирования, выполняемого силами центрального процессора.

Основные задачи OpenGL-режима - снижение загрузки центрального процессора при выводе видео высокого разрешения (1 МП и более) и обеспечение максимально возможного качества картинки (разница в качестве интерполяции, контрастности и насыщенности цветов заметна невооружённым глазом).

При сравнении режимов вывода видео необходимо учитывать следующие обстоятельства:

1.Должна использоваться дискретная видеокарта, при использовании процессора Intel встроенное видео должно быть полностью отключено;

2.Для сравнения загрузки процессора надо отслеживать, в первую очередь, загрузку клиентского процесса;

3.Отслеживание нагрузки на процессор надо начинать не ранее, чем через 1 минуту после загрузки клиента или переключения режима вывода.

Не гарантируется корректная работа на портативных компьютерах с интегрированным видео.В таких случаях рекомендуем отключать аппаратное ускорение!

В поле "Видеобуфер" устанавливается временной размер буфера обмена, который будет использоваться для хранения и обработки видеоинформации.

"Максимальный размер видеобуфера" - позволяет установить максимальное количество кадров, которое будет храниться в буфере. Если Вы точно не уверены в том, что делаете, лучше не меняйте эти параметры.

Если к клиенту подключено большое количество камер и используется недостаточно мощный компьютер (или возникают конфликты с оборудованием), то возможно "торможение" кадров. В этом случае рекомендуем уменьшить значение "Максимального размера видеобуфера" до 5-10 кадров (в самых "тяжелых" случаях рекомендуем выставлять 1 кадр).

При максимально или очень большой загрузке центрального процессора можно активировать опцию "Использовать предварительную буферизацию", при котором видео кадры сначала сохраняются на компьютере в буфер, а затем уже выводятся на просмотр и пишутся в архив. При активизации данного режима, возможны небольшие задержки с отображением видео, но при этом Вы сэкономите немного вычислительной мощности центрального процессора, т.к. все операции будут производиться уже не "на лету".

"Минимальная частота обновления окон" - то, как часто окно будет обновляться.

"Независимые видеоканалы" - использовать независимые каналы видео.

"Сглаживание скорости" - используется для настройки равного времени отображения каждого кадра в окне, что даст впечатление плавного видеоряда.


Вкладка "Аудио"

Настройки > Настройки программы >

Вкладка "Аудио"

В разделе "Аудио" выбирается "Метод вывода звука" и "Устройство", которое отвечает за обработку аудио информации (аудио плата).

•"Аудиобуфер" - устанавливается временной размер буфера обмена, который будет использоваться для хранения и обработки аудиоинформации. Последние два параметра задают минимальный и максимальный размер аудиобуфера

"Пропускать кадры при расхождении " - пропуск всех устаревших кадров в буфере, для которых не соблюдается ограничение допустимой разницы времени.

"Независимые аудиоканалы" - использовать независимые каналы аудио.


Вкладка "Скриншоты"

Настройки > Настройки программы >

Вкладка "Скриншоты"

В данном разделе настраиваются комбинации клавиш для мгновенного сохранения текущего кадра с определенных камер.

•Укажите в поле "Укажите место сохранения изображений" путь, куда будут сохраняться изображения с камер.

•Далее в поле "Укажите клавишу или комбинацию клавиш для создания скриншотов камер" укажите какой комбинацией клавиш будет выполняться сохранение.

•В поле "Выберите камеры" укажите для каких из камер делать "мгновенный скриншот".


Вкладка "Журнал"

Настройки > Настройки программы >

Вкладка "Журнал"

Раздел "Журнал", во-первых, подскажет, где находится файл журнала и поможет настроить его максимальный размер. Здесь же можно открыть журнал для просмотра, создать новый и, если у Вас имеются несколько журналов, выбрать один из них для просмотра.


Вкладка "Интеграция"

Настройки > Настройки программы >

Вкладка "Интеграция"

Основные настройки

В данном разделе производятся настройки совместной работы GOALcity с Автоматизированным Рабочим Местом охранника "Орион", WEB Сервером GOALcity.

•Пункт "Номера" используется для работы сторонних программ с компонентами ActiveX. Если сторонние программы не поддерживают текстовые строки, то вместо них на данной вкладке задается цифровой индекс.

•В пункте "АРМ Орион" производятся настройки интеграции с Системой Орион.

•"Запускать АРМ Орион" - поставьте галочку, чтобы ядро Ориона запускалось вместе с GOALcity.

•"Запускать АРМ Орион на компьютере:" - если сервер Ориона находится на другом ПК, то укажите IP адрес этого компьютера, на котором будет запускаться Орион при включении клиента GOALcity. Более подробную инструкцию по настройке связи "Орион+GOALcity" Вы можете скачать по ссылке.

•Активирование пункта "WEB Сервер" разрешает доступ к панелям "Внимание!" через веб интерфейс, а так же возможность включения\выключения записи из веб интерфейса GOALcity.

Краткая информация о том, как настроить интегрированную работу GOALcity и Parsec

1) Включить в настройках Parsec, на вкладке "Общие" интеграцию с GOALcity - галочка напротив "Видео подсистема GOALcity". В "Устройствах" - "Видеосистема" добавить видеосервер GOALcity, список камер запрашивается и сохраняется в системе автоматически.

2) Для того, чтобы из Parsec можно было записывать видео с камер GOALcity, необходим Архивный сервер. На машине, где расположен Архивный сервер, должен быть установлен также Parsec.

3) На этой машине в мониторе Parsec на вкладке "Камеры" нужно разместить камеры GOALcity и через контекстное меню ActiveX'а GOALcity указать настройки для записи - выбрать архивный сервер и скорость записи. После этого необходимо перезагрузить Parsec для сохранения настроек. Команду на запись можно отправить с любой рабочей станции Parsec, но фактическая запись будет производиться на той машине, где установлен Архивный сервер и произведена настройка.

4) Просмотр записанных фрагментов возможен с той же машины, где производится непосредственная запись из Генератора отчетов "Анализ".


Вкладка "Настраиваемые кнопки"

Настройки > Настройки программы >

Вкладка "Настраиваемые кнопки"

"Настраиваемые кнопки" являются аналогами текстовых датчиков. Они выполняют роль активаторов событий SL++. Для того, чтобы данные датчики были доступны, необходим мультимедиа сервер.

Кнопки, которым Вы присвоите название, появятся на Главной панели управления программы.

Для того, чтобы активировать последовательность событий SL++ необходимо просто нажать ту кнопку, на которую они запрограммированы.


Вкладка "Надежность"

Настройки > Настройки программы >

Вкладка "Надежность"

Раздел "Надежность" позволяет настроить перезагрузку программы и/или службы, или компьютера ежедневно в заданное время. Также можно активировать антизависающую функцию, которая перезапускает программу в случае, если пользовательский интерфейс недоступен, т.е. "завис".

Важно перезагружать компьютер не реже раза в неделю, особенно если он интенсивно используется. Перезагрузка позволяет очистить память и завершить ошибочные процессы и службы, которые начали работу. Во время перезагрузки закрываются все программы, работающие на компьютере (не только те, которые отображаются на панели задач, но также десятки служб, которые могли быть запущены различными программами и не были остановлены. Перезагрузка может устранить непонятные проблемы с производительностью, когда сложно установить их причину.

Если открыто так много программ, и перезагрузка представляется проблемой, то это серьезный повод все-таки перезагрузить компьютер. Чем больше открыто программ и чем дольше они работают, тем выше шансы, что компьютер будет работать все медленнее и в конце концов образуется нехватка памяти.


Вкладка "Обновления"

Настройки > Настройки программы >

Вкладка "Обновления"

В разделе "Обновления" можно проверить последнюю доступную на сайте версию программы, дату/время последней проверки, узнать информацию о текущей версии, а также перейти на страницу сайта с описанием свежих релизов. Если поставить галочку в поле "Проверять обновления", то поиск новых версий будет проходить в автоматическом режиме с уведомлением Администратора GOALcity.


Вкладка "Системные утилиты"

Настройки > Настройки программы >

Вкладка "Системные утилиты"

На вкладке "Системные утилиты" собраны ссылки на часто используемые инструменты при настройке операционной системы и GOALcity.

Кликом левой мыши по кнопке запускается соответствующая утилита.

Обратите внимание! Некоторые из этих утилит будут работать только если GOALcity запущена из под учетной записи с правами Администратора!

Опция "Запуск при старте системы вместо проводника" отключает стандартный интерфейс Windows и оставляет работать только систему GOALcity, экономя тем самым ресурсы ПК.

Важно! Возможны конфликты при работе с антивирусным ПО. Используйте на свой страх и риск.


Вкладка "Настройка карт"

Настройки > Настройки программы >

Вкладка "Настройка карт"

На этой вкладке можно указать путь к оффлайн картам. Если не укзать путь до оффлайн карт, то будут использоваться онлайн карты. Для использования онлайн карт необходимо подключение к сети интернет.


Настройки панели управления

Настройки >

Настройки панели управления

Основным элементом управления GOALcity является Главная панель. По умолчанию она выглядит так:

Информацию о назначении кнопок дает всплывающая при подведении к ней указателя мыши подсказка

Функции кнопок:

main-menu-button Кнопка вызова Главного меню программы. Она имеет два состояния: в неактивном она выглядит как центральный затвор фотоаппарата или ирисовая диафрагма, раскрывающаяся при наведении на неё указателя мыши. В активном – меняется её цвет и появляется стилизованная буква «G», клик по которой вызывает Главное меню программы.

За кнопкой Главного меню программы следует блок кнопок main-panel-04 для управления окнами и видами GOALcity.

main-panel-05 Закрепить размещение окон – нажатие данной кнопки фиксирует расположение окон на дисплее, после чего их невозможно куда-либо переместить (такой режим называется - Режим блокировки). При закреплении размещения заголовки окон исчезают, блокируются возможности переключения конфигурации, свертывания окон, завершения программы, включения/выключения записи по детекции, открытия диаграммы подключений, включения воспроизведения архивных записей и переключения пользователей.

main-panel-06 Кнопка Показать все - разворачивает все свернутые окна и делает их видимыми. Любое из окон может быть свернуто (скрыто) двумя способами: нажатием пиктограммы "Свернуть" (точно такой же, как в любой программе, работающей в ОС Windows), либо путем выбора команды Скрыть из контекстного меню, раскрывающегося при нажатии правой кнопки мыши в окне.

main-panel-07 Кнопка Автоматического переключения видов - Включение опции периодической смены расположения окон (видов). Интервал смены можно установить в настройках программы в разделе Вид.

main-panel-08 Кнопка Cохранения текущего вида расположения окон - Чтобы запомнить текущий внешний вид программы (схему расположения окон), нажмите кнопку "M" (Memory), затем выберите одну из трех кнопок активации (А, В или С) и введите название сохраняемой схемы.

После блока кнопок управления окнами и видами следует фирменный логотип программы. Справа потянув мышью за колесико вниз, либо кликая по "стрелочкам" вверх и вниз, мы получим доступ к дополнительным кнопкам панели управления.

main-panel-11 Кнопки активации запуска проигрывателя записей локального или сетевого архива (Примечание: если установлен Архивный сервер, то проигрыватель запустится только для подключенных к окнам GOALcity сетевых архивов); смена пользователя программы, (GOALcity – многопользовательская система. По умолчанию первый раз она загружается для пользователя с правами администратора. Он может менять все настройки системы, в том числе и создать неограниченное количество новых пользователей, присвоив каждому из них разные права), и кнопка открытия диспетчера подключений GOALcity.

main-panel-09 Кнопки переключения различных схем расположения окон. Кнопки активируются только после сохранения "на них" одного из вида расположения окон. При нажатии кнопки окна расположатся в соответствии с сохраненными настройками. На каждую кнопку можно сохранить до 256 схем расположения окон. Для удаления схемы размещения необходимо сначала нажать main-panel-08 , затем выбрать одну из трех кнопок, на которой сохранена данная схема размещения, написать её название или выбрать из выпадающего списка, и нажать Удалить. После этого нужно нажать кнопку Отмена, иначе, если нажать кнопку Ок, схема будет повторно сохранена.

main-panel-12 Кнопки активации программируемых клавиш. Программирование осуществляется в основных настройках GOALcity.

main-panel-13 Кнопки активации дополнительных аналитических алгоритмов (активация происходит для камер, у которых предварительно настроены данные алгоритмы). Первая кнопка активирует отображение истории детекции движения, вторая - траектории движения объектов в кадре, третья - направление движения.

При нажатии кнопки main-menu-05 загрузится основная конфигурация системы.

Если Вы случайно подвинули одно из окон и хотите вернуть его на место нажмите на кнопку main-menu-12 . Кнопка main-panel-strahovka включает\отключает страховочную запись, которая задается в настройках видео источников.

Управление основными функциями:

Кнопка main-panel-rec включает/выключает запись информации со всех источников системы (видео, аудио, датчики и т. п.).

Кнопка main-panel-dd включает/выключает запись по детекции изменения информации со всех источников. Программой предусматривается также включение/выключение записи по детекции по каждому источнику в отдельности.

Кнопка main-panel-slpp предназначена для активации/дезактивации Событий SL++ и событий на 3D Плане. После включения соответствующая кнопка становится яркой, пиктограмма занимает всю область кнопки.

Кнопка main-panel-comment создания комментария - служит для добавления текстового комментария ко всей записываемой в данный момент информации. По комментарию можно быстро отыскать запись в архиве.

Две последние кнопки main-panel-close Главной панели управления такие же, как в заголовке любой программы операционной системы Windows и имеют такое же назначение: Свернуть программу и Закрыть программу. Также для закрытия программы можно воспользоваться привычной комбинацией клавиш "Alt+F4". По команде закрытия GOALcity, откроется диалоговое окно, в котором следует выбрать одно из четырех действий: завершить программу, завершить программу и службу, перезапустить программу, перезапустить программу и службу.

Примечание: Перезапуск службы может потребоваться после добавления какого-либо оборудования (например, хаба, подключенного к USB порту).

Главную панель управления можно увеличивать и уменьшать до нужного Вам размера, качество отрисовки иконок-кнопок на ней при этом не пострадает. Её также можно свободно перемещать по экрану (если не нажата кнопка Закрепить размещение окон).

Через Главное меню программы можно включить Сокращённый вид Главной панели. В этом случае на ней будет отображаться минимум элементов управления.

Для того, чтобы вернуть Полный вид со всеми кнопками, необходимо войти в Главное меню программы и выбрать соответствующий пункт.


Главное меню

Настройки > Настройки панели управления >

Главное меню

Нажатием первой кнопки Главной панели управления main-menu-button вызывается Главное меню программы.

Главное меню поделено горизонтальными пробелами на секции. В каждой из секций содержится несколько команд

Первая сверху секция содержит всего три команды Развернуть, Свернуть и Спрятать:

После выбора команды "Свернуть", окна клиентской программы будут убраны с экрана. Чтобы их восстановить, необходимо обратиться к иконке программы, находящейся в системном трее, и, кликнув по ней правой клавишей мыши, выбрать в открывшемся меню команду "Развернуть".

Воспользовавшись командой "Спрятать", вы уберете не только окна программы, но и все следы ее работы, в том числе и иконку в системном трее. При этом сама система продолжает функционировать так же, как и до запуска команды. Если включена, то ведётся запись поступающей информации, срабатывают детекторы и т.д. Но тому, кто смотрит на монитор это не заметно.

Теперь, чтобы восстановить "спрятанный" интерфейс, нужно ввести с клавиатуры комбинацию клавиш, которую вы назначили при настройке программы в меню "Загрузка". По умолчанию это клавиши "Ctrl+Alt+G". Назначенную комбинацию клавиш необходимо запомнить, иначе, чтобы вернуть на экран программу, придется прибегать к некоторым хитростям, известным опытным пользователям Windows, чтобы закрыть программу и запустить ее снова, либо – к перезагрузке операционной системы.

Ниже этих двух строк – новый раздел Главного меню - "Настройки размещения окон на экране".

Нажатие мышью по первой строке этого меню - "Выстроить по умолчанию" приведет к тому, что окна всех камер разместятся посредине свободного пространства Рабочего стола. То есть, если, к примеру, у вас пару строк в нижней части дисплея занимают Панель задач и Панель быстрого запуска программ операционной системы Windows, а вверху экрана место "забито" еще каким-нибудь из многочисленных "украшений" Рабочего стола, то окна вместе с Панелью управления GOALcity расположатся посредине оставшегося свободным пространства.

Нажатие на строку "Настроить размещение" откроет окно "Менеджер размещения", в котором можно сохранить созданную схему расположения окон, создать новую, или загрузить сохраненную ранее.

Чтобы создать новую схему размещения окон, выберите в соответствующих окошках в верхней части Менеджера размещения желаемое их количество по ширине рабочего стола и по его высоте. На иллюстрации отображено окно со схемой 3 х 4. Если хотите сохранить созданную схему, нажмите кнопку "Сохранить". Созданная схема появится в окошке в правой части Менеджера размещений. Теперь, при каждом обращении к этой опции, здесь будут условно отображаться все ранее сохранённые схемы размещений окон. Для загрузки той, которая необходима в данный момент, выберите ее, нажмите сначала кнопку "Разместить", а затем "Ок". Окна камер разместятся на Рабочем столе компьютера в соответствии с выбранной схемой и займут на нём максимально возможное пространство с сохранением пропорций кадра.

Ниже раздела с настройками размещения окон есть еще один, содержащий всего одну строку. Здесь можно переключить внешний вид Главной панели управления. Предоставляются две опции: "Полный вид" – со всеми кнопками, и "Сокращенный вид" – при котором видны только часть кнопок

В следующем разделе Главного меню собраны команды, управляющие конфигурациями.

Клик по строчке "Автоконфигурация" выведет на экран предупреждение о том, что текущая конфигурация будет утеряна. И, если вы ответите согласием, перед вами откроется "Диаграмма подключений" точно в таком же виде, как при первом запуске клиентской программы.

•После запуска команды "Загрузить конфигурацию" откроется окно Проводника Windows в каталоге, куда вы записали последнюю сохраненную конфигурацию системы (по умолчанию – это "C:\Program Files\Speclab\GOALcity\..."), предоставив вам возможность выбрать нужный из файлов с расширением *.cfg.

•Команда "Загрузить последнюю конфигурацию" позволяет выбрать и загрузить одну из последних сохраненных конфигураций.

•Команда "Сохранить конфигурацию как…" откроет дополнительное окно, в котором Вам предоставляется выбор какую из конфигураций программы необходимо сохранить. Можно сохранить клиентские настройки, основную конфигурацию и сохранить конфигурацию в файл.

Сохранив основную конфигурацию программы, Вы запишите текущее расположение окон, Главной панели управления и других открытых элементов клиентской программы в качестве основной. Именно она будет запускаться при нажатии кнопки main-menu-05 "Восстановить основную конфигурацию" главной панели управления или при выполнении команды "Загрузить основную конфигурацию" Главного меню программы.

Рекомендуем! Когда Вы создадите оптимальную конфигурацию интерфейса клиентской программы, воспользоваться командой "Сохранить основную конфигурацию". Тогда в случае, если после экспериментов операторов с окнами и панелями, интерфейс превратится в малопонятную мешанину картинок, Вы всегда сможете восстановить основную конфигурацию программы одним нажатием кнопки на главной панели управления.

Следующие команды описаны в соответствующих разделах: "Настройка программы", "Настройка подключений", "Настройка заданий", "Групповые настройки".

•Строка "Смена пользователя" выводит диалоговое окно и предлагает ввести имя пользователя и пароль, аналог кнопки на Главной панели программы.

•"Настройка событий SL++", "Настройка планов", "Настройка панели "Внимание!" также подробно рассмотрены в настоящем руководстве.

•Панель "Розыск". Позволяет вывести на экран панель отображать на ней фотографии или любую другую графическую информацию. Настраивается панель "Розыск" очень просто: после активации соответствующего пункта в главном меню, на экране появится чистая панель. Нажмите на кнопку и вызовите меню, в нем выберите команду "Добавить фото". Фотография появится на панели. Панель масштабируется и подгоняется под необходимый размер, чтобы рационально использовать пространство рабочего стола. Чтобы удалить одно из фото с панели, достаточно щелкнуть по нему правой кнопкой мыши и в контекстном меню выбрать команду "Удалить".

•Команда "Просмотр журнала" откроет "Журнал", в котором регистрируются все действия Пользователя и манипуляции с программой.

•"Фоновые задачи" - эта команда открывает окно, в котором показывается список выполняемых в фоновом режиме задач программы.

•"Статистика" позволяет выбрать и отобразить статистику записи в архив и сетевую статистику.

•Команда "GOALcity в Интернете" откроет в браузере официальный сайт. Команда "Справка" откроет интегрированную в программу справочную систему.

•Функция "Отменить действия с окном" - отменяет последнее действие пользователя с окном программы, аналог кнопки Главной панели управления.

•Строка "Показать главную панель" пригодится в случае, когда пользователь случайно скрыл главную панель программы, например, за край монитора или потерял под окнами камер, эта функция вернет ее на экран.

•Пункт меню "О программе" выведет окно с информацией о версии программы, ID ключа защиты, сетевом имени, IP-адресе компьютера, о том, кто и когда запустил программу и о времени её работы.

•Команда "Выход" предлагает выбрать одно из четырех действий: завершить программу, завершить программу и службу, перезапустить программу, перезапустить программу и службу.


Диаграмма подключений

Настройки > Настройки панели управления >

Диаграмма подключений

Для того, чтобы открыть Диаграмму подключений GOALcity нажмите на Главной панели управления кнопку diagramma-03

Перед вами откроется Диаграмма подключений.

Нажмите кнопку Добавить в правом верхнем углу Диаграммы для того, чтобы выполнить поиск серверов GOALcity (Мультимедиасервер, Архивный, Видеосервер, Аудиосервер, )

Область поиска серверов:

1. На этом компьютере - будут подключены сервера, которые находятся на этом же компьютере

Чтобы подключить сервера, установленные на этом же компьютере - отметьте пункт На этом компьютере, если на другом - поставьте отметку На компьютере и, в рядом расположенном поле, впишите его IP адрес, а в другом поле - порт (по умолчанию 3107). После нажатия кнопки Далее запустится поиск серверов.

При этом учетные записи на сервере и на клиенте должны совпадать. Т.е. на сервере, к которому подключается клиент, должна быть учетная запись с соответствующими правами и паролем, и именно такая же учетная запись с тем же именем и паролем должна быть на клиенте. В противном случае при поиске не будет найдено ни одного сервера по указанному адресу, никаких уведомлений или ошибок выдаваться не будет. Надо иметь ввиду, что при сетевом подключении серверов системы GOALcity их настройки (IP-адреса и порты) лучше уточнить у системного администратора (если сервера находятся в локальной сети) или у провайдера (если сервера находятся в сети Интернет).

Время поиска серверов, установленных на локальном компьютере, порой может превышать 5 минут. Причин может быть несколько: высокая загрузка процессора, большое количество установленных серверов, наличие ключей Guardant для работы с другими программами.

В случае поиска серверов на большом количестве компьютеров в локальной сети отметьте "В сети" и нажмите кнопку "Далее".

Чтобы добавить или изменить диапазон поиска, нажмите кнопку "Добавить" или "Изменить" соответственно, откроется окно выбора диапазона IP-адресов для поиска. Если этот диапазон неизвестен, то лучше уточнить его у системного администратора, иначе поиск может занять очень много времени, даже если установить максимальную скорость. Для начала поиска нажмите "Далее".

По окончанию поиска откроется окно "Результаты поиска". Выберите необходимые сервера, поставив напротив них галочку, нажмите кнопку "Завершить" - сервера добавятся на Диаграмму подключений.

Обратите внимание на треугольник в заголовке сервера после его сокращенного названия и IP-адреса. Когда острый угол треугольника обращен вниз, то на схеме отображаются все камеры сервера.

Если кликнуть по треугольнику мышью, то на схеме сервера останутся только те из камер, которые подключены к окнам клиента.

Нажатие "крестика" в правом углу заголовка сервера приведет к удалению его из Диаграммы подключений. При этом из интерфейса клиентской программы удалятся и все камеры этого сервера, а в соответствующих им окнах появится надпись: "Отключено".

Аналогично "крестику" действует кнопка Диаграммы подключений "Удалить". Чтобы она сработала, необходимо сначала выделить нужный сервер, кликнув в любой точке его схематического изображения (при этом вокруг него возникнет пунктирная линия) и нажать кнопку "Удалить". Чтобы открыть контекстное меню сервера, щелкните правой кнопкой мыши по "шапке" сервера.

•Команда меню "Обновить" произведёт Актуализацию сервера, т.е. проверит его версию, доступность, количество подключенных и активных камер.

•Действие команды "Настроить" аналогично результату нажатия кнопки "Свойства" Диаграммы подключений, т.е. вызов настроек текущего сервера.

•Команда "Удалить" аналогична нажатию "крестика" в правом углу данного сервера - удаление выбранного сервера.

Следующие три команды позволяют производить групповое подключение камер:

•"Подключить активные" - подключает к окнам GOALcity только те источники, от которых есть сигнал (выделяются зеленым цветом).

•"Подключить выбранные" - подключает только выбранные камеры к окнам GOALcity. Несколько камер можно выбрать с зажатой кнопкой "Ctrl" на клавиатуре.

•"Подключить все" - подключает к окнам GOALcity все источники.

Кнопка "Выстроить" в правой части "Диаграммы подключений" поможет вам "навести порядок" - автоматически расставит по местам схемы серверов.

Кнопки с пиктограммами луп diagramma-14 (одна со знаком "минус", другая – с "плюсом") соответственно уменьшат или увеличат масштаб отображения элементов "Диаграммы подключений". Особенно полезны эти кнопки, когда в системе задействовано большое количество камер.

И последняя в этом ряду кнопка с двумя полосками (прямой и ломаной) служит для переключения режима отображения соединений камер и окон GOALcity. Клик по кнопке "Подключить" вызовет окно "Стиль подключения", в котором можно настроить количество камер, информация от которых будет отображаться в одном окне.

Подключение источника к окну

Выполнить подключения устройств к окнам GOALcity вручную очень просто. Подведите указатель мыши к виртуальной клемме соответствующего устройства (камеры, ключа, датчика, микрофона и т.д.). Указатель примет вид кисти руки, над которым появится описание данного сервера.

Теперь, нажав левую кнопку мыши, "протащите" возникшую пунктирную линию к пиктограмме "Новое подключение". Как только Вы доведете пунктир до виртуальной клеммы окна GOALcity, курсор "превратится" в кисть с вытянутым указательным пальцем.

Следует отметить, что подключения можно производить в одно окно, тем самым группируя источники.

Повторите описанные выше действия со всеми необходимыми источниками. Нажмите кнопку "Ок" в нижней части Диаграммы подключений для принятия изменений. После подключения в GOALcity появятся окна, отображающие видеосигнал с IP-камер.


Окна

Настройки > Настройки панели управления >

Окна

Общее описание

Окно – главный элемент интерфейса для любой системы видеонаблюдения. Это полностью справедливо и для системы GOALcity. Помимо своего основного назначения – отображать информацию, поступающую от подключенного к нему источника (видеокамеры, микрофона, датчика и т. п.), в этой системе окно информирует пользователя о своих настройках и помогает их изменить. Не закрывая его и не убирая курсор мыши, можно выполнить множество самых разных настроек.

Обратите внимание! Для многомониторных конфигураций рекомендуем в настройках видеодрайвера "выстраивать" все мониторы в ряд (слева-направо) или столбик (сверху-вниз), но не совмещать такие расположения. Иначе при развертывании или сворачивании окна есть шанс "потерять" его на мониторах. Данная особенность связана с внутренней архитектурой видеодрайверов NVIDIA и ATI и внутренним распределением видеопамяти видеокарты.

Сразу под заголовком, уже непосредственно в окне, располагается полупрозрачная информационная строка (она может быть убрана при настройке свойств камеры). Когда она видна, на ней отображается различная информация: слева-направо расположены следующие индикаторы: разрешение кадра, включение режима увеличения кадра, программный автоконтраст, детектор движения, индикатор записи, текущая скорость записи (при условии, что запись настроена). По середине отображается название видеоисточника и в правом углу текущая скорость отображения видео в окне.

Функции всплывающей панели

Чтобы вызвать служебную панель управления, необходимо навести курсор мыши на окно GOALcity, панель появится автоматически. Панель можно отключить в настройках свойств текущего окна, но мы рекомендуем оставлять панель включенной для более оперативной работы. По умолчанию выводятся самые необходимые в работе кнопки, но панель может "сдвигаться" вправо и влево, открывая дополнительные кнопки быстрых действий.

Основные функции:

Чтобы включить\выключить постоянную запись нажмите на кнопку button-rec . Следующая кнопка button-dd активирует\деактивирует запись по детекции движения. Просмотр архива с текущей камеры вызывается нажатием на кнопку button-play . Чтобы перейти к настройкам текущего окна и камеры нажмите на кнопку button-settings . Если видеоизображение в окне пропало или "замерло" переподключить камеру поможет последняя кнопка button-reconect .

Следующие кнопки Панели управления предназначены для управления свойствами изображения. Увеличение области кадра, переворот кадра, масштабирование и прочие функции. Все кнопки снабжены всплывающими подсказками.

Окна, как типичные для ОС Windows, имеют заголовок. Они могут быть в двух состояниях: активном (заголовок подсвечен цветом) и неактивном (заголовок – серый).

"Ухватив" мышью окно за заголовок, Вы можете "перетащить" его в любое место Рабочего стола. А "взяв" за любую границу или уголок, произвольно изменять его размеры. Если "ухватить" одно окно и перетащить его на другое место на столе, удерживая при этом нажатой клавишу "Ctrl", то вместе с ним будут перемещаться все остальные окна программы и Главная панель управления.

У окна GOALcity, в правом верхнем его углу, отображаются две традиционные для Windows функции: "Скрыть" и "Развернуть/восстановить".

Четыре значка windows-02 в левой части заголовка окна имеют специфическое для GOALcity назначение.

Нажатие на первую кнопку windows-03 выведет контекстное меню окна. В данном меню продублированы все основные настройки видеоисточника и окна.

Нажав вторую кнопку windows-04 , Вы сделаете это окно образцом для других окон системы.

Теперь, если нажать кнопку windows-05 в другом окне , то оно примет такие же размеры, как у отмеченного в качестве образца.

При нажатии кнопки windows-06 на экране появится окно с опциями, позволяющими настроить "поведение" данного окна при изменении его размеров.

Можно включить/отключить сохранение пропорций окна в обычном режиме и при блокировке. Если активировать пункт "Не сохранять", то размеры окна со всем его содержимым можно будет менять произвольно.

Контекстное меню окна

Чтобы вызвать контекстное меню окна, необходимо кликнуть левой кнопкой мыши по кнопке в заголовке окна или правой кнопкой в любом месте видеоизображения в окне. Откроется следующее меню:

•Команда "Развернуть" позволит отобразить окно "на весь монитор" или в реальном размере, (или в место, указанное с помощью опции "Зафиксировать позицию всплытия") если разрешение видео меньше чем разрешение вашего монитора.

•Команда "Скрыть" свернет окно с рабочего стола, но все настройки и параметры окна при этом сохранятся. Вернуть окно можно с помощью кнопки "Показать все" на главной панели управления.

•Команда "Закрыть" закроет выбранное окно, при этом все настройки, сделанные для этого окна и видео потока в нем будут утеряны.

•Команда "Зафиксировать позицию всплытия" позволяет указать размер и место в которое будет "разворачиваться" камера при выполнении команды "Развернуть", двойном клике мышкой по видео в окне или сработке событий SL++. То есть вы можете "перетащить" окно с помощью мыши в нужное вам место, задать его размер и включить данную опцию, в дальнейшем это окно будет "разворачиваться" именно сюда с сохраненными Вами размерами.

•Команда "Поверх других окон" заставит окно отображаться всегда сверху любых других элементов и интерфейсов как GOALcity так и других программ.

•Если в окно подключено несколько видеоисточников, то с помощью команды "Выстроить" можно запустить мастер расстановки камер, внутри окна.

•"Ручная расстановка" позволит расставить несколько видеоисточников внутри окна в ручном режиме, перетаскивая границы с помощью мыши.

•Команда "Транслировать" позволяет включить использование VSS-Ретранслятора для данного окна. Если функция включена, то активируется опция "Настройки трансляции" в которой можно указать разрешение и частоту кадров для данного транслируемого окна.

•Опция "Окно образец" запомнит размер данного окна, и позволит использовать опцию "По образцу" для других окон. Функция необходима для упрощения выстраивания и группирования окон на рабочем столе.

•Команда "Сохранить" сохраняет текущее окно в файл со всеми настроенными в нем параметрами.

•Самая нижняя строчка открывает параметры текущего видеоисточника в упрощенном виде.

Функция "пролистывания" в окне камеры

Если "схватить" левой кнопкой мыши изображение в окне камеры и переместить его вправо, то мы увидим файл расположения (например, картинка с планом вашего объекта, на котором отмечено место установки данной камеры). Файл задается в настройках окна. Этим файлом может быть любое изображение в формате .bmp.

При перемещении изображения окна влево, мы увидим последние записи аналитики с данной камеры, (если данная опция включена в настройках камеры) при условии, что камера обрабатывается панелью "Внимание!". В правом верхнем углу окна будет мигать надпись "Архив", оповещая пользователя о том, что он смотрит уже запись. Перелистывать можно и дальше, в таком случае события, отображаемые в окне, будут отображаться от самого нового к старому.

Возврат к отображению видео в окне происходит автоматически при "бездействии" оператора в течении 10 секунд, обратным "перетаскиванием", либо двойным щелчком левой кнопки мыши по окну.

Сохранить текущий кадр с камеры можно с помощью настройки "Скриншоты" в основных настройках программы.

Масштабирование видео в окне просмотра

Масштабирование видео производится прямо в окне "живого" просмотра с помощью мыши и клавиатуры. Увеличенную область можно еще раз увеличить и так сколько угодно раз.

Чтобы увеличить видеоизображение, достаточно навести курсор мыши на желаемую область, зажать на клавиатуре клавишу "Ctrl" и "поскролить" колесиком мыши. Изображение масштабируется исходя из расположения курсора мыши в окне, другими словами, центрируется по нему.

Также, можно увеличить определенную область зажав все туже клавишу "Ctrl" на клавиатуре, кликнув левой кнопкой мыши и, не отпуская кнопку, "нарисовать" прямоугольник поверх видео (аналог группового выделения файлов с помощью мыши). "Нарисованный" прямоугольник и будет увеличен на все окно просмотра.

Увеличенную область изображения можно "таскать" по окну с помощью правой кнопки мыши при зажатой на клавиатуре клавише "Сtrl".

Чтобы вернуться к "реальной" картинке, кликните "колесиком" (средней кнопкой мыши) в любом месте видеоизображения.

GOALcity позволяет добавить любую надпись в окно и отражать её поверх видео. Чтобы это сделать, откройте настройки камеры кликом по кнопке button-settings на всплывающей панели, перейдите на вкладку "Клиент", активируйте пункт "Надписи" и нажмите на кнопку с изображением шестеренки справа.

Откроется окно добавления и редактирования надписей.

•Кнопка "Добавить" позволяет создать новую надпись, кнопка "Изменить" - редактировать одну из уже созданных.

•Кнопки "Копировать", "Вставить" позволяют клонировать уже созданные надписи как для текущей камеры, так и для любой другой. То есть нажав кнопку "Копировать" и открыв параметры надписей для другой камеры можно вставить эту надпись туда.

Чтобы настроить текст, его положение в окне камеры, размер и другие параметры, выделите надпись которую необходимо изменить и нажмите кнопку "Изменить". Сам текст настраивается очень просто. Вы можете менять параметры и параллельно смотреть как они отображаются на внешнем виде роликов на панели "Внимание!".

Так же, вместо обычного текста Вы можете использовать переменные:

•%t - выведет текущее время поверх видеоизображения в формате Ч:М

•%T - вермя в формате Ч:М:С

•%d - выведет текущую дату, а %D текущую дату с указанием дня недели.


Схемы

Настройки > Настройки панели управления >

Схемы

Активация схем

Для активации «Схем», кликните правой кнопкой мыши по «шапке» окна камеры и в выпадающем списке поставьте «галочку» на против пункта «Схемы расположения окон»

Окно поменяет свой вид и появятся дополнительные элементы управления

Элементы управления

кнопки переключения между схемами. Расположены в верхней левой части окна

кнопки управления схемами. Расположены в верхней правой части окна.

zakrep закрепить окна. В неактивном состоянии позволяет перемещать и удалять окна камер на схеме.

добавить схему. Отвечает за создание новых или редактирование уже имеющихся «схем».

удалить схему. Удаляет ненужную схему.

открывает панель устройств.

На панели устройств отображаются все устройства заведенные на «Диаграмму подключений» (камеры, микрофоны, ключи и т.д.).

В верхней части панели находятся кнопки-фильтры, деактивация\активация которых позволяет скрыть\показать то или иное устройство

Кнопка карты karta включает отображение карты, на которой отображаются камеры согласно заданым координатам. Координаты указываются на вкладке «Дополнительно» в настройках камеры (пример: 57.000191, 40.951193).

Отображение карты возможно только при наличии интернет доступа. Для использования оффлайн карт обратитесь в службу технической поддержки «Спецлаб»

Работа со схемами

Добавление схем

Нажмите кнопку «Добавить схему» [image] и в выпадающем выберите пункт «Создать схему». В открывшемся укажите количество строк и столбцов. Нажмите «Выполнить»

Откроется окно редактор созданной схемы. Можно оставить как есть или отредактировать как Вам нужно

Для объединения нескольких ячеек в одну, необходимо их выделить с зажатой ЛКМ. Ячейки, которые будут объединены поменяют цвет

Отпустите ЛКМ. Выделенные ячейки объединятся в одну

Нажмите «Создать»

В следующем окне задайте имя схеме (не больше двух символов). Нажмите «Создать»

После создания схемы, программа переключится на новую схему

Удаление схем

Для удаления схемы выберите ее на панели выбора схемы [image] и нажмите кнопку «Удалить схему»

В открывшемся окне подтвердите удаление

Добавление камер на схему

Нажмите кнопку «Панель» [image] . Откроется список устройств

Чтобы добавить камеру на схему, выделите ее и с зажатой ЛКМ перетащите в нужную ячейку

Удаление камер со схемы

Камеру со схемы можно удалить только если кнопка «Закрепить окна» zakrep неактивна. Разблокируйте окна нажав на соответствующую кнопку

Нажмите ПКМ на камере, которую необходимо убрать со схема и подтвердите удаление нажав на пункт «Удалить».


Групповые настройки

Настройки >

Групповые настройки

Общее описание

GOALcity содержит в себе множество настроек и параметров для всех источников и элементов программы, как для обычного пользователя, так и для любителей "тонкой" настройки. Настройка каждого элемента в отдельности может занять приличное количество времени, особенно если Вы делаете это впервые.

Групповые настройки позволяют значительно упростить и ускорить процесс настройки видео источников и других элементов. С помощью них можно менять множество параметров всего за несколько кликов мышки. Чтобы открыть настройки, выберите в Главном меню GOALcity пункт "Групповые настройки".

Настройка параметров

После запуска групповых настроек, Вы увидите окно, в котором перечислены все источники, подключенные к GOALcity. Все элементы представлены в виде "дерева" и позволяют изменять параметры каждого в отдельности или всех вместе.

Чтобы открыть диалог группового изменения параметров, кликните по кнопке button-04 справа от необходимой группы источников. То есть, если Вы хотите изменить параметры сразу всех видео источников, нажимайте на кнопку справа от строки "Видео" и т. д.

Перед Вами откроется новое окно с выбранными элементами

Можно отметить для изменения как отдельные источники, поставив "галочку" рядом с его именем, либо все сразу, поставив птичку в поле "Все" в верхней части окна.

После выбора изменяемых источников в поле "Свойства" появятся группы элементов, доступные для настройки. Отметьте "птичками" необходимые для настройки группы. Выбранные группы появятся в нижнем поле текущего окна.

"Пробегитесь" по "дереву" параметров и установите необходимые Вам значения. Сохраните всё нажатием кнопки "Ок". Сделанные Вами изменения будут применены сразу ко всем выбранным источникам.


Отображение

Настройки > Групповые настройки > Панель "Внимание!" >

Отображение

Пункт «Мигание рамки вокруг камеры» включает мигание рамки при появлении нового события на панели внимание.

Пункт «Отображать название алгоритма» включает отображение сработавшего алгоритма в окне события.

Пункт «Отображать дату» включает дату сработавшего алгоритма.

Пункт «Отображать номер автомобиля» включает отображение номера зафиксирофанного автомобиля.

Пункт «Отрисовывать состояние алгоритмов в окне камеры» включает графическое отображение сработки алгоритмов в окне камеры

Пункт «Проигрывать ролики только при наведении указателя» установив данный параметр ролик с событийем на панели "Внимание!" будут воспроизводиться, только если на него навести указатель мыши.

Пункт «Показывать окно просмотра при добавлении события» при появлении нового события автоматически открывается окно просмотра появившегося события.

Пункт «Включение экрана при новом событии» Если настроено автоматическое выключения экрана, эта опция позволяет включать экран при появлении нового события. Для корректной работы отключите экран блокировки в настройках операционной системы.

Пункт «Отображать надписи» отображает надписи поверх видео у всех видеороликов для текущей камеры и текущей панели "Внимание!".


Авария

Настройки > Групповые настройки > Панель "Внимание!" >

Авария

Алгоритм панели "Внимание!" "Авария" служит для оперативного оповещения оператора о том, что с одной из видеокамер пропал видеосигнал. Даже если оператор отвлекся, он всегда увидит это оповещение на одной из панелей "Внимание!".

Обратите внимание! Для работы алгоритма необходимо, чтобы у камеры была настроена и включена запись в архив, т.к. ролики формируются именно из текущего архива камеры.

Пункт «Активировать» активирует работу алгоритмов панели «Внимание!» для данной группы камер.

Пункт «Начальная задержка» задержка перед началом работы алгоритма.

Пункт «Допустимо время отсутствия видео» здесь устанавливается период, после которого будет выводиться оповещение на панель "Внимание!". То есть, если видео "пропало" на 29 секунд и появилось на 30-ой - оповещения не будет.

Пункт «Реагировать на отсутствие записи» поможет Вам отслеживать моменты пропадания видеозаписи с текущей камеры в случае повреждения жесткого диска или каких либо других проблем. На панель внимание так же будет выведен ролик с последними секундами записи и иконкой перечеркнутого жесткого диска.

Пункт «Допустимое время отсутствия записи» здесь устанавливается период, после которого будет выводиться оповещение на панель "Внимание!". То есть, если запись "пропала" на 29 секунд и появилась на 30-ой - оповещения не будет.

Пункт «Длительность ролика последних записанных кадров» в данном пункте устанавливается длительность ролика, который будет выведен на панель "Внимание!".

Пункт «Записывать тестовый ролик для GM-2» поможет Вам записать ролик для мобильного сервиса GOALmobile2 для работы с приложениями смартфонов и планшетов.

Пункт «Задержка тестового ролика» используется для задержки тестового ролика на панели "Внимание!".

Пункт «Выводить тестовый ролик на панель» используется для вывода тестового ролика на панель "Внимание!".

Пункт «Проверять перекрытие камеры» - выводит ролик на панель "Внимание!" если камера была закрыта. Для работы детектора перекрытия необходимо активировать его в настройках видеоисточника.


Автономера

Настройки > Групповые настройки > Панель "Внимание!" >

Автономера

Алгоритм «Автономера» служит для оперативного оповещения оператора о том, что в обзоре одной из видеокамер появился автомобильный номер. Даже если оператор отвлекся, он всегда увидит это оповещение на одной из панелей "Внимание!".

Для работы алгоритма необходимо активировать детектор автономеров на сервере!

Пункт «Активировать» активирует работу алгоритмов панели «Внимание!» для данной группы камер.

Пункт «Продолжительность отслеживания» время проезда автомобиля перед камерой. Если один и тот же номер повторяется, увеличьте значение!

Пункт «Список масок номеров через запятую (?-любой символ)» Для добавления номера в список номеров нажмите и напечатайте нужный номер в формате "А111АА37". Если один из символов не известен замените его вопросительным знаком (?). Например: "А11?А?37".

Пункт «Реагировать только на номера из списка» При активации данной функции на панель "Внимание!" будут попадать только те номера, которые есть в списке номеров.

Пункт «Не реагировать на номера из списка» При активации данной функции на панель "Внимание!" будут попадать только те номера, которых нет в списке номеров.


Лица

Настройки > Групповые настройки > Панель "Внимание!" >

Лица

Пункт «Активировать» активирует работу алгоритмов панели «Внимание!» для данной группы камер.

Пункт «Продолжительность отслеживания» время прохождения перед камерой. Если одно и то же лицо повторяется, увеличьте значение!

Пункт «Точность сравнения лиц(%)» Если лица не находятся в базе, уменьшите значение. Если имена не совпадают с лицами, увеличьте! Нормальный уровень - 50%.

Пункт «Список лиц» здесь будет выводиться список лиц для данной панели "Внимание!" Что бы добавить базу лиц для конкретной панели «Внимание!», зайдите в настройки панели "Внимание!" и выберите камеру, на которой нужно активировать идентификацию лиц.

Пункт «Выводить только лица из списка» При активации данной функции на панель "Внимание!" будут попадать только те лица, которые есть в списке имен.

Пункт «Выводить только лица не из списка» При активации данной функции на панель "Внимание!" будут попадать только те лица, которых нет в списке имен.

Пункт «Живое лицо» - опция предназначена для защиты от картинок (фотографий).

Параметр «0» - функциия отключена лицо будет определяться с одного ракурса.

Параметр «1» - лицо определится, только если человек покажет в камеру не менее двух ракурсов (анфас и профиль).

Параметр «2» - лицо определится, только если человек покажет в камеру не менее трех ракурсов (анфас, профиль левый, профиль правый).

Пункт «Искать имена в списке» - может быть активирована только при отключенных опциях «Выводить только лица не из списка» и «Выводить только лица из списка». При активации, попавшие на панель "Внимание!" известные лица, будут подписаны согласно списку имен.

Пункт «Количество лиц для поиска имени» позволяет задать то количество лиц, которое будет достаточно для того, чтобы начать поиск имени.

Пункт «Выводить только лица, прошедшие распознавание» При активации данной функции на панель "Внимание!" будут попадать только те лица, которые были распознаны.

Пункт «Задержка на повторное включение» можно задать время, после которого произойдет повторное подключение.

Пункт «Управление телепатией разрешено» разрешает активировать опцию управления телепатией.

Пункт «Адрес/порт телепатии» ip адрес и порт по которому находится контроллер.

Пункт «Таймаут запроса к телепатии (сек)» задержка замыкания ключа между сработками алгоритма.

Пункт «Замкнуть ключ телепатии на время (сек)» время на которое замкнется выбраный ключ.

Пункт «Номер ключа телепатии» ключ, который будет замыкатся при сработки алгоритма.

Пункт «Автоматически добавлять неизвестные лица» - неизвестные лица будут автоматически добавляться в общую базу. Неизветному лицу присвоится цифровой идентификатор, который может быть изменен.

Пункт «Вести статистику» - отображает сколько раз определенное лицо попало на камеру.

Пункт «Выводить ролик только если количество посещений больше заданного» минимальное количество раз, которое одно и тоже лицо должно определится, прежде чем ролик с ним попадет на панель "Внимание!".

Пункт «Заданное количество посещений» позволяет задать то количество раз, которое одно и то же лицо может определиться на камере, прежде чем ролик с нима попадет на панель "Внимание!".


Помехи

Настройки > Групповые настройки > Панель "Внимание!" >

Помехи

Пункт «Активировать» активирует работу алгоритмов панели «Внимание!» для данной группы камер.

Вкладка «Растения»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Проводить настройку при загрузке программы» Позволит проводить подстройку алгоритма при каждом запуске в автоматическом режиме. Система сама проанализирует видеопоток и "вычленит" проблемные места.

Пункт «Отображать уровень опасности в окне камеры» Позволяет включить цветовое наложение на видеопоток, на котором будут отмечены красным цветом зоны, исключенные из внимания. Данную опцию можете включить, если Вам интересно, в каком месте кадра система определила помехи.

Пункт «Уровень опасности (0-300)» Если ложные сработки идут часто, повысьте уровень. Если полезные объекты не определяются, то понизьте.

Пункт «Ширина каймы опасной зоны» система пытается предугадать начальную стадию развития помехи. Например, ветер только начинается и качает лишь незначительно ветку. Следующий порыв ветра с более сильным колебанием ветки будет компенсирован этой каймой.

Пункт «Время нарастания уровня движения» Время непрерывной детекции движения, спустя которое, в окне камеры будет отображаться карта уровня опасности.

Пункт «Время снижения уровня движения» В течении установленного времени, при отсутствии детекции движения, карта уровня опасности будет постепенно уменьшаться, а по истечению установленного времени, исчезнет.

Вкладка «Атмосфера»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункты «Уровень помех по горизонтали» и «Уровень помех по вертикали» Постарайтесь, с помощью двух пунктов, «подогнать» площадь помех к тому, что Вы реально видите в кадре. Другими словами, выберите максимальную площадь детекции, если детекция будет больше указанной площади, то сработок алгоритмов не будет.

Пункт «Объединение по всем кадрам» Оценивает площади детекции всех кадров ролика события, объединяя их в одну общую площадь. На отдельных кадрах может не быть превышения детекции по площади, но по другим кадрам идет много ложных сработок в разных частях кадра. В этом случае рекомендуется активировать эту настройку.

Вкладка «Нейронная сеть»

Пункт «Использовать оффлайн нейросеть» - использовать нейросеть, не подключенную к сети.

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер. Для работы данного фильтра требуется включенная нейросеть на видеосервере.

Пункт «Проверять присутствие объекта» Программа будет выводить только те ролики на панель «Внимание!», на которых присутствуют объекты указанных классов.

Пункт «Классы и вероятности присутствующих объектов» в данном пункте впишите классы объектов, через запятую, в соответствии с установленной нейронной сетью, на которые будет реагировать алгоритм присутствия.

Пункт «Проверять отсутствие объекта» Программа будет выводить только те ролики на панель «Внимание!», на которых отсутствуют объекты указанных классов.

Пункт «Классы и вероятности отсутствующих объектов» в данном пункте впишите классы объектов, через запятую, в соответствии с установленной нейронной сетью, на которые будет реагировать алгоритм отсутствия.

Пункт «Проверять появление объекта» На панель «Внимание!» будут выводится только те алгоритмы, во время сработки которых появятся указанные объекты классов. Программа покадрово проверяет ролик и, если на начало проверки объекта не было, а в последующих кадрах он есть, это и будет считаться появлением.

Пункт «Классы и вероятности появляющихся объектов» в данном пункте впишите классы объектов, через запятую, в соответствии с установленной нейронной сетью, на которые будет реагировать алгоритм отсутствия.

Пункт «Проверять исчезновение объекта» На панель «Внимание!» будут выводится только те алгоритмы, во время сработки которых исчезнут указанные объекты классов. Программа покадрово проверяет присутствие объекта в ролике и, если на начало проверки объект был, а в последующих кадрах его не будет, это и будет считаться исчезновением.

Пункт «Классы и вероятности исчезающих объектов» в данном пункте впишите классы объектов, через запятую, в соответствии с установленной нейронной сетью, на которые будет реагировать алгоритм исчезающих объектов.

Пункт «Проверять движение объекта» Будут выводится все указанные, двигающиеся объекты. Для таких объектов как автомобили чаще нужно отслеживать не их присутствие в кадре, а только движение. В отличие от человека, автомобиль может находиться в кадре вечно, что не добавляет информативности, а только увеличивает бесполезные сработки.

Пункт «Классы и вероятности движущихся объектов» в данном пункте впишите классы объектов, через запятую, в соответствии с установленной нейронной сетью, на которые будет реагировать алгоритм движущихся объектов.

Пункт «Допустимый процент пересечения областей неподвижного объекта» здесь можно установить, в процентах от области неподвижного объека, степень перекрытия, при которой непроизойдет сработка детектора на начало движения.

Пункт «Тестовый режим» Не рекомендуется включать без указания службы технической поддержки. При включении на панель «Внимание!» будут попадать все ролики.

Пункт «Отображать информацию» Не рекомендуется включать без указания службы технической поддержки. Данная функция включает вывод служебной информации в ролике на панели «Внимание!».

Пункт «Активен в указанное время» При активации появляется возможность включения и отключения алгоритма в заданное время.

Пункты «Час начала активности» и «Минута начала активности» в данном меню задается время, с наступлением которого алгоритм будет включен.

Пункты «Час окончания активности» и «Минута окончания активности» в данном меню задается время, с наступлением которого алгоритм будет выключен.

Пункт «Активен в дневное время» включает активность в дневное время в соответствии с указанными координатами.

Пункты «Широта в десятичных градусах» и «Долгота в десятичных градусах» позволяют указать географические координаты места установки камеры.

Пункт «Минимальное количествто кадров с объектом» - минимальное количество раз, когда объект должен появиться в кадре.

Вкладка «Движение»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Отслеживать движение только в области сработки» При активации, будет выводить ролики на панель "Внимание!" только при детекции движения в области события.

Пункт «Активен в указанное время» При активации появляется возможность включения и отключения алгоритма в заданное время.

Пункты «Час начала активности» и «Минута начала активности» в данном меню задается время, с наступлением которого алгоритм будет включен.

Пункты «Час окончания активности» и «Минута окончания активности» в данном меню задается время, с наступлением которого алгоритм будет выключен.

Пункт «Активен в дневное время» включает активность в дневное время в соответствии с указанными координатами.

Пункты «Широта в десятичных градусах» и «Долгота в десятичных градусах» позволяют указать географические координаты места установки камеры.


Нейро-Р

Настройки > Групповые настройки > Панель "Внимание!" >

Нейро-Р

Важно! Для работы видеоаналитики требуется включать детектор объектов на видеосервере.

Вкладка "Параметры"

Пункт «Активировать» активирует работу видеоаналитических алгоритмов панели «Внимание!» для данной группы камер.

Пункт «Буфер кадров» сколько хранится кадров до сработки алгоритма, для вывода на панель «Внимание!»

Пункт «Разрешить внешние алгоритмы» активирует возможность для настройки взаимодействия и совместной работы внешних плагинов и панели "Внимание!".

Пункт «Название внешних алгоритмов» в данном меню указываются названия внешних алгоритмов через запятую.

Вкладка «Направление»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Начальная задержка» устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и прочим.

Пункт «Длительность усреднения» суть данного параметра заключается в следующем. В реальности объект движется неравномерно. Для математического анализа необходима некая усредненная траектория движения, в рамках которой будут производиться расчеты. В данном пункте устанавливается, на протяжении скольких кадров будет производиться усреднение. Значение влияет на чувствительность алгоритма.

Пункт «Продолжительность отслеживания» здесь устанавливается время, в течении которого программа, не прекращая отслеживание, будет ожидать движения объекта при его исчезновении.

Вкладка «Пересечение»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Продолжительность отслеживания» здесь устанавливается время, в течении которого программа, не прекращая отслеживание, будет ожидать движения объекта при его исчезновении.

Пункт «Использовать нейросеть» Нейросеть позволяет избирательно реагировать на те или иные действия именно человека или машины, а также других полезных целей. Нейросеть в данном случае не определяет сработку алгоритмов, а только дополняет их своими фильтрами. В случае её активации в этом разделе, любой событийный ролик перед тем, как выйти на панель «Внимание!», проверяется на наличие в нем объектов указанных классов. При их отсутствии во всех кадрах ролика или отсутствии их заданного типа активности, событийный ролик сбрасывается в «корзину».

Вкладка «Поворот»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункты «Разрешенный левый поворот» и «Разрешенный правый поворот» позволяют установить, в градусах, значение максимального угла поворота объекта налево и направо соответственно, ниже которого сработка алгоритма не произойдет.

Пункт «Начальная задержка» устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и прочим.

Пункт «Длительность усреднения» суть данного параметра заключается в следующем. В реальности объект движется неравномерно. Для математического анализа необходима некая усредненная траектория движения, в рамках которой будут производиться расчеты. В данном пункте устанавливается, на протяжении скольких кадров будет производиться усреднение. Значение влияет на чувствительность алгоритма.

Пункт «Продолжительность отслеживания» здесь устанавливается время, в течении которого программа, не прекращая отслеживание, будет ожидать движения объекта при его исчезновении.

Пункт «Использовать нейросеть» включает использование нейросети для фильтрации объектов в кадре. Требуется включенная нейросеть на видеосервере.

Пункт «Отставание базового вектора» суть этого параметра заключается в том, что аналитический аппарат в каждом новом кадре к траектории движущегося объекта строит касательную-вектор. Между последним таким вектором и предпоследним, который называется "базовым", рассчитывается угол, по которому и определяется на сколько "опасен" поворот. Значение, выставленное в данном пункте, задает в каком кадре, относительно последнего, будет строиться базовый вектор. Меняя этот параметр, меняем чувствительность алгоритма.

Вкладка «Зона»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Начальная задержка» устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и прочим.

Пункт «Показывать движение только в заданной зоне» включает отображение движение только в указанной зоне.

Вкладка «Предмет» для работы данного алгоритма необходимо включить детектор фона на видеосервере.

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Время предпросмотра в архиве» укажите, какой период времени должен анализироваться для сработки алгоритма. Другими словами, сколько должен находится предмет в кадре до сработки.

Пункт «Продолжительность отслеживания после обнаружения» укажите задержку на сработку алгоритма после обнаружения предмета в кадре за время, установленное в предыдущем поле.

Пункт «Исключать людей» данный параметр исключает из своего внимания людей. Эта настройка работает только с включенной нейросетью на видеосервере.

Пункт «Время отслеживания людей и животных» здесь устанавливается время, в течении которого программа, не прекращая отслеживание, будет ожидать появление объекта при его исчезновении.

Пункт «Реагировать только на багаж» включив данную настройку алгоритм будет реагировать только на багаж. Данная настройка работает только с включенной нейросетью на видеосервере.

Пункт «Время отслеживания сумок и коробок» здесь устанавливается время, в течении которого программа, не прекращая отслеживание, будет ожидать появление объекта при его исчезновении.

Вкладка «Цвет» активирует работу алгоритма панели «Внимание!» для данной группы камер

Вкладка «Время»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Период превышения» рассчитывается исходя из того, сколько времени по максимуму требуется обычно, чтобы покинуть зону видимости камеры. Как правило, на проход по лестничной площадке требуется около 10 сек. Но для подготовки ограбления этого мало: нужно изучить замки, глазки, взломоустойчивость двери. Именно эта разница во времени нахождения в зоне наблюдения камеры и используется для распознавания "хороших" и "плохих".

Пункт «Макс. время отсутствия движения» задается время, по истечении которого, если не произошло ни одного движения, то алгоритм сработает.

Вкладка «Покой»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Период превышения» рассчитывается исходя из того, сколько времени по максимуму обычно в кадре ничего не происходит.

Пункт «Максимальное время движения» задается время, по истечении которого, если не произошло ни одного сработки покоя, то алгоритм сработает.

Вкладка «Площадь»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Начальная задержка» устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и прочим.

Пункт «Соотношение» вычисляется инсценированием событий перед камерой. "Актёрами" воспроизводятся сцены возможных несанкционированных действий и по результатам их анализа устанавливаются параметры изменения площади детекции.

Пункт «Время усреднения» период, на протяжение которого допускается кратковременное изменение площади с возвращением её в прежние пределы. Это время необходимо для того, чтобы избежать ложных сработок в случае кратковременного попадания в зону обзора посторонних предметов, не представляющих опасности, например, флагов, развеваемых порывом ветра.

Пункт «Реагировать на уменьшение площади движения» указывает алгоритму на необходимость сработки не только в случае увеличения площади движущихся объектов, но и в обратной ситуации – при ее уменьшении.

Вкладка «Количество»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Разрешенное количество» здесь выбирается какое число объектов одновременно может появиться в поле зрения камеры без сработки алгоритма (если количество объектов больше, то алгоритм сработает).

Пункт «Начальная задержка» устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и прочим.

Пункт «Минимальное расстояние между объектами» позволяет установить предельное расстояние между детектируемыми объектами, до которого они могут сблизиться.

Вкладка «Пропорция»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Подавление помех» включает фильтр сложных помех на видеосервере для данной группы камер.

Пункт «Время усреднения» период, на протяжение которого допускается кратковременное изменение площади с возвращением её в прежние пределы. Это время необходимо для того, чтобы избежать ложных сработок в случае кратковременного попадания в зону обзора посторонних предметов, не представляющих опасности, например, флагов, развеваемых порывом ветра.

Пункт «Минимальное допустимое соотношение ширины к высоте» в данном пункте устанавливается минимальное соотношение сторон объекта. Если данный параметр будет ниже, алгоритм сработает.

Пункт «Максимальное допустимое соотношение ширины к высоте» в данном пункте устанавливается максимальное соотношение сторон объекта. Если данный параметр будет превышен, алгоритм сработает.

Вкладка «Скорость»

Пункт «Активировать» активирует работу алгоритма панели «Внимание!» для данной группы камер.

Пункт «Подавление помех» включает фильтр сложных помех на видеосервере для данной группы камер.

Пункт «Отслеживание автономеров» включает отслеживание номеров в зоне расчета скорости. Для работы данной функции необходимо включить детектор номера на видеосервере.


Оповещения

Настройки > Групповые настройки > Панель "Внимание!" >

Оповещения

Пункт «Передача событий GM2 активна» для использования этой необходимо скачать клиент GM-2 себе на устройство. На данный момент поддерживаются практически любые Android устройства с версией 5 и выше. Нажмите на кнопку "Мобильное приложение" и перед Вами откроется магазин Google Play на страничке загрузки. Установите приложение себе на устройство. Более подробную информацию о загрузке и установке приложения Вы можете найти в инструкции к GOALmobile-2.

Пункт «Передача событий удаленному свидетелю активна» чтобы использовать "Далекий свидетель" необходимо зарегистрироваться в системе cloud.farwit.com где Вам и нужно указать все необходимые данные. Запомните их, они еще пригодятся.

Вкладка «Разрешение»

Пункт «Тип видео контейнера» в данной вкладке выбирается формат видео записи из mp4, mov, avi, ts.

Пункты «Ширина» и «Высота» позволяют задать разрешение импортируемого ролика.

Пункт «Соотношение» в данном меню задается соотношение сторон для импортируемого ролика.

Пункт «Перевернуть» установив данный параметр отсылаемое видео будет приходить в перевернутом виде.

Пункт «Скорость» в данном меню устанавливается скорость воспроизведения для передаваемого ролика.

Пункт «Качество» в данном пункте устанавливается битрейт передаваемого видео ролика. Выбирайте под разрешение, в котором ролики будут отправляться.

Вкладка «Виджет»

Мобильное приложение GOALmobile-2 имеет свой виджет для рабочего стола Android устройств. На вкладке "Виджет" настройте какой из кадров видео ролика будет "попадать" на данный виджет. Рекомендуем оставить значение по умолчанию - "Показывать наилучший кадр". Таким образом GOALcity в момент создания ролика будет создавать и один кадр для предпросмотра, который по "мнению" системы отражает всю суть происходящего в ролике. Этот кадр Вы и будете видеть на рабочем столе вашего Android устройства.

Вкладка «Аудио»

Для еще большей информативности Вы можете активировать звуковой сигнал, который будет подаваться при создании каждого ролика. Нужно это или нет, решать Вам, при большом объеме экспортированной информации компьютер может начать раздражать "пищанием" внутреннего динамика и наоборот может привлечь к себе внимание при редких видео событиях.


Интерфейс

Настройки > Групповые настройки > Видео >

Интерфейс

Во вкладке интерфейс настраивается общее отображение информационных панелей для выбранной группы камер.

Пункт «Всплывающая панель» Данный параметр отвечает за появление панели настроек окна, в которой можно производить различные действия с камерой.

Пункт «Информационная строка» данный пункт отвечает за вывод технической информации на панель. Таких как «Разрешение кадра», «Автоконтраст», «Детектор движения», «Индикатор записи» и другие.

Пункт «Полупрозрачная информационная строка» если данная настройка включена, то строка информации будет выводится поверх изображения, в полупрозрачном виде. Отключение данной настройки сделает строку непрозрачной, она будет выводится над кадром.

Пункт «Выводить предупреждение поверх видеокадра» данный пункт настроек отвечает за отображения предупреждений о проблемах с камерой. Например, если связь с камерой будет потеряна, в окне будет отображаться последний полученный кадр, а поверх нее будет полупрозрачное изображение камеры в перечеркивающем круге.

Пункт «Настоящий размер кадра» размеры окна можно менять абсолютно произвольно. В итоге всех этих преобразований может измениться соотношение сторон, что приведет к искажению линейности изображения. Нажатием этой кнопки можно привести соотношение сторон в норму, или, наоборот, сделать так, что «картинка» займёт всю площадь окна.

Пункт «Сохранять соотношение сторон кадра» если эта кнопка не зафиксирована, то при изменении размеров окна изображение будет полностью его заполнять, а пропорции «картинки» - искажаться. Нажатие данной кнопки устранит искажения.

Пункт «При наведении мыши отображать план в окне камеры» Включает отображение расположения камеры на миниплане, в правом нижнем углу окна.

Пункт «Разрешить листание в окне камеры» включает и отключает перелистывание на план расположения и архив. Если "схватить" левой кнопкой мыши изображение в окне камеры и переместить его вправо или влево.

Пункт «Таймаут возврата к просмотру живого видео, сек» здесь задается временной промежуток, через который в окне снова будет воспроизводиться живое видео, после перелистывания на план или архив.

Пункт «Режим клиента ретранслятора» Данный пункт выбирается, если данное окно принимает видео с другого клиента GOALcity.

Пункт «Таймаут возврата к исходной камере, сек» здесь задается временной промежуток, через который в окне снова будет транслироваться исходная камера. Если включен режим ретранслятора, то можно развернуть одну камеру из группы.


Плата

Настройки > Групповые настройки > Видео >

Плата

В данной вкладке меню настраиваются параметры вывода изображения.

Пункт «Формат кадра» - зависит от камеры. Найдите в паспорте на камеру тип ее выходного сигнала (стандарт видео) и выберите в настройке тот же тип. В 99% случаев у вас будет PAL, поэтому по умолчанию предлагается именно он. В качестве альтернативы – NTSC-M и SECAM-B. Изображение с камеры может быть цветным или черно-белым. Найдите в паспорте на камеру ее цветность и выберите в настройке тот же формат кадра. Некоторые производители камер обозначают черно-белый формат как «Стандарт видео – CCIR».

Пункт «Дейнтерлейсинг» Этот режим улучшает качество кадра, особенно, если в нем имеются быстро движущиеся объекты, убирая так называемую «гребенку».

Пункт «Режим казино» Сущность этого режима заключается в том, что АЦП оцифровывает последовательно четные и нечетные полукадры, а GOALcity программно эмулирует чересстрочную развертку аналогового телевидения. Данный режим предназначен в первую очередь для записи событий, связанных с быстрыми движениями, например, наблюдения за игральным столом в казино. Отсюда и его название.

Пункт «Режим спорт» отличается от режима «Казино» отсутствием дрожания картинки и работой только с разрешением 768х288. Он помогает избежать вертикальных дерганий кадров при просмотре быстро происходящих событий.


Просмотр живого видео

Настройки > Групповые настройки > Видео >

Просмотр живого видео

Пункт «Установить скорость просмотра» в данной графе выбирается скорость воспроизведения видео с камеры, в которой не происходит ни одна из настроенных детекций.

Пункт «Без видео» отключает вывод видео в окне, но сохраняет вывод включенных детекций. В окне дальше будут отображаться данные с аналитики камеры, а также место их расположения.

Пункт «Отключать декомпрессию видеопотока при сворачивании окна» - данная настройка позволяет отключить сжатие файлов видеопотока в том случае, если окно будет свернуто.

Пункт «Режим» позволяет выбрать тип воспроизведения.

Пункт «Обнаружено движение» данный пункт выбирается, если требуется увеличивать скорость воспроизведения видео, когда в кадре появляется любое движение. Для работы данной настройки требуется включенный «Видеодетектор» в настройках сервера.

Пункт «Обнаружен автономер» данный пункт выбирается, если требуется увеличивать скорость воспроизведения видео, когда в кадре детектируется автомобильный номер. Для работы данной функции требуется включенный «Детектор номера» в настройках сервера.

Пункт «Обнаружено лицо» данный пункт выбирается, если требуется увеличивать скорость воспроизведения видео, когда в кадре детектируется лицо. Для работы данной функции требуется включенный «Детектор лиц» в настройках сервера.

Пункт «Ускорение по флагам» здесь устанавливается скорость кадров, с которой будет воспроизводиться видео в окне, если одна из включенных детекций сработает.

Пункт «Время (секунд)» здесь устанавливается временной порог, на время которого будет ускорено воспроизведение в группе окон.

Пункт «Отображать видеопоток низкого разрешения» отображать видеопоток даже в том случае, если разрешение низкое.

Пункт «Аппаратное ускорение декомпрессии видеопотока при просмотре» Данная настройка позволяет выбрать алгоритм аппаратного ускорения, который будет помогать в распаковке сжатых файлов на видеосервере. С практической точки зрения данный режим стоит задействовать только на сервере GOALcity не поддерживающем режим NVIDIA CUVID, но поддерживающем DirectX 11.2. В остальных случаях наилучшим режимом будет NVIDIA CUVID, либо, если он недоступен - DXVA2, который можно использовать на удалённых клиентах с самым разным оборудованием, вплоть до встроенных ГП Intel и AMD. Автоматический выбор метода декомпрессии работает именно по такому алгоритму: сначала выполняется проверка доступности NVIDIA CUVID, затем DXVA2 и D3D11VA. Если ни один из них недоступен используется программная декомпрессия.

Пункт «Индекс ускорителя декомпрессии видеопотока» Индекс ускорителя декомпрессии позволяет выбрать устройство, на котором будет производиться декомпрессия. Данная настройка нужна, если в системе установлено несколько устройств, которые могут выполнять декомпрессию. Например, несколько видеокарт. Так, первая видеокарта будет 0, вторая 1. Если у вас отключено аппаратное ускорение декомпрессии, данную настройку лучше не использовать и оставить по умолчанию


Настройки записи

Настройки > Групповые настройки > Видео >

Настройки записи

Вкладка «Настройка записи»

Пункт «Скорость основной записи, к/с» в данном пункте задается количество кадров, сколько будет записываться при включении записи, если в кадре ничего не происходит.

Пункт «Записывать видеопоток низкого разрешения» производить запись видеопотока в низком разрешении.

Вкладка «Запись по детекции»

Пункт «Начальная задержка, кадры» В данной вкладке включается программный фильтр, который позволяет защититься от мельканий света от бликующих поверхностей, частой смены цветности (например, шелеста листьев) и прочих мелких помех. Задается количество кадров, после которых пойдет запись по детекции.

Пункт «Буфер предзаписи, сек» здесь задается время, которое программа будет хранить в предзаписанном состоянии. Если одна из детекций сработает, то данные из этого буфера также будут записаны.

Пункт «Скорость записи по детекции, к/с» здесь устанавливается скорость кадров, с которой будет записываться видео, если одна из включенных детекций сработает.

Пункт «Записывать» в данном пункте выбирается как будет записывать программа, при срабатывании детекции.

Пункт «Длительность записи» здесь задается значение на какой период будет вестись запись по детекции.

Пункт «Записывать только кадры с движением» при выборе этой настройки будет производиться запись только тех кадров, на которых естьдвижение.

Вкладка «Контент»

Пункт «Записывать все кадры» данную настройку стоит выбрать, если надо записать все кадры.

Пункт «Записывать только кадры с движением» данная настройка выбирается, когда нужно записывать кадры, в которых есть движение. Применяется там, где движение происходит редко, чтобы сэкономить ресурсы жестких дисков. Для работы данного пункта требуется включенный «Видеодетектор» в настройках сервера.

Пункт «Обнаружено лицо» данная настройка выбирается, когда нужно записывать кадры, в которых система идентифицирует лица. Для работы данного пункта требуется активировать «Детектор лиц» в настройках сервера.

Пункт «Обнаружен автономер» данная настройка выбирается, когда нужно записывать кадры, в которых система определяет автомобильный номер. Для работы данного пункта требуется активировать «Детектор автомобильных номеров». Например, нужно записывать кадры, когда автомобиль находится на парковке, но не требуется, когда автомобиль уехал.

Пункт «Обнаружен объект» данная настройка выбирается, когда нужно записывать кадры, в которых есть объекты. Для работы данного пункта требуется включенный «Детектор объектов» в настройках сервера.

Вкладка «Отладка записи»

Пункт «Использовать системное время при записи кадра (отладка и тестирование)» - технологическая настройка, только для специалистов.

Пункт «Таймаут записи кадра, мс» задержка записи кадра.

Вкладка «Архив для записи» предназначена для выбора архива, в который данная камера будет записывать видео. В выпавшем окне будет выбор из архивов, подключенных к текущей сессии GOALcity.

Вкладка «Просмотр записи» позволяет выбрать тип просматриваемой записи в окнах.

Вкладка «Архив для просмотра» предназначен для выбора записи для просмотра в окне, который позволяет выбрать между записью с текущей камеры и записью из архива с удаленного сервера. Если оставить параметр «Записываемый», то в окне будет воспроизводиться видео из архива, в который ведется запись.


Контроль

Настройки > Групповые настройки > Видео >

Контроль

Вкладка "Контроль"

Пункт «Ограничение времени подключения, сек» устанавливается время, в течение которого программа будет пытаться подключиться к камере. По истечении его, если ответа от сервера нет, эти попытки будут прекращены.

Пункт «Ограничение времени получения кадра, сек» настраивается время для получения кадра с камеры, по истечении его система будет считать, что пропал сигнал.

Вкладка «Переподключаться автоматически» программа будет сама пытаться подключиться к камере, с которой пропала связь.

Пункт «Таймаут, сек» здесь настраивается, через какой временной период программа будет пытаться это делать. Если выбрать 1 минуту, то через каждую минуту времени будет происходить попытка переподключения.

Пункт «Буферизация на клиенте, кадры» здесь задается количество кадров, которое будет сохраняться в памяти, для временного хранения, на компьютере клиенте.

Пункт «Буферизация на сервере, кадры» здесь задается количество кадров, которое будет сохраняться в памяти, для временного хранения, на компьютере, где расположен сервер.

Вкладка «Звуковой сигнал при пропадании видео сигнала»

Пункт «Тип сигнала» позволяет включить и выбрать подачу звукового сигнала, если сообщение с камерой пропадает.

Пункт «Файл» здесь задается путь к файлу, если выбран свой звуковой сигнал.

Вкладка «Звуковой сигнал при перекрытии камеры»

Пункт «Тип сигнала» позволяет включить и выбрать подачу звукового сигнала, если сообщение с камерой пропадает.

Пункт «Файл» здесь задается путь к файлу, если выбран свой звуковой сигнал.

Вкладка «Журнал»

Пункты «Записывать время подключения и отключения», «Записывать время пропадания видео сигнала», «Записывать время перекрытия камеры» включают запись сообщений в системный журнал GOALcity, который можно открыть из главного меню, пункт «Просмотр журнала».


Видеопоток

Настройки > Групповые настройки > Видео >

Видеопоток

Вкладка «Кодек»

Пункт «Основной кодек» в данном пункте выбирается кодек, между SpecLab MJPEG Light и SpecLab MJPEG Hard. Выбирать кодек SpecLab MJPEG Hard следует, если скорость между камерой и клиентом меньше 100 мбит/с.

Пункт «Качество, %» в данном пункте задается степень сжатия кодеком.

Вкладка«Дополнительная компрессия для удаленного клиента»

Пункт «Разрешить кодек» Включает работу кодека для сжатия при передаче на удаленный клиент.

Пункт «Кодек» в данном пункте выбирается кодек, между SpecLab MCV и SpecLab MCV Turbo.

Пункт «Качество, %» в данном пункте задается степень сжатия кодеком.

Пункт «Размер блока изображения» В данном пункте вы можете задать размер блока изображения или оставить его на выбор системы, которая сама подстроится под вашу сеть.

Пункт «Увеличение области движения» активирует/дезактивирует увеличение области движения.

Пункты «Интервал между ключевыми кадрами, кадр» и «Интервал между ключевыми кадрами, мс» Позволяет настроить интервал между ключевыми кадрами, это число кадров, после обработки которых кодек создает ключевой кадр при экспорте видео. Значение интервала ключевых кадров указывает кодировщику частоту проведения повторной оценки видеоизображения и записи полного кадра, или ключевого кадра, в файл. Если в кадре происходит частая смена сцен, присутствуют быстро движущиеся объекты, то общее качество изображения можно повысить сокращением интервала ключевых кадров. Уменьшение интервала между ключевыми кадрами приводит к увеличению размера выходного файла. Для ключевого файла устанавливается 2 значения. Временной, в милисекундах, и кадровый. Выдача нового ключевого кадра будет происходить по первому сработавшему алгоритму.

Пункт «Снижение блочности» включение данного алгоритма уменьшает артефакты сжатия, увеличивая нагрузку на процессор.

Пункт «Компенсация шумов» служит для улучшения визуального восприятия, после цифровой обработки изображения

Пункт «Анализ цветовых каналов» включает анализ цветовых каналов, для улучшения восприятия изображения и уменьшения исходящего потока. Увеличивает нагрузку на процессор

Пункт «Углублённый анализ контрастных областей» включает углубленный анализ контрастных областей. Улучшает яркостные характеристики в градациях серого.

Пункт «Повышенное качество промежуточных кадров» улучшает качество кадров, которые находяться между ключевыми

Пункт «Отображать блоки изображения (Настройка и тестирование)» технологическая настройка, только для специалистов.

«Параметры потока для удалённого клиента»

Пункт «Запретить передачу избыточного видеопотока» включение данной функции отключает возможность посылки кодером избыточного представления областей изображений, позволяя воспроизвести области изображений (обычно с некоторой потерей качества), данные о которых были потеряны в процессе передачи.

Пункт «Аппаратное ускорение декомпрессии видеопотока при преобразовании в формат клиента» Данная настройка позволяет выбрать алгоритм аппаратного ускорения, который будет помогать в распаковке сжатых файлов на видеосервере. С практической точки зрения данный режим стоит задействовать только на сервере GoalCity не поддерживающем режим NVIDIA CUVID, но поддерживающем DirectX 11.2. В остальных случаях наилучшим режимом будет NVIDIA CUVID, либо, если он недоступен - DXVA2, который можно использовать на удалённых клиентах с самым разным оборудованием, вплоть до встроенных ГП Intel и AMD. Автоматический выбор метода декомпрессии работает именно по такому алгоритму: сначала выполняется проверка доступности NVIDIA CUVID, затем DXVA2 и D3D11VA. Если ни один из них недоступен используется программная декомпрессия.

Пункт «Индекс ускорителя декомпрессии видеопотока» Индекс ускорителя декомпрессии позволяет выбрать устройство, на котором будет производиться декомпрессия. Данная настройка нужна, если в системе установлено несколько устройств, которые могут выполнять декомпрессию. Например, несколько видеокарт. Так, первая видеокарта будет 0, вторая 1. Если у вас отключено аппаратное ускорение декомпрессии, данную настройку лучше не использовать и оставить по умолчанию.

Пункт «Количество потоков центрального процессора для декомпрессора (0-авто)» - с помощью данной настройки можно задать то количество потоков центрального процессора, которое будет использоваться для сжатия файлов.

Пункт "Протокол передачи видеопотоков"- позволяет выбрать тип потока, по которым данная камера может передавать видео.

Пункт "Режим буферизации потока (RTSP)"- настройка для сохранения потока (RTSP).

Пункт "Запретить преобразование кадра во внешнем процессе"- настройка, с помощью которой можно запретить изменение кадра во внешнем процессе.


Автоконтраст

Настройки > Групповые настройки > Видео >

Автоконтраст

Пункт «Разрешить» данная опция отвечают за активацию алгоритма "Автоконтраст". Если поставить данную галочку, то система будет динамически менять уровни яркости и контрастности при изменении освещенности картинки.

Пункт «Использовать маску» Работу алгоритма можно корректировать наложением маски. Области кадра, закрытые маской, не будут приниматься в расчет при работе алгоритма. Это полезно, если в кадр попадают слишком светлые или слишком темные объекты. В этом случае их нужно закрыть маской, чтобы изображение не получалось слишком темным или слишком светлым.


Детектор движения

Настройки > Групповые настройки > Видео >

Детектор движения

Вкладка «Детектор движения»

Пункт «Разрешить» включает детектор движения на видеосервере.

Пункт «Скорость детекции» здесь задается сколько кадров в секунду будет анализировать алгоритм.

Пункт «Чувствительность %» Отвечает за чувствительность детектора, к происходящему в кадре. Если ложные сработки идут часто, понизьте уровень чувствительности. Если полезные объекты не определяются, то повысьте.

Пункт «Автоматическая подстройка чувствительности» включает автоматическую подстройку чувствительности

Пункты «Минимальный размер объекта» и «Максимальный размер объекта» используются для настройки точности работы видеодетектора, относительно размеров. Устанавливается в процентном соотношении от размера кадра. Требуется для отсеивания особо мелких и крупных объектов.

Пункт «Режим цветовой детекции» позволяет настроить детекцию по цвету.

Пункт «Детекция цветового движения в областях обычного движения» включает детекцию по цвету в областях, где есть детекция движения.

Пункт «Точность» данный пункт используется для настройки точности детекции движения.

Вкладка «История движения»

Пункт «Разрешить» включает историю движений.

Пункт «Глубина истории, мс» в данном параметре указывается, сколько времени будет отображаться история движений.

Вкладка «Фильтр шумов»

В данной вкладке включается программный фильтр, который позволяет защититься от мельканий света от бликующих поверхностей, частой смены цветности (например, шелеста листьев) и прочих мелких помех. Данный фильтр увеличивает нагрузку на процессор.

Пункт «Разрешить» Включает фильтр шумов.

Пункт «Чувствительность %» Отвечает за чувствительность детектора. Если ложные сработки идут часто, повысьте уровень чувствительности. Если полезные объекты не определяются, то понизьте.

Вкладка «Сложные помехи»

Пункт «Разрешить» включает фильтр сложных помех.

Пункт «Время падения чувствительности» в данном параметре указывается на какой промежуток времени будет понижена чувствительность в области, где алгоритм обнаруживает помеху.

Пункт «Время повышения чувствительности» в данном параметре указывается через какой промежуток времени будет повышена чувствительность к изначальной, если в области пониженной чувствительности не было помех.

Пункт «Разрешить» включает отображение зоны детекции в виде множества элементов, а не одним квадратом как раньше. Обозначает более точно области, в которых зафиксировано движение.

Пункт «Минимальный размер элемента отображения области движения» здесь задается минимальный размер стороны элемента при детекции движения в пикселях.

Вкладка «Подробное отображение области движения»

Пункт «Разрешить» включает отображение зоны детекции в виде множества элементов, а не одним квадратом как раньше. Обозначает более точно области, в которых зафиксировано движение.

Пункт «Минимальный размер элемента отображения области движения» здесь задается минимальный размер стороны элемента при детекции движения в пикселях.

Вкладка «Уведомление о детекции» включает в себя настройки, которые будет использовать программа при визуализации детекций. Настройки для разных алгоритмов аналогичны. Потому в пример будет приведены настройки по движению

Вкладка «Движение»

Пункт «Отмечать область движения» Включает визуализацию в окне, для данной группы камер.

Пункт «Цвет» в данной вкладке выбирается цвет, который будет использоваться при визуализации.

Пункт «Штриховка» в данном пункте выбирается, использовать штриховку в областях детекции или нет.

Вкладка «Звуковой сигнал»

Пункт «Тип сигнала» позволяет включить и выбрать подачу звукового сигнала, если сообщение с камерой пропадает.

Пункт «Файл» здесь задается путь к файлу, если выбран свой звуковой сигнал.

Пункт «Активизировать окно при обнаружении движения» раскрывает и помещает в центр окно камеры, в котором происходит движение.

Пункт «Записывать время начала и окончания движения в журнал» записывает в журнал событие, который определил алгоритм, в системный журнал GOALcity, который можно открыть из главного меню, пункт «Просмотри журнала».

Вкладка «Сохранять кадры с движением в папку»

Пункт «Разрешить» включает сохранение кадров, где была детекция движения.

Пункт «Папка» здесь задается путь к папке, в которую будут сохранятся кадры с движением.

Вкладка «Цветовое движение»

Пункт «Отмечать область движения» Включает визуализацию в окне, для данной группы камер.

Пункт «Цвет» в данной вкладке выбирается цвет, который будет использоваться при визуализации.

Пункт «Штриховка» в данном пункте выбирается, использовать штриховку в областях детекции или нет.

Вкладка «Оставленные/унесенные предметы»

Пункт «Разрешить» включает фильтр оставленных или унесенных предметов.

Пункт «Папка» здесь задается путь к папке, в которую будут сохранятся кадры с оставленными или унесенными предметами.

Вкладка «Перекрытие фона»

Пункт «Отмечать области перекрывающие фон» Включает визуализацию в окне, для данной группы камер.

Пункт «Цвет» в данной вкладке выбирается цвет, который будет использоваться при визуализации.

Пункт «Штриховка» в данном пункте выбирается, использовать штриховку в областях детекции или нет.


Детектор номера

Настройки > Групповые настройки > Видео >

Детектор номера

Вкладка «Детектор номера»

Пункт «Разрешить» включает детектор автономеров на видеосервере.

Пункт «Скорость детекции» здесь задается сколько кадров в секунду будет анализировать алгоритм.

Пункт «Страна» в данном пункте выбираются автомобильные номера страны, которые будет искать алгоритм в кадре.

Пункт «Регион» в данном пункте для Российских номеров можно задать регион.

Пункт «Определять номера только выбранной страны» выбрав данный пункт алгоритм будет искать и выводить автомобильные номера, выбранные в пункте «Страна». Если данный параметр не выбран, алгоритм будет искать номера всех стран, которые он может определить.

Вкладка «Уведомление о детекции»

Пункт «Отмечать номера» при включении данного параметра в окне просмотра камеры будут отображаться автомобильные номера, которые определил алгоритм.

Пункт «Цвет» в данном пункте можно выбрать цвет отображения номера в окне.

Пункт «Записывать сведения о детекции номеров в журнал» записывает в журнал номер, который определил алгоритм, в системный журнал GOALcity, который можно открыть из главного меню, пункт «Просмотр журнала».

Пункт «Звуковой сигнал» позволяет выбрать и настроить подачу звукового сигнала при сработке данного алгоритма.

Пункт «Сохранять кадры с номерами в папку» данный пункт настроек выбирается, если нужно сохранять кадры, в которых алгоритм нашел автомобильный номер, с указанием места сохранения.

Вкладка «Звуковой сигнал»

Пункт «Тип сигнала» позволяет включить и выбрать подачу звукового сигнала, если сообщение с камерой пропадает.

Пункт «Файл» здесь задается путь к файлу, если выбран свой звуковой сигнал.

Вкладка «Сохранять кадры с движением в папку» сохраняет кадры, на которых было обнаружено движение, в выбранную папку

Пункт «Папка» здесь задается путь к папке, в которую будут сохранятся кадры с номерами.


Детектор лиц

Настройки > Групповые настройки > Видео >

Детектор лиц

Вкладка «Детектор лиц»

Пункт «Разрешить» включает детектор лиц на видеосервере.

Пункт «Скорость детекции» здесь задается сколько кадров в секунду будет анализировать алгоритм.

Пункт «Хранить историю, секунд» Параметр только для текущего просмотра оператором, не влияет на поиск в базах.

Пункт «Искать лица только при наличии движения» установив этот параметр алгоритм будет искать лица только в областях общего движения. Требуется включенный детектор движения.

Пункт «Улучшить распознавание на мегапиксельных камерах» помогает настраивать и улучшать распознавание лиц на мегапиксильных камерах.

Вкладка «Уведомление о детекции» включает в себя настройки, которые будет использовать программа при визуализации детекций. Настройки для разных алгоритмов аналогичны. Потому в пример будет приведены настройки по движению:

Пункт «Отмечать лица» Включает визуализацию в окне, для данной группы камер.

Пункт «Цвет» в данной вкладке выбирается цвет, который будет использоваться при визуализации.

Пункт «Активировать окно при обнаружении движения» раскрывает и помещает в центр окно камеры, в котором происходит движение.

Пункт «Записывать сведения о детекции лиц в журнал» записывает в журнал событие, который определил алгоритм, в системный журнал GOALcity, который можно открыть из главного.

Вкладка «Звуковой сигнал»

Пункт «Тип сигнала» позволяет включить и выбрать подачу звукового сигнала, если сообщение с камерой пропадает.

Пункт «Файл» здесь задается путь к файлу, если выбран свой звуковой сигнал.

Вкладка «Сохранять кадры с движением в папку» кадры с зафиксированным движением будут сохраняться в выбранную папку.

Пункт «Разрешить» включает сохранение кадров, где была детекция лица.

Пункт «Папка» здесь задается путь к папке, в которую будут сохранятся кадры с лицами.


Почтовые уведомления

Настройки > Групповые настройки > Видео >

Почтовые уведомления

Пункт свойств источников "Почтовые уведомления" служит для групповой настройки отправки электронных писем о событиях, представляющих особую важность для администратора системы видеонаблюдения GOALcity. Вы можете за несколько кликов настроить отправку почты о неисправностях, возникающих в процессе работы видео источников (например, "Потеря видеосигнала" или "Перекрытие камеры") и прочей служебной информации.

Активируйте почтовые уведомления отметив пункт "Разрешить" галочкой.

В поле "SMTP-сервер" укажите необходимый сервер исходящей почты, обязательно дописав порт. Эту информацию можно получить у Вашего почтового сервиса. Информацию по наиболее популярным сервисам Вы можете посмотреть здесь для mail.ru или здесь для yandex.ru.

В полях "Пользователь" и "Пароль" укажите данные для авторизации на почтовом сервере (логин и пароль от вашей почты).

Все современные почтовые сервисы используют шифрование данных, поэтому отметьте "птичкой" пункт "Разрешить SSL". Если Вы используете свой собственный почтовый сервер без шифрования (например для отправки и получения почты только в пределах определенной локальной сети), не активируйте данный пункт. В любом случае, рекомендуем проконсультироваться у Вашего системного администратора.

Поле "Отправитель" позволяет задать от чьего имени будет отправлено письмо. Полезно использовать в том случае, если Вы контролируете работу нескольких видео серверов с одного аккаунта электронной почты и нужно разграничить от какого именно видео сервера пришло сообщение.

Затем, задайте "Получателя оповещений по умолчанию", то есть, для всех настроенных далее событий, если не указывать электронную почту явно, будет использоваться этот адрес.

В поле "Тема сообщения" укажите, с какой темой Вам будут приходить оповещения. Рекомендуем не изменять данный параметр, потому что он настроен на динамические темы. Другими словами, в зависимости от сообщения, тема будет автоматически изменяться с помощью переменных в "теле" темы.

Поддерживаются следующие подстановки:

%esn - имя источника события, %en - имя события, %est - локальное время первого события, %elt - локальное время последнего события, %ec - количество повторов события.

С полем "Текст сообщения по умолчанию" все полностью аналогично выше описанному про "Тему сообщения".

Если к письмам необходимо прикреплять какой либо файл, укажите путь до файла в поле "Прикрепляемый файл по умолчанию".

После настройки всех параметров учетной записи и текстов темы и сообщений, раскройте поле "События" и выберите необходимые Вам, отметив их "птичкой".

У каждого события есть свои настройки получателя, темы, текста сообщения и прикрепляемого файла. Если оставить эти поля пустыми, то будут использоваться параметры настроенные выше (по умолчанию). Но Вы можете указать и персональные, например, чтобы сообщения о потере видеосигнала приходили на один почтовый адрес, а о перекрытии камеры - на другой.

Также для каждого события настраивается "Минимальное количество повторов события" и "Минимальный период уведомлений". Говоря простым языком, если событие случилось столько то раз, оправить сообщение, но не чаще чем один раз в такой то промежуток времени. В примере это 3 события, сообщение о которых отправляется 1 раз в час.


Подключаемые фильтры

Настройки > Групповые настройки > Видео >

Подключаемые фильтры

Вкладки "Брокер кадров - предварительный" и "Брокер кадров терминальный"

Брокер используется для совместной обработки данных от нескольких источников, тогда как обычный фильтр работает только с данными от одного источника. Главным отличием предварительного брокера кадров от терминального является тот факт, что предварительный брокер получает данные ДО их обработки фильтрами, а терминальный - ПОСЛЕ.

Настройки для обоих брокеров идентичны.

"Режим рассылки кадров" - данная настрой позволяет выбрать сквозной, с постоянной базовой скоростью, с ускорением по детекции или только по детекции, режим рассылки кадров.

"Базовая скорость рассылки кадров, к/с" - скорость, с которой будет производиться основная рассылка кадров.

"Скорость рассылки кадров при детекции, к/с" - с помощью этой настройки можно установить скорость рассылки кадров при детекции.

"Таймаут рассылки кадров по детекции, к/с" - задержка рассылки кадров после детекции движения.

"Обработчики" - на данный момент для брокера есть только один обработчик - анализатор метаданных.

Вкладка «Трекер лиц»

Пункт «Идентификация лиц / расчет метрики» - Необходима для работы базы лиц и списка имен панели "Внимание!".

Пункт «Искать лица только в областях "человек" (с нейросетью)» - При включенной нейросети исследует только те области, где есть люди. Уменьшает загрузку процессора.

Пункт «Минимальный размер лица» - Позволяет отфильтровать лица на заднем плане, а также исключить ложные сработки на очень малые размеры лиц, в которых мало биометрики.

Пункт «Время отслеживания, Точность отслеживания и Точность сравнения метрик лиц» - Параметр только для текущего просмотра оператором, не влияет на поиск в базах.

Пункт «Количество потоков» - если камера не успевает идентифицировать лица, то следует увеличить количество потоков, но при этом может не хватить ресурсов для других камер, которые идентифицируют лица, а также для других задач программы.

Например: для камер, где скорость прохождения людей выше, это значение должно быть больше (камера на входе). А для камер, где скорость прохождения людей ниже, это значение должно быть меньше (длинный коридор).

Это высоконагрузочный алгоритм для процессора компьютера. Активируйте только в случае использования!

Вкладка «История Детекций»

Суть «истории детекции» заключается в том, что в поле зрения камеры где-то чаще, а где-то реже, детектируется движение, лица или автомобильные номера. На мониторе это может отображаться в виде цветной, монохромной или суммарной карты. В случае цветной карты, области, в которых чаще детектируется или было совсем недавно зафиксировано, например, движение, окрашиваются в определенный цвет (по умолчанию в красный), и называются «горячим следом», а те области, где движения не было давно или же нет совсем, в другой цвет, и называются «холодным следом». Там, где движение детектировалось недавно, остается «теплый след», который в свою очередь окрашивается в свой цвет. Таким образом, можно проконтролировать, где чаще всего детектируются движение, лица или автономера.

Пункт «Включить» задействует историю детекций. Чтобы отображать в окне историю детекций, нужно включить визуализатор в настройках клиента.

Пункт «Время истории детекций» данный параметр отвечает за время, во время которого будет отображаться след в секундах.

Вкладка «Оставленный предмет» отвечает за специализированный детектор оставленных предметов, предназначающийся для особых условий.

О вкладке «Резервная запись» Вы можете узнать подробнее в настройках записи.

О вкладке «Высокоскоростные номера» Вы можете узнать подробнее в настройках автономеров.

Вкладка «Нейронная сеть»

Пункт «Разрешен» - Включает нейронную сеть на видеосервере.

Пункт «Вычислительное устройство» – Позволяет выбрать мощьности какого устройства будут задействованы для работы нейросети. (Видеокарта или центральный процессор)

Пункт «Нейронная сеть в базе данных» – Информирует какой тип нейронной сети установлен.

Пункт «Размер сети» – разрешение картинки, используемое для нейросети. Может повысить качество распознавания, но перегрузить процессоры, поэтому не рекомендуется менять без указания службы технической поддержки. Значение по умолчанию – 0.

Пункт «Точность» – Отвечает за точность сравнения детектируемых объектов с базой данных нейросети. Если полезные объекты не определяются, то понизить. Если определяются помехи как полезные объекты – повысить.

Пункт «Минимальный размер объекта» в данном параметре задается минимальный размер объекта в процентах, от общей площади кадра.

Пункт «Максимальный размер объекта» в данном параметре задается максимальный размер объекта в процентах, от общей площади кадра.

Пункт «Использовать цвета» – По умолчанию, нейронная сеть анализирует черно-белое изображение. Эта настройка позволяет нейросети использовать цветное изображение. Это улучшает детекцию, но и увеличивает нагрузку на компьютер. И надо понимать, что в темное время камеры работают в черно-белом режиме.

Пункт «Длительность истории отслеживания» данная настройка овтечает, сколько по времени нейронная сеть будет помнить объект после его исчезновения из кадра.

Пункт «Обновлять данные детектора движений» – Заменяет работу детектора движений на работу нейросети. Все настройки, ориентированные на видеодетектор, например, запись видео на диск, будут работать по данным сработок нейросети. При активации необходимо выключить детектор движений, чтобы исключить конфликты модулей программы.

Пункт «Обновлять данные детектора объектов» – Заменяет работу детектора объектов на работу нейросети. При активации необходимо выключить детектор объектов, чтобы исключить конфликты модулей программы.

Пункт «Изменение размера кадра» настройка позволяет настроить размеры кадра.

Пункт «Путь к файлу базы данных сетей» Путь к файлу базы данных нейронной сети с объектами не входящих в стандартную сборку.

Пункт «Ключ доступа базы данных сетей» Пароль от базы данных нейронной сети с объектами не входящих в стандартную сборку.


Трекер автономеров

Настройки > Групповые настройки > Видео >

Трекер автономеров

"Устройства для расчетов (1 - CPU, 0 - GPU1...)" - Позволяет выбрать мощьности какого устройства будут задействованы для работы нейросети. (Видеокарта или центральный процессор)

"Обновлять данные детектора движений" - Заменяет работу детектора движений на работу нейросети. Все настройки, ориентированные на видеодетектор, например, запись видео на диск, будут работать по данным сработок нейросети. При активации необходимо выключить детектор движений, чтобы исключить конфликты модулей программы.

"Обновлять данные детектора объектов" - Заменяет работу детектора объектов на работу нейросети. При активации необходимо выключить детектор объектов, чтобы исключить конфликты модулей программы.

"Обновлять данные детектора автономеров" - Заменяет работу устаревшего детектора автономеров на работу нейросети.

"Искать автомобиль" - данная настройка предназначена для поиска автомобиля в кадре.

"Определять цвет/модель автомобиля" - настройка позволяет определить модель или увет автомобиля.

"Искать номер" - данная настройка предназначена для поиска номера в кадре.

"Обрабатывать негоризонтальные номера" - возможность обрабатывать не только горизонтальные, но и вертикальные номера.

"Искать номера в областях движения" - поиск номера в кадрах с движением.

"Распознавать текст номера" - распознавание букв в номерах.

"Распознавать светлый текст номера" - распознавание текста номера на светлом фоне.

"Распознавать номер в один шаг" - распознавание номера за один кадр.

"Минимальное количество повторений номера" - минимальное количество повторений номера, которое требуется для его определения.

"Многопоточный режим" - использование нескольких потоков.

"Весь мир" - распознавать номера любой страны.

"Скорость работы к/с" - скорость, с которой происходит распознавание номера.

"Количество ошибок в номере" - количество ошибок, которые присутствуют в номере.

"Путь к папке лога" - данная настройка используется разработчиками

"Регионы интереса" - настройка, с помощью которой можно определить регион автомобилей, требуемый для распознавания.


Дополнительно

Настройки > Групповые настройки > Видео >

Дополнительно

Пункт «Настройки видео» в этой вкладке можно настроить разрешение, качество видео, частоту кадров и длину GOV (через сколько кадров будет получен опорный кадр). Изменения в данных настройках затрагивают настройки камеры и будут применены для всех, кто подключается к ней.

Пункт «Удалять избыточную информацию» данный пункт активирует функцию удаления избыточной информации.

Пункт «Показывать “битые” кадры» если данный пункт активен, с камеры будут также приниматься и кадры, которые были повреждены и имеют визуальные деффекты. Это позволит наблюдать полную картину происходящего, но с искажением.

Пункт «Аудио» включает получение аудио потока с камеры, если в ней предоставлена такая функция. Зайдя на диаграмму подключений и обновив мультимедиа сервер, появится еще одна графа с названием видео источника, с которого будет поступать аудио.

Пункт «Протокол потока» позволяет выбрать тип потока, по которым данная камера может передавать изображение.

Пункт «Показывать предупреждение при остановке потока» выводит предупреждение в окне транслируемой камеры о том, что поток передачи остановился, но связь с камерой сохранилась.

Пункт «Использовать время потока» данный пункт позволяет получать информацию о времени с камеры, если в ней есть данная функция.

Пункт «Оптимизация для мультипроцессорных систем» данный пункт надо отмечать, когда в системе установлено 2 или более процессоров, для оптимизации работы GOALcity.

Пункт «Количество буферов оптимизации» в данном пункте указывается количество буферов, которые будут оптимизировать работу GOALcity в многопроцессорных системах.

Пункт «Повернуть» данная настройка переворачивает изображение на 180 градусов, относительно текущего. Данная настройка нужна, если изображение с камеры поступает перевернутым, для приведения их в единый вид.

Пункт «Повернуть на 90 градусов» предложит выбор из «Повернуть влево на 90 гр.» и «Повернуть вправо на 90 гр.»: при выборе одного из данных пунктов камера будет повернута на 90 градусов. Данная настройка нужна, если камера посылает изображение повернутым, чтобы привести в единый вид.

Важно! На аналоговых камерах, ввиду особенностей работы оцифровщиков, данная настройка отсутствует.

Пункт «Включить проверку на пустой кадр» активирует проверку на пустые кадры в данном окне. Если в потоке камеры появится пустой кадр, то программа не выведет его на просмотр, а покажет цельный, который был ранее.

Пункт «Включить проверку на одинаковые кадры» активирует проверку на одинаковые кадры в данном окне. Если в потоке камеры появится повторяющийся кадр, то программа не выведет на просмотр этот кадр, а покажет тот, который был ранее.

Пункт «Безопасный кодек» включает внутреннюю конвертацию в отдельном процессе GOALcity. Данный параметр позволяет избавиться от ошибок перекодирования камер и избавить изображение от подергиваний и прерываний.

Пункт «Аппаратное ускорение декомпрессии видеопотока при использовании алгоритмов» Данная настройка позволяет выбрать алгоритм аппаратного ускорения, который будет помогать в распаковке сжатых файлов на видеосервере, если в пункте «Разрешить алгоритмы» стоит галочка. С практической точки зрения данный режим стоит задействовать только на сервере GoalCity не поддерживающем режим NVIDIA CUVID, но поддерживающем DirectX 11.2. В остальных случаях наилучшим режимом будет NVIDIA CUVID, либо, если он недоступен - DXVA2, который можно использовать на удалённых клиентах с самым разным оборудованием, вплоть до встроенных ГП Intel и AMD. Автоматический выбор метода декомпрессии работает именно по такому алгоритму: сначала выполняется проверка доступности NVIDIA CUVID, затем DXVA2 и D3D11VA. Если ни один из них недоступен используется программная декомпрессия.

Пункт «Индекс ускорителя декомпрессии видеопотока» Индекс ускорителя декомпрессии позволяет выбрать устройство, на котором будет производиться декомпрессия. Данная настройка нужна, если в системе установлено несколько устройств, которые могут выполнять декомпрессию. Например, несколько видеокарт. Так, первая видеокарта будет 0, вторая 1. Если у вас отключено аппаратное ускорение декомпрессии, данную настройку лучше не использовать и оставить по умолчанию.

Пункт «Поправка времени кадра(мс)» в данном меню задается время в милисекундах, на которое будет изменятся время кадра.

Пункт «Отладочный режим» Технологическая настройка, только для специалистов.

Пункт «Нестандартный JPEG» данная настройка предназначена если ваша камера использует нестандартное разрешение, отличные от 16:9, 4:3, 16:10, для избегания ошибок в работе.

Пункт «Авто выбор JPEG кодека» в данном пункте задается, чтобы GOALcity автоматически выбирал JPEG кодеки видео камеры, при наличии нескольких различных кодеков. Тогда в архив пишутся только полные кадры JPEG.

Вкладка «Детекторы» ,которая, в свою очередь, состоит из трёх подпунктов:

Пункт «Детектор закрытия камеры», который в свою очередь состоит из трёх подпунктов.

Пункт «Включить» - позволяет активировать детектор. Без активации этого пункта, настройка загораживания камеры работать не будет.

Пункт «Показывать грани» - включает показ на мониторе отображение логики работы камеры (не имеет практического назначения, необходимо лишь для демонстрации работы детектора).

Пункт «Уровень закрытия» - здесь можно установить, в процентах от общей отображаемой площади, степень закрытия камеры, при которой произойдет сработка детектора.


Интеграция с системами ОПС

»«

Интеграция с системами ОПС

Важно! Для корректной работы необходимо подключать пульт к ПК используя интерфейс RS232 и только через COM порт! Можно использовать преобразователи USB to Com, но в любом случае, подключение должно производиться через COM порт! Т.е. от устройства должен приходить провод с COM портом!

Подготовка

Для начала необходимо установите на ПК программное обеспечение ОПС "Стрелец" и подключите к управляющему устройству все датчики и ключи. Про подключение и настройку устройств можно почитать здесь. Подключите РРОП через COM-порт (RS-232) к компьютеру, на который будет установлена система GOALcity. Подключение можно осуществлять через промышленные приемо-передатчики RS-232 либо через конвертор интерфейсов БПИ RS-И при значительном удалении РРОП и сервера системы друг от друга. В диспетчере устройств проверьте, что подключение прошло удачно и в разделе "Порты COM и LTP" у Вас появился нужный порт. Запомните номер СОМ-порта, он понадобится в дальнейшем для настройки. Устанавите программу WirelEx из комплекта ПО "Стрелец" и запустите ее.

Выберите опцию "Файл" -> "Новая система", откроется окно выбора типа системы, выберите Динамическую. В окне свойств новой системы выьберите Код системы и рабочую частоту, эти параметры должны быть указаны в документации к ОПС Стрелец.

Новая система создана, теперь необходимо добавить в нее управляющие и управляемые устройства. Перейдите на вкладку "Конфигурирование", в поле "Топология радиосети" кликните правой кнопкой мыши по заголовку и выберите строчку "Добавить КР".

В окне выбора типа управляющего устройства выберите необходимый. В примере это РРОП.

Откроется окно свойств управляющего устройства.

Важно! Для корректной работы необходимо присвоить расширителю нулевой адрес!

Остальные параметры можно оставить по умолчанию либо изменить их, руководствуясь документацией по управляющему устройству.

Вернитесь к вкладке "Конфигурирование" и увидите, что управляющее устройство добавилось. Кликните по нему правой кнопкой мыши и считайте с него параметры. В поле "Дочерние устройства" отобразится список устройств, уже подключенных к расширителю. Если Вы делаете все с нуля, то, соответственно, данное поле останется чистым.

Добавление нового устройства

Кликните правой кнопкой мыши по иконке расширителя и выберите пункт "Добавить дочернее устройство". Откроется список устройств, с которыми может работать данный расширитель.

Выберите необходимое Вам устройство и нажмите кнопку "Добавить". В примере рассмотрен охранный извещатель Икар-Р. Откроется окно свойств добавляемого устройства.

Управляющее устройство РРОП имеет 16 разделов. GOALcity работает с разделом целиком, т. е. если подключить несколько датчиков в один раздел, то постановка, снятие с охраны и тревога будут работать для всех устройств в данном разделе. Выберите номер раздела. В примере будет рассмотрен первый раздел и 4-ый адрес извещателя внутри раздела. Период передачи контрольных сигналов лучше поставить минимальный, чтобы извещатель как можно чаще сообщал о своем состоянии расширителю. Нажмите кнопку "Ок".

Дочернее устройство (Икар-Р) появится в списке, но для работы его необходимо запрограммировать в память расширителя. Кликните правой кнопкой мыши по устройству и выберите строчку "Программирование локальное (RS232)". Начнется процесс программирования, и его необходимо подтвердить переключением тумблера на самом устройстве. Как это сделать подробно описано в инструкции к данному устройству или вы можете посмотреть здесь.

Добавление других устройств происходит аналогично, различаются только параметры добавляемых устройств, про которые можно почитать в документации к этим устройствам. Главное - помнить, что работа будет происходить с целыми разделами, и подключайте устройства грамотно. Например, можно завести на первый раздел 5 датчиков движения в левом крыле здания, на второй раздел пожарные датчики в этом же крыле и т. д.

Настройка видеосистемы

Установите GOALcity, для чего запускайте поочередно следующие дистрибутивы программы из комплекта поставки: 1_GOALcity_Client_x64.exe – видео клиент системы, 2_IP_Server_x64.exe – мультимедиа сервер, 9_SLDA_Driver.exe – драйвер взаимодействия с устройствами. Если вы настраиваете подключение ОПС Стрелец в уже предустановленной системе GOALcity, то установите только необходимые модули. Перезагрузите ПК после установки всех элементов.

Откройте Диаграмму подключений GOALcity, выберите локальный мультимедиа сервер и откройте его настройки. Локальный мультимедиа сервер имеет в своем названии IP адрес 127.0.0.1.

Обратите внимание! Удаленный (установленный на другом компьютере) мультимедиа сервер не сможет работать с устройствами (COM-порт), физически к нему не подключенными.

Откройте настройки "Мультимедиа сервера" и выберите пункт "SLDA Source".

В пункте "Датчики и ключи" нажатием серой кнопки button-01 откройте меню добавления устройств. Выберите пункт "Добавить Стрелец".

В создавшемся элементе в обязательном порядке последовательно заполните все пункты.

•"Название" - укажите название, понятное для каждого, кто будет работать с системой.

•"СОМ порт" - укажите номер COM порта, запомненный ранее.

•"Код доступа" - укажите код доступа к РРОП, с которым осуществляется связь по COM порту (RS-232). При заводских настройках РРОП имеет код доступа 0х11112222. Если заводской код доступа не подходит, значит, он был изменен инсталлятором системы ОПС Стрелец. Обратитесь к нему за получением нового кода доступа.

•"Номер расширителя" - укажите номер РРОП в системе ОПС Стрелец, был ему присвоен при добавлении управляющего устройства в программе WirelEx из комплекта ПО Стрелец. По умолчанию это нулевой номер.

•"Номер локального раздела" - укажите номер локального раздела на выбранном РРОП в системе ОПС Стрелец. Это и есть те самые разделы, про которые писалось выше.

•"Частота обновления" - задайте частоту обновления. Данная частота обновления не связана с внутренним опросом устройств внутри системы Стрелец и отвечает только за частоту посылки запросов к РРОП на наличии в нем изменений.

Сохраните все настройки нажатием кнопки "Ок" во всех диалоговых окнах мультимедиа сервера. После применения всех настроек на мультимедиа сервер появится новое устройство. Соедините появившееся устройство с окном видео клиента и нажмите кнопку "Ок" для применения настроек.

В создавшемся окне Вы должны увидеть состояние раздела РРОП и можете управлять постановкой/снятием данного раздела с охраны.

В верхней части окна находится историю состояний текущего раздела. Размер поля истории можно изменить. В нижней части окна находится выпадающий список действий с текущим разделом. Вы можете выбрать снятие с охраны раздела, постановку на охрану или сброс тревог. Для подтверждения выбранной задачи необходимо сделать двойной щелчок левой кнопкой мыши по пиктограмме в центре окна.

При наступлении тревоги вокруг окна будет мигать красная рамка.

Расшифровка ошибок

•Неверный код доступа - неверный код доступа, по умолчанию - 0x11112222

•Не удается открыть COM порт - неверно указан COM порт

•Ошибка чтения-записи - устройства выключены

•Неизвестное состояние - состояние, при котором система опросила COM порт, сверила код, но не получила от Стрельца состояние раздела


ОПС "Болид"

Интеграция с системами ОПС >

ОПС "Болид"

Минимальный набор компонентов GOALcity для работы с ОПС "Болид" это:

•Мультимедиа сервер (2_IP_Server_x64.exe),

•Клиент GOALcity (1_GOALcity_Client_x64.exe),

•SLDA драйвер для GOALcity (9_SLDA_Driver.exe),

•Архивный сервер (3_Archive_Server_x64.exe).

•"Модуль управления ИСО Орион";

•Пульт С2000М производства фирмы "Болид" и адресные датчики (ключи, считыватели).

Установка и первоначальная настройка программного обеспечения

Начните с установки компонентов GOALcity. Установите Мультимедиа сервер, SLDA драйвер, затем Клиент GOALcity и перезагрузите ПК.

После перезагрузки установите "Ядро опроса Орион Про" и снова перезагрузите ПК. Процесс установки всех вышеперечисленных компонентов довольно прост - просто следуйте подсказкам мастера установки.

Важно! "Ядро опроса Орион Про" может быть установлено и на другой ПК, который, в данном случае, будет выступать в качестве сервера ОПС "Болид".

Когда компьютер загрузиться, запустите клиентскую часть GOALcity и выполните следующие действия:

Откройте Диаграмму подключений GOALcity и добавьте на неё все установленные ранее компоненты.

Создайте архив на Архивном сервере GOALcity.


Блейзер

Интеграция с системами ОПС >

Блейзер

Интернет-Видеорегистратор производства "Спецлаб"

Блейзер – это объединение облачных технологий с вашей «железякой».

Блейзер имеет массу особенностей, отличающих его от простой «писалки-смотрелки». И прежде всего, сетевая логика, адаптированная к любым, даже самым слабым каналам. Чтобы по ним что-то прокачать, нужно умение сокращать информацию и выбирать важное. Поэтому самое главное достоинство Блейзера - видеоаналитика, в ней производится преданализ событий, за счет чего убираются многие часы пустого видео. Интернет посылаются уже оформленные сюжеты - для более интеллектуального исследования более мощными серверами. При этом в тысячи раз сокращается трафик – теперь он больше не грузит домашнюю или офисную сеть. Появляется возможность установки в местах с очень слабым Интернетом. И в том числе, с неустойчивыми каналами. Если живое видео от камер безвозвратно теряется в момент сбоя, то каждый видеосюжет из Блейзера будет пытаться отправиться по назначению до скончания вечности: как только появляется хоть какая-то связь, короткие видеоролики уходят в «Далекий свидетель».


Подключение устройства

Интеграция с системами ОПС > Блейзер >

Подключение устройства

Блейзер подключается к сети передачи данных, поддерживающей протокол TCP/IP, через встроенную розетку формата RJ-45 или Wi-Fi, а к монитору через кабель HDMI. Устройство имеет 3 USB порта, один выведен для легкого подключения устройств ввода-вывода, два других располагаются на плате и необходимы для подключения иных перефейрийных устройств, например внешних USB накопителей, для хранения архива. Электропитание осуществляется напряжением в 12V. Блок питания, преобразующий 220V в 12V, поставляется в комплекте.

Ниже представлена схема подключения устройства для начала работы.

Пример готового подключения:


Подключение камер IP-камер к Блейзеру

Интеграция с системами ОПС > Блейзер >

Подключение камер IP-камер к Блейзеру

Блейзер позволяет вести событийную запись роликов на само устройство или внешний жесткий диск, а также отправку этих роликов в облачный сервис GOALcity - "Далекий свидетель" по вашему усмотрению.

Блейзер работает только с IP-камерами, позволяя подключить их до 4-х штук. Также ИВР осуществляет постоянную запись пока есть видеодетекция. Если же активности долго нет - запись приостанавливается до ее появления.

Блейзер выполняет первичный видеоанализ с формированием событийного ряда. В облачный сервис GOALcity - "Далекий свидетель" будут отправляться уже оформленные сюжеты для дальнейшей консолидации и анализа с выстраиванием логических цепочек на более мощных серверах.

Пример подключения IP-камер к ИВР:


Главное меню

Интеграция с системами ОПС > Блейзер >

Главное меню

Основным элементом управления Блейзера является Главное меню. По умолчанию оно выглядит так:

Условно главное меню можно поделить на 3 зоны:

Первая зона располагается в левой части экрана, размещая в себе архив событий. Кликнув по событию, Вы перейдете в меню просмотра архива с воспроизведением выбранного события.

Вторая зона, зона просмотра, в которой отображаются ваши камеры, подключенные к ИВР. Нажав на камеру, она раскроется на всю зона просмотра. Если нажать на номер камеры, то ИВР запишет 10 секундный ролик в архив.

Третья зона является технической зоной и несет в себе следующие функции:

Нажатие на надпись "Спецлаб" перебросит вас на сайт разработчика.

Данная кнопка позволяет переключать изображение в окнах, выбирая между настоящим размером кадра и заполнением в окне. Это позволяет привести в единый вид камеры с различными разрешениями вывода.

"Поиск камеры" - данная кнопка предназначена для перехода на панель поиска камер по протоколу Onvif.

"Старт"/"Стоп" - данная кнопка позволяет включать и отключать активную работу ИВР.

"Архив" - нажатие данной кнопки приведет Вас в меню просмотра архивных роликов.

"Далекий свидетель" - нажатие в этом месте переведет Вас на сайт "Далекий свидетель".

"Настройки" - нажав данный пункт вы перейдете в меню расширенных настроек камеры.


Поиск камер

Интеграция с системами ОПС > Блейзер >

Поиск камер

Для начала, мы рекомендуем произвести поиск камер по протоколу ONVIF, потому что почти все современные камеры поддерживают этот протокол. На главной панели управления нажмите "Поиск камер" А уж если что-то не найдется, то можно будет добавить вручную.

Найденные камеры будут отображены столбцом в левой части экрана. Если Ваша камера не была найдена, то в нижней части экрана нажмите на кнопку "Добавить камеру". В появившемся окне введите IP-адрес устройства, которое нужно добавить. Выберите из списка камеру, которую хотите подключить.

"Имя пользователя" - здесь задается имя пользователя, которое установлено на видеокамере, которое было установлено с завода или изменено пользователем. Для доступа к камере.

"Пароль" - в данном пункте задается пароль, для подключения к видеокамере, который был установлен с завода или изменен пользователем. Для доступа к камере.

"Потоки" - в данном пункте выбирается поток, из группы потоков камеры, для сохранения на ИВР.

"Яркость" - перемещение ползунка настраивает яркость отображения видеопотока в ИВР.

"Контраст" - перемещение ползунка настраивает контраст отображения видеопотока в ИВР.

Во вкладке "Сохранить как" выбирается в какой пункт будет сохранен выбранный поток камеры.


Архив

Интеграция с системами ОПС > Блейзер >

Архив

Архив - это менеджер записи, хранения и просмотра истории событий системы.

Пункт "Очистить архив" удаляет все события из архива.

Пункт "Добавить лицо в базу данных" добавляет лицо в базу данных с текущего просматриваемого ролика, в котором оно было определено.

Пункт "Лица" переводит вас в базу лиц. Отметьте справа от лица "галочку" и нажмите удалить, для исключения лиц из базы.

Пункт "Автономера" переводит вас в базу автомобильных номеров, в которой можно добавлять и удалять номера, для работы датчиков/ключей. Отмив справа "галочкой" номера, нажмите удалить, для исключения номеров из базы.

Пункт "Область детекции автономеров" позволяет настроить зону определения автомобильных номеров с текущего просматриваемого ролика. Как правило, в реальных условиях при проезде (остановке) транспортного средства в зоне охвата камеры, номера находятся в ограниченной зоне кадра. Для ускорения обработки кадра желательно установить границы, в которых программа и будет пытаться обнаружить автомобильный номер. Делается это выделением границ рамки с помощью мыши при нажатой и удерживаемой её левой клавише.


Настройки

Настройки камеры

Интеграция с системами ОПС > Блейзер >

Настройки камеры

Данная вкладка предназначена для изменений настроек подключения к камере. Смены потоков камеры (для много поточных камер), а также смены порта и настроек времени переподключения к камере. В случае, если в настройках камеры были изменены настройки пользователя, здесь их также можно поменять.

"URL потока для анализа (MJPEG или H264)" данная настройка аналогична с настройками камеры на диаграме подключений. Данный пункт отвечает за то, что будет отображаться в окне камеры.

"URL (для записи)" Данная настройка аналогична с настройками камеры на диаграме подключений. Данный пункт отвечает за то, что будет записываться в архив. Рекомендуем использовать поток на котором используется кодек h264 и максимальное разрешение.

"Имя пользователя" здесь задается имя пользователя, которое установлено на видеокамере, которое было установлено с завода или изменено пользователем.

"Пароль" в данном пункте задается пароль, для подключения к видеокамере, который был установлен с завода или изменен пользователем.

"Програмный декодер" задействует программный декодер вместо аппаратного. Рекомендуется использовать при нестандартных потоках видео.


Видеоаналитика

Интеграция с системами ОПС > Блейзер > Настройки >

Видеоаналитика

Данная вкладка предназначена для изменений настроек видеоаналитических алгоритмов камер. Блейзер включает в себя четыре типа детектора: детектор движения, детектор людей, детектор лиц и детектор автомобильных номеров.

Модуль детектора движений имеет развитую систему индикации и предупреждений.

Пункт "Включить ДД" активирует работу детектора движения на текущей камере.

Пункт "Чувствительность ДД" отвечает за чувствительность детектора, к происходящему в кадре. Если ложные сработки идут часто, понизьте уровень чувствительности. Если полезные объекты не определяются, то повысьте.

Пункт "Вести запись пока есть детекция" При активации данного параметра ИВР будет записывать постоянно ролики длинной в 1 минуту, пока в окне есть движение. То есть, если, например, в окне камеры будет детекция в течении 10 минут 36 секунд, то Вы получите 10 роликов длинной в 1 минуту и 1 ролик длинной в 36 секунд.

Модуль детектора людей служит для распознавания в изображении силуэтов людей и классификации их действий, присущих людям. Детектор людей - ресурсоемкий алгоритм, его не рекомендуется включать более чем на 3 камерах, при отсутствии работы других алгоритмов, за исключением детектора движения.

Пункт "Включить детектор людей" активирует работу детектора людей на текущей камере.

Пункт "Чувствительность детектор людей" отвечает за чувствительность детектора, к происходящему в кадре. Если ложные сработки идут часто, понизьте уровень чувствительности. А если полезные объекты не определяются, то повысьте.

Детектор лиц выявляет в кадре появление человеческих лиц, оценивает их индивидуальные параметры, позволяя идентифицировать людей и сопоставлять их с базами данных. Благодаря встроенному аналитическому алгоритму Блейзер «умеет» отследить из всей передаваемой камерой информации человеческие лица, и инициировать соответствующую реакцию системы согласно произведенным вами настройкам. Детектор лиц - ресурсоемкий алгоритм, его не рекомендуется включать более чем на 3 камерах, при отсутствие работы других алгоритмов, за исключением детектора движения.

Пункт "Включить детектор лиц" активирует работу детектора лиц на текущей камере.

Пункт "Размер лица" позволяет настроить размер лица, на которое будет проводится сработка

Пункт "Включить распознование лиц" включает рассчет метрики для сравнения лиц с лицами, находящимися в базе данных. Использовать распознование лиц рекомендуется не более чем на 2 камерах, так как это очень ресурсоемкий процесс.

Пункт "Процент достоверности для распознавания лиц" Если лица не находятся в базе, уменьшите значение. Если имена не совпадают с лицами, увеличьте! Нормальный уровень - 50%.

Пункт "Управлять ключом" в данном пункте указывается ключ ИВР который нужно замкнуть при определении лица из базы данных.

Пункт "Замыкать ключ на время (сек.) при распознавании лица из базы данных" в данном пункте задается время на которое будет замкнут ключ при определении лица из базы данных.

Данная вкладка предназначена для включения алгоритма по определению автомобильного номера в кадре камеры. Детектор автономеров - ресурсоемкий алгоритм, его не рекомендуется включать более чем на 2 камерах, при условии, что другие камеры не будут задействованы вовсе.

Пункт "Включить распознавание автономеров" активирует работу детектора автомобильных номеров на текущей камере.

"Ключ открытия" - в данном пункте указывается ключ ИВР, который нужно замкнуть для открывания шлагбаума/ворот при определении номера из базы данных.

Пункт "Замыкать ключ открытия на время (сек.) при совпадении номера с номером из базы данных" - в данном пункте задается время на которое будет замкнут ключ для открывания шлагбаума/ворот.

"Ключ закрытия" - в данном пункте указывается ключ Блейзера который нужно замкнуть для закрывания шлагбаума/ворот при истечении времени открытия.

"Замыкать ключ закрытия на время (сек.)" - в данном пункте задается время на которое будет замкнут ключ для закрывания шлагбаума/ворот.

"Время открытия (сек.)" - в данном пункте задается время, через которое программа попробует закрыть ворота. Если датчики перекрытия не будут воздейств

"Датчик открытия" - в данном пункте указывается датчик Блейзера с которого будет приходить информация о том, что ворота открыты.

"Датчик закрытия" - в данном пункте указывается датчик ИВР с которого будет приходить информация о том, что ворота закрыты.

"Проверять на совпадение первые символы номера в количестве (0-все)" - в данном поле указывается сколько символов в номере должны совпадать с номером из базы данных, для работы с ключами.

Алгоритм "Опасное начало" предупреждает, что в зоне видимости какой-то из камер, для которых он включен, после отсутствия движения в течение некоторого времени, появился движущийся объект. Применение его особенно эффективно в тех случаях, когда ведется наблюдение за объектами, на которых нет постоянно движущихся предметов (автомобилей, людей, подвижного оборудования). Идеален для ночной охраны. Но, как правило, и в дневное время несанкционированные действия производятся при более-менее продолжительном отсутствии людей, которые могут стать свидетелями.

Пункт "Начальная задержка в кадрах" - устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и и прочим.

"Учитывать период отсутствия движения" - в течении установленного времени сработка по алгоритму произойдет, даже если событие будет продолжительным.

"Период отсутствия движения в секундах" - в данном пункте задается время отсутствия движения после которого произойдет сработка алгоритма.

Как правило, на любой камере есть зоны, детекция движения в которых не нужна или нежелательна. Чтобы настроить маску детекции, перейдите на вкладку "Маска". Данная настройка применима только к "Детектору движения". После активации работы маски, перейдите на главное меню и нажмите в окне камере на те места, где необходимо "нарисовать" маску. Переключение стирания и нанесения маски изменяется в левом нижнем углу камеры. Знак плюс соответсвует нанесению маски, знак минус соответствует ее стиранию.

Пункт "Использовать маску" позволяет исключить из зоны детекции место (места), где присутствуют объекты, на которые детектор не должен реагировать.

Пункт "Показывать маску" включает отображение маски в окне просмотра камеры.


Далекий свидетель

Интеграция с системами ОПС > Блейзер > Настройки >

Далекий свидетель

Farwit ("Далекий свидетель") является дополнительным "помощником" в обеспечении вашей безопасности. Но, в отличии от вашего Блейзера, он может быть всегда с вами - в вашем смартфоне.

Пункт "Включить" - поставьте галочку в данном пункте, чтобы включить отправку событий на "Далекий свидетель"

Пункт "Адрес облака "Далекий свидетель" - в данном меню лучше оставить значения по умолчанию. Функция изменения предоставлена для технических специалистов

Пункт "Пользователь"- введите логин, указанный при регистрации на cloud.farwit.com

"Пароль" в данном пункте вводите пароль, указанный при регистрации на cloud.farwit.com

"Максимальное количество событий" в данном пункте указывается количество событий готовящиеся к отправке на далекий свидетель. При привышении этого параметра, самое старое событие будет заменяться самым новым.


Архив

Интеграция с системами ОПС > Блейзер > Настройки >

Архив

Данная вкладка предназначена для изменений настроек событийного архива.

Пункт "Максимальное количество событий" - здесь указывается максимальное количество событий, которое будет хранится в архиве. По достижению предела самые старые будут перезаписаны самыми новыми.

Пункт "Место хранения архива" - здесь выбирается хранилище между внутренним и внешним хранилищем. Важно! Внешним хранилищем является устройство хранения данных, подключенное через USB интерфейс


Отправка событий из Блейзера в GOALcity

Интеграция с системами ОПС > Блейзер > Настройки >

Отправка событий из Блейзера в GOALcity

Для того, чтобы настроить отправку событий из Блейзера в GOALcity необходимо:

1. В веб интерфейсе блейзера в строке "Сетевой адрес" прописать ip адрес и порт сервера GOALcity, на который необходимо передавать ролики с Блейзера, а также поставить галку "Включить".

Обратите внимание, что вам также необходимо прописать логин и пароль пользователя GOALcity, у которого есть права на доступ к этому архиву.

Порт сервера вы можете посмотреть в настройках GOALcity Tweaker. Для этого зайдите в "Пуск", найдите папку "Speclab", пункт "Tweaker".
В строке WS2 - порт HTTP сервера вы увидите необходимый вам порт.

2. Затем необходимо активировать Архив событий на сервере GOALcity.

Посмотреть подробнее как это сделать вы можете посмотреть здесь.

3. После того, как вы активировали Архив событий, перейдите в Настройки Панели Внимание и во вкладке "Дополнительно" активируйте пункт "Загружать с удаленных серверов архивов". Затем выберите сервер, на который необходимо передавать данные.


Датчики

Интеграция с системами ОПС > Блейзер > Настройки >

Датчики

Данная вкладка предназначена для изменений настроек записи при срабатывании датчиков . Позволяет выбрать на какой камере вести запись после срабатывания датчика.


Разное

Интеграция с системами ОПС > Блейзер > Настройки >

Разное

Данная вкладка предназначена для различных сторонних настроек в работе Блейзере.

Пункт "Аппаратный перезагрузчик" позволяет включить аппаратный модуль перезагрузки, в случае сбоя в работе программы или устройства. Для применения данного пункта настройки требуется перезагрузка устройства.


Подключение датчиков и ключей

Интеграция с системами ОПС > Блейзер > Настройки >

Подключение датчиков и ключей

В Блейзере предусмотрена работа с датчиками и ключами, с возможностью удаленного контроля срабатывания датчиков. На плате установлены колодки подключения внешних устройств, колодки подключения датчиков и технический разъем, предназначенный для сотрудников "Спецлаб".

Панель ключей. Каждый канал пронумерован и имеет три контакта, для обеспечения возможности смены активного состояния линии с замкнутого на разомкнутое. Если необходимо замыкание контактов управляемого устройства по команде пользователя, то его необходимо подключить на 2 и 3 контакт колодки, если необходим обратный эффект (размыкание контактов по команде пользователя), то на 1 и 3. Могут коммутировать ток до 3-х Ампер 220 Вольт переменного тока или до 5 Ампер 30 Вольт постоянного тока.

Справа колодки для подключения линий датчиков. Контакт c обозначением "<-" обозначает положительный контакт, "—|" обозначает землю, каждый датчик обладает своим собственным контактом земли. Работают на замыкание относительно земли.

Технический разъем предназначен только для специалистов "СпецЛаб"!


Практическое применение

Подключение видеоролика в качестве живой камеры

»«

Подключение видеоролика в качестве живой камеры

Подключение видеоролика в качестве живой камеры применяется для предварительного изучения условий работы видеоаналитики Спецлаб на видеоматериале клиента.

Создание и обработка видеоролика

Для клиента:

1. Для съемки подойдет любая любительская камера, даже камера мобильного телефона. Видео должно быть снято с места предполагаемой установки камеры видеонаблюдения.

2. Записанный видеоролик необходимо выложить на любой облачный сервис (например, GoogleDrive) и прислать ссылку на почту s@goal.ru с пометкой «Видеоролик».

Для специалиста:

1. Перенесите присланый клиентом видеоролик на жесткий диск компьютера на котором собираетесь работать в программе GOALcity.

2. Подключите видеоролик в качестве живой камеры к окнам GOALcity согласно этой инструкции.

Подключение видеофайла

Для подключения видеоролика в качестве живой камеры к окнам GOALcity, используется программный модуль VLCSource.

Чтобы подключить видеофайла к GOALcity, проделайте следующие действия:

1. Откройте диаграмму подключений кликнув по соответствующей иконке на главной панели GOALcity.

2. На диаграмме подключений откройте настройки "Мультимедиа сервера" дважды кликнув по нему левой кнопкой мыши.

3. В настройках мультимедиа сервера, на против пункта "VLCSource", кликните по кнопке

4. В открывшемся окне кликните по кнопке [image] напротив пункта “Камера” и укажите:

•"Путь к VLC" – Укажите путь до установленного VLC Player'а. (папка по умолчанию C:\Program Files\VideoLAN\VLC)

•"Имя" - задайте имя видеоисточнику.

•"Url" - укажите путь до видеоролика в формате file:///полный путь до Вашего видео ролика. (пример file:///e:\1.avi)

•"Надежность" - отметьте "птичкой" это поле, если наблюдаются кратковременные или длительные "пропажи" видеосигнала в окне GOALcity.

Нажмите "ОК".

5. После проделанных настроек, на мультимедиа сервере должен появиться подключенный источник.

6. Подключите видеоисточник к нужному окну и нажмите кнопку “OK”.

Примечание: В случае изменения параметров подключения (URL) в окне камеры ранее подключенного источника VlcSource, после перезагрузки программы и службы потеряется связь источника с окном т.к., поменяется моникер источника и, соответственно, необходимо настроить новое подключение на стороне клиента.

Работа с видеороликом

После применения настроек появляется окно камеры, в котором проигрывается видеоролик.

Работа с роликом почти ничем не отличается от работы с обычной камерой. К нему можно применить все алгоритмы видеоаналитики.

Для более наглядного обзора процессов рекомендуется активировать визуализаторы на вкладке Клиент в настройках Камеры


Создание базы лиц

Для организации автоматического доступа на объект, учета сотрудников, отслеживания и поиска преступников, оповещения о появлении нужного человека (людей), систематизации путей передвижения, времени прохождения и т. д., нужна база лиц, с которой и будет работать GOALcity.

В GOALcity есть два вида базы лиц: общая база лиц и база лиц (список имен) для конкретной панели «Внимание!». Общая база формируется путем добавления лиц из уже имеющихся у вас фотографий и добавления новых лиц из панели «Внимание!».

Наработка и добавление базы лиц

Для добавления базы лиц проделайте следующие действия:

1. Включите идентификацию и активируйте алгоритм "Лица" на панели "Внимание!".

2. Подойдите к камере, для которой активизирована идентификация лиц. Детектор лиц обнаружит лицо и оно попадет на панель "Внимание!".

Появление двойной рамки будет свидетельствовать, что параметры вашего лица полностью изучены.

3. Далее выберите нужное лицо в панели «Внимание!» и нажмите правую кнопку мышки на нем.

4. Кликните по пункту «Добавить лицо...» и присвойте выбранным лицам имена, тем самым занеся их в общую базу лиц GOALcity.

Также базу лиц можно сформировать из уже имеющихся фотографий нужных вам людей. Фотографии с лицами можно добавлять как по одной, так и целой папкой с файлами.

Чтобы добавить один файл, зайдите в настройки панели «Внимание!» на вкладку "Лица" в пункт "Общая база".

Нажмите кнопку «Добавить файл...»:

В открывшемся окне:

1.Укажите путь к файлу на жестком диске, кликнув по кнопке

2.Задайте имя, которое будет выводиться на панель «Внимание!» при обнаружении данного человека.

3. Нажмите «ОК».

Если на фотографии, которую вы добавляете, GOALcity не обнаружит лицо, то система выдаст ошибку:

Для добавления папки с фотографиями нажмите кнопку «Добавить папку...».

В открывшемся окне:

1. Укажите путь к папке с файлами на жестком диске, кликнув по кнопке

2. Нажмите кнопку «Добавить...».

GOALcity просканирует указанную папку и выдаст отчет о количестве обработанных, добавленных (в которых есть лица) и не добавленных (в которых нет лиц) файлов.

При добавлении папки с файлами имена файлов будут использованы как имена в базе.

Для удаления лиц из базы нажмите кнопку «Удалить...».

В открывшемся окне выберите нужные имена и нажмите кнопку «ОК».

Для выделения нескольких имен просто выделите их по очереди. Для того, чтобы снять выделение, кликните по имени еще раз.

Формирование списка имен

После того как Вы сформировали общую базу лиц, можно приступать к созданию списка имен для конкретной камеры.

Чтобы добавить лица в список имен проделайте следующие действия:

1. Откройте настройки панели"Внимание!", кликнув по шапке панели правой кнопкой мыши и выберете пункт "Настройки".

2. В открывшемся окне нажмите кнопку "Настроить".

3. Откроется окно настроек алгоритмов. В нем перейдите на вкладку "Лица" и нажмите кнопку "Добавить".

4. Появится окно общей базы лиц. Выберите нужные имена и нажмите "ОК". Чтобы выбрать несколько имен, по очереди выделите их мышкой. Кликните по имени еще раз, чтобы отменить выбор. Нажмите кнопку "Выбрать все", для добавления всех имен из базы.

5. Выбраные Вами лица появятся в списке имен.

Если при попытке добавить лицо в список имен программа выдаст сообщение:

но при этом список имен пуст, то это означает, что в общей базе лиц нет ни одного имени.

Если Вы пытаетесь добавить лицо в список имен, в котором уже присутствуют имена, но программа выдает это же сообщение, то это означает, что все имена из базы уже добавлены.


Настройка камер для распознавания лиц

Практическое применение >

Настройка камер для распознавания лиц

Для корректного распознавания лиц необходимо:

1. Отрегулировать выдержку затвора. С помощью изменения времени выдержки затвора можно контролировать степень "размытия" кадра. Для того, чтобы минимизировать степень "размытия" необходимо занизить время затвора до упора, насколько вам позволит камера при данной освещенности.

2. Настроить глубину резкости. Данный параметр зависит от отдаленности объекта от камеры, а также от выбранного разрешения. Цель настройки глубины резкости - выделить объект из окружающей среды, в нашем случае это лицо. Рекомендуется выбирать камеру с возможностью управления диафрагмой. Чем больше открыта диафрагма и чем ближе лицо, тем меньше глубина резкости.

3. Обеспечить расположение камеры таким образом, чтобы объект смотрел и двигался вперед в направлении камеры. Здесь можно предпринять организационные меры, например, создать небольшие коридоры, по которым человек сможет двигаться только прямо. В случае, если на данном отрезке пути люди могут заслонять друг друга, собираясь, например, в очередь, рекомендуем установить сразу несколько камер с разных сторон.

4. Исключить (или максимально уменьшить) расположение информационных стоек, баннеров или мониторов сбоку этих коридоров, чтобы исключить повороты головы и как можно дольше удерживать лицо человека прямо перед камерой.

5. Минимизировать возможность "засвета" камеры. В случае, если засвет происходит при открытии двери из помещения на улицу, рекомендуем организовать изолирующий тамбур без прозрачных стекол или приобрести более дорогие камеры с мультиматрицей, которая позволит сгладить яркий свет.

Технические требования к организации системы распознавания лиц можно свести в таблицу:

ПАРАМЕТР | ТРЕБОВАНИЕ
Плотность пикселей | Не менее 500 пикс/м
Углы отклонения | Не более 15⁰ по вертикали и горизонтали
Диафрагма объектива | Регулируемая; с возможностью ручного управления
Светосила объектива | Не менее 1:1.4 (т.е., например, объектив 1:1.2 имеет бОльшую светосилу, чем 1.4)
Размер матрицы | Не менее 1/3”
Выдержка | Не более 1/100 с (т.е. с выдержкой, например, 1/25 с возможно появление смазывания движущихся объектов)
Освещенность | Не менее 150 лк; освещение лица должно быть равномерным
Требования к фото | Размер лица в кадре не менее 150px *150px


Боремся с устойчивыми помехами

Практическое применение >

Боремся с устойчивыми помехами

Еще одно коренное отличие новой версии GOALcity от предыдущей в новой мощной системе борьбы с помехами. Вот именно борьбы - никак иначе сказать нельзя, фразы типа фильтрация помех здесь даже не катят, потому что всё, что было изобретено в этом направлении ДО GOALcity , нельзя поставить на одну полку не только по уровню, но и по пониманию процессов.

Вот такая вот веточка

или такая

может засорить весь экран событийного видеонаблюдения.

И сразу кто-то скажет такую гадость: И что здесь сложного – наложить маску? Правильно, все так и делают, в местах растительности помечают зоны, на которых отключается видеодетекция.

Но, во-первых, отключать на постоянную где-либо видеодетекцию – это УЖЕ плохо. Тем более, в кустах, где преступник и будет, наверное, прятаться. Во-вторых, сегодня эта травинка выросла в левой части кадра, завтра в правой, в обед образовалась лужа и бликует, зимой вообще травы может не быть, а летом вся растительность дает активные тени в непредсказуемых местах.

По идее старых, а для всех других еще и действующих на сегодняшний день технологий, к системе видеонаблюдения нужно приставлять настройщика, который каждые два часа будет «маску недетекции» менять.

Иначе в этих местах будет происходить постоянное срабатывание. И о таком уже полюбившемся термине, как интеллектуальное видеонаблюдение придется забыть. Хотя, если клиенту показывать работу только в хорошую погоду и не больше часа, то любая система видеоаналитики будет работать суперзамечательно. Ну, не пробудет же клиент в демозале весь день, тем более еще и ночь, когда картинка поменяется на вообще несусветную.

Весной и осенью за один день несколько раз может измениться даже основной фон, относительно которого работает контрастный видеодетектор. А все маски снежного покрова не актуальны для лета, и наоборот.

Устойчивая помеха может появиться в любом месте непредсказуемо для настройщика системы. Пытаться угадывать такие места достаточно сложно, тем более с перспективой на смену сезонов. Хотя мы сталкивались, что на каждый час времени каждого числа в одной системе можно настроить свою маску, и автоматически менять эти конфигурации. Во, идея! Надо весь год каждый час настраивать. А в следующем году все равно вырастит новый куст. И у них это уже называется динамической маской.

Еще есть нейросети – можно пытаться находить полезные образы в каждом кадре каждой многомегапиксельной камеры, для чего потребуется лишь суперкомпьютер за несколько миллионов долларов.

Ставить маски «недетекции» везде, где теоретически возможна устойчивая помеха – значит, уменьшать вероятность записи реальных целей. Давайте подойдем поближе к практике! Спецлаб нашел и выбрал достаточно простое и мало затратное в плане ресурсов компьютера решение «Динамическая автомаска». Только не надо путать с «динамической маской» - той, которая настраивается на год. Мы применяем слово автомаска потому, что наша программа сама решает, где поставить маску.

Новая версия GOALcity сама находит устойчивые помехи, локализованные замкнутыми зонами, и сама проставляет на них маску для детектора движения. Причем, это не просто маска недетекции, как в обычном варианте. Сама маска имеет 255 уровней чувствительности. GOALcity уменьшает чувствительность этих зон в зависимости от активности и длительности устойчивой помехи. Все параметры плавно адаптируются к изменениям активности и объему зоны.

Таким образом, алгоритм «Растения» позволяет моментально выявлять устойчивую помеху и сразу банить ее – исключать из алгоритмов видеоаналитики. Начался ветреный день – качающиеся растения сразу попали под маску. Стих ветер надолго – маска испарилась.

С внедрением технологии выясняется, что надо маскировать не столько растения, которые фильтруются старыми методами видеодеткции, а тени от них. Да и вообще оказалось, что возникает много зон, которые почему-то вдруг резко начинают контрастировать – на глаз не понятно, почему.

GOALcity отслеживает и смещение маски во времени, например, если это тень от веток, которая вместе с движением солнца может меняться весь день.

Легко обнаруживаются возникшие после дождя лужи и их отражение также перестает влиять на логику программ. Да даже окна, стекла или крыши с лакированной краской недавно поставленных автомобилей – всё это раньше доставляло нам массу неприятных срабатываний. Ведь компьютер не знает, что ему показывают зеркало. Такого он вообще еще не научился понимать. Поэтому GOALcity говорит ему: там лукавая какая-то зона, не обращай на неё внимания.

Естественно, надо понимать, что разговор идет о событийном видеонаблюдении, когда от компьютера ждут реакцию по событию. Сам видеодетектор, который дает команду на запись, продолжает работать во всех зонах и на всякий случай записывает в архив всё, что движется.

Все разновидности устойчивых помех сложно перечислить. Это и качание самой опоры камеры, и паутина на объективе, и даже крупные предметы, двигающиеся на ветру. Мы назвали свой алгоритм "Растения" лишь для упрощенного понимания пользователя. Если он столкнется с тем, что его событийный механизм начинает колбасить от какой-то ветки – а он обязательно когда-нибудь это почувствует – то активация кнопки "Растения" позволит избавиться и от других многочисленных помех, относящихся к группе «устойчивые помехи».

Что эта за группа? Да, не было такого устойчивого термина, пришлось его придумать. Мы относим к ней постоянную или периодическую активность, не меняющую или медленно меняющую свою зону действия, в течение последних 30 – 60 минут.

Почему мы выбрали именно этот участок времени? Ну, во-первых, надо понимать, что мы, как и говорилось раньше, не используем высоконагрузочные нейросети (хотя и можем, но это другая тема), а задействуем массовые дешевые компьютерные ресурсы, поэтому не анализируем полезность той или иной активности. А значит, будем показывать первоначальную помеху тоже как событие. Другое дело, и это во-вторых, мы не станем долбить оператора этой помехой каждые 20 секунд. Мы решили, что одна-две помехи в час с одной камеры – это тот уровень, который еще не превращает событийное видеонаблюдение в обычное. Проснуться пару раз в час – не самое страшное для психики человека.

Кстати сказать, человек никогда точно не догадается, как вообще компьютер видит детекцию, очевидная активность для нас часто фильтруется самим детектором. А казалось бы незаметные шевеления программа воспринимает как высокую активность. Поэтому надо доверить машине самой указывать на то, что является устойчивой помехой для нее.

Хотя естественно, человеку предоставляется менторская возможность указать компьютеру, какие зоны являются приоритетными, на которые нужно реагировать в независимости от того, что он нашел в них устойчивую помеху. Тогда программа будет срабатывать на все изменения в этих зонах, хотя и небезрассудно, а с учетом общей помеховой ситуации на всей площади кадра. Соответственно, нужно выбирать только те места, где естественная помеха крайне вероятна, но также наиболее вероятно прохождение полезных целей: людей – машин. Общая площадь таких зон не должна превышать 50% кадра.


Частная жизнь в тотальном видеонаблюдении

Практическое применение >

Частная жизнь в тотальном видеонаблюдении

Территория частного дома

Конечно, это хорошо, что какой-то охранник наблюдает за ней, тем более, если дом находится в глуши. Но и в глуши хочется уединения. Так частная жизнь или безопасность? Последнее, конечно, важнее, но и первое тоже можно обеспечить с системой GOALcity.

•Во-первых, можно отсечь стеклянные окна из обзора камеры в меню "Маскирование".

•Во вторых, можем оставить оператору обзор только тех зон подступа к объекту, где не гуляют хозяева.

•Или наоборот, оставить только зону захода в дом, тем самым контролируя жизненно важный участок, не мешая хозяевам наслаждаться жизнью на всей территории земельного участка.

При этом сама система видеоконтроля будет писать всю площадь охвата камеры, и хозяин всегда сможет просмотреть полный архив. Правда, в данном случае без окон, т.к. мы их затерли для всех вариантов просмотра.

Нужно последить за рабочим-отделочником в частном доме. Но при этом не смотреть на хозяев. Выбираем ракурс просмотра для оператора.

Складское помещение

Зачем охраннику видеть, что там хранится и как используется?

Можно оставить лишь область просмотра входа-выхода.

И отвлекает меньше, и заметить каждого входящего-выходящего намного проще. А писаться в архив для хозяина будет всё.

Банкомат

Здесь камера нужна очень, но как-то надо и закон соблюсти, ведь набор ПИН-кода – операция секретная. Здесь ограничением обзора не обойдешься, тем более что клавиатура находится в центре камеры.

Применяем маскирование. В отличие от выбора зоны просмотра, эта часть кадра не пишется в архив.

Офис

В наше неспокойное время охранникам лучше отслеживать посетителей не только на входе, но и в процессе их нахождения в кабинетах фирмы. Только в рамках дозволенного, все-таки охранник тоже может представлять угрозу фирме, если будет слишком много знать. Да и большинству руководителей не слишком нравится, чтобы за ними кто-то наблюдал. Прайвеси или безопасность? Поставить в этом предложении союз "и" может система GOALcity.

Для этого можно ограничиться зонами просмотра, где находятся гости.

Оператору необязательно видеть в подробностях лица посетителей, а только поведение. Поэтому на изображение для него можно наложить черно-белый или любой другой фильтр.

При этом в архив будет писаться весь кадр и в полном качестве, и "хозяин" сможет просмотреть запись в чистом виде.

Но есть и более радикальный способ скрыться – путем маскирования зон нахождения сотрудников компании.

Причем, уровень неразборчивости можно регулировать. Например, сделать доступным просмотр силуэтов, дабы контролировать какой-то экшен.

Во всех случаях этот вариант в архиве не оставляет реального изображения под ретушью.


"Скульптурное" видеонаблюдение

Практическое применение >

"Скульптурное" видеонаблюдение

За сколько секунд вы на мониторе оператора найдете место, в котором движется человек?

Даем подсказку – это место подсвечено синей рамкой детекции.

Надеемся, Вы сразу нашли эту 2-х мегапиксельную камеру, которая – если верить производителям - позволяет заметить даже мелкие детали.

На всякий случай увеличим данную камеру на весь экран.

Увы, и так не особо заметно. И это лишь на 2-х мегапикселах, а на уже ставшими привычными 5-и Mp надо увеличивать картинку во всю стену, чтобы увидеть то, что видит камера. На многоканальном мониторе оператора супер мегапиксельные камеры теряют всякий смысл – чем они мощнее, тем меньше в них можно чего-либо заметить.

Еще раз всмотритесь в первую картину видеонаблюдения – сколько там палитры и непонятных образов! Взять хотя бы одну эту камеру, причем, с реальной охраны, где оператору требуется вычислять, что пропадает или приносится строителями. Попробуйте там найти новый объект!

В панели видеоаналитики "Внимание!" много полезных настроек, сегодня разберем еще одну – "Показывать полный кадр или только место события". Она звучит немного по-другому, т.к. по умолчанию изначально показывается только место события. А человек, естественно, может в любом случае выбирать, т.к. мы никогда не претендуем на суд последней инстанции – может быть, всё, что мы тут говорим, в корне неверно – решать предоставляем вам.

Тем не менее, мы предлагаем алгоритм, позволяющий в тысячи раз сокращать бесполезный поток информации, выделяя главное – отсекая лишнее.

Мы вырезали 1/64 часть кадра в том месте, где есть движение и увеличили ее – для лучшего восприятия.

На 5-и мегапиксельной камере мы бы вырезали тысячную часть. Это так просто, а сколько отсекается лишней информации!

Сравните, что дает или отменяет эта галочка в настройках. Сверху панель "Внимание!" с показом одного лишь места события, снизу – полного кадра.

Согласитесь, в виду дефицита места на мониторе и количества глаз у пользователя намного эффективнее выглядит вариант с вырезанной частью кадра! Оператор всегда может щелчком мыши увеличить место события до полного кадра.


Дополнительная информация

Фильтр Smart Screen

»«

Фильтр Smart Screen

Фильтр Smart Screen в Microsoft Defender

Это компонент Windows, Internet Explorer и Microsoft Edge, защищающий пользователей от сомнительных веб-сайтов и приложений.

Исходный код сайтов goal.ru, cloud.goal.ru, speclab.ru и speslab.com является проверенным и не содержит никакого вредноносного ПО. Однако, у Microsoft свои алгоритмы проверки безопасности сайтов, которые происходят в автоматическом режиме, поэтому могут быть случаи ложного срабатывания.

Пример предупреждения о небезопасном сайте

Для того, чтобы сообщить о безопасности сайта необходимо нажать на кнопку Дополнительно в окне предупреждения, а затем на ссылку Сообщить об отсутствии угроз фишинга на этом веб-сайте:

Далее заполните необходимые данные о нажмите кнопку Отправить:

После проверки Microsoft предепреждения будут удалены из браузеров и результатов поиска спустя некоторое время.


Сбор технической информации

Сбор технической информации GOALcity

Дополнительная информация >

Сбор технической информации GOALcity

Сбор и отправка служебной информации GOALcity - программа по улучшению качества системы комплексной безопасности GOALcity.

Программа собирает информацию о работе системы GOALcity, не мешая Вашей работе и работе всей системы.

Данная программа будет установлена во время инсталляции GOALcity (подробнее об установке программы Вы можете прочитать здесь).

На одном из этапов установки перед Вами откроется окно "Установка дополнительного программного обеспечения", в котором Вы можете настроить "Сбор технической информации GOALcity".

Создать ярлык для программы "Сбор технической информации GOALcity" - при активации данного пункта на вашем рабочем столе будет создан ярлык

Включить сбор технической информации - при активации данного пункта, в случае обнаружения проблем, эта программа позволит оперативно собрать все необходимые технические данные и отправить их на анализ разработчику. Никакая личная информация при этом не собирается.

Если программа работает некорректно или зависла и не отвечает ни на какие Ваши действия, Вы можете собрать служебную информацию и отправить ее разработчику:

1. В случае, если при инсталляции GOALcity в окне "Установка дополнительного программного обеспечения" Вы отметили "птичкой" пункт "Создать ярлык для программы Сбор технической информации GOALcity", Вам необходимо запустить данную программу, нажав на ярлык [image] на Вашем рабочем столе.

Так же Вы можете найти и запустить данную программу воспользовавшись поиском в меню "Пуск".

2. После запуска программы перед Вами откроется окно для сбора и отправки служебной информации.

3. После нажатия на кнопку "Отправить служебные данные о неисправностях разработчику" перед Вами откроется окно для сбора и отправки отчетов.

4. Здесь Вам необходимо:

1) Выбрать причину, по которой произошла проблема;

2) Указать Ваши данные для обратной связи;

3) Нажать на кнопку "Сформировать отчет";

4) После нажатия данной кнопки у Вас появится два варианта для отправки отчета с необходимыми техническими данными.

В случае, если у Вас возникли дополнительные вопросы, Вы можете обратиться в техническую поддержку.