Введение

Navigation: »No topics above this level«

Введение

Комплексная система безопасности, ОПС и аналитического видеоконтроля GOALcity

"Комплексная система безопасности, ОПС и аналитического видеоконтроля GOALcity" (далее GOALcity) – это мощный, легко масштабируемый и наращиваемый по возможностям аппаратно-программный комплекс, позволяющий решать любые задачи по обеспечению безопасности объектов. Главные его особенности: модульность архитектуры и распределено-сетевой принцип построения. Благодаря им GOALcity является универсальной системой безопасности, предназначенной для применения на объектах любого типа.

Основой GOALcity является универсальная сетевая архитектура, способная объединить все типы объектов в единую структуру с использованием любых коммуникаций. Высокоскоростная сеть, телефонные линии, Интернет, радиоканалы, GPRS, Wi-Fi, спутниковые каналы и т. д. могут быть задействованы для единого контроля и управления. Обычный мобильный телефон способен стать средством для просмотра видео и управления системой в реальном времени.

GOALcity – это передовые технологии систем видеонаблюдения и комплексной безопасности, обеспечивающие функциональное превосходство и высочайшую степень надежности.

·GOALcity полностью оптимизирована работа с многопроцессорными/многоядерными системами на базе решений от Intel и AMD. Поддерживаются новейшие процессоры и графические адаптеры. Оптимизирована работа с интегрированным видео.

·GOALcity поддерживает работу с 64-х разрядными операционными системами Windows 10 включая серверные версии ОС. Использует новые 4-х, 8-ми или 16-ти канальные платы видеозахвата. Переработанный интерфейс приложения стал более простым, информативным и интуитивно понятным. Оптимизирована работа с сенсорными дисплеями. Реализованы групповые настройки и групповое управление правами пользователей.

·В GOALcity используется комплекс дополнительных мер для повышения надёжности соединения с источниками видео.

Для сжатия информации при передаче видео по сети и записи на жесткий диск GOALcity использует разработанные НИИ "СпецЛаб" покадровые кодеки "SpecLab JPEG LITE video codec" и "SpecLab security video codec S-JPEG HARD". Благодаря этому все каналы видео можно передать и записать с высоким качеством в любом формате (от 96х72 до 768х576 для аналоговых камер и в мегапиксельном разрешении для МП и HD-SDI камер) и цвете. Технология покадрового кодека обеспечивает максимальное качество каждого кадра.

Примечание: только покадровые кодеки допускаются к применению в подсистемах видеонаблюдения, обработки и хранения видеоинформации (ПВН) аппаратно-программных комплексов правоохранительного сегмента системы обеспечения общественной безопасности городов РФ. Данное требование предназначено для реализации МВД, ГУВД, УВД по субъектам РФ, ОВДРО и УВДТ МВД России при заказе и установке оборудования ПВН.

Дополнительно GOALcity поддерживает все потоковые кодеки, которые поддерживаются VLC плейером. К системе могут быть подключены все типы камер: аналоговые, IP, мегапиксельные, HD-SDI, а также различные IP видеосерверы.

·Аналоговые камеры оцифровываются с помощью плат видеозахвата производства "СпецЛаб" на базе АЦП "Philips", "Techwell" и "Conexant". Лучший по своим характеристикам кодек SpecLab JPEG Lite сохраняет высокое качество видео после сжатия и при передаче по сети.

Беспредельная масштабируемость системы наблюдения – число серверов в сети не ограничено. Все они надежно общаются между собой. Типы серверов определяются условиями объекта. Это может быть специализированный высокоскоростной видеосервер GOALcity, ретранслятор (VSS-Retr), сервер IP-устройств и т. д.

·Все серверы имеют веб-интерфейс (WEBCam), с помощью которого к ним легко подключиться обыкновенным браузером из любой точки мира. Информация со всех серверов по сети доступна любому клиенту, имеющему соответствующие права. Она удобно систематизируется в единой системе просмотра данных – клиентской части GOALcity.

·Всепогодные помехоустойчивые видеодетекторы способны определять количество, направление и размер движущихся объектов, анализируя их поведение, отфильтровывая естественные видеошумы и помехи.

В мире, где на каждого человека приходится по нескольку компьютеров, когда электроника стала неотъемлемой частью жизни, гораздо больше информации можно почерпнуть, контролируя компьютеры, а не только людей. Для этого в системе присутствует распределенно-сетевой комплекс сбора информации с удаленных ПК – "Амальгама", позволяющий отследить все, что делается на мониторе удаленного ПК. Также реализовано удаленное управление мышью и клавиатурой (опционально). При этом ведется запись в архив по детектору, постоянно или по различным событиям.

Сохранение данных обеспечивается архивными серверами. Архивный сервер GOALcity – это менеджер записи, хранения и просмотра видео-, аудиоданных, а также истории событий системы в комплексе или индивидуально по каждому элементу безопасности. Он разграничивает доступ большого числа пользователей как локально, так и по сети, обеспечивая контроль прав, перераспределение ресурсов, защиту данных. Для повышения надежности хранения и переноса данных в GOALcity был разработан новый защищенный формат файлов - SSDF (Secure Streaming Datа Format). При этом скорость экспорта увеличилась в несколько раз. При записи видео по событиям можно использовать буферы пред- и пост- записи.

·В GOALcity встроен 3D-движок управления трехмерными планами (3D Plan) - как плоскими, так и объемными объектами, с огромным числом возможностей, созданных специально для сферы безопасности.

·GOALcity обладает простым, интуитивно понятным внутренним языком пользовательского программирования SL++. Он легко позволяет создать самые сложные алгоритмы реакции системы на поведение движущихся объектов, сработку различного типа видеодетекторов, датчиков и других используемых устройств. Причем система может реагировать как на сиюминутное состояние (это реализовано во всех других системах видеонаблюдения), так и на различные комбинации состояний за определенный период времени (этого нет ни у кого). Возможных вариантов реакции на те или иные события множество: включение сигнализации, отправка e-mail или SMS, звонок на телефон, активация режима усиленной охраны и т. д.

·GOALcity может экспортировать архивные записи в свой защищенный формат или в самовоспроизводящийся архив с интегрированным интерфейсом плеера GOALcity. При экспорте данные дополнительно шифруются длинными хэш-ключами по технологии "Энигма" (электронная цифровая подпись). Также есть возможность экспортировать записи в формат AVI для просмотра Windows-плеерами.

Просмотр данных осуществляется с помощью интегрированного в систему плеера - SpecLab Secure Player 2. Плеер GOALcity способен показывать все камеры одновременно и синхронно, позволяя увидеть весь комплекс событий. Причем не только камеры. В одном масштабе времени просматриваются и события по датчикам, ключам, различным устройствам, демонстрируются значения тех или иных приборов в каждый момент времени, воспроизводится звук по выбранным каналам. Сервис плеера GOALcity позволяет в любой момент перевести внимание пользователя из многоканального просмотра в одноканальный, развернув во весь экран только одну камеру или другой элемент, выполнить масштабирование.

·В GOALcity реализована совместная работа с другими системами безопасности: различное оборудование фирм "Болид", "Стрелец", СКУД "Парсек", Чек-ТВ, Тромбон ПУ-8. Список интегрированных систем постоянно расширяется. Данные технологические особенности характеризуют GOALcity как современный, многофункциональный, качественный и надежный продукт обеспечения безопасности.


Информация для инсталляторов

Navigation: »No topics above this level«

Информация для инсталляторов

Видеосервер и Видеоклиент

Современные системы видеозаписи – это уже далеко не то, что было раньше: «включил запись – пишет, выключил – не пишет». Современная запись, да еще по сети – это многогранный сложный комплекс, а в системе GOALcity – это целая философия. Чтобы ее понять, нужно определиться с терминами. Структура сетевой записи состоит из двух основных частей: видеосервера и видеоклиента.

·Видеосервер – это устройство, к которому подключены видеокамеры. Видеосервер оцифровывает видео и выдает в сеть кадры видео.

·Видеоклиент – программа, получающая, демонстрирующая на экране и записывающая кадры видео, приходящие по сети. (Может работать и локально.)

Видеосервер и видеоклиент могут находиться на одном компьютере, но их взаимодействие от этого меняется ненамного, обычно убирается только процесс распаковки сжатых данных на просмотр.

Для уменьшения объема данных, как при записи на диск, так и для передачи в сеть, используется процедура сжатия. Как правило, запаковка кадров происходит только на видеосервере. Видеоклиент записывает сжатые кадры, полученные по сети, на жесткий диск. Кроме того, он их распаковывает, чтобы показать на мониторе (если это требуется).

Просмотр и Запись по сети – это совершенно разные процессы. Приходящие по сети кадры могут использоваться как для записи, так и для просмотра. Оба этих процесса независимы, поэтому и настройки для них различны. Это важно понимать.

Кроме того, в охранной записи широко используется видеодетекция – определение изменений в последовательности кадров. Видеодетектор может быть установлен как на видеосервере, так и на видеоклиенте. В GOALcity он работает именно на видеосервере. Такая структура позволяет принимать решение о передаче данных в сеть на самом источнике, в результате чего экономится пропускная способность сети. В системах, где видеодетектор встроен в клиентскую часть, приходится тратить ресурсы на сетевой трафик, ведь только получив данные, можно понять, нужны они или нет. В GOALcity видеодетектор стоит на видеосервере . Это важно знать.

Немного про объем данных

В сетевой видеозаписи объем переданных данных не всегда соответствует полученному. Нужно обязательно понимать, что видеоклиент может получать не все кадры, передаваемые видеосервером. Видеосервер и видеоклиент могут находиться в разных городах и даже странах, и они могут не учитывать всех параметров друг друга. Передаваемые видеосервером кадры могут частично или полностью не доходить до видеоклиента в силу сложности условий.

·Идеальные условия: видеосервер с высокой производительностью, с видеоисточниками реального времени и видеоклиент с высокой производительностью, подключенные друг к другу по локальной высокоскоростной сети.

·Сложные условия: видеосервер с высокой загрузкой и видеоклиент с высокой загрузкой, связанные друг с другом многоранговой разнородной сетью.

Если Вы настраиваете клиентскую часть на запись со скоростью 25 кадров в секунду, то это не значит, что так оно и будет в сложных условиях. Видеоклиент может просто недополучать кадры, и в результате скорость записи будет ниже запланированной. Это возможно по следующим причинам:

·Сервер оцифровывает мультиплексированное видео с меньшей частотой из-за самой конфигурации оборудования.

·Сервер перегружен большим объемом операций, в результате чего его производительность снижена.

·Пропускная способность сети недостаточна, чтобы передать заданный объем информации.

·Клиент перегружен большим объемом операций, в результате чего его производительность снижена.

Важно понять главное: до клиентской части могут не доходить некоторые кадры, кроме того, могут не доходить кадры со служебной информацией, да и сама служебная информация. В этом и есть основная сложность сетевой архитектуры.

В этих условиях хорошая система видеоконтроля должна обеспечивать наилучшую запись и просмотр видео с минимальными потерями и в то же время не перегружать сеть, компьютер и пользователя излишними данными. Вот эту задачу и решает совсем нетривиальная архитектура видеозаписи GOALcity.

Видеодетектор

Основное регулирование потоков данных основано на высокоточном видеодетекторе технологии "Snack-2". Именно он по большей части регулирует, что посылать в сеть и что писать. Однако его высокая точность – понятие относительное, основанное лишь на лабораторных тестах. Жизнь, природные явления часто не совпадают со "стерильными" условиями лабораторий. Всевозможные помехи: солнечные и прожекторные блики, качающиеся ветки, движущиеся тени, летающие птицы, ползающие по объективу насекомые и прочее – это факторы, которые машина пока не может с малыми затратами производительности отличать от движения человека или автомобиля. Чтобы сделать комфортной систему получения информации в реальной жизни, потребовалось создать сложную архитектуру видеоконтроля, невидимую пользователю. Человек имеет право на получение информации в полном объеме, но быстро и без сложностей.

"Философия" записи

"Философия" записи в GOALcity исходит из того, что писать нужно как можно больше, а показывать как можно меньше. При этом реализуются возможности доступа к данным так, чтобы просмотр записей отвечал трём основным требованиям: быстро, комфортно, досконально. И еще есть режим "очень быстро" – с применением аналитики.

"Быстро" предполагает минимальную избыточность информации – показ только того, что машина посчитала движением. При этом просматриваются только те кадры, где есть детекция движения.

Но видеодетектор работает не так, как привык воспринимать глаз человека. А потому он может не выбрать кадры, естественные для разумного существа, или захватить много таких кадров, которые совсем неинтересны. Комфортный просмотр предполагает именно то видео, которое привык видеть человек, как в жизни, так и на экранах телевизоров. Естественно, это добавляет избыточности и требует большего времени.

Но и комфортный просмотр в GOALcity избавляет от груды подробной информации, в 99% которой, как правило, не содержится ничего полезного. Однако существует тот один процент, ради которого стоит перейти к доскональному просмотру определенного участка времени. Он может потребоваться, если заранее известно о происшествии или что-то необычное обнаружено во время любого из предыдущих типов просмотра. Как правило, ЧП – основная причина просмотра видеозаписи с максимальной избыточностью. В обычное же время такой просмотр может занять много времени. Поэтому его еще называют чрезвычайным.

Таким образом, при заходе в Плеер вам будет предложен выбор:

·Максимальная избыточность – для досконального просмотра.

·Средняя избыточность – для комфортного просмотра.

·Минимальная избыточность – для быстрого просмотра.

Кроме того, существует аналитический просмотр, который предлагает только те события, которые, по его мнению, заслуживают внимания. Он в сотни раз меньше по объему информации, поэтому значительно ускоряет работу с системой. Однако это требует правильной настройки аналитики.

Аналитика – это тема другого раздела, поэтому опишем механизм первых трех. Они складываются из различных параметров записи. Основа всего – это видеодетекция. Однако современные видеодетекторы или требуют суперкомпьютеров на распознавание реального движения человека или часто детектируют не всё и не то, что нужно. Чтобы детектировать только то, что нужно, в GOALcity есть возможность максимально уйти от помех.

Во-первых, здесь есть фильтр шумов, который можно настроить под заданную местность, во-вторых, если включить автоматическую чувствительность, то видеодетектор GOALcity почти перестанет реагировать даже на самые сложные помехи – поступательные движения, сильно напоминающие человеческие или автомобильные. Однако в этой борьбе с помехами можно и переборщить. Поэтому при таких настройках рекомендуется включать запись по команде пользователя.

Как правило, страхующая постоянная запись со скоростью – 5-10 кадров в минуту не отражается на производительности. Но это именно та максимальная избыточность, которая может понадобиться при доскональном просмотре. То есть это постоянная запись вне зависимости, была детекция или нет. При сегодняшних объемах дисков такая запись не ложится тяжелым бременем на архив. При обычном просмотре пользователь ее не видит, она требуется только при том одном проценте, потребность в котором может возникнуть в результате ЧП.

Сначала мы долго говорили о видеодетекторе, а закончили тем, что писать надо все вне зависимости от видеодетектора. Это совсем не значит, что он тут не нужен. Именно видеодетектор вносит в запись ту информацию, которая говорит о ее категории. Определяя детекцию в кадре, он записывает туда данные о себе и посылает клиенту. Всё, продетектированное системой – это то, что машина определила как изменения в видеопоследовательности. Там обязательно содержится какое-нибудь движение, поэтому пользователю не придется просматривать пустые стенки или асфальт. Таким образом, просмотр только тех кадров, в которых содержится информация о детекции – есть минимальная избыточность, а значит, это самый быстрый просмотр.

В продетектированных кадрах совсем нет статических объектов. Однако это совсем не похоже на то, что мы привыкли видеть в реальной жизни. Если человек занимает небольшую площадь кадра, то видеодетектор может не реагировать на шевеление губ при разговоре, мелкие движения рук или ног и даже на медленную ходьбу. Поэтому в записи по детекции может оказаться всего лишь десяток кадров из получасового нахождения человека перед камерой. В связи с этим мы можем совсем неправильно оценить записанную ситуацию. Вот для более привычного и комфортного просмотра и существует такой алгоритм – приращение записи. Он добавляет плотность кадров в детектируемый интервал времени, внося некоторую избыточность для комфортного просмотра.

Алгоритм "приращения записи"

Приращение записи – это алгоритм, основанный на интуитивном расчете периода отсутствия движения у подвижного объекта, который находится в поле зрения камеры. Это так называемый период "недвижения". Как правило, ни один человек не может долго находиться в статическом состоянии, каждые несколько секунд он то крутит головой, то переминается, то чешет у себя под носом… В зависимости от того, насколько крупно берет обзор камеры человека, можно вычислить приблизительное время его "недвижения" и заложить этот параметр в настройки. Чем меньше фигура человека в кадре, тем больше должно быть приращение. При таком алгоритме в архив будут писаться не только кадры, в которых есть информация о движении, но и промежуточные, где как такового движения не было, но само поведение объекта представляет интерес. Даже самые сильные эмоции видеодетектор рассмотреть не может, а нам при просмотре могут потребоваться и эти особенности.

Алгоритм "приращения записи" устроен так, что он не прерывает запись до тех пор, пока, пусть и изредка, продолжают поступать кадры с детекцией. И только после исхода всего периода "недвижения" запись останавливается, предполагая, что движущиеся объекты вышли из кадра.

Период "приращения записи" – это период, в течение которого будет писаться видео с повышенной плотностью после последнего кадра с детекцией. Пользователь может задать его в секундах или в кадрах. Кроме того, пользователь может задать и плотность данного типа записи, выражаемую в скорости. Чем выше скорость, тем выше плотность, а значит и комфортность просмотра. Но требуется и больше времени на просмотр.

Для еще большей комфортности существует и буфер предзаписи. Если наблюдение ведется за крайне мелкими объектами с низкой контрастностью по отношению к фону, то видеодетектор может и не заметить появления какого-либо объекта сразу. При активной настройке периода предзаписи на диск будет писаться даже то, что было до появления первого кадра с детекцией.

GOALcity пишет всегда только в оперативную память. При появлении команды на запись от пользователя или по детекции предзапись сбрасывается на диск, и запись на диск продолжается уже в реальном времени.

Так много технологий, чтобы сделать работу комфортней, не только из-за того, что видеодетекция несовершенна по отношению к человеческому зрению – это то, с чем еще можно мириться в локальных системах записи. Гораздо критичней проблема сложных условий, определение которым дано выше. Дело в том, что чисто гипотетически по сети кадры с детекцией могут не приходить вовсе. Например, человек делает только одно движение, занимающее всего один кадр в секунде. И этот кадр в виду сложных условий может теряться в сети. И так каждую секунду. Мы можем получать 24 кадра в секунду, и в них не будет ни одного кадра с детекцией. И так 10 минут подряд. Так долго маловероятно, но вполне возможно, если учесть что и скорость оцифровки может быть маленькой, и сама скорость детекции по умолчанию только 5 кадров в секунду, и скорость опроса – просмотра реального видео может быть занижена, чтобы не загружать сеть. Т.е. в сети мы рискуем вообще не получить сигнала о детекции.

Чтобы этого избежать, в GOALcity введена дополнительная технология избыточной детекции, которая встраивает данные о детекции не только в тот кадр, в котором обнаружена реальная детекция, но и в ряд последующих. Избыточность определяется специальным алгоритмом, поэтому пользователь может не бояться выставлять низкую скорость детекции на сервере, этот алгоритм заботится, чтобы не было пробелов в получении таких важных кадров, которые несут информацию о детекции. Поэтому за скорость детекции в GOALcity можно особо не волноваться и не перегружать зря процессор, если этого не требуется для мощной аналитики.

Этот же сложный алгоритм может отличать реальные кадры с детекцией от избыточных, чтобы не влиять на ход принятия решений, связанных с командами по детекции. Опять же мы мало поговорили о ложных сработках, природных явлениях, изменение которых видеодетектор может принять за нужный объект. Видеодетектор "Snack-2" имеет довольно продвинутый алгоритм (гордость разработчиков компании СпецЛаб), чтобы быстро отстраиваться от различного рода помех, однако и ему на это нужно время, если помеха сильно напоминает движение человека или автомобиля. Защититься от "ложняков" поможет настройка "Записывать после получения столько-то кадров". В этом варианте, запись в реальном времени, а также предзапись попадут на диск только в том случае, если придет заданное число последовательно детектированных кадров. В одном-двух кадрах может проскочить и помеха, а если детектированных кадров множество подряд, то можно начинать запись.

Таким образом, мы избавляем пользователя от необходимости просматривать движение тени от облаков, качание веток от ветра, падение снега или сильного дождя. А ведь эти процессы могут составлять более половины всех записей! Вот поэтому нам важно знать на приемной стороне, содержат ли кадры реальную детекцию или избыточную. Ориентироваться можно только на реальную, так как избыточная не отражает реальных сработок. Иначе мы будем писать все явления природы. В сложных условиях, в которых возможно множественное выпадение кадров, крайне нетривиальный алгоритм GOALcity производит точную селекцию.


Системные требования

Navigation: Общие сведения >

Системные требования

Операционная система

Windows 10, Windows Server 2016. ПО DirectX 9c версии выпуска не ранее августа 2009 года.

Обязательно убедитесь, что у Вас установлены все обновления ОС на текущий момент времени!

Поддерживаются только 64-х разрядные версии операционных систем!

Процессоры

·Intel Core i3, i5, i7. Серверные процессоры Xeon моделей Е3, Е5, Е7.

·AMD Phenom серий X2 (минимально), X3, X4, X6. Серверные процессоры Opteron серий 3000, 4000, 6000.

Мощность процессора зависит от выбранной конфигурации СВН. Чем больше живых (25 к/с) камер, чем больше алгоритмов задействовано, чем больше панелей «Внимание» присутствует в системе - тем мощнее должен быть процессор.

Обратите внимание на то, что чем больше физических ядер (не виртуальных!), тем лучше. Режим Hyper-threading можно вообще отключить, т. к. для наших задач он не приносит никакой пользы.

Материнские платы

·В принципе, с нашими (да и любыми другими) платами с шиной PCI-E должны работать любые материнские платы. Однако производители МВ часто лукавят. Например, если на МВ есть 7 PCI-E 16х слотов, то это совсем не означает, что она имеет 7*16 = 112 линий PCI-E.

·Во-первых, нужно смотреть, сколько линий поддерживает чипсет. Как правило, гораздо меньше.

·Во-вторых, материнские платы имеют встроенные USB, сетевые, звуковые и прочие интегрированные устройства, которые также могут использовать линии экспресс-шины.

Как материнская плата использует и распределяет линии между экспресс-слотами и интегрированными устройствами, определяется только производителем, а он эту информацию не выкладывает для всеобщего пользования. Поэтому приходится проводить тестирование, чтобы определить, работает ли та или иная МВ с полной нагрузкой. Обычно, если не установлено 2 видеокарты, линий для наших плат должно хватать.

Оперативная память

2 GB (минимально) фирм Samsung, Kingston, Corsair, Kingmax. Более подробно о поддержке конкретных моделей ОП смотрите в спецификации к материнской плате или процессору (если контроллер памяти находится в нем). При выборе ОП обратите внимание на то, чтобы количество планок памяти соответствовало числу каналов контроллера. Так, например, для 3-х канального контроллера памяти число планок лучше взять равным трем, для 4-х канального - четырем. В этом случае (в сочетании с последующим пунктом) будет достигнуто максимальное быстродействие, что очень важно для высокопроизводительных систем.

Берите модули памяти с максимальным по частоте стандартом, поддерживаемым процессором или материнской платой. В сочетании с предыдущим пунктом это позволит достичь максимального быстродействия. Лучше использовать наборы модулей - KIT - специально подобранные и протестированные для совместной работы планки памяти.

Жесткие диски

Seagate, Western Digital, Hitachi. Если у Вас для ОС используется отдельный диск, то используйте модель повышенной надежности. Для архива используйте диски, специально предназначенные производителем для систем видеонаблюдения. Объем дискового массива зависит от требуемого времени хранения информации.

Объем всего установленного ПО - 2Gb. Минимальный объем жесткого диска - 120Gb.

Видеокарта

Рекомендуется использовать видеокарту серий AMD Radeon 7000, R7, R9, RX (GCN), т.к. они поддерживают более эффективный метод загрузки данных из системной памяти, отсутствующий у NVIDIA GeForce. Если же у вас видеосервер не выводит изображение на мониторы, а лишь осуществляет предварительную обработку видео и (или) запись, то можно обойтись встроенным видео с 16 МБ, например.

На данный момент мы не рекомендуем использовать встроенное видео на базе Intel из-за нестабильности работы. Если Вам необходимо именно встроенное видео, то используйте его на базе AMD.

В GOALcity режим вывода видео на основе OpenGL был существенно оптимизирован.

Однако, при определённых условиях загрузка процессора в GDI-режиме по-прежнему может быть ниже, чем в OpenGL-режиме, особенно при работе с большим количеством камер низкого разрешения. Причина - дополнительные накладные расходы в исполняющей подсистеме OpenGL, связанные с невозможностью загрузки данных кадра в видеопамять без дополнительной стадии копирования, выполняемого силами центрального процессора.

Основные задачи OpenGL-режима - снижение загрузки центрального процессора при выводе видео высокого разрешения (1 МП и более) и обеспечение максимально возможного качества картинки (разница в качестве интерполяции, контрастности и насыщенности цветов заметна невооружённым глазом).

При сравнении режимов вывода видео необходимо учитывать следующие обстоятельства:

1.Должна использоваться дискретная видеокарта, при использовании процессора Intel встроенное видео должно быть полностью отключено;

2.Для сравнения загрузки процессора надо отслеживать, в первую очередь, загрузку клиентского процесса;

3.Отслеживание нагрузки на процессор надо начинать не ранее, чем через 1 минуту после загрузки клиента или переключения режима вывода;

Блок питания

Качественный блок питания (не NoName!). Подробнее о требованиях к блоку питания смотрите в описании на МВ. Рассчитать требуемую мощность вам поможет калькулятор БП от ASUS. Настоятельно рекомендуем использовать источник бесперебойного питания (ИБП), работающий в режиме двойного преобразования (On-line) или по линейно-интерактивной (Line-Interactive) схеме. Рассчитать необходимую мощность ИБП вам поможет калькулятор от APC.

Настоятельно рекомендуем использовать ИБП требуемой мощности.


Функции подсистем

Navigation: Общие сведения >

Функции подсистем

Поддерживаемые языки

В настоящее время в дистрибутив включены языки:

·русский

·английский (США)

·французский (Франция)

·испанский (традиционная сортировка)

·азербайджанский (латиница)

По запросу в дистрибутив можно добавить любой другой язык.

Клиентская часть

Файл установки – 1_GOALcity_Client_x64.exe (ранее файл назывался setupcc_x64.exe).

Интерфейс для подключения, управления и настройки всех серверов GOALcity, как локально, так и по сети. Локальный архив. Можно создать только один архив (папку). К нему нет доступа по сети. Запись видео и аудио в локальный архив и архивный сервер.

По умолчанию доступно два сетевых подключения.

Важно! В настоящий момент в бесплатной версии GOALcity стоит ограничение на подключение только 1-го клиента. Однако, так как в бесплатной версии ограничение в 1 клиент сохраняется в конфигурацию при выгрузке, то, соответственно, при запуске GOALcity с ключом "подцепляется" это же значение из ранее сохраненной (в бесплатной версии) конфигурации. Другими словами, если Вы после использования бесплатной версии установите платную и решите подключить больше 1-го клиента, то после запуска GOALcity с ключом необходимо будет зайти в настройки фаервола нужного сервера и выставить там требуемое значение.

Проигрыватель архивов (локального архива и архивного сервера) позволяет осуществлять:

·просмотр видео, в т. ч. синхронно нескольких камер

·прослушивание аудио, в т. ч. синхронно с видео

·комплексный синхронный просмотр событий: видео, аудио, сработки датчиков, показания приборов

·поиск интересующего отрезка времени

·экспорт видео, аудио, в защищенный формат, в исполняемый файл, в контейнер AVI

·экспорт кадров в формате JPG

·технология "Энигма"

Панель "Внимание!-3". Сигнализирует оператору при сработке алгоритмов"«Внимание":

·Опасное начало;

·Опасное время;

·Опасный покой;

·Опасное количество;

·Опасные зоны;

·Опасная площадь;

·Опасный поворот;

·Опасное направление;

·Предметы;

·Автономера;

·Лица.

Детекции:

·лиц;

·номеров, в том числе и автомобильных;

·унесенных - оставленных предметов;

·объектов.

Панель «Внимание» позволяет:

·вставлять в видеозапись комментарии в текстовом виде;

·открывать окно камеры, в которой произошла сработка алгоритма "Внимание";

·открывать место в архиве, где произошла сработка;

·перемещать ролики с одной панели на другую;

·выводить на панель по какому-либо событию ролики из архива.

Панель "Розыск". Позволяет вывести на панель фотографии лиц, на которых охране стоит обратить особое внимание.

·Обработка событий, алгоритмов.

·Источник ретрансляции.

·Планировщик заданий.

·Ведение журнала.

Видеосервер (Loc, Net, Quatro Loc, Quatro Net)

Файл установки – 4_Analog_Video_Server_x64.exe (ранее файл назывался setupgc_x64.exe).

Захват видео плат на чипах Conexant CX 2388x, SAA 713x, BT 8xx, Techwell TW 680x, Conexant CX 2585x и Gennum GV7601.

Детекторы:

·движения;

·лиц (локальный) SL-Face;

·номеров, в т.ч. автомобильных – SL-Traffic;

·унесенных - оставленных предметов;

·объектов.

Аудиосервер

Файл установки – 5_Analog_Audio_Server_x64.exe (ранее файл назывался setupacs_x64.exe).

Захват звука с плат на чипах Conexant CX 2388x, SAA 713x, BT 8xx, Techwell TW 680x, Conexant CX 2585x и Gennum GV7601.

Детекторы:

·Детектор сигнала.

·Детектор голоса.

·Система подавления шумов.

Архивный сервер

Файл установки – 3_Archive_Server_x64.exe (ранее файл назывался setupas_x64.exe).

Сетевой архив. Запись – локально, просмотр – локально и по сети. Можно создавать множество архивов (папок).

Мультимедиа сервер - поддержка IP устройств

Файл установки – 2_IP_Server_x64.exe (ранее файл назывался setupvss_x64.exe).

Захват видео и аудио, работа с датчиками и ключами:

·IP камер,

·IP серверов,

·мегапиксельных камер.

Видеоретранслятор – VSS-Retr

Файл установки – 2_IP_Server_x64.exe (ранее файл назывался setupvss_x64.exe).

Захват видео из окна клиента GOALcity. Рекомендуется использовать в следующих случаях:

·Когда нужно "расширить" узкие места в топологии сети или конкретного соединения. Например, видео передается одному клиенту по узкому каналу, а уже он передает его многим клиентам по широкому.

·Для "изоляции" видеосервера от большого числа подключений. Например, если где-то произойдет происшествие, то все захотят посмотреть его. Массовое подключение к одной камере одного видеосервера может существенно замедлить его работу. Ретранслятор в нашем случае выступит экраном, который позволит видеосерверу работать в обычном режиме.

·Для пережатия кадров и отдачи их в сеть с другими разрешениями.

·Возможно включение - выключение трансляции видео по событию GOALcity.

Мобильное видеонаблюдение

Файлы установки – GOALobserver.msi (для установки на ПК) и GOALmobile-2.apk (для установки на смартфон или КПК с ОС Android 2.3 и выше).

Позволяет передать на смартфон (КПК) ролики, кадры и сообщения, появившиеся на какой-либо панели "Внимание".

Сервер удаленного контроля – АМАЛЬГАМА

Файлы установки – 2_IP_Server_x64.exe (ранее файл назывался setupvss_x64.exe) и amalgama_x64.exe.

Использование рабочего стола удаленного видео сервера как источника видео. Позволяет записывать в архив состояние рабочего стола и изменения на нем (в том числе перемещение мыши, курсора, окон и т. п.), например, по детектору движения. Иначе сказать, содержимое рабочего стола система воспринимает как изображение с обыкновенной камеры.

Сервер устройств – SpecLab Device Assistant SLDA

Файл установки – 2_IP_Server_x64.exe (ранее файл назывался setupvss_x64.exe) и 9_SLDA_Driver.exe (ранее файл назывался sldasetup.exe).

Работает с:

·датчиками и ключами интегрированных систем;

·датчиками и ключами IP контроллеров Спецлаб Telepatya;

·виртуальными ключами GOALcity.

·работает с устройствами типа HUB, конвертерами интерфейсов.

Компонент для работы с серверными ОС

Файл установки – 6_Windows_Server_OS_x64.exe (ранее файл назывался setup_winsrv_x64.exe).


Первый запуск программы

Navigation: Быстрый старт >

Первый запуск программы

Дистрибутив GOALcity состоит из нескольких исполняемых файлов:

·1_GOALcity_Client_x64.exe (ранее файл назывался setupcc_x64.exe) - Клиент GOALcity.

·2_IP_Server_x64.exe (ранее файл назывался setupvss_x64.exe) - Мультимедиа сервер GOALcity,

·3_Archive_Server_x64.exe (ранее файл назывался setupas_x64.exe) - Архивный сервер GOALcity,

·4_Analog_Video_Server_x64.exe (ранее файл назывался setupgc_x64.exe) – Видеосервер + Клиент GOALcity,

Важно! Программа использует программный ключ защиты Guardant Sign, а не аппаратный Guardant Stealth II как это было в более ранних версиях. Убедитесь, что Вы скопировали файл license.txt в корневой каталог диска, на который установлена операционная система перед запуском программы. Без файла-лицензии программа будет работать в демо-режиме.

После установки необходимого ПО и перезагрузки ПК, запустите GOALcity. На экран будет выведен загрузочный сплэш программы.

Обратите внимание! Сплэш можно отключить добавлением команды /nosplash в ярлык загрузки GOALcity.

Загрузка без рабочего стола Windows

·Скачайте себе на компьютер следующий архив. Скопируйте файл start.bat в папку C:\Windows\.

·Запустите редактор реестра Windows командой regedit. В реестре по пути - "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" измените значение параметра "Shell" на "C:\Windows\start.bat" без кавычек.

·Перезагрузите ПК.

Для запуска explorer'a вместо GOALcity нужно:

·В реестре по пути - "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" измените значение параметра "Shell" на "explorer.exe" (без кавычек).

·Перезагрузите ПК.

После запуска, программа предложит задать или найти локальный архив.

Внимание! Если в комплект GOALcity приобретен Архивный сервер, то необходимо отказаться от создания локального архива!

Укажите путь к папке нового локального архива, указанная папка при этом должна быть пустой.

Настройте параметры архива под свои нужды, ограничив либо время записи, либо максимальный размер архива.

После конфигурирования локального архива, программа предложит добавить установленные серверы GOALcity.

Поиск серверов

GOALcity - система с сетевой архитектурой, поэтому ее клиентская программа может находиться на одном компьютере, а сервер - на другом. При первом запуске программы откроется окно "Поиск серверов". Если сервер установлен на этом же компьютере - отметьте пункт "На этом компьютере", если на другом - поставьте отметку в пункте "На компьютере" и в рядом расположенном поле впишите его IP адрес. После нажатия кнопки "Далее" запустится поиск серверов.

Время поиска серверов, установленных на локальном компьютере, порой может превышать 5 минут. Причин может быть несколько: высокая загрузка процессора, большое количество установленных серверов, наличие ключей Guardant для работы с другими программами.

В случае поиска серверов в локальной сети отметьте "В сети".

После нажатия кнопки "Добавить" откроется окно выбора диапазона IP-адресов для поиска. Если этот диапазон неизвестен, то лучше уточнить его у системного администратора, иначе поиск может занять очень много времени.

Для начала поиска серверов нажмите "Далее" и по окончанию откроется окно "Результаты поиска".

Выберите необходимые серверы, поставив напротив них галочку, нажмите кнопку "Завершить" - сервера добавятся на Диаграмму подключений.


Подключаем IP камеры к системе

Navigation: Быстрый старт >

Подключаем IP камеры к системе

Чтобы подключить IP камеру в систему GOALcity не нужно особых навыков работы с ПК, достаточно знать модель камеры и поддерживаемые ей кодеки сжатия видео. Чтобы использовать покадровый кодек mjpeg обычно камера должна пройтирасширенную интеграцию с GOALcity. Но, как показывает практика, боmльшинство из камер работают и без дополнительной интеграции.

Чтобы использовать потоковый кодек h264 необходимо знать rtsp ссылку на поток с данной камеры. Ссылка, как правило, приводится в документации к оборудованию, либо отображается в веб интерфейсе устройства.

Рекомендации по подключению IP камер

Современные IP камеры могут "отдавать" сразу несколько видео потоков в разном разрешении и с использованием разных кодеков. Используя эту функцию камер, мы доработали наш RTSP источник тем самым, позволяя существенно снизить нагрузку на ЦП, путем вывода на просмотр в маленьком окне "небольшого" потока, но при "распахивании" окна GOALcity автоматически переключаться на "полный" поток. Другими словами, в маленьком окне Вы будете видеть "маленькую" картинку, но так как размер окна мал, то отличий от изображения в полном разрешении практически не будет. При максимизации окна Вы будете видеть изображение в полном разрешении.

Запись при этом ведется всегда "полного" потока в максимальном разрешении.

Чтобы настроить такой алгоритм работы, выполните следующие действия:

·Используйте RTSP источник для создания камер или мастер добавления IP камер GOALcity.

·"раскройте" созданный RTSP источник и введите необходимые данные в поля "URL для просмотра" и "URL для записи"

В поле "URL для просмотра" необходимо вводить ссылку на "маленький" видео поток с IP камеры, он будет отображаться в маленьком окне GOALcity. Рекомендуем использовать кодек jpeg и разрешение 640х480 или меньше в зависимости от размера окна.

В поле "URL для записи" необходимо вводить ссылку на "полный" видео поток с этой же IP камеры, он будет отображаться при распахивании окна GOALcity и постоянно записываться. Рекомендуем использовать кодек h264 и максимальное разрешение.

Мастер добавления IP камер

После первого поиска серверов GOALcity перед Вами сразу же откроется мастер поиска IP камер.

Для начала, мы рекомендуем произвести поиск камер по протоколу ONVIF, потому что почти все современные камеры поддерживают этот протокол. А уж если что-то не найдется, то можно будет добавить вручную. Отметьте данное поле "точкой" и нажмите кнопку "Вперед".

Выберите тип поиска: "Discovery" - поиск, используя специальный ONVIF протокол, либо укажите пул IP адресов в ручном режиме. Нажмите кнопку "Поиск".

GOALcity произведет поиск камер. Найденные камеры будут отображены в верхнем окне.

Если для доступа к камере требуется авторизация, система оповестит Вас об этом. В таком случае, кликните правой кнопкой мыши по данной камере и укажите данные для авторизации.

Отметьте «птичками» камеры, которые хотите добавить в GOALcity и нажмите кнопку "Вперед". Перед Вами откроется список всех камер, которые Вы собираетесь добавить. Нажмите кнопку "Добавить" и завершите работу мастера.

Все выбранные камеры добавятся на мультимедиа сервере.

IP Source или подключение IP камеры с использованием кодека mjpeg

Откройте настройки "Мультимедиа сервера" двойным щелчком по "шапке" сервера. Выберите пункт "IP Source".

IpSource - источник работы с различным IP оборудованием (видео камеры, видео серверы, мегапиксельные камеры, в том числе для некоторых производителей поддерживается работа со встроенными каналами звука (аудио), со встроенными датчиками и реле. Устанавливается вместе с мультимедиа сервером, но для работы с данным источником требуется наличие в прошивке ключа защиты компонента Сервер поддержки IP устройств.

Для того, чтобы попасть в его настройки, необходимо нажать кнопку button-04 и в появившемся меню выбрать "Редактировать". Здесь к GOALcity подключаются различные IP устройства: камеры, микрофоны, передатчики и т.д.

Для примера рассмотрим пункт "Камеры". При нажатии кнопки button-04 напротив него, появится меню в котором перечислены все интегрированные устройства. Выберите тип создаваемого IP-источника и перейдите к его настройкам. Укажите все необходимые для подключения данные и нажмите кнопку "Ок".

Теперь на диаграмме подключений в "Мультимедиа сервере" Вы увидите созданную IP-камеру. Осталось только ее подключить к окну GOALcity.

RTSP и FFSource или подключение IP камер с использованием кодека h264

FFSource - новая версия источника для работы с IP видео камерами через RTP и RTSP протокол передачи мультимедийных данных. Компонент использует программные библиотеки ffmpeg, которые распространяются в интернете на бесплатной основе. В некоторых случаях может использоваться для работы с устаревшим оборудованием и для клиентов прошивается по рекомендации службы технической поддержки Спецлаб. Устанавливается вместе с Мультимедиа сервером GOALcity.

Принцип создания источника очень похож на выше рассмотренный, только вместо IP адреса камеры используется rtsp ссылка на поток. Большое количество RTP ссылок для IP камер различных производителей Вы можете посмотреть по ссылке.

Откройте настройки "Мультимедиа сервера" описанным. Выберите пункт "FFSource" или "RTPSource".

Нажатием кнопки button-04 вызовите всплывающее меню и выберите "Добавить видео-источник". Откроется окно добавления нового источника.

Укажите все необходимые параметры и сохраните изменения. Аналогично прошлому примеру, созданный источник появиться в "Мультимедиа сервере" и останется только подключить его к окну GOALcity.

Подключение источника к окну

Выполнить подключения устройств к окнам GOALcity вручную очень просто. Подведите указатель мыши к виртуальной клемме first-start-15 соответствующего устройства (камеры, ключа, датчика, микрофона и т.д.). Указатель примет вид кисти руки, над которым появится описание данного сервера.

Теперь, нажав левую кнопку мыши, "протащите" возникшую пунктирную линию к пиктограмме "Новое подключение". Как только Вы доведете пунктир до виртуальной клеммы окна GOALcity, курсор "превратится" в кисть с вытянутым указательным пальцем. Отпустите кнопку мыши - процедура подключения одного из виртуальных источников завершена. Следует отметить, что подключения можно производить в одно окно, тем самым группируя источники.

Повторите описанные выше действия со всеми необходимыми источниками. Нажмите кнопку "Ок" в нижней части Диаграммы подключений для принятия изменений. После подключения в GOALcity появятся окна, отображающие видеосигнал с IP-камер.


Создание архива с помощью архивного сервера

Navigation: Быстрый старт >

Создание архива с помощью архивного сервера

Установите дистрибутив "Архивного сервера" - 3_Archive_Server_x64.exe (ранее файл назывался setupas_x64.exe). Запустите клиентскую часть GOALcity и произведите поиск серверов GOALcity. Отметьте галочками все найденные серверы и добавьте их на Диаграмму подключений.

Откройте настройки "Архивного сервера", кликнув правой кнопкой мыши на прямоугольнике "Сервер архива" и в появившемся меню выберите "Настроить...", либо дважды кликните по "шапке" сервера архивов.

Откроется окно настроек, которое поделено на две части. Слева располагается список основных пунктов в виде дерева, справа - окно, в котором производятся те или иные настройки.

Нажмите кнопку "Добавить" и затем "Создать" (либо "Подключить" если хотите использовать ранее созданный архив).

Укажите путь к папке, в которой будет храниться архив и укажите ограничения архива по:

·максимальному размеру архива;

·минимальному свободному месту на жестком диске;

·времени записи.

Для создания архива на сетевом диске или сетевом хранилище следует вручную вписать путь к архиву в диалоге добавления архива, не используя встроенный диалог выбора папки.

Путь будет выглядеть примерно так: \\192.168.10.150\Arh, а не как на рисунке выше.

Важно! Для корректного подключения сетевого диска необходимо в настройках служб Windows изменить тип входа в систему для службы SpecLab Server Host (slssh.exe) с системной учетной записи на учетную записью администратора или любого другого пользователя обладающего этими правами! Так же, необходимо убедиться, что пользователь, от которого будет загружаться служба имеет доступ по локальной сети в "расшаренную" для архива папку.

В рамках Архивного сервера можно создать неограниченное количество сетевых архивов!

Преимущество "Архивного сервера" перед локальным архивом состоит еще и в том, что можно создать неограниченное количество архивов на разных дисках и в каждый вести запись информации с любого количества источников. Таким образом, можно настроить запись так, что с одной группы источников запись идет в один архив, который находится на одном жестком диске, а с другой группы - на другой диск и т.д.

При достижении любого порогового значения ограничений, место под новые записи будет освобождаться путем удаления старых, т.е. активируется механизм самостирания.

Обратите внимание! Если при настройке архива было указано одно значение минимального свободного места, а затем изменено на большее, то освобождение дискового пространства произойдет не мгновенно, а в течении 15-30 минут работы GOALcity. Например, архив занимал на жестком диске 1,5 ТБ, изменяем его параметры и ставим ограничение размера в 500 ГБ. Сохраняем настройки. "Свободное место" появится в течении 15-30 минут.

Сохраните изменения нажатием кнопки "Ок". При этом в окне настроек сервера появится архив, имя архива совпадает с именем указанной папки.

После выполнения всех настроек Архивного сервера нажмите кнопку "Ок" и перейдите на Диаграмму подключений. От созданного сетевого архива протяните связь в новое окно клиента GOALcity.

После этого нажмите в правом нижнем углу "Диаграммы подключений" кнопку "Ок". Откроется клиент GOALcity с окном созданного архива.

В примере рассмотрено создание одного архива, но можно создать и несколько, поочередно

добавляя их указанным способом!


Настройка записи видео в архив

Navigation: Быстрый старт >

Настройка записи видео в архив

Выбор архива для записи

После создания архива и добавления видео источника необходимо включить запись видео.

Откройте настройки Вашего видео источника нажатием на кнопку button-settings на всплывающей в окне камеры панели управления и перейдите ко вкладке "Настройки" и затем к строчке "Архив".

Укажите созданный Вами архив в строке "Писать в архив".

В строке "Просматривать из окна камеры" выберите, каким образом система будет реагировать на нажатие кнопки button-play - "Архив" на всплывающей в окне камеры панели. Либо просматривать архив только выбранной камеры, либо открывать архив полностью, с возможностью выбора нескольких камер. Мы рекомендуем оставить значение "Записываемый", т.е. просмотр будет только выбранной камеры.

Что будем записывать?

Важно ничего не упустить! Перейдите на строчку "Контент" и отметьте галочкой "Записывать все кадры". Но можно активировать и "щедящий архив режим", и записывать только кадры по определенным событиям, например, только кадры с лицами или автомобильными номерами.

Настройка скорости и типа записи

Перейдите на вкладку "Запись". Если активировать "Минимальную избыточность", то система будет писать только те кадры, в которых присутствует детекция движения. Это сэкономит пространство на жестком диске, но т.к. записываться будут далеко не все кадры и не постоянно, велика возможность упустить что-либо важное.

"Средняя избыточность". Оптимальный для записи вариант. Активируйте данную строчку. Если не настроена страховочная запись (о чем чуть ниже), то в состоянии покоя (детектор движения не активен) система вести запись не будет, но как только в кадре появиться какое-либо действие (детектор движения активен) сразу же включиться запись со скоростью, указанной в поле "Скорость записи" на время или определенное количество кадров.

Рекомендуем использовать именно "Среднюю избыточность" для записи в архив.

Страховочная запись

Все же не стоит полностью полагаться на программный детектор движения, поэтому последней стадией настройте страховочную запись для камеры. Перейдите к строке "Страховка" и отметьте поле "Страховочная". При активации этой настройки система начнет непрерывную запись с указанной скоростью. Эта запись не влияет ни на какие другие виды записи и ведется непрерывно и постоянно.

Даже если Вы выключите запись по детекции и основную запись, страховочная запись все равно будет продолжаться.

Сохраните все изменения нажатием кнопки "Ок".

Не забудьте включить запись, щелкнув по кнопкам

и
на всплывающей панели в окне камеры.


HD-SDI и Аналоговое видео

Navigation: Быстрый старт >

HD-SDI и Аналоговое видео

Сигнал с HD-SDI камер обрабатывается с помощью плат на базе чипов "Gennum". Аналоговые камеры оцифровываются с помощью плат видеозахвата на базе АЦП "Philips", "Techwell", "Conexant".

Установка плат производится при выключенном компьютере!

Рекомендуем также отключить от системного блока все провода. Если это невыполнимо, необходимо отключить хотя бы шнур электропитания и все провода, связывающие компьютер с устройствами, подключенными к электросети (напрямую или через другие устройства). Не забудьте отключить и кабель локальной сети.

Установите плату видеозахвата в свободный PCI или PCI-E слот. При этом не применяйте чрезмерных усилий, чтобы случайно не повредить материнскую плату или слот.

·Закрепите плату в корпусе винтом;

·Закройте крышку корпуса;

·Подключите провода к разъёмам;

·Включите компьютер.

В данный момент система GOALcity может работать как с платами нашего производства, так и с платами китайских производителей. Системотехники Спецлаб разработали специальное дополнение к бортовой электронике китайских производителей - SpecLab WatchDog, следящее за критическими процессами работоспособности. Антизависающее устройство нивелирует ошибки драйверов, тем самым обеспечивая реальную надежность.

После установки плат и инсталляции программного обеспечения на диаграмме подключений появится Видеосервер GOALcity со всеми источниками видео. Источники, от которых система получает видеосигнал, будут подкрашены зеленым цветом, в противном случае источник будет подкрашен черным цветом.


Просмотр видео и настройки окна

Navigation: Быстрый старт >

Просмотр видео и настройки окна

Общее описание

Окно – главный элемент интерфейса для любой системы видеонаблюдения. Это полностью справедливо и для системы GOALcity. Помимо своего основного назначения – отображать информацию, поступающую от подключенного к нему источника (видеокамеры, микрофона, датчика и т. п.), в этой системе окно информирует пользователя о своих настройках и помогает их изменить. Не закрывая его и не убирая курсор мыши, можно выполнить множество самых разных настроек.

Обратите внимание! Для многомониторных конфигураций рекомендуем в настройках видеодрайвера "выстраивать" все мониторы в ряд (слева-направо) или столбик (сверху-вниз), но не совмещать такие расположения. Иначе при развертывании или сворачивании окна есть шанс "потерять" его на мониторах. Данная особенность связана с внутренней архитектурой видеодрайверов NVIDIA и ATI и внутренним распределением видеопамяти видеокарты.

Сразу под заголовком, уже непосредственно в окне, располагается полупрозрачная информационная строка (она может быть убрана при настройке свойств камеры). Когда она видна, на ней отображается различная информация: слева-направо расположены следующие индикаторы: разрешение кадра, включение режима увеличения кадра, программный автоконтраст, детектор движения, индикатор записи, текущая скорость записи (при условии, что запись настроена). По середине отображается название видеоисточника и в правом углу текущая скорость отображения видео в окне.

Функции всплывающей панели

Чтобы взывать служебную панель управления, необходимо навести курсор мыши на окно GOALcity, панель появится автоматически. Панель можно отключить в настройках свойств текущего окна, но мы рекомендуем оставлять панель включенной для более оперативной работы. По умолчанию выводятся самые необходимые в работе кнопки, но панель может "сдвигаться" вправо и влево, открывая дополнительные кнопки быстрых действий. Основные функции:

Чтобы включить\выключить постоянную запись нажмите на кнопку button-rec. Следующая кнопка button-dd активирует\деактивирует запись по детекции движения. Просмотр архива с текущей камеры вызывается нажатием на кнопку button-play. Чтобы перейти к настройкам текущего окна и камеры нажмите на кнопку button-settings. Если видеоизображение в окне пропало или "замерло" переподключить камеру поможет последняя кнопка button-reconect.

Следующие кнопки Панели управления предназначены для управления свойствами изображения. Увеличение области кадра, переворот кадра, масштабирование и прочие функции. Все кнопки снабжены всплывающими подсказками.

Окна, как типичные для ОС Windows, имеют заголовок. Они могут быть в двух состояниях: активном (заголовок подсвечен цветом) и неактивном (заголовок – серый).

"Ухватив" мышью окно за заголовок, Вы можете "перетащить" его в любое место Рабочего стола. А "взяв" за любую границу или уголок, произвольно изменять его размеры. Если "ухватить" одно окно и перетащить его на другое место на столе, удерживая при этом нажатой клавишу "Ctrl", то вместе с ним будут перемещаться все остальные окна программы и Главная панель управления.

У окна GOALcity, в правом верхнем его углу, отображаются две традиционные для Windows функции: "Скрыть" и "Развернуть/восстановить".

Четыре значка windows-02 в левой части заголовка окна имеют специфическое для GOALcity назначение.

Нажатие на первую кнопку windows-03 выведет контекстное меню окна. В данном меню продублированы все основные настройки видеоисточника и окна. Нажав вторую кнопку windows-04, Вы сделаете это окно образцом для других окон системы. Теперь, если нажать кнопку windows-05 в другом окне , то оно примет такие же размеры, как у отмеченного в качестве образца.

При нажатии кнопки windows-06 на экране появится окно с опциями, позволяющими настроить "поведение" данного окна при изменении его размеров.

Можно включить/отключить сохранение пропорций окна в обычном режиме и при блокировке. Если активировать пункт "Не сохранять", то размеры окна со всем его содержимым можно будет менять произвольно.

Контекстное меню окна

Чтобы взывать контекстное меню окна, необходимо кликнуть левой кнопкой мыши по кнопке windows-03 в заголовке окна или правой кнопкой в любом месте видеоизображения в окне. Откроется следующее меню:

·Команда "Развернуть" позволит отобразить окно "на весь монитор" или в реальном размере, (или в место, указанное с помощью опции "Зафиксировать позицию всплытия") если разрешение видео меньше чем разрешение вашего монитора.

·Команда "Скрыть" свернет окно с рабочего стола, но все настройки и параметры окна при этом сохранятся. Вернуть окно можно с помощью кнопки "Показать все" на главной панели управления.

·Команда "Закрыть" закроет выбранное окно, при этом все настройки, сделанные для этого окна и видео потока в нем будут утеряны.

·Команда "Зафиксировать позицию всплытия" позволяет указать размер и место в которое будет "разворачиваться" камера при выполнении команды "Развернуть", двойном клике мышкой по видео в окне или сработке событий SL++. То есть вы можете "перетащить" окно с помощью мыши в нужное вам место, задать его размер и включить данную опцию, в дальнейшем это окно будет "разворачиваться" именно сюда с сохраненными Вами размерами.

·Команда "Поверх других окон" заставит окно отображаться всегда сверху любых других элементов и интерфейсов как GOALcity так и других программ.

·Если в окно подключено несколько видеоисточников, то с помощью команды "Выстроить" можно запустить мастер расстановки камер, внутри окна.

·"Ручная расстановка" позволит расставить несколько видеоисточников внутри окна в ручном режиме, перетаскивая границы с помощью мыши.

·Команда "Транслировать" позволяет включить использование VSS-Ретранслятора для данного окна. Если функция включена, то активируется опция "Настройки трансляции" в которой можно указать разрешение и частоту кадров для данного транслируемого окна.

·Опция "Окно образец" запомнит размер данного окна, и позволит использовать опцию "По образцу" для других окон. Функция необходима для упрощения выстраивания и группирования окон на рабочем столе.

·Команда "Сохранить" сохраняет текущее окно в файл со всеми настроенными в нем параметрами.

·Самая нижняя строчка открывает параметры текущего видеоисточника в упрощенном виде.

Функция "пролистывания" в окне камеры.

Если "схватить" левой кнопкой мыши изображение в окне камеры и переместить его вправо, то мы увидим файл расположения (например, картинка с планом вашего объекта, на котором отмечено место установки данной камеры). Файл задается в настройках окна. Этим файлом может быть любое изображение в формате .bmp.

При перемещении изображения окна влево, мы увидим последние записи аналитики с данной камеры, (если данная опция включена в настройках камеры) при условии, что камера обрабатывается панелью "Внимание!". В правом верхнем углу окна будет мигать надпись "Архив", оповещая пользователя о том, что он смотрит уже запись. Перелистывать можно и дальше, в таком случае события, отображаемые в окне, будут отображаться от самого нового к старому.

Возврат к отображению видео в окне происходит автоматически при "бездействии" оператора в течении 10 секунд, обратным "перетаскиванием", либо двойным щелчком левой кнопки мыши по окну.

Сохранить текущий кадр с камеры можно с помощью настройки "Скриншоты" в основных настройках программы.

Масштабирование видео в окне просмотра

Масштабирование видео производится прямо в окне "живого" просмотра с помощью мыши и клавиатуры. Увеличенную область можно еще раз увеличить и так сколько угодно раз.

Чтобы увеличить видеоизображение, достаточно навести курсор мыши на желаемую область, зажать на клавиатуре клавишу "Ctrl" и "поскролить" колесиком мыши. Изображение масштабируется исходя из расположения курсора мыши в окне, другими словами, центрируется по нему.

Увеличение видео. Первый способ.

Также, можно увеличить определенную область зажав все туже клавишу "Ctrl" на клавиатуре, кликнув левой кнопкой мыши и, не отпуская кнопку, "нарисовать" прямоугольник поверх видео (аналог группового выделения файлов с помощью мыши). "Нарисованный" прямоугольник и будет увеличен на все окно просмотра.

Увеличение видео. Второй способ.

Увеличенную область изображения можно "таскать" по окну с помощью правой кнопки мыши при зажатой на клавиатуре клавише "Сtrl".

Чтобы вернуться к "реальной" картинке, кликните "колесиком" (средней кнопкой мыши) в любом месте видеоизображения.

Внешний вид и надписи

GOALcity позволяет добавить любую надпись в окно и отражать её поверх видео. Чтобы это сделать, откройте настройки камеры кликом по кнопке button-settings на всплывающей панели, перейдите на вкладку "Клиент", активируйте пункт "Надписи" и нажмите на кнопку с изображением шестеренки справа.

Откроется окно добавления и редактирования надписей.

·Кнопка "Добавить" позволяет создать новую надпись, кнопка "Изменить" - редактировать одну из уже созданных.

·Кнопки "Копировать", "Вставить" позволяют клонировать уже созданные надписи как для текущей камеры, так и для любой другой. То есть нажав кнопку "Копировать" и открыв параметры надписей для другой камеры можно вставить эту надпись туда.

Чтобы настроить текст, его положение в окне камеры, размер и другие параметры, выделите надпись которую необходимо изменить и нажмите кнопку "Изменить". Сам текст настраивается очень просто. Вы можете менять параметры и параллельно смотреть как они отображаются на внешнем виде роликов на панели "Внимание!".

Так же, вместо обычного текста Вы можете использовать переменные:

·%t - выведет текущее время поверх видеоизображения в формате Ч:М

·%T - вермя в формате Ч:М:С

·%d - выведет текущую дату, а %D текущую дату с указанием дня недели.


Установка видеосервера

Navigation: Установка компонентов >

Установка видеосервера

После того, как Вы установите платы видеозахвата в компьютер и начнёте загружать операционную систему, Windows сообщит об обнаружении новых устройств и предложит установить для них драйверы. На данном этапе следует отказаться от автоматической установки драйверов. Это позволит корректно установить все необходимые драйверы при инсталляции клиентской программы.

Важно! Программа использует электронный аппаратный ключ защиты Guardant Sign или Guardant Stealth-II. Убедитесь, что Вы скопировали файл license.txt в корневой каталог диска, на который установлена операционная система перед запуском программы. Без файла-лицензии программа будет работать в демо-режиме. Если в системе используется ключ Stealth-II то необходимо дополнительно вручную установить драйвера на ключ защиты!

·Инсталляцию системы нужно проводить, загрузив ОС под именем пользователя, обладающего правами администратора этого ПК;

·Система GOALcity должна работать в сеансе того пользователя ОС, который производил инсталляцию системы

·Категорически запрещается работать одновременно под разными пользователями ОС, каждый из которых запускает свой сеанс GOALcity.

Запустите исполняемый файл 4_Analog_Video_Server_x64.exe (ранее файл назывался setupgc_x64.exe). Мастер установки предложит выбрать используемый язык программы. Если Вы ошиблись с выбором языка, его можно будет изменить позже, используя Tweaker GOALcity.

Обратите внимание! Если Вы устанавливаете систему на серверную ОС (Windows Server 2016), первым дистрибутивом необходимо установить файл 6_Windows_Server_OS_x64.exe (ранее файл назывался setup_winsrv_x64.exe), и только затем остальные компоненты GOALcity.

Затем, на мониторе Вы увидите окно "Установка GOALcity", в котором отображается версия программы и номер сборки.

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена" (текст лицензионного соглашения будет показан только при "чистой" установке программы, если любой из компонентов уже установлен, то мастер автоматически пропустит этот шаг).

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции"Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск".

Затем, мастер откроет окно "Опции установки", предлагающее три варианта инсталляции. К каждому из них даны достаточно подробные пояснения, поэтому выбрать нужный вариант не трудно.

Будьте внимательны! Если при установке на клиентское место (ПК, на котором нет плат видеозахвата) выбрать первый пункт "Будет установлен ВИДЕОСЕРВЕР и ВИДЕОКЛИЕНТ.", то после запуска GOALcity программа будет постоянно сообщать об ошибке ключа защиты.

После этого мастер предложит выбрать какие из плат используются в системе - тип А, B, C или D. Все платы промаркированы необходимой буквой в верхней части, рядом с креплением в системный блок. Выберите нужные и нажмите кнопку "Далее".

Начнется процесс записи файлов программы на ПК, ход которой отображается в окне "Копирование файлов", пожалуйста, немного подождите.

Примерно на 50% общего процесса установки начнется распаковка и установка драйверов на платы SL-4, SL-8 и SL-16. Следуйте указаниям мастера установки.

Важно! После окончания процесса установки драйверов на платы видеозахвата необходимо отказаться от перезагрузки ПК и полностью завершить установку GOALcity.

Если программа, вернее компонент программы, устанавливается впервые (т.е. других компонентов на ПК еще нет) то по окончании, мастер установки предложит перезагрузить ПК. Как правило, GOALcity требует установки нескольких компонентов, поэтомуможно перезагрузить ПК после установки всех.


Установка клиента

Navigation: Установка компонентов >

Установка клиента

GOALcity – сетевая система, основная её особенность заключается в том, что различные ее составные части (программно-аппаратные компоненты) могут работать на разных компьютерах, объединенных в сеть. Так компьютер оператора (клиент) может находиться в одном месте, а ПК с платой или платами видеозахвата – в другом, удаленном от первого.

Важно! Программа использует электронный аппаратный ключ защиты Guardant Sign или Guardant Stealth-II. Убедитесь, что Вы скопировали файл license.txt в корневой каталог диска, на который установлена операционная система перед запуском программы. Без файла-лицензии программа будет работать в демо-режиме. Если в системе используется ключ Stealth-II то необходимо дополнительно вручную установить драйвера на ключ защиты!

·Инсталляцию системы нужно проводить, загрузив ОС под именем пользователя, обладающего правами администратора этого ПК;

·Система GOALcity должна работать в сеансе того пользователя ОС, который производил инсталляцию системы

·Категорически запрещается работать одновременно под разными пользователями ОС, каждый из которых запускает свой сеанс GOALcity.

Запустите исполняемый файл 1_GOALcity_Client_x64.exe (ранее файл назывался setupcc_x64.exe). Мастер установки предложит выбрать используемый язык программы. Если Вы ошиблись с выбором языка, его можно будет изменить позже, используя Tweaker GOALcity.

Затем, на мониторе Вы увидите окно "Установка GOALcity Client", в котором отображается версия программы и номер сборки.

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена" (текст лицензионного соглашения будет показан только при "чистой" установке программы, если любой из компонентов уже установлен, то мастер автоматически пропустит этот шаг).

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции "Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск".

Затем, мастер откроет окно "Опции установки", предлагающее варианты инсталляции. К каждому из них даны достаточно подробные пояснения, поэтому выбрать нужный вариант не трудно.

После этого шага мастер предложит Вам установить серверную часть GOALmobile 2. Если Вы используете GOALmobile 2, то отметьте поле галочкой и нажмите "Далее".

Затем, мастер откроет окно "Опции повторной установки". Отметьте "птичками" необходимые действия: если нужно удалить все предыдущие настройки GOALcity - "Удалить файлы настроек". Если драйвера на ключ защиты Guardant уже установлены в системе, и переустанавливать их нет необходимости - "Не переустанавливать драйверы ключа защиты". Нажмите кнопку "Установить".

Начнется процесс записи файлов программы на ПК, ход которой отображается в окне "Копирование файлов", пожалуйста, немного подождите.


Установка мультимедиа сервера

Navigation: Установка компонентов >

Установка мультимедиа сервера

Запустите исполняемый файл 2_IP_Server_x64.exe (ранее файл назывался setupvss_x64.exe). На мониторе Вы увидите окно "Установка Support Server", в котором отображается версия программы и номер сборки.

Важно! Программа использует электронный аппаратный ключ защиты Guardant Sign или Guardant Stealth-II. Убедитесь, что Вы скопировали файл license.txt в корневой каталог диска, на который установлена операционная система перед запуском программы. Без файла-лицензии программа будет работать в демо-режиме. Если в системе используется ключ Stealth-II то необходимо дополнительно вручную установить драйвера на ключ защиты!

·Инсталляцию системы нужно проводить, загрузив ОС под именем пользователя, обладающего правами администратора этого ПК;

·Система GOALcity должна работать в сеансе того пользователя ОС, который производил инсталляцию системы

·Категорически запрещается работать одновременно под разными пользователями ОС, каждый из которых запускает свой сеанс GOALcity.

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена" (текст лицензионного соглашения будет показан только при "чистой" установке программы, если любой из компонентов уже установлен, то мастер автоматически пропустит этот шаг).

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции"Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск".

После этого мастер откроет окно "Опции повторной установки". Отметьте "птичками" необходимые действия: если нужно удалить все предыдущие настройки GOALcity - "Удалить файлы настроек". Если драйвера на ключ защиты Guardant уже установлены в системе, и переустанавливать их нет необходимости - "Не переустанавливать драйверы ключа защиты". Нажмите кнопку "Установить".

Начнется процесс записи файлов программы на ПК, ход которой отображается в окне "Копирование файлов", пожалуйста, немного подождите.

Завершите установку Мультимедиа сервера нажатием кнопки "Готово".


Установка архивного сервера

Navigation: Установка компонентов >

Установка архивного сервера

Запустите исполняемый файл 3_Archive_Server_x64.exe (ранее файл назывался setupas_x64.exe). На мониторе Вы увидите окно "Установка Archive Server", в котором отображается версия программы и номер сборки.

Важно! Программа использует электронный аппаратный ключ защиты Guardant Sign или Guardant Stealth-II. Убедитесь, что Вы скопировали файл license.txt в корневой каталог диска, на который установлена операционная система перед запуском программы. Без файла-лицензии программа будет работать в демо-режиме. Если в системе используется ключ Stealth-II то необходимо дополнительно вручную установить драйвера на ключ защиты!

·Инсталляцию системы нужно проводить, загрузив ОС под именем пользователя, обладающего правами администратора этого ПК;

·Система GOALcity должна работать в сеансе того пользователя ОС, который производил инсталляцию системы

·Категорически запрещается работать одновременно под разными пользователями ОС, каждый из которых запускает свой сеанс GOALcity.

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена" (текст лицензионного соглашения будет показан только при "чистой" установке программы, если любой из компонентов уже установлен, то мастер автоматически пропустит этот шаг).

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции "Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск".

После этого мастер откроет окно "Опции повторной установки". Отметьте "птичками" необходимые действия: если нужно удалить все предыдущие настройки GOALcity - "Удалить файлы настроек". Если драйвера на ключ защиты Guardant уже установлены в системе, и переустанавливать их нет необходимости - "Не переустанавливать драйверы ключа защиты". Нажмите кнопку "Установить".

Начнется процесс записи файлов программы на ПК, ход которой отображается в окне "Копирование файлов", пожалуйста, немного подождите.

Завершите установку Архивного сервера GOALcity нажатием кнопки "Готово".


Установка аудиосервера

Navigation: Установка компонентов >

Установка аудиосервера

Запустите исполняемый файл 5_Analog_Audio_Server_x64.exe (ранее файл назывался setupacs_x64.exe). На мониторе Вы увидите окно "Установка Audio Server", в котором отображается версия программы и номер сборки.

Важно! Программа использует электронный аппаратный ключ защиты Guardant Sign или Guardant Stealth-II. Убедитесь, что Вы скопировали файл license.txt в корневой каталог диска, на который установлена операционная система перед запуском программы. Без файла-лицензии программа будет работать в демо-режиме. Если в системе используется ключ Stealth-II то необходимо дополнительно вручную установить драйвера на ключ защиты!

·Инсталляцию системы нужно проводить, загрузив ОС под именем пользователя, обладающего правами администратора этого ПК;

·Система GOALcity должна работать в сеансе того пользователя ОС, который производил инсталляцию системы

·Категорически запрещается работать одновременно под разными пользователями ОС, каждый из которых запускает свой сеанс GOALcity.

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена" (текст лицензионного соглашения будет показан только при "чистой" установке программы, если любой из компонентов уже установлен, то мастер автоматически пропустит этот шаг).

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции"Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск".

После этого мастер предложит выбрать какие из плат используются в системе - тип А, B, C или D. Все платы промаркированы необходимой буквой в верхней части, рядом с креплением в системный блок. Выберите нужные и нажмите кнопку "Далее".

Следующий шаг окно "Опции повторной установки". Отметьте "птичками" необходимые действия: если нужно удалить все предыдущие настройки GOALcity - "Удалить файлы настроек". Если драйвера на ключ защиты Guardant уже установлены в системе, и переустанавливать их нет необходимости - "Не переустанавливать драйверы ключа защиты". Нажмите кнопку "Установить".

Начнется процесс записи файлов программы на ПК, ход которой отображается в окне "Копирование файлов", пожалуйста, немного подождите.

Завершите установку Аудио сервера нажатием кнопки "Готово".


Главное меню

Navigation: Настройка >

Главное меню

Нажатием первой кнопки Главной панели управления main-menu-button или щелчком правой кнопкой мыши по значку программы в системном трее (рядом с часами) вызывается Главное меню программы.

Главное меню поделено горизонтальными пробелами на секции. В каждой из секций содержится несколько команд.

Первая сверху секция содержит всего три команды "Развернуть", "Свернуть" и "Спрятать". После выбора команды "Свернуть", окна клиентской программы будут убраны с экрана. Чтобы их восстановить, необходимо обратиться к иконке программы, находящейся в системном трее, и, кликнув по ней правой клавишей мыши, выбрать в открывшемся меню команду "Развернуть". Воспользовавшись командой "Спрятать", вы уберете не только окна программы, но и все следы ее работы, в том числе и иконку в системном трее. При этом сама система продолжает функционировать так же, как и до запуска команды. Если включена, то ведётся запись поступающей информации, срабатывают детекторы и т.д. Но тому, кто смотрит на монитор это не заметно. Теперь, чтобы восстановить "спрятанный" интерфейс, нужно ввести с клавиатуры комбинацию клавиш, которую вы назначили при настройке программы в меню "Загрузка". По умолчанию это клавиши "Ctrl+Alt+G". Назначенную комбинацию клавиш необходимо запомнить, иначе, чтобы вернуть на экран программу, придется прибегать к некоторым хитростям, известным опытным пользователям Windows, чтобы закрыть программу и запустить ее снова, либо – к перезагрузке операционной системы.

Ниже этих двух строк – новый раздел Главного меню - Настройки размещения окон на экране. Нажатие мышью по первой строке этого меню - "Выстроить по умолчанию" приведет к тому, что окна всех камер разместятся посредине свободного пространства Рабочего стола. То есть, если, к примеру, у вас пару строк в нижней части дисплея занимают Панель задач и Панель быстрого запуска программ операционной системы Windows, а вверху экрана место "забито" еще каким-нибудь из многочисленных "украшений" Рабочего стола, то окна вместе с Панелью управления GOALcity расположатся посредине оставшегося свободным пространства.

Нажатие на строку "Настроить размещение" откроет окно "Менеджер размещения", в котором можно сохранить созданную схему расположения окон, создать новую, или загрузить сохраненную ранее.

Чтобы создать новую схему размещения окон выберите в соответствующих окошках в верхней части Менеджера размещения желаемое их количество по ширине рабочего стола и по его высоте. На иллюстрации отображено окно со схемой 3 х 4. Если хотите сохранить созданную схему, нажмите кнопку "Сохранить", созданная схема появится в окошке в правой части Менеджера размещений. Теперь, при каждом обращении к этой опции, здесь будут условно отображаться все ранее сохранённые схемы размещений окон. Для загрузки той, которая необходима в данный момент, выберите ее, нажмите сначала кнопку "Разместить", а затем "Ок". Окна камер разместятся на Рабочем столе компьютера в соответствии с выбранной схемой и займут на нём максимально возможное пространство с сохранением пропорций кадра.

Ниже раздела с настройками размещения окон есть еще один, содержащий всего одну строку. Здесь можно переключить внешний вид Главной панели управления. Предоставляются две опции: "Полный вид" – со всеми кнопками, и "Сокращенный вид" – при котором видны только часть кнопок.

В следующем разделе Главного меню собраны команды, управляющие конфигурациями. Клик по строчке "Автоконфигурация" выведет на экран предупреждение о том, что текущая конфигурация будет утеряна. И, если вы ответите согласием, перед вами откроется "Диаграмма подключений" точно в таком же виде, как при первом запуске клиентской программы.

·После запуска команды "Загрузить конфигурацию" откроется окно Проводника Windows в каталоге, куда вы записали последнюю сохраненную конфигурацию системы (по умолчанию – это "C:\Program Files\Speclab\GOALcity\..."), предоставив вам возможность выбрать нужный из файлов с расширением *.cfg.

·Команда "Загрузить последнюю конфигурацию" позволяет выбрать и загрузить одну из последних сохраненных конфигураций.

·Команда "Сохранить конфигурацию как…" откроет дополнительное окно, в котором Вам предоставляется выбор какую из конфигураций программы необходимо сохранить. Можно сохранить клиентские настройки, основную конфигурацию и сохранить конфигурацию в файл.

Сохранив основную конфигурацию программы, Вы запишите текущее расположение окон, Главной панели и других открытых элементов клиентской программы в качестве основной. Именно она будет запускаться при нажатии кнопки main-menu-05 "Восстановить основную конфигурацию" Главной панели управления или при выполнении команды "Загрузить основную конфигурацию" Главного меню программы.

Рекомендуем! Когда Вы создадите оптимальную конфигурацию интерфейса клиентской программы, воспользоваться командой "Сохранить основную конфигурацию". Тогда в случае, если после экспериментов операторов с окнами и панелями, интерфейс превратится в малопонятную мешанину картинок, Вы всегда сможете восстановить основную конфигурацию программы одним нажатием кнопки на Главной панели управления.

Следующие команды описаны в соответствующих разделах: "Настройка программы", "Настройка подключений", "Настройка заданий", "Групповые настройки".

·Строка "Смена пользователя" выводит диалоговое окно и предлагает ввести имя пользователя и пароль, аналог кнопки на Главной панели программы.

· "Настройка событий SL++", "Настройка планов", "Настройка панели "Внимание!" также подробно рассмотрены в настоящем руководстве.

·Панель "Розыск". Позволяет вывести на экран панель отображать на ней фотографии или любую другую графическую информацию.

Настраивается панель "Розыск" очень просто: после активации соответствующего пункта в главном меню, на экране появится чистая панель. Нажмите на кнопку и вызовите меню, в нем выберите команду "Добавить фото". Фотография появится на панели. Панель масштабируется и подгоняется под необходимый размер, чтобы рационально использовать пространство рабочего стола. Чтобы удалить одно из фото с панели, достаточно щелкнуть по нему правой кнопкой мыши и в контекстном меню выбрать команду "Удалить".

·Команда "Просмотр журнала" откроет "Журнал", в котором регистрируются все действия Пользователя и манипуляции с программой.

·"Фоновые задачи" - эта команда открывает окно, в котором показывается список выполняемых в фоновом режиме задач программы.

·"Статистика" позволяет выбрать и отобразить статистику записи в архив и сетевую статистику.

·Команда "GOALcity в Интернете" откроет в браузере официальный сайт. Команда "Справка" откроет интегрированную в программу справочную систему.

·Функция "Отменить действия с окном" - отменяет последнее действие пользователя с окном программы, аналог кнопки main-menu-12 Главной панели управления.

·Строка "Показать главную панель" пригодится в случае, когда пользователь случайно скрыл главную панель программы, например, за край монитора или потерял под окнами камер, эта функция вернет ее на экран.

·Пункт меню "О программе" выведет окно с информацией о версии программы, ID ключа защиты, сетевом имени, IP-адресе компьютера, о том, кто и когда запустил программу и о времени её работы.

·Команда "Выход" предлагает выбрать одно из четырех действий: завершить программу, завершить программу и службу, перезапустить программу, перезапустить программу и службу.

Примечание. Перезапуск службы может потребоваться после добавления какого-либо оборудования (например, хаба, подключенного к USB порту), так как с устройствами работает только служба, и "подцепляет" их только в момент запуска.


Главная панель управления

Navigation: Настройка >

Главная панель управления

Основным элементом управления GOALcity является Главная панель. По умолчанию она выглядит так:

Информацию о назначении кнопок дает всплывающая при подведении к ней указателя мыши подсказка.

Функции кнопок

main-menu-button Кнопка вызова Главного меню программы. Она имеет два состояния: в неактивном она выглядит как центральный затвор фотоаппарата или ирисовая диафрагма, раскрывающаяся при наведении на неё указателя мыши. В активном – меняется её цвет и появляется стилизованная буква «G», клик по которой вызывает Главное меню программы.

За кнопкой Главного меню программы следует блок кнопок main-panel-04 для управления окнами и видами GOALcity.

main-panel-05 "Закрепить размещение окон" – нажатие данной кнопки фиксирует расположение окон на дисплее, после чего их невозможно куда-либо переместить (такой режим называется - "Режим блокировки"). При закреплении размещения заголовки окон исчезают, блокируются возможности переключения конфигурации, свертывания окон, завершения программы, включения/выключения записи по детекции, открытия диаграммы подключений, включения воспроизведения архивных записей и переключения пользователей.
main-panel-06 Кнопка "Показать все" - разворачивает все свернутые окна и делает их видимыми. Любое из окон может быть свернуто (скрыто) двумя способами: нажатием пиктограммы "Свернуть" (точно такой же, как в любой программе, работающей в ОС Windows), либо путем выбора команды "Скрыть" из контекстного меню, раскрывающегося при нажатии правой кнопки мыши в окне.
main-panel-07 Кнопка "Автоматического переключения видов" - Включение опции периодической смены расположения окон (видов). Интервал смены можно установить в настройках программы в разделе "Вид".

main-panel-08 Кнопка сохранения текущего вида расположения окон - Чтобы запомнить текущий внешний вид программы (схему расположения окон), нажмите кнопку "M" (Memory), затем выберите одну из трех кнопок активации (А, В или С) и введите название сохраняемой схемы.

После блока кнопок управления окнами и видами следует фирменный логотип программы. Справа потянув мышью за колесико вниз, либо кликая по "стрелочкам" вверх и вниз, мы получим доступ к дополнительным кнопкам панели управления.

main-panel-11 Кнопки активации запуска проигрывателя записей локального или сетевого архива (Примечание: если установлен Архивный сервер, то проигрыватель запустится только для подключенных к окнам GOALcity сетевых архивов); смена пользователя программы, (GOALcity – многопользовательская система. По умолчанию первый раз она загружается для пользователя с правами администратора. Он может менять все настройки системы, в том числе и создать неограниченное количество новых пользователей, присвоив каждому из них разные права), и кнопка открытия диспетчера подключений GOALcity.
main-panel-09 Кнопки переключения различных схем расположения окон. Кнопки активируются только после сохранения "на них" одного из вида расположения окон. При нажатии кнопки окна расположатся в соответствии с сохраненными настройками. На каждую кнопку можно сохранить до 256 схем расположения окон. Для удаления схемы размещения необходимо сначала нажать main-panel-08, затем выбрать одну из трех кнопок, на которой сохранена данная схема размещения, написать её название или выбрать из выпадающего списка, и нажать "Удалить". После этого нужно нажать кнопку "Отмена", иначе, если нажать кнопку "Ок", схема будет повторно сохранена.
main-panel-12 Кнопки активации программируемых клавиш. Программирование осуществляется в основных настройках GOALcity.
main-panel-13 Кнопки активации дополнительных аналитических алгоритмов (активация происходит для камер, у которых предварительно настроены данные алгоритмы). Первая кнопка активирует отображение истории детекции движения, вторая - траектории движения объектов в кадре, третья - направление движения.

При нажатии кнопки main-menu-05 загрузится основная конфигурация системы.

Если Вы случайно подвинули одно из окон и хотите вернуть его на место нажмите на кнопку main-menu-12. Кнопка main-panel-strahovka включает\отключает страховочную запись, которая задается в настройках видео источников.

Управление основными функциями.

Кнопка main-panel-rec включает/выключает запись информации со всех источников системы (видео, аудио, датчики и т. п.).

Кнопка main-panel-dd включает/выключает запись по детекции изменения информации со всех источников. Программой предусматривается также включение/выключение записи по детекции по каждому источнику в отдельности.

Кнопка main-panel-slpp предназначена для активации/дезактивации Событий SL++ и событий на 3D-плане. После включения соответствующая кнопка становится яркой, пиктограмма занимает всю область кнопки.

Кнопка main-panel-comment создания комментария - служит для добавления текстового комментария ко всей записываемой в данный момент информации. По комментарию можно быстро отыскать запись в архиве.

Две последние кнопки main-panel-close Главной панели управления такие же, как в заголовке любой программы операционной системы Windows и имеют такое же назначение: "Свернуть программу" и "Закрыть программу". Также для закрытия программы можно воспользоваться привычной комбинацией клавиш "Alt+F4". По команде закрытия GOALcity, откроется диалоговое окно, в котором следует выбрать одно из четырех действий: завершить программу, завершить программу и службу, перезапустить программу, перезапустить программу и службу.

Примечание. Перезапуск службы может потребоваться после добавления какого-либо оборудования (например, хаба, подключенного к USB порту).

Главную панель управления можно увеличивать и уменьшать до нужного Вам размера, качество отрисовки иконок-кнопок на ней при этом не пострадает. Её также можно свободно перемещать по экрану (если не нажата кнопка"Закрепить размещение окон").

Через Главное меню программы можно включить "Сокращённый вид" Главной панели. В этом случае на ней будет отображаться минимум элементов управления.

Для того, чтобы вернуть "Полный вид" – со всеми кнопками, необходимо войти в Главное меню программы и выбрать соответствующий пункт.


Диаграмма подключений

Navigation: Настройка >

Диаграмма подключений

Общее описание

Чтобы открыть "Диаграмму подключений" GOALcity выберите в Главном меню программы строчку "Настройка подключений", или нажмите на Главной панели управления кнопку diagramma-03.

Все кнопки в этом окне сосредоточены в правой его части и снабжены всплывающими подсказками при наведении на них указателя мыши.

Первая из кнопок - "Добавить" - открывает окно "Поиск серверов", с помощью которого производится подключение к серверам GOALcity (Видеосервер, Аудиосервер, Мультимедиа сервер, Архивный сервер).

Важная информация! Пользователю клиентской части должны быть даны соответствующие права на сервере. Т.е. активная учетная запись клиента должна полностью совпадать с разрешенной учетной записью сервера. Например, пользователю "Администратор" (по умолчанию ему разрешено все) на Мультимедиа сервере (и/или видео сервере и т.д.) назначили пароль. Если на клиентской части, которой подключаются к данному серверу, не назначить такой же пароль "Администратору" и не сделать его активным, то к серверу подключиться не получится!

В целях безопасности, как правило, пользователю "Администратор" назначают пароль и создают другого пользователя, которому дают права, например, только на подключение и просмотр. На сервере можно создать несколько подобных пользователей с ограниченными правами. Делается это для разграничения прав для различных клиентов. Например, одним мы разрешим настройки и просмотр, другим мы разрешим только просмотр определенных камер, третьим мы дадим права на создание других пользователей - сделаем их так называемыми "провайдерами ресурсов" и т.д.

Для подключения к серверу, на клиенте GOALcity необходимо создать определенного пользователя (такого же, как и на сервере), дать ему права в самой клиентской программе, сделать его активным (залогиниться под ним) и, собственно, выполнить подключение к серверу.

Чтобы подключить сервера установленные на этом же компьютере - отметьте пункт "На этом компьютере", если на другом - поставьте отметку "На компьютере" и в рядом расположенном поле впишите его IP адрес, а в другом поле - порт (по умолчанию 3107). После нажатия кнопки "Далее" запустится поиск серверов.

При этом учетные записи на сервере и на клиенте должны совпадать. Т.е. на сервере, к которому подключается клиент, должна быть учетная запись с соответствующими правами и паролем, и именно такая же учетная запись с тем же именем и паролем должна быть на клиенте. В противном случае при поиске не будет найдено ни одного сервера по указанному адресу, никаких уведомлений или ошибок выдаваться не будет. Надо иметь ввиду, что при сетевом подключении серверов системы GOALcity их настройки (IP-адреса и порты) лучше уточнить у системного администратора (если сервера находятся в локальной сети) или у провайдера (если сервера находятся в сети Интернет).

Время поиска серверов, установленных на локальном компьютере, порой может превышать 5 минут. Причин может быть несколько: высокая загрузка процессора, большое количество установленных серверов, наличие ключей Guardant для работы с другими программами.

В случае поиска серверов на большом количестве компьютеров в локальной сети отметьте "В сети" и нажмите кнопку "Далее".

Чтобы добавить или изменить диапазон поиска, нажмите кнопку "Добавить" или "Изменить" соответственно, откроется окно выбора диапазона IP-адресов для поиска. Если этот диапазон неизвестен, то лучше уточнить его у системного администратора, иначе поиск может занять очень много времени, даже если установить максимальную скорость. Для начала поиска нажмите "Далее".

По окончанию поиска откроется окно "Результаты поиска". Выберите необходимые сервера, поставив напротив них галочку, нажмите кнопку "Завершить" - сервера добавятся на Диаграмму подключений.

Обратите внимание на треугольник в заголовке сервера после его сокращенного названия и IP-адреса. Когда острый угол треугольника обращен вниз, то на схеме отображаются все камеры сервера.

Если кликнуть по треугольнику мышью, то на схеме сервера останутся только те из камер, которые подключены к окнам клиента.

Стрелка-треугольник в этом случае повернется на 90 градусов против часовой стрелки и будет направлена вправо.

Нажатие "крестика" в правом углу заголовка сервера приведет к удалению его из Диаграммы подключений. При этом из интерфейса клиентской программы удалятся и все камеры этого сервера, а в соответствующих им окнах появится надпись: "Отключено".

Аналогично "крестику" действует кнопка Диаграммы подключений "Удалить". Чтобы она сработала, необходимо сначала выделить нужный сервер, кликнув в любой точке его схематического изображения (при этом вокруг него возникнет пунктирная линия) и нажать кнопку "Удалить". Чтобы открыть контекстное меню сервера, щелкните правой кнопкой мыши по "шапке" сервера.

·Команда меню "Обновить" произведёт Актуализацию сервера, т.е. проверит его версию, доступность, количество подключенных и активных камер.

·Действие команды "Настроить" аналогично результату нажатия кнопки "Свойства" Диаграммы подключений, т.е. вызов настроек текущего сервера.

·Команда "Удалить" аналогична нажатию "крестика" в правом углу данного сервера - удаление выбранного сервера.

Следующие три команды позволяют производить групповое подключение камер.

·"Подключить активные" - подключает к окнам GOALcity только те источники, от которых есть сигнал (выделяются зеленым цветом).

·"Подключить выбранные" - подключает только выбранные камеры к окнам GOALcity. Несколько камер можно выбрать с зажатой кнопкой "Ctrl" на клавиатуре.

·"Подключить все" - подключает к окнам GOALcity все источники.

Кнопка "Выстроить" в правой части "Диаграммы подключений" поможет вам "навести порядок" - автоматически расставит по местам схемы серверов.

Кнопки с пиктограммами луп diagramma-14 (одна со знаком "минус", другая – с "плюсом") соответственно уменьшат или увеличат масштаб отображения элементов "Диаграммы подключений". Особенно полезны эти кнопки, когда в системе задействовано большое количество камер.

И последняя в этом ряду кнопка с двумя полосками (прямой и ломаной) служит для переключения режима отображения соединений камер и окон GOALcity. Клик по кнопке "Подключить" вызовет окно "Стиль подключения", в котором можно настроить количество камер, информация от которых будет отображаться в одном окне.

Подключение источника к окну

Выполнить подключения устройств к окнам GOALcity вручную очень просто. Подведите указатель мыши к виртуальной клемме first-start-15 соответствующего устройства (камеры, ключа, датчика, микрофона и т.д.). Указатель примет вид кисти руки, над которым появится описание данного сервера.

Теперь, нажав левую кнопку мыши, "протащите" возникшую пунктирную линию к пиктограмме "Новое подключение". Как только Вы доведете пунктир до виртуальной клеммы окна GOALcity, курсор "превратится" в кисть с вытянутым указательным пальцем. Отпустите кнопку мыши - процедура подключения одного из виртуальных источников завершена. Следует отметить, что подключения можно производить в одно окно, тем самым группируя источники.

Повторите описанные выше действия со всеми необходимыми источниками. Нажмите кнопку "Ок" в нижней части Диаграммы подключений для принятия изменений. После подключения в GOALcity появятся окна, отображающие видеосигнал с IP-камер.


Основные настройки

Navigation: Настройка >

Основные настройки

Чтобы попасть в основные настройки GOALcity, откройте главное меню и выберите строчку "Настройка программы".

tipbulb Смотрите также:

· Вкладка "Вид"

· Вкладка "Загрузка"

· Вкладка "Пользователи"

· Вкладка "Доступ"

· Вкладка "Видео"

· Вкладка "Аудио"

· Вкладка "Архив"

· Вкладка "Журнал"

· Вкладка "Интеграция"

· Вкладка "Настраиваемые кнопки"

· Вкладка "Надежность"

· Вкладка "Обновления"


Вкладка "Вид".

Navigation: Настройка > Основные настройки >

Вкладка "Вид"

На вкладке "Вид" собраны настройки, отвечающие за внешний вид программы, пропорции окон при автоматическом выстраивании и прочие "косметические" настройки.

·"Размер окна при выстраивании" - здесь Вы указываете и высоту каждого окна (пропорции), которые установятся при автоматическом выстраивании на "текущий" или "виртуальный рабочий стол". По умолчанию - 640*480.

·"Размер окна при максимизации в процентах от размера экрана" - если дважды щелкнуть по окну нему левой кнопкой мыши, то оно увеличится в размерах и всплывет по середине монитора. Этим параметром Вы регулируете масштаб увеличения. Таким образом, если выставить здесь "100%" и "максимизировать" любое окно, то оно "развернется" на весь монитор.

·"Задержка на переключение при автоматической смене расположения окон" - данный параметр отвечает за периодичность смены сохраненных схем расположения окон.

Чтобы отключить отображение часов на Главной панели GOALcity, снимите галочку "Отображать часы в главной панели", и наоборот, если Вы хотите отображать регулятор нагрузки на ЦП, то поставьте "птичку" в поле "Отображать регулятор нагрузки в главной панели".

Если поставить галочку в окно "Всплытие с авторасположением окон", то будут доступны настройки, с помощью которых можно установить минимальное и максимальное время всплытия окна, например, по детекции движения или по какому-либо событию. Зафиксировать положение и размер окна при всплытии можно следующим образом: выбрать необходимое окно, вручную изменить его размер, местоположение, как Вам нужно, нажать на правую кнопку мыши в данном окне и в появившемся меню выбрать "Зафиксировать позицию всплытия".

·Опция "Отображать кнопку закрытия окна" добавляет на панели управления окном еще одну кнопку, с помощью которой можно быстро закрыть текущее окно. По умолчанию эта возможность отключена чтобы пользователь случайно "непозакрывал" окна и прервал запись и обработку видео.

Режим восстановления вида требуется для восстановления одного из сохраненных в GOALcity видов, чтобы избежать перемещения окон GOALcity и вернуть все в исходный заранее настроенный вид. Выберите необходимый вид в поле "Вид" и установите необходимый интервал времени для его загрузки.


Вкладка "Загрузка"

Navigation: Настройка > Основные настройки >

Вкладка "Загрузка"

В данном разделе настраиваются опции загрузки клиентской программы.

GOALcity может загружаться автоматически при старте Windows, свернутой в маленький значок (иконку) в системном трее или загружаться скрытой (для активации опций необходимо поставить флажки в соответствующие клетки). Здесь же можно сменить комбинацию клавиш для выхода из скрытого режима. Скрытый режим полностью убирает с монитора весь интерфейс программы, оставляя работать его скрыто для пользователя. Чтобы вернуть интерфейс на место, необходимо нажать комбинацию клавиш, указанную в поле "Комбинация клавиш для выхода из скрытого режима". Очень важно помнить эту комбинацию.

·Поле "Загружать основную конфигурацию" активизирует постоянную загрузку ранее сохраненной основной конфигурации программы.

Обратите внимание, что для корректной работы автозагрузки программы под ОС Windows 10 необходимо запускать программу именно с правами администратора, поставив следующие "птички" у ярлыка программы:

·В поле "Пользователь" - задается, под каким пользователем будет выполняться вход в программу.

Если требуется, чтобы после загрузки все окна GOALcity были заблокированы от перетаскивания, то отметьте птичкой поле - "С заблокированным рабочим столом".


Вкладка "Пользователи"

Navigation: Настройка > Основные настройки >

Вкладка "Пользователи"

В разделе "Пользователи" можно добавлять, убирать, изменять права пользователей клиентской части программы. Чтобы добавить пользователя, нажмите кнопку "Добавить", и в открывшемся окне "Добавление пользователя" заполните соответствующие поля.

Чтобы настроить права вновь созданного пользователя, или изменить существующего, выделите его, и нажмите кнопку "Изменить". В открывшемся окне можно сменить пароль пользователя и добавить/убрать предоставляемые права по настройке клиентской программы и доступу к сетевым ресурсам.

Чтобы предоставить или отменить предоставленное право необходимо поставить или убрать галочку в соответствующем поле. Имеется возможность "Разрешить все" и "Запретить все" нажатием соответствующих кнопок в нижней части окна "Настройки пользователя".

Для быстрого переключения между пользователями используется кнопка "Смена пользователя" на Главной панели управления.


Вкладка "Доступ"

Navigation: Настройка > Основные настройки >

Вкладка "Доступ"

По умолчанию, GOALcity подключает одного Пользователя – Администратора с правом автоматического входа (т.е. без пароля). Чтобы установить ему пароль, нажмите кнопку "Сменить", и введите необходимый пароль в соответствующее поле. Если снять флажок "Скрыть пароль" при вводе, то пароль будет виден в окне ввода.

Далее следуют настройки режима закрепленных окон, который активируется нажатием кнопки "Закрепить размещение окон" main-panel-05 на Главной панели управления. На выход из режима "Закрепления окон" можно установить пароль, чтобы пресечь несанкционированный доступ к настройкам GOALcity. Если такая функция требуется - ведите его в поле "Пароль".

Когда режим "Закрепления окон" активен, на Главной панели управления блокируются все элементы управления кроме тех, что вы отметите в блоке опций "Разрешить кнопку .....".

Активация опции "Блокировать рабочий стол" позволит в режиме "Закрепления окон" так же блокировать и рабочий стол Windows. На мониторе останется только интерфейс клиентской программы GOALcity.


Вкладка "Видео"

Navigation: Настройка > Основные настройки >

Вкладка "Видео"

Раздел "Видео" содержит настройки аппаратного ускорения и видеобуфера GOALcity.

·"Аппаратное ускорение" - это обработка видеосигнала средствами DirectX (DirectShow и Direct3D). Другими словами, аппаратное ускорение позволит часть работы по обработке видео переложить на видео карту ПК. Рекомендуем оставлять параметр в положении "Выбирать автоматически". GOALcity "поймет" какая у Вас установлена видео карта и подберет лучший режим. Но можете и поэкспериментировать с параметром, например, при активации OpenGl картинка будет более приятная на глаз. При отключении аппаратного ускорения обработка информации видео картой прекращается и полностью "возлагается на плечи" процессора, в результате чего загрузка последнего возрастает.

Включение GDI-режима по умолчанию приведёт к тому, что в абсолютном большинстве случаев будет использоваться только он. В результате существенно увеличиться нагрузка на ЦП, особенно, в случае использования камер высокого разрешения (1 МП и выше).

В GOALcity режим вывода видео на основе OpenGL был существенно оптимизирован.

Однако, при определённых условиях загрузка процессора в GDI-режиме по-прежнему может быть ниже, чем в OpenGL-режиме, особенно при работе с большим количеством камер низкого разрешения. Причина - дополнительные накладные расходы в исполняющей подсистеме OpenGL, связанные с невозможностью загрузки данных кадра в видеопамять без дополнительной стадии копирования, выполняемого силами центрального процессора.

Основные задачи OpenGL-режима - снижение загрузки центрального процессора при выводе видео высокого разрешения (1 МП и более) и обеспечение максимально возможного качества картинки (разница в качестве интерполяции, контрастности и насыщенности цветов заметна невооружённым глазом).

При сравнении режимов вывода видео необходимо учитывать следующие обстоятельства:

1.Должна использоваться дискретная видеокарта, при использовании процессора Intel встроенное видео должно быть полностью отключено;

2.Для сравнения загрузки процессора надо отслеживать, в первую очередь, загрузку клиентского процесса;

3.Отслеживание нагрузки на процессор надо начинать не ранее, чем через 1 минуту после загрузки клиента или переключения режима вывода;

Не гарантируется корректная работа на портативных компьютерах с интегрированным видео.В таких случаях рекомендуем отключать аппаратное ускорение!

В поле "Видеобуфер" устанавливается временной размер буфера обмена, который будет использоваться для хранения и обработки видеоинформации. "Максимальный размер видеобуфера" - позволяет установить максимальное количество кадров, которое будет храниться в буфере. Если Вы точно не уверены в том, что делаете, лучше не меняйте эти параметры.

Если к клиенту подключено большое количество камер и используется недостаточно мощный компьютер (или возникают конфликты с оборудованием), то возможно "торможение" кадров. В этом случае рекомендуем уменьшить значение "Максимального размера видеобуфера" до 5-10 кадров (в самых "тяжелых" случаях рекомендуем выставлять 1 кадр).

При максимально или очень большой загрузке центрального процессора можно активировать опцию "Использовать предварительную буферизацию", при котором видео кадры сначала сохраняются на компьютере в буфер, а затем уже выводятся на просмотр и пишутся в архив. При активизации данного режима, возможны небольшие задержки с отображением видео, но при этом Вы сэкономите немного вычислительной мощности центрального процессора, т.к. все операции будут производиться уже не "на лету".


Вкладка "Аудио"

Navigation: Настройка > Основные настройки >

Вкладка "Аудио"

В разделе "Аудио" выбирается "Метод вывода звука" и "Устройство", которое отвечает за обработку аудио информации (аудио плата).

·"Аудиобуфер" - устанавливается временной размер буфера обмена, который будет использоваться для хранения и обработки аудиоинформации. Последние два параметра задают минимальный и максимальный размер аудиобуфера.


Вкладка "Скриншоты"

Navigation: Настройка > Основные настройки >

Вкладка "Скриншоты"

В данном разделе настраиваются комбинации клавиш для мгновенного сохранения текущего кадра с определенных камер.

·Укажите в поле "Укажите место сохранения изображений" путь, куда будут сохраняться изображения с камер.

·Далее в поле "Укажите клавишу или комбинацию клавиш для создания скриншотов камер" укажите какой комбинацией клавиш будет выполняться сохранение.

·В поле "Выберите камеры" укажите для каких из камер делать "мгновенный скриншот".


Вкладка "Архив"

Navigation: Настройка > Основные настройки >

Вкладка "Архив"

Если Вы установили бесплатное ПО, а затем перешли на платное, но не приобрели архивный сервер, то его нужно удалить через "Программы и компоненты".

Раздел "Архив" содержит настройки локального архива. Данная вкладка предназначена для настройки только локального архива. При наличии установленного Архивного сервера она пропадет, и настройка уже существующего локального архива станет недоступной.

Чтобы Вы могли ориентироваться, программа показывает сколько свободного места осталось на жёстком диске и размер архива.

Если активировать "Ограничение размера архива", то максимальный размер локального архива будет равен установленному в данном поле значению. Если размер архива достигнет максимального значения, то место под новые записи будет освобождаться путем удаления старых, т.е. активируется механизм самостирания.

"Минимальное свободное место на диске" - в данном поле необходимо указать количество свободного места, которое будет игнорироваться программой при записи и всегда оставаться свободным. Минимальное значение должно быть не ниже 2х гигабайт на один видео источник и не менее 10% от всей ёмкости жесткого диска. Данный объем необходим для нормальной работы механизма самостирания. При необходимости Вы можете выделить больше места.

Примечание. Механизм самостирания предусматривает запись в архив новых видеофайлов на место старых. Т.е. если записываемым в архив видеофайлам недостаточно места на жестком диске (достигнуто значение, указанное в поле "Минимальное свободное место на диске" или "Ограничение размера архива"), то самые старые записи будут удаляться, а новые будут записываться на их место. Удаляется сразу 1 час самых старых записей. Механизм самостирания активируется автоматически и его нельзя отключить или изменить.

При записи по детекции движения объем записываемой информации уменьшится от 2 до 10 раз.

Также можно "Создать новый" или "Выбрать существующий" архив на жёстком диске. Принцип создания или подключения локального архива полностью идентичен созданию или подключению Архивного сервера GOALcity, с той лишь разницей, что архив может быть только один.


Вкладка "Журнал"

Navigation: Настройка > Основные настройки >

Вкладка "Журнал"

Раздел "Журнал", во-первых, подскажет, где находится файл журнала и поможет настроить его максимальный размер. Здесь же можно открыть журнал для просмотра, создать новый и, если у Вас имеются несколько журналов, выбрать один из них для просмотра.


Вкладка "Интеграция"

Navigation: Настройка > Основные настройки >

Вкладка "Интеграция"

В данном разделе производятся настройки совместной работы GOALcity с Автоматизированным Рабочим Местом охранника "Орион", WEB Сервером GOALcity.

·Пункт "Номера" используется для работы сторонних программ с компонентами ActiveX. Если сторонние программы не поддерживают текстовые строки, то вместо них на данной вкладке задается цифровой индекс.

·В пункте "АРМ Орион" производятся настройки интеграции с Системой Орион.

·"Запускать АРМ Орион" - поставьте галочку, чтобы ядро Ориона запускалось вместе с GOALcity.

·"Запускать АРМ Орион на компьютере:" - если сервер Ориона находится на другом ПК, то укажите IP адрес этого компьютера, на котором будет запускаться Орион при включении клиента GOALcity.

·Активирование пункта "WEB Сервер" разрешает доступ к панелям "Внимание!" через веб интерфейс, а так же возможность включения\выключения записи из веб интерфейса GOALcity.

Краткая информация о том, как настроить интегрированную работу GOALcity и Parsec.

1) Включить в настройках Parsec, на вкладке "Общие" интеграцию с GOALcity - галочка напротив "Видео подсистема GOALcity". В "Устройствах" - "Видеосистема" добавить видеосервер GOALcity, список камер запрашивается и сохраняется в системе автоматически.

2) Для того, чтобы из Parsec можно было записывать видео с камер GOALcity, необходим Архивный сервер. На машине, где расположен Архивный сервер, должен быть установлен также Parsec.

3) На этой машине в мониторе Parsec на вкладке "Камеры" нужно разместить камеры GOALcity и через контекстное меню ActiveX'а GOALcity указать настройки для записи - выбрать архивный сервер и скорость записи. После этого необходимо перезагрузить Parsec для сохранения настроек. Команду на запись можно отправить с любой рабочей станции Parsec, но фактическая запись будет производиться на той машине, где установлен Архивный сервер и произведена настройка.

4) Просмотр записанных фрагментов возможен с той же машины, где производится непосредственная запись из Генератора отчетов "Анализ".


Вкладка "Настраиваемые кнопки"

Navigation: Настройка > Основные настройки >

Вкладка "Настраиваемые кнопки"

"Настраиваемые кнопки" являются аналогами текстовых датчиков. Они выполняют роль активаторов событий SL++. Для того, чтобы данные датчики были доступны, необходим мультимедиа сервер.

Кнопки, которым Вы присвоите название, появятся на Главной панели управления программы.

Для того, чтобы активировать последовательность событий SL++ необходимо просто нажать ту кнопку, на которую они запрограммированы.


Вкладка "Надежность"

Navigation: Настройка > Основные настройки >

Вкладка "Надежность"

Раздел "Надежность" позволяет настроить перезагрузку программы и/или службы, или компьютера ежедневно в заданное время. Также можно активировать антизависающую функцию, которая перезапускает программу в случае, если пользовательский интерфейс недоступен, т.е. "завис".

Важно перезагружать компьютер не реже раза в неделю, особенно если он интенсивно используется. Перезагрузка позволяет очистить память и завершить ошибочные процессы и службы, которые начали работу. Во время перезагрузки закрываются все программы, работающие на компьютере (не только те, которые отображаются на панели задач, но также десятки служб, которые могли быть запущены различными программами и не были остановлены. Перезагрузка может устранить непонятные проблемы с производительностью, когда сложно установить их причину.

Если открыто так много программ, и перезагрузка представляется проблемой, то это серьезный повод все-таки перезагрузить компьютер. Чем больше открыто программ и чем дольше они работают, тем выше шансы, что компьютер будет работать все медленнее и в конце концов образуется нехватка памяти.


Вкладка "Обновления"

Navigation: Настройка > Основные настройки >

Вкладка "Обновления"

В разделе "Обновления" можно проверить последнюю доступную на сайте версию программы, дату/время последней проверки, узнать информацию о текущей версии, а также перейти на страницу сайта с описанием свежих релизов. Если поставить галочку в поле "Проверять обновления", то поиск новых версий будет проходить в автоматическом режиме с уведомлением Администратора GOALcity.


Вкладка "Системные утилиты"

Navigation: Настройка > Основные настройки >

Вкладка "Системные утилиты"

На вкладке "Системные утилиты" собраны ссылки на часто используемые инструменты при настройке операционной системы и GOALcity.

Кликом левой мыши по кнопке запускается соответствующая утилита.

Обратите внимание! Некоторые из этих утилит будут работать только если GOALcity запущена из под учетной записи с правами Администратора!

Экспериментальная опция "Запуск при старте системы вместо проводника" отключает стандартный интерфейс Windows и оставляет работать только систему GOALcity, экономя тем самым ресурсы ПК. Важно! возможны конфликты при работе с антивирусным ПО. Используйте на свой страх и риск.


Настройки видеоисточников

Navigation: Настройка >

Настройки видеоисточников

Общее описание

Настройки всех видеоисточников подразделяются на 2 главные категории - серверные и клиентские. Серверные настройки едины для всех клиентов, подключенных к данному источнику, клиентские же, могут быть заданы для каждого из подключенных клиентов индивидуально.

Чтобы открыть настройки видеоисточника, кликните левой кнопкой мыши по кнопке button-settings всплывающей панели в окне камеры. Интерфейс настроек "притерпел" большие изменения, стал более понятен "рядовому" пользователю. Все опции снабжены подробными подсказками и пояснениями.

Окно настроек разделено на 3 группы: "Все настройки", "Клиент" и "Сервер". Соответственно вкладка "Клиент" отвечает за настройки только текущего клиентского места, и не затронет больше никого. Вкладка "Сервер" позволяет менять параметры сразу для всех подключенных к данному видеоисточнику клиентов GOALcity. Вкладка "Все настройки" рекомендуется для "продвинутых" пользователей, в ней собраны абсолютно все настройки без разграничений сервер-клиент. Другими словами, изменяя настройки через вкладку "Все настройки" Вы можете, сами того не зная, поменять параметры сразу для всех подключенных клиентов. Осторожнее с этим!

Основные параметры сгруппированы на соответствующих вкладках и их можно включать\выключать одним нажатием. Напротив каждого пункта есть кнопка, позволяющая открыть расширенные параметры.


Групповые настройки

Navigation: Настройка > Настройки видеоисточников >

Групповые настройки

Общее описание

GOALcity содержит в себе множество настроек и параметров для всех источников и элементов программы, как для обычного пользователя, так и для любителей "тонкой" настройки. Настройка каждого элемента в отдельности может занять приличное количество времени, особенно если Вы делаете это впервые.

Групповые настройки позволяют значительно упростить и ускорить процесс настройки видео источников и других элементов Запустите исполняемый файл 1_GOALcity_Client_x64.exe (ранее файл назывался setupcc_x64.exe). . С помощью них можно менять множество параметров всего за несколько кликов мышки. Чтобы открыть настройки, выберите в Главном меню GOALcity пункт "Групповые настройки".

Настройка параметров

После запуска групповых настроек, Вы увидите окно, в котором перечислены все источники, подключенные к GOALcity. Все элементы представлены в виде "дерева" и позволяют изменять параметры каждого в отдельности или всех вместе.

Чтобы открыть диалог группового изменения параметров, кликните по кнопке button-04 справа от необходимой группы источников. То есть, если Вы хотите изменить параметры сразу всех видео источников, нажимайте на кнопку справа от строки "Видео" и т. д.

Перед Вами откроется новое окно с выбранными элементами.

Можно отметить для изменения как отдельные источники, поставив "птичку" рядом с его именем, либо все сразу, поставив птичку в поле "Все" в верхней части окна.

После выбора изменяемых источников в поле "Свойства" появятся группы элементов, доступные для настройки. Отметьте "птичками" необходимые для настройки группы. Выбранные группы появятся в нижнем поле текущего окна.

"Пробегитесь" по "дереву" параметров и установите необходимые Вам значения. Сохраните всё нажатием кнопки "Ок". Сделанные Вами изменения будут применены сразу ко всем выбранным источникам.

Почтовые уведомления

Пункт свойств источников "Почтовые уведомления" служит для групповой настройки отправки электронных писем о событиях, представляющих особую важность для администратора системы видеонаблюдения GOALcity. Вы можете за несколько кликов настроить отправку почты о неисправностях, возникающих в процессе работы видео источников (например "Потеря видеосигнала" или "Перекрытие камеры") и прочей служебной информации.

Активируйте почтовые уведомления отметив пункт "Разрешить" галочкой.

В поле "SMTP-сервер" укажите необходимый сервер исходящей почты, обязательно дописав порт. Эту информацию можно получить у Вашего почтового сервиса. Информацию по наиболее популярным сервисам Вы можете посмотреть здесь для mail.ru или здесь для yandex.ru.

В полях "Пользователь" и "Пароль" укажите данные для авторизации на почтовом сервере (логин и пароль от вашей почты).

Все современные почтовые сервисы используют шифрование данных, поэтому отметьте "птичкой" пункт "Разрешить SSL". Если Вы используете свой собственный почтовый сервер без шифрования (например для отправки и получения почты только в пределах определенной локальной сети), не активируйте данный пункт. В любом случае, рекомендуем проконсультироваться у Вашего системного администратора.

Поле "Отправитель" позволяет задать от чьего имени будет отправлено письмо. Полезно использовать в том случае, если Вы контролируете работу нескольких видео серверов с одного аккаунта электронной почты и нужно разграничить от какого именно видео сервера пришло сообщение.

Затем, задайте "Получателя оповещений по умолчанию", то есть, для всех настроенных далее событий, если не указывать электронную почту явно, будет использоваться этот адрес.

В поле "Тема сообщения" укажите, с какой темой Вам будут приходить оповещения. Рекомендуем не изменять данный параметр, потому что он настроен на динамические темы. Другими словами, в зависимости от сообщения, тема будет автоматически изменяться с помощью переменных в "теле" темы.

Поддерживаются следующие подстановки:

%esn - имя источника события, %en - имя события, %est - локальное время первого события, %elt - локальное время последнего события, %ec - количество повторов события.

С полем "Текст сообщения по умолчанию" все полностью аналогично выше описанному про "Тему сообщения".

Если к письмам необходимо прикреплять какой либо файл, укажите путь до файла в поле "Прикрепляемый файл по умолчанию".

После настройки всех параметров учетной записи и текстов темы и сообщений, раскройте поле "События" и выберите необходимые Вам, отметив их "птичкой".

У каждого события есть свои настройки получателя, темы, текста сообщения и прикрепляемого файла. Если оставить эти поля пустыми, то будут использоваться параметры настроенные выше (по умолчанию). Но Вы можете указать и персональные, например, чтобы сообщения о потере видеосигнала приходили на один почтовый адрес, а о перекрытии камеры - на другой.

Также для каждого события настраивается "Минимальное количество повторов события" и "Минимальный период уведомлений". Говоря простым языком, если событие случилось столько то раз, оправить сообщение, но не чаще чем один раз в такой то промежуток времени. В примере это 3 события, сообщение о которых отправляется 1 раз в час.


Детектор движения

Navigation: Настройка > Настройки видеоисточников >

Детектор движения

Система GOALcityполучила следующую версию видеодетектора «Snake-II» - это комбинированный координатный помехозащищенный видеодетектор с автоматической адаптацией к окружению.

Всепогодность обеспечивает алгоритм автоматической подстройки чувствительности, а также алгоритмы защиты от помех. В условиях сильных помех, кроме того, при наличии модуля видео аналитики, может включаться фильтр-детектор поступательного движения. Защиту от выпадения данных обеспечивает технология избыточной записи.

GOALcity включает в себя четыре основных типа детектора: контрастный, фоновый детектор (ДОП-детектор), детектор объектов и фильтр-детектор поступательного движения.

Кроме того, в модуле видео аналитики содержится большое число статистических видеодетекторов. Также существуют специализированные видеодетекторы: детектор лиц, видеодетектор автомобильного номера, видеодетектор скорости движения, видеодетектор направления, объема объектов и прочее.

Модуль видеодетекцию имеет развитую систему индикации и предупреждений, а также собственную запись, независимую от основного архива. В кадре разными цветами могут отображаться области контрастного движения, области перекрытия фона, оставленные и (или) унесенные предметы. По сработке любого типа видеодетекцию может выдаваться звуковой сигнал через встроенный динамик компьютера или с выхода звуковой карты.

Включение и настройка

По умолчанию видеодектор всегда включен для любой вновь созданной камеры. Чтобы его выключить, или перейти к настройкам, выполните следующие действия:

Откройте настройки видеоисточника кликом по кнопке button-settings на всплывающей панели в окне камеры. Перед Вами откроется окно настроек окна и видеоисточника:

По умолчанию открываются абсолютно все настройки окна и видеоисточника, сгруппированные по важности. В данный момент нас интересуют настройки только видеодетектора, поэтому перейдите на вкладку "Сервер". На данной вкладке можно включить\выключить основные компоненты GOALcity и отдельно их настроить. Видеодетектор является серверным компонентом, т.е. изменение его настроек затронет всех клиентов GOALcity подключенных к данному серверу.

Как Вы можете видеть, по умолчанию Видеодетектор включен. Чтобы его выключить, щелкните левой кнопкой мыши по надписи "Видеодетектор" или в любом другом месте "красного прямоугольника". В выключенном состоянии кнопка окраситься в серый цвет. Чтобы перейти к настройками детектора, щелкните по кнопке dd-nastroiki-03. Откроется окно с настройками, касающихся работы видеодетектора GOALcity.

У всех настроек есть детальное описание, настроить детектор "под себя" очень просто. Каждая вкладка отвечает за свою группу параметров и все настройки выполнены в стиле "больше-меньше".

Маска детекции

Как правило, на любой камере есть зоны, детекция движения в которых не нужна или не желательна. Чтобы настроить маску детекции, перейдите на вкладку "Маска" и отметьте птичкой поле "Есть". Перед Вами откроется "живое" изображение с текущей камеры. "Нарисуйте" с помощью мыши область, детекция движения в которой Вам не нужна.

Маска "рисуется" левой кнопкой мыши, правой - стирается. Масштаб "кисти" изменяется с помощью скрола. Клик средней кнопкой мыши (колесиком) полностью очищает текущую маску.


Детектор лиц

Navigation: Настройка > Настройки видеоисточников >

Детектор лиц

Включение и настройка

Важно! Для нормальной работы системы определения лиц требуются следующие условия:

·Минимальное расстояние между глаз - 40, предпочтительно - более 60 и идеально - 100 пикселей.

·Наклон головы вверх-вниз - не более 15 градусов.

·Поворот вправо-влево - не более 20 градусов.

·Наклон вправо-влево - не более 10 градусов.

Обратите внимание на наши рекомендации по установке камер для детекции лиц!

По умолчанию детектор лиц всегда выключен для любой вновь созданной камеры. Чтобы его выключить, или перейти к настройкам, выполните следующие действия:

Откройте настройки видеоисточника кликом по кнопке button-settings на всплывающей панели в окне камеры. Перед Вами откроется окно настроек окна и видеоисточника:

По умолчанию открываются абсолютно все настройки окна и видеоисточника, сгруппированные по важности. В данный момент нас интересуют настройки только детектора лиц, поэтому перейдите на вкладку "Сервер". На данной вкладке можно включить\выключить основные компоненты GOALcity и отдельно их настроить. Детектор лиц является серверным компонентом, т.е. изменение его настроек затронет всех клиентов GOALcity подключенных к данному серверу.

По умолчанию, как уже писали выше, детектор лиц выключен. Чтобы его включить, щелкните левой кнопкой мыши по надписи "Детектор лиц". Кнопка подстветится красным цветом, сигнализируя что детектор активен. В выключенном состоянии кнопка окраситься в серый цвет.

Чтобы перейти к настройками детектора, щелкните по кнопке face-detector-02. Откроется окно с настройками, касающихся работы детектора лиц GOALcity.

·Установите необходимую скорость детекции. Не рекомендуем сильно "задирать" скорость, т.к. это скажется на нагрузке ЦП.

·Параметр "Хранить историю" отвечает за то, как долго будет формироваться ролик для панели "Внимание!" пока идет детекция лица.

·Опция "Искать лица только при наличии движения" позволяет активировать работу алгоритма только при наличии движения в кадре.

·Можете выбрать цвет, которым будет обводиться контур лица или отключить эту возможность с помощью параметра "Отмечать лица как".

·Остальные параметры не нуждаются в дополнительных комментариях и вполне понятны.

Маска детекции

Как правило, на любой камере есть зоны, детекция движения в которых не нужна или не желательна. Чтобы настроить маску детекции, отметьте птичкой поле "Использовать маску" и перейдите на вкладку "Маска" внизу окна. Перед Вами откроется "живое" изображение с текущей камеры. "Нарисуйте" с помощью мыши область, детекция лиц в которой Вам не нужна.

Маска "рисуется" левой кнопкой мыши, правой - стирается. Масштаб "кисти" изменяется с помощью скрола. Клик средней кнопкой мыши (колесиком) полностью очищает текущую маску.

Закончив настройку, не забудьте активировать алгоритм "Лица" для необходимой панели "Внимание!" чтобы все видео события с детекцией лиц собирались на ней.


Настройка записи

Navigation: Настройка > Настройки видеоисточников >

Настройка записи

Выбор архива для записи

После создания архива и добавления видео источника необходимо включить запись видео.

Откройте настройки Вашего видео источника нажатием на кнопку button-settings на всплывающей в окне камеры панели управления и перейдите ко вкладке "Настройки" и затем к строчке "Архив".

Укажите созданный Вами архив в строке "Писать в архив".

В строке "Просматривать из окна камеры" выберите, каким образом система будет реагировать на нажатие кнопки button-play - "Архив" на всплывающей в окне камеры панели. Либо просматривать архив только выбранной камеры, либо открывать архив полностью, с возможностью выбора нескольких камер. Мы рекомендуем оставить значение "Записываемый", т.е. просмотр будет только выбранной камеры.

Что будем записывать?

Важно ничего не упустить! Перейдите на строчку "Контент" и отметьте галочкой "Записывать все кадры". Но можно активировать и "щедящий архив режим", и записывать только кадры по определенным событиям, например, только кадры с лицами или автомобильными номерами.

Настройка скорости и типа записи

Перейдите на вкладку "Запись". Если активировать "Минимальную избыточность", то система будет писать только те кадры, в которых присутствует детекция движения. Это сэкономит пространство на жестком диске, но т.к. записываться будут далеко не все кадры и не постоянно, велика возможность упустить что-либо важное.

"Средняя избыточность". Оптимальный для записи вариант. Активируйте данную строчку. Если не настроена страховочная запись (о чем чуть ниже), то в состоянии покоя (детектор движения не активен) система вести запись не будет, но как только в кадре появиться какое-либо действие (детектор движения активен) сразу же включиться запись со скоростью, указанной в поле "Скорость записи" на время или определенное количество кадров.

Рекомендуем использовать именно "Среднюю избыточность" для записи в архив.

Страховочная запись

Все же не стоит полностью полагаться на программный детектор движения, поэтому последней стадией настройте страховочную запись для камеры. Перейдите к строке "Страховка" и отметьте поле "Страховочная". При активации этой настройки система начнет непрерывную запись с указанной скоростью. Эта запись не влияет ни на какие другие виды записи и ведется непрерывно и постоянно.

Даже если Вы выключите запись по детекции и основную запись, страховочная запись все равно будет продолжаться.

Сохраните все изменения нажатием кнопки "Ок".

Не забудьте включить запись, щелкнув по кнопкам

и
на всплывающей панели в окне камеры.


Алгоритм разворачивания группы камер

Navigation: Настройка > Настройки видеоисточников >

Алгоритм разворачивания группы камер

Общее описание

Почти в любой системе видеонаблюдения построенных на базе IP камер и сетевой структуре зачастую возникает вопрос как же уменьшить трафик сети, но при этом не потерять в качестве видео? Эту проблему решает фирменный алгоритм Спецлаб db-cklick.

Серверная часть GOALcity принимает видео в полном разрешении, обрабатывает его и записывает. Клиентская же часть GOALcity подключается к уже "обработанному" видео с уменьшенным разрешением и частотой кадров, но при двойном клике по видеоизображению получает полный видеопоток.

Говоря простым языком, алгоритм позволяет просматривать на клиенте GOALcity множество камер в маленьком разрешении в одном окне, но при клике по одной из камер показывает её в полном разрешении. Тем самым, Вы можете "тянуть" 16 двухмегапиксельных IP камер (заметим, что поток одной двухмегапиксельной камеры при скорости воспроизведения 25 к\с около 6 Мб/сек) с минимальной загрузкой сети (1-2 Мб/сек) одновременно, но детализированная картика у Вас будет исходная. В архив при этом пишется тоже исходное видео в полном разрешении и установленной вами частоте кадров.

Алгоритм может работать не только с IP камерами, но и с аналоговым видео, HD-SDI камерами и любыми другими видеоисточниками подключаемыми к GOALcity.

Что для этого нужно?

Для реализации алгоритма необходим компонент VSS-Retr (Ретранслятор), Мультимедиа сервер или Видеосервер на серверной стороне GOALcity и клиентская часть GOALcity на другом ПК с которого будет производиться подключение. В примере будет рассмотрен вариант с четырьмя IP камерами и Мультимедиа сервером.

Настройка алгоритма на серверной стороне

Установите все необходимые компоненты и перейдите на Диаграмму подключений. Откройте настройки Мультимедиа сервера и создайте (добавьте) необходимые видеоисточники используя SL Source, IP Source, FF Source или RTSP Source. Какой именно из источников использовать зависит от марки и модели Ваших IP камер. Список проверенного нами оборудования Вы всегда можете найти на нашем сайте технической поддержки.

Подключите созданные камеры в ОДНО ОКНО GOALcity.

Можно переименовать это окно, чтобы потом было понятно что именно оно является транслируемым. Объединять (подключать в одно окно) можно любое количество камер, в примере рассмотрен вариант использования четырех камер.

Пример подключения камер

Пример подключения камер

Сохраните настройки Диаграммы подключений нажатием кнопки "Ок".

Перед Вами откроется окно, в котором будут отображаться сразу все Ваши созданные ранее IP камеры.

Пример окна на 4 камеры

Пример окна на 4 камеры

Можете настроить запись в архив для этих камер, настроить видеодектор и другие, необходимые Вам параметры. Все они будут работать на серверной стороне GOALcity и не будут мешать Вашему удаленному просмотру с помощью клиента GOALcity.

Кликните левой кнопкой мыши по иконке windows-03 в левом верхнем углу окна и в ниспадающем списке команд выберите команду "Транслировать". Откроется окно настроек трансляции.

Окно настроек трансляции до изменения параметров

Окно настроек трансляции до изменения параметров

Снимите верхнюю птичку "Без изменений" и установите необходимое разрешение для всей группы камер, тем самым "ужимая" 4 мегапиксельные камеры до разрешения 320х240. Разрешение дано для примера, в практическом применении рекомендуем устанавливать более высокое, т.к. при разрешении 320х240 картинка на удаленном клиенте будет "не читабельна". Про экономию трафика при передаче этих данных говорить уже излишне. Вместо 4-х потоков в с мегапиксельных камер Вы будете получать 1 поток с разрешением 320х240. Остальные параметры оставьте неизменными. Сохраните настройки нажатием кнопки "Ок".

Окно настроек трансляции после изменения параметров

Окно настроек трансляции после изменения параметров

Откройте Диаграмму подключений GOALcity, кликните правой кнопкой мыши по "шапке" Мультимедиа сервера и выберите пункт "Обновить" - появится еще один источник - "Имя окна@GOALcity". Это и есть новое транслируемое окно с заданными выше параметрами.

Мультимедиа сервер с транслируемым окном

Мультимедиа сервер с транслируемым окном

На этом настройка серверной GOALcity части закончена.

Настройка алгоритма на клиентской части

Установите клиентскую часть GOALcity на удаленный ПК, откройте диаграмму подключений и выполните поиск серверов GOALcity по IP адресу серверной части GOALcity. Добавьте мультимедиа сервер. Также можно добавить и архивный сервер (если используется) для удаленного просмотра записей с камер.

Подключите к окну GOALcity ранее созданное транслируемое окно с Вашей группой камер.

Примеры онка трансляции с разными параметрами

Примеры онка трансляции с разными параметрами

При настройках разрешения транслируемого окна 320х240 на видео что либо разобрать довольно сложно из-за высокой "пикселизации" изображения, а вот при разрешении 640х480 картинка уже приятна глазу и разборчива. Экономия трафика при этом огромна, т.к. Вы "тянете" не 4 потока двухмегапиксельных камер, а только один поток с низким разрешением и бетрейтом.

Откройте настройки транслируемого окна кликом по кнопке button-settings на всплывающей панели и перейдите на вкладку "Просмотр".

Вкладка "Просмотр" настроек камеры

Вкладка "Просмотр" настроек камеры

Активируйте птичку "Клиент ретранслятора" и нажмите кнопку "Применить". Затем перейдите на вкладку "Клиент" и отключить все детекторы, т.к. детекторы камеры Вы уже настраивали на сервере и на клиентской части они не нужны. Сохраните настройки источника нажатием кнопки "Ок".

Теперь по двойному клику на видеоизображении будет открываться полный поток с этой камеры в полном разрешении и с полной частотой кадров и Вы можете оценить текущий трафик от видеоисточников в верхней полупрозрачной строке окна GOALcity.

Настройка клиентской части GOALcity на этом закончена.


Окна

Navigation: Настройка >

Окна

Общее описание

Окно – главный элемент интерфейса для любой системы видеонаблюдения. Это полностью справедливо и для системы GOALcity. Помимо своего основного назначения – отображать информацию, поступающую от подключенного к нему источника (видеокамеры, микрофона, датчика и т. п.), в этой системе окно информирует пользователя о своих настройках и помогает их изменить. Не закрывая его и не убирая курсор мыши, можно выполнить множество самых разных настроек.

Обратите внимание! Для многомониторных конфигураций рекомендуем в настройках видеодрайвера "выстраивать" все мониторы в ряд (слева-направо) или столбик (сверху-вниз), но не совмещать такие расположения. Иначе при развертывании или сворачивании окна есть шанс "потерять" его на мониторах. Данная особенность связана с внутренней архитектурой видеодрайверов NVIDIA и ATI и внутренним распределением видеопамяти видеокарты.

Сразу под заголовком, уже непосредственно в окне, располагается полупрозрачная информационная строка (она может быть убрана при настройке свойств камеры). Когда она видна, на ней отображается различная информация: слева-направо расположены следующие индикаторы: разрешение кадра, включение режима увеличения кадра, программный автоконтраст, детектор движения, индикатор записи, текущая скорость записи (при условии, что запись настроена). По середине отображается название видеоисточника и в правом углу текущая скорость отображения видео в окне.

Функции всплывающей панели

Чтобы взывать служебную панель управления, необходимо навести курсор мыши на окно GOALcity, панель появится автоматически. Панель можно отключить в настройках свойств текущего окна, но мы рекомендуем оставлять панель включенной для более оперативной работы. По умолчанию выводятся самые необходимые в работе кнопки, но панель может "сдвигаться" вправо и влево, открывая дополнительные кнопки быстрых действий. Основные функции:

Чтобы включить\выключить постоянную запись нажмите на кнопку button-rec. Следующая кнопка button-dd активирует\деактивирует запись по детекции движения. Просмотр архива с текущей камеры вызывается нажатием на кнопку button-play. Чтобы перейти к настройкам текущего окна и камеры нажмите на кнопку button-settings. Если видеоизображение в окне пропало или "замерло" переподключить камеру поможет последняя кнопка button-reconect.

Следующие кнопки Панели управления предназначены для управления свойствами изображения. Увеличение области кадра, переворот кадра, масштабирование и прочие функции. Все кнопки снабжены всплывающими подсказками.

Окна, как типичные для ОС Windows, имеют заголовок. Они могут быть в двух состояниях: активном (заголовок подсвечен цветом) и неактивном (заголовок – серый).

"Ухватив" мышью окно за заголовок, Вы можете "перетащить" его в любое место Рабочего стола. А "взяв" за любую границу или уголок, произвольно изменять его размеры. Если "ухватить" одно окно и перетащить его на другое место на столе, удерживая при этом нажатой клавишу "Ctrl", то вместе с ним будут перемещаться все остальные окна программы и Главная панель управления.

У окна GOALcity, в правом верхнем его углу, отображаются две традиционные для Windows функции: "Скрыть" и "Развернуть/восстановить".

Четыре значка windows-02 в левой части заголовка окна имеют специфическое для GOALcity назначение.

Нажатие на первую кнопку windows-03 выведет контекстное меню окна. В данном меню продублированы все основные настройки видеоисточника и окна. Нажав вторую кнопку windows-04, Вы сделаете это окно образцом для других окон системы. Теперь, если нажать кнопку windows-05 в другом окне , то оно примет такие же размеры, как у отмеченного в качестве образца.

При нажатии кнопки windows-06 на экране появится окно с опциями, позволяющими настроить "поведение" данного окна при изменении его размеров.

Можно включить/отключить сохранение пропорций окна в обычном режиме и при блокировке. Если активировать пункт "Не сохранять", то размеры окна со всем его содержимым можно будет менять произвольно.

Контекстное меню окна

Чтобы взывать контекстное меню окна, необходимо кликнуть левой кнопкой мыши по кнопке windows-03 в заголовке окна или правой кнопкой в любом месте видеоизображения в окне. Откроется следующее меню:

·Команда "Развернуть" позволит отобразить окно "на весь монитор" или в реальном размере, (или в место, указанное с помощью опции "Зафиксировать позицию всплытия") если разрешение видео меньше чем разрешение вашего монитора.

·Команда "Скрыть" свернет окно с рабочего стола, но все настройки и параметры окна при этом сохранятся. Вернуть окно можно с помощью кнопки "Показать все" на главной панели управления.

·Команда "Закрыть" закроет выбранное окно, при этом все настройки, сделанные для этого окна и видео потока в нем будут утеряны.

·Команда "Зафиксировать позицию всплытия" позволяет указать размер и место в которое будет "разворачиваться" камера при выполнении команды "Развернуть", двойном клике мышкой по видео в окне или сработке событий SL++. То есть вы можете "перетащить" окно с помощью мыши в нужное вам место, задать его размер и включить данную опцию, в дальнейшем это окно будет "разворачиваться" именно сюда с сохраненными Вами размерами.

·Команда "Поверх других окон" заставит окно отображаться всегда сверху любых других элементов и интерфейсов как GOALcity так и других программ.

·Если в окно подключено несколько видеоисточников, то с помощью команды "Выстроить" можно запустить мастер расстановки камер, внутри окна.

·"Ручная расстановка" позволит расставить несколько видеоисточников внутри окна в ручном режиме, перетаскивая границы с помощью мыши.

·Команда "Транслировать" позволяет включить использование VSS-Ретранслятора для данного окна. Если функция включена, то активируется опция "Настройки трансляции" в которой можно указать разрешение и частоту кадров для данного транслируемого окна.

·Опция "Окно образец" запомнит размер данного окна, и позволит использовать опцию "По образцу" для других окон. Функция необходима для упрощения выстраивания и группирования окон на рабочем столе.

·Команда "Сохранить" сохраняет текущее окно в файл со всеми настроенными в нем параметрами.

·Самая нижняя строчка открывает параметры текущего видеоисточника в упрощенном виде.

Функция "пролистывания" в окне камеры.

Если "схватить" левой кнопкой мыши изображение в окне камеры и переместить его вправо, то мы увидим файл расположения (например, картинка с планом вашего объекта, на котором отмечено место установки данной камеры). Файл задается в настройках окна. Этим файлом может быть любое изображение в формате .bmp.

При перемещении изображения окна влево, мы увидим последние записи аналитики с данной камеры, (если данная опция включена в настройках камеры) при условии, что камера обрабатывается панелью "Внимание!". В правом верхнем углу окна будет мигать надпись "Архив", оповещая пользователя о том, что он смотрит уже запись. Перелистывать можно и дальше, в таком случае события, отображаемые в окне, будут отображаться от самого нового к старому.

Возврат к отображению видео в окне происходит автоматически при "бездействии" оператора в течении 10 секунд, обратным "перетаскиванием", либо двойным щелчком левой кнопки мыши по окну.

Сохранить текущий кадр с камеры можно с помощью настройки "Скриншоты" в основных настройках программы.

Масштабирование видео в окне просмотра

Масштабирование видео производится прямо в окне "живого" просмотра с помощью мыши и клавиатуры. Увеличенную область можно еще раз увеличить и так сколько угодно раз.

Чтобы увеличить видеоизображение, достаточно навести курсор мыши на желаемую область, зажать на клавиатуре клавишу "Ctrl" и "поскролить" колесиком мыши. Изображение масштабируется исходя из расположения курсора мыши в окне, другими словами, центрируется по нему.

Увеличение видео. Первый способ.

Также, можно увеличить определенную область зажав все туже клавишу "Ctrl" на клавиатуре, кликнув левой кнопкой мыши и, не отпуская кнопку, "нарисовать" прямоугольник поверх видео (аналог группового выделения файлов с помощью мыши). "Нарисованный" прямоугольник и будет увеличен на все окно просмотра.

Увеличение видео. Второй способ.

Увеличенную область изображения можно "таскать" по окну с помощью правой кнопки мыши при зажатой на клавиатуре клавише "Сtrl".

Чтобы вернуться к "реальной" картинке, кликните "колесиком" (средней кнопкой мыши) в любом месте видеоизображения.

Внешний вид и надписи

GOALcity позволяет добавить любую надпись в окно и отражать её поверх видео. Чтобы это сделать, откройте настройки камеры кликом по кнопке button-settings на всплывающей панели, перейдите на вкладку "Клиент", активируйте пункт "Надписи" и нажмите на кнопку с изображением шестеренки справа.

Откроется окно добавления и редактирования надписей.

·Кнопка "Добавить" позволяет создать новую надпись, кнопка "Изменить" - редактировать одну из уже созданных.

·Кнопки "Копировать", "Вставить" позволяют клонировать уже созданные надписи как для текущей камеры, так и для любой другой. То есть нажав кнопку "Копировать" и открыв параметры надписей для другой камеры можно вставить эту надпись туда.

Чтобы настроить текст, его положение в окне камеры, размер и другие параметры, выделите надпись которую необходимо изменить и нажмите кнопку "Изменить". Сам текст настраивается очень просто. Вы можете менять параметры и параллельно смотреть как они отображаются на внешнем виде роликов на панели "Внимание!".

Так же, вместо обычного текста Вы можете использовать переменные:

·%t - выведет текущее время поверх видеоизображения в формате Ч:М

·%T - вермя в формате Ч:М:С

·%d - выведет текущую дату, а %D текущую дату с указанием дня недели.


Настройка событий SL++

Navigation: Настройка >

Настройка событий SL++

Общее описание

SL++ - Security Language - язык программирования для систем безопасности особого назначения.

Множество охранных систем, и особенно компьютерных, уже имеют некоторую возможность пользовательского программирования. Однако, это в основном простейшие комбинации, такие как "сработал датчик – включить сирену" и их модификации. Такие алгоритмы не намного сложнее обходятся злоумышленниками. В то же время сегодняшние средства детектирования позволяют выдавать массу параметров о ситуации на объекте, что дает возможность производить автоматический анализ, на основании чего предпринимать технические действия, направленные на защиту человека и его имущества.

SL++ позволяет описать самое сложное поведение движущихся объектов на основании различного типа датчиков, видеодетекторов и других используемых устройств. При этом человеку предлагается выбор возможных вариантов. Обучение такой форме программирования среднестатистического человека занимает не более одного дня

Работа с окном "События"

Для вызова настроек событий SL++ кликните левой кнопкой мыши по соответствующему пункту Главного меню программы.

Откроется окно "События".

·Кнопка "Добавить..." позволяет создать новую запрограмированную последовательность событий на языке SL++.

·Кнопка "Изменить..." открывает настройки уже созданного события, и позволяет изменить его параметры.

·Кнопка "Удалить" стирает из памяти выбранное событие.

·Кнопка "Копировать" позволяет сделать полную копию текущего выбранного события.

·"Стрелки" позволяют настроить приоритет выполнения событий SL++. Перемещение вверх - увеличение приоритета и наоборот.

·Опция "Тестовый режим (F10)" позволяет протестировать активные в данный момент события. Активируйте данную опцию, нажмите кнопку "Ок" и затем клавишу "F10" на клавиатуре. Все активные события "сработают" и Вы увидите всю последовательность выполняемых действий.

Создание нового события SL++

Чтобы создать новое событие, нажмите кнопку "Добавить...". Откроется окно в котором осуществляется программирование на SL++.

Укажите в верхнем поле "Название" понятное описание Вашего нового события.

Поле "Активатор"

Нажмите кнопку "Изменить" и выберите один из источников, который будет являться активатором события, т.е. изменение его состояния будет запускать всю дальнейшую цепь действий.

Активатором в системе GOALcity может быть практически любой элемент, и у каждого есть свои условия и состояния. Все они подробно описаны, и сложностей с выбором необходимого быть не должно.

Поля "Условий"

Ниже следуют два поля - "Выполняются условия" и "Не выполняются условия".

После сработки активатора программа проверяет условия, которые должны выполняться или наоборот, не должны выполняться. Причем проверяются они в прошедшем времени на заданном интервале до момента сработки активатора.

Важно! Проверка производится по архиву, т.е., если запись информации с выбранного элемента в Архивный сервер не производилась, то никакой проверки не будет и работа созданной конструкции станет не возможной и Вы увидите сообщение о ошибке.

Проверка условий работает только с Архивным сервером! С локальным архивом работают только простые события, т.е. без "выполняющихся" и "не выполняющихся" условий.

·Кнопка "Добавить..." позволяет создать новое условие.

·Кнопка "Изменить..." открывает настройки уже созданного условия, и позволяет изменить его параметры.

·Кнопка "Удалить" стирает из памяти выбранное условие.

Нажмите кнопку "Добавить", откроется окно настроек условий.

В меню "Условие" в поле "Источник" выбирается камера, в зоне видимости которой должны выполняться события, указанные в поле "Флаги (любой из)".

Можно выбрать любые из "флагов", нажимая по ним левой кнопкой мыши. Выбранные здесь события связываются логическим И (AND).

·Например, выбраны "флаги": обнаружено движение, обнаружен автономер, обнаружено лицо.

·Логическая связка: обнаружено движение И обнаружен автономер И обнаружено лицо.

Таким образом, должны выполняться сразу три условия. Если не обнаружено хотя бы одного из указанных событий, то вся логическая связка становится ложной (условие не выполняется).

На диаграмме точка отсчета "0" - это момент времени, в который происходит сработка активатора.

·С помощью двух полей ниже задается временной интервал до сработки активатора, в котором происходит анализ событий и поиск "флагов", выбранных в меню "Условие".

·В меню "Количество сработок" выберите, сколько раз должно произойти каждое выбранное событие ("флаг") на заданном временном интервале до сработки активатора для того, чтобы условие считалось выполненным.

В меню "Длительность" выбирается, сколько должно длиться каждое выбранное событие ("флаг") на задданом временном интервале до сработки активатора для того, чтобы условие считалось выполненным.

Для "выполняющихся" и "не выполняющихся" условий настройки полностью аналогичны.

Поле "Действия"

После полей условий идет поле действий. Нажмите кнопку "Добавить" и откройте окно добавления нового действия.

Действие будет выполнено, если сработал активатор и соблюдены все условия. В самом верхнем поле окна выбирается элемент, выполняющий действие. Это может быть любая из камер, Панель "Внимание" или целый ряд других элементов, объединенных под общим названием "GOALcity".

Для каждого действия предусмотрены индивидуальные настройки, смысл которых понятен интуитивно и в дополнительном описании не нуждается.

В целом, логическую конструкцию алгоритма, составленного на SL++, можно представить следующим образом: допустим, что в определенный момент времени происходит некоторое событие a, которое является активатором. Заданы 2 условия, которые должны выполняться (условие_0 и условие_1) и 2 условия, которые не должны выполняться (условие_2 и условие_3). Результат выполнения всех условий - 2 действия (действие_0 и действие_1). Тогда условный программный код будет иметь вид:

IF a = активатор AND (условие_0 = true OR условие_1 = true) AND (условие_2 = false OR условие_3 = false) THEN (действие_0 AND действие_1), здесь true - истина (выполняется условие); false - ложь (условие не выполняется); IF - "если"; AND - "и"; OR - "или"; THEN - "тогда".

Для того, чтобы события SL++ функционировали, необходимо активировать соответствующую кнопку на Блоке управления функциями главной панели программы.

SL++ дает возможность по системе событий менять права пользователей, загружать другую конфигурацию, включать индикацию проблемного места, менять режимы просмотра и записи, производить целый комплекс различного типа оповещения. Все возможности прописаны, и достаточно их только выбрать.


3D План

Navigation: Настройка >

3D План

Общее описание

Система GOALcity вышла на новый уровень охраны объектов. 3D-движок позволяет создавать и управлять трехмерными планами - как плоскими, так и объемными объектами с огромным числом возможностей, созданных специально для сферы безопасности.

На сегодняшний день нет никакой сложности найти компьютерного специалиста, кто представит ваш дом, офис или целый город в трехмерном виде. GOALcity легко подгружает стандартную 3D-графику. И делает на ней уникальную систему безопасности.

В трехмерном виде человек наглядно видит не только само место происшествия, но и динамику развития процесса. Интересуемые зоны сработки выводятся в зрелищном (именно это слово здесь уместно) виде с плавным переходом от общего плана. Каждый конкретный участок виден в совокупности с полной моделью объекта.

Все датчики, ключи, замки, освещение и т.д. представлены в их графическом отображении и могут быть нарисованы самим пользователем. Человек теперь сам строит свою систему безопасности! Все события и управление могут также осуществляться непосредственно с Плана. Например, по сработке датчика вы можете видеть, как мигает виртуальный датчик, как идет 3D-человек или изменяется объемный цвет самой комнаты. Чтобы включить освещение, достаточно щелкнуть мышкой на виртуальном торшере, а чтобы открыть дверь – на виртуальном замке.

Создание 3D Плана

Чтобы создать новый 3D План, откройте Главное меню GOALcity и выберите соответствующий пункт.

Важно! Для работы 3D плана GOALcity использует библиотеки DirectX версии 9c и выше. Необходимо заранее позаботится о том, чтобы DirectX был установлен в систему. Если DirectX не установлен в системе то строчки "Настройка планов" в главном меню попросту не будет и настройка планов станет невозможна!

Если Вы установили DirectX, а строчка "Настройка планов" так и не появилась, выполните следующие действия:

·завершите программу и службу GOALcity,

·запустите команду "Выполнить" нажав сочетание клавиш "Win+R" на клавиатуре,

·зарегистрируйте в системе библиотеку gcplan.dll выполнив команду regsvr32 "C:\Program Files (x86)\Speclab\GOALcity\gcplan.dll"

·перезагрузите ПК и запустите клиентскую часть GOALcity. Строчка "Настройка планов" должна появиться.

После активации "Настройки планов" перед Вами откроется окно "Менеджер планов". Нажмите кнопку "Добавить" и укажите путь до вашей 3D модели в формате .x, либо до любого "плоского" изображения в формате .jpg.

Выбранный файл появится в "Менеджере планов". Кликните по нему левой кнопкой мыши и нажмите кнопку "Ок". Откроется окно плана со "станадартным" видом.

Режим настройки вида

Нажмите на кнопку windows-03 в левом верхнем углу окна плана, откроется контекстное меню. Выберите "Режим настройки вида".

Теперь план можно "крутить и вертеть" во всех плоскостях. Прозрачный круг в центре окна просмотра, символизирует собой центр осей координат (точку 0.0.0.).

С помощью зажатой левой кнопки мыши можно вращать камеру, с зажатой правой клавишей мыши - наклонять, колесиком мыши производится масштабирование.

Настройте удобный для просмотра вид, и сохраните его нажав на кнопку 3dplan-05 в панели справа от основного окна:

Создайте несколько видов для более удобной работы с 3D планом и возможности их смены, по определенным событиям. Все они будут отображаться в миниатюрах на панели видов

Режим редактирования

В "Режиме редактирования" производится добавление новых объектов на план.

Нажмите на кнопку

и выберите в контекстном меню пункт "Режим редактирования". Справа (где была панель видов) откроется менеджер объектов. Все объекты хранятся в папке "C:\Program Files\Speclab\GOALcity\Plan\objects". Если нужно будет добавить новый объект, необходимо поместить его в эту папку и перезапустить GOALcity.

"Раскройте" папку "objects" и выберите необходимый объект. Для примера, пусть это будет "зона". Данный объект представляет из себя обычную плоскость, с помощью которой удобно отмечать "зоны интереса", покрытие датчиков и т.д. Кликом на "плюсик" рядом с объектом можно посмотреть его анимации, т.е. как он должен себя вести на плане при сработке определенных алгоритмов.

Нажмите кнопку "Добавить", задайте имя новому объекту. Старайтесь давать объектам простые и понятые имена, чтобы в дальнейшем при настройке не путаться в куче одинаковых названий.

Нажмите кнопку "Ок" в окне "имени" и объект появится на плане в центре координат. С помощью мыши переместите объект в нужное положение. Правой кнопкой мыши осуществляется наклон объекта, левой - "перетаскивание", колесиком можно масштрабировать объект. При размещении объекта пользуйтесь блокированием осей, это сильно упростит процесс размещения!

Подпись объектов плана

В новых версия программы добавлена возможность наложения текста на план для удобства подписи необходимых объектов плана.

Чтобы добавить надпись на план, активируйте "Режим редактирования" и выберите из списка объектов объект "label" (папка "Наложение"). Нажмите кнопку "Добавить".

Откроется окно с параметрами текста. Укажите необходимый шрифт, размер шрифта, выравнивание и прочие параметры.

Обратите внимание! Несмотря на то, что 3D план имеет три проекции и может "вращаться" текст всегда будет обращен к Вам "лицом" и доступен для чтения.

Клонирование объектов плана

Как правило, датчиков и охранных зон довольно много, и объектов требуется несколько. Чтобы упростить работу, можно клонировать уже настроенные объекты. Переключитесь в "Режим редактирования", кликните правой кнопкой мыши по объекту который нужно скопировать и выберите в контекстном меню пункт "Клонировать текущий объект". Объект будет полностью идентичен предыдущему! Измените его имя в строке "Название" и не забудьте, затем, поменять привязки к источникам GOALcity.

Привязка объектов плана к источникам и настройка анимации

Нажмите на кнопку

и выберите в контекстном меню пункт "Объекты плана". Откроется окно в котором перечислены все объекты добавленные на план.

Выберите объект, который нужно "связать" с источником GOALcity. Нажмите кнопку "Настроить". Откроется окно "привязки" .

Анимация состояний устройства

Выберите источник GOALcity с которым хотите "связать" объект плана в строке "Выберите объект программы". Важно! Чтобы устройство появилось в списке, необходимо подключить его к клиенту GOALcity, на Диаграмме подключений, иначе в списке его просто не окажется!

Для каждого устройства существует несколько состояний и они изменяются в зависимости от типа этого устройства.

Выберите состояние, к которому нужно привязать анимацию, и нажмите кнопку "Настроить". Откроется окно "Настройка состояния".

·"Программа видов" - если устройство переходит в выбранное состояние, камера на 3D плане покажет ранее сохраненный вид на указанное в настройках время.

·"Программа анимаций" - активизирует анимацию объекта на плане при переходе устройства в выбранное состояние.

Управление устройствами непосредственно с плана

В поле "Список действий" окна "Настройка объекта плана" настраивается взаимодействие объекта плана и различных способов "кликов" по этому объекту.

Выберите способ "клика" и в поле "Команда объекта программы" укажите необходимое действие. Все довольно просто. Действия устройств полностью аналогичны действиям при настройке событий SL++.

Сохраните все изменения последовательным нажатием кнопок "Ок".

Важно! Для того, чтобы анимация и действия с объектами плана отрабатывали, необходимо включить обработку событий SL++ на главной панели управления, даже если у Вас не создано ни одного события SL++!

Режим просмотра

Нажмите на кнопку

и выберите в контекстном меню пункт "Режим просмотра". Это общий вид плана для работы оператора. При этом работают все настроенные на объекты события мыши, анимация всех объектов и прочие настройки плана.


WEBcam

WEBcam - Веб интерфейс пользователя.

Navigation: Настройка >

WEBcam - Веб интерфейс пользователя.

Общее описание

WEBCam - полезное бесплатное дополнение к GOALcity, которое позволяет через браузер просматривать видео с камер и публиковать его в сети.

Подключение

Для того, чтобы подключиться к WEBCam, укажите в браузере IP адрес компьютера и порт, через который GOALcity обменивается данными через сеть (по умолчанию 3107). Для примера адрес будет 192.168.10.23, то есть в браузере это будет выглядеть так: http://192.168.10.23:3107.

Откроется стартовая страница.

Кликните левой кнопкой мыши по надписи "SPECLAB" в центре страницы. Откроется веб интерфейс системы GOALcity. Пока что он пуст, нет ни камер, ни датчиков, ни архивов.

Кликните по строке "Администратор" и введите данные для доступа к системе. Пароли настраиваются на вкладке "Пользователи" Основных настроек GOALcity.

Просмотр "живого" видео

Кликните левой кнопкой мыши по строке "Видео камеры" и в ниспадающем списке выберите, какие из камер хотите просматривать.

"Окна" камер можно масштабировать и располагать по всей площади окна браузера. Панель управления внутри окошка с видео позволяет задать скорость просмотра видео, развернуть камеру на "весь экран" (на все окно браузера), включить\выключить запись и перевернуть изображение на 180 градусов.

Важно! Функция включения\выключения записи будет работать только после настройки необходимого архива в клиенте GOALcity, активизации опции "Web сервер" на вкладке "Интеграция" основных настроек GOALcity и включения SL++.

В верхней строке отображается текущее состояние и скорость записи камеры.

Просмотр панелей "Внимание!"

Кликните левой кнопкой мыши по строке "Панели "Внимание!" и в ниспадающем списке выберите, какую из панелей хотите просматривать.

Панели можно масштабировать и располагать по всей площади окна браузера.

Важно! Функция просмотра панелей "Внимание!" будет работать только после активизации опции "Web сервер" на вкладке "Интеграция" основных настроек GOALcity.

Просмотр записей с камер

Кликните левой кнопкой мыши по строке "Видео архивы" и в ниспадающем списке выберите, архив какой из камер Вы хотите посмотреть.

"Окно" архива точно так же масштабируется и "перетаскивается" с помощью мыши. Панель управления внутри окна позволяет задать начало просматриваемого периода, установить скорость просмотра, развернуть архив на "весь экран" (на все окно браузера) и перевернуть изображение на 180 градусов.

В правом верхнем углу окна отображается текущая дата и время просматриваемого архива. т.е. какой момент Вы видите в данное время.

Работа с ключами и датчиками

Кликните левой кнопкой мыши по строке "Датчики и ключи" и в ниспадающем списке выберите, необходимые датчики или ключи.

"Окно" датчика\ключа масштабируется и "перетаскивается" с помощью мыши. Двойным кликом в "теле" ключа можно изменить его состояние.

Таким образом WEBcam GOALcity позволяет настроить гибкое рабочее "веб" место, внешний вид которого будет полностью совпадать с полноценным в системе. Все элементы веб интерфейса могут одновременно находится в поле видимости и масштабироваться под Ваши нужды.


Как подключить IP камеру

Navigation: Настройка >

Как подключить IP камеру

Чтобы подключить IP камеру в GOALcity, не нужно особых навыков работы с ПК, достаточно знать модель камеры и поддерживаемые ей способы (кодеки) сжатия видео. Чтобы использовать покадровый кодек mjpeg обычно камера должна пройти расширенную интеграцию с GOALcity. Но, как показывает практика, большинство из камер работают и без дополнительной интеграции.

Чтобы использовать потоковый кодек h264, необходимо знать rtsp ссылку на поток с данной камеры. Ссылка, как правило, приводится в документации к оборудованию, либо отображается в веб интерфейсе устройства.

tipbulb Смотрите также:

· IP Source. Подключение IP камеры с использованием кодека mjpeg

· RTSPSource. Подключение IP камер с использованием кодека h264


IP Source. Подключение IP камеры с использованием кодека mjpeg

Navigation: Настройка > Как подключить IP камеру >

IP Source. Подключение IP камеры с использованием кодека mjpeg

Общее описание

IpSource - приемник для работы с различным IP оборудованием (видеокамеры, видеосервера, мегапиксельные камеры). Для некоторых моделей оборудования дополнительно поддерживается работа со встроенными каналами звука (аудио), датчиками и реле. Устанавливается вместе с мультимедиа сервером.

Создание источников

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке

напротив пункта "IP Source" и выберите строчку "Редактировать". Через этот источник можно подключить к GOALcity различные IP устройства: камеры, микрофоны, передатчики и т.д. Полный список интегрированных камер Вы всегда можете найти на нашем сайте технической поддержки.

Кликните по кнопке button-04 справа от пункта "Камеры", перед Вами откроется список всего оборудования, прошедшего расширенную интеграцию. Выберите источник "Axis-Video".

В окне настроек заполните необходимые поля соответсвующими данными:

·"Название" - введите название видео источника.

·"Хост" -введите IP адрес видео источника.

·"Пользователь" и "Пароль" - введите данные для аутентификации на устройстве.

·"Использовать прокси" - если Ваша сеть использует прокси-сервер, введите его параметры.

·"Время ожидания ответа" - укажите интервал времени в секундах, за которое должен быть получен ответ от камеры, если за это время камера не ответит, в окне вместо видео появится надпись "Нет сигнала".

·"Камера" - номер камеры (видео канала), укажите необходимый канал, при условии что подключаемся к видео серверу с несколькими каналами. Если это одиночная камера, оставьте значение "1".

·"Разрешение" - укажите разрешение камеры. Важно! Разрешение при подключении камеры в GOALcity и в веб интерфейсе камеры должны совпадать!

Нажмите кнопку "Ок" сохраните изменения и закройте настройки "Мультимедиа сервера".

Обратите внимание! Для каждого из источников набор параметров может отличаться: для каких-то камер можно указать разрешение, для каких-то - скорость просмотра и другие параметры. Но, зачастую, все необходимые настройки разрешения и скорость отображения видео нужно производить в веб интерфейсе IP камеры.

Теперь на Диаграмме подключений в "Мультимедиа сервере" Вы увидите созданную IP-камеру. Осталось только ее подключить к окну GOALcity.

Подключение микрофонов, датчиков, ключей и прочего оборудования выполняется идентично. Вся разница в выборе источника - Микрофоны, Устройства и прочее.

Клонирование источников

Функция клонирования используется для создания нескольких копий выбранного элемента (камера, микрофон, датчик, ключ). Копия может отличаться от оригинала несколькими параметрами (название, ip-адрес, и т. д.). При клонировании можно автоматически изменить числовые элементы в параметрах "Имя" и "Host" в сторону возрастания. Для этого надо сразу после числа, которое необходимо изменить, поставить два знака "+". Например, пусть элемент называется "video 1". Тогда, добавив в параметр "Название" два знака "+", получим "video 1++". При клонировании, к числу "1" будет добавлен порядковый номер создаваемой копии, и в результате будут созданы элементы с названиями "video 2", "video 3" и т. д.


RTSPSource. Подключение IP камер с использованием кодека h264.

RTSPSource или FFSource. Подключение IP камер с использованием кодека h264

Navigation: Настройка > Как подключить IP камеру >

RTSPSource или FFSource. Подключение IP камер с использованием кодека h264

Общее описание

RTPSource - приемник для работы с IP видеокамерами или серверами по RTP или RTSP протоколу передачи мультимедийных данных. Устанавливается вместе с мультимедиа сервером. Поддерживается работа и по протоколу ONVIF, имеется автоматический поиск поддерживаемых камер.

FFSource - другая версия источника для работы с IP видео камерами через GOALcity и RTSP протокол передачи мультимедийных данных. В работе используются программные библиотеки ffdshow. Устанавливается вместе с Мультимедиа сервером GOALcity. Является заменой устаревшего источника VLCSource.

Разница между источниками

·RTSPSource получает и пишет видео кодеком H.264. Так как для записи используется потоковый кодек, то трафик и размер архива будет на порядок меньше, чем при использовании покадрового кодека. Однако при просмотре будет тратиться много процессорных ресурсов. Просмотреть синхронно несколько камер в полном формате практически невозможно. Из-за структуры потока проблематичен и покадровый просмотр назад.

·FFSource также получает видео в формате H.264, но запись на жесткий диск производится с использованием покадрового кодека mjpeg, т. е. записывается каждый кадр. Размер архива будет больше, чем при использовании потокового кодека, но ресурсов при просмотре будет тратиться намного меньше и просмотреть несколько камер синхронно не составит никакого труда. Покадровый просмотр назад также идет без проблем.

Рекомендации по подключению IP камер

Современные IP камеры могут "отдавать" сразу несколько видео потоков в разном разрешении и с использованием разных кодеков. Используя эту функцию камер, мы доработали наш RTSP источник тем самым, позволяя существенно снизить нагрузку на ЦП, путем вывода на просмотр в маленьком окне "небольшого" потока, но при "распахивании" окна GOALcity автоматически переключаться на "полный" поток. Другими словами, в маленьком окне Вы будете видеть "маленькую" картинку, но так как размер окна мал, то отличий от изображения в полном разрешении практически не будет. При максимизации окна Вы будете видеть изображение в полном разрешении.

Запись при этом ведется всегда "полного" потока в максимальном разрешении.

Чтобы настроить такой алгоритм работы, выполните следующие действия:

·Используйте RTSP источник для создания камер или мастер добавления IP камер GOALcity.

·"раскройте" созданный RTSP источник и введите необходимые данные в поля "URL для просмотра" и "URL для записи"

В поле "URL для просмотра" необходимо вводить ссылку на "маленький" видео поток с IP камеры, он будет отображаться в маленьком окне GOALcity. Рекомендуем использовать кодек jpeg и разрешение 640х480 или меньше в зависимости от размера окна. Рекомендуем устанавливать разрешение камеры с сохранением пропорций изображения!

В поле "URL для записи" необходимо вводить ссылку на "полный" видео поток с этой же IP камеры, он будет отображаться при распахивании окна GOALcity и постоянно записываться. Рекомендуем использовать кодек h264 и максимальное разрешение.

Создание источников

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке

напротив пункта "RTPSource" или "FFSource" и выберите строчку "Редактировать". Принцип создания источника очень похож на выше рассмотренный, только вместо IP адреса камеры используется rtsp ссылка на поток. Большое количество RTP ссылок для IP камер различных производителей Вы можете найти в интернете.

Нажатием кнопки button-04 вызовите всплывающее меню и выберите "Добавить видео источник". Откроется окно добавления нового источника.

Укажите все необходимые параметры и сохраните изменения. Аналогично прошлому примеру, созданный источник появиться в Мультимедиа сервере и останется только подключить его к окну GOALcity.

Чтобы повторно открыть настройки видео источника, достаточно щелкнуть по пиктограмме напротив необходимого источника. Удаление ненужных источников производится кликом по кнопке vss-19. Так же настройки подключения можно поменять непосредственно из окна камеры, зайдя в её настройки и перейдя на вкладку "Подключение". Настройки полностью аналогичны и могут быть изменены любым из доступных методов.

Клонирование источников

Функция клонирования используется для создания нескольких копий выбранного элемента (камера, микрофон, датчик, ключ). Копия может отличаться от оригинала несколькими параметрами (название, ip-адрес, и т. д.). При клонировании можно автоматически изменить числовые элементы в параметрах "Имя" и "Host" в сторону возрастания. Для этого надо сразу после числа, которое необходимо изменить, поставить два знака "+". Например, пусть элемент называется "video 1". Тогда, добавив в параметр "Название" два знака "+", получим "video 1++". При клонировании, к числу "1" будет добавлен порядковый номер создаваемой копии, и в результате будут созданы элементы с названиями "video 2", "video 3" и т. д.


Tweaker

Navigation: Настройка >

Tweaker

Служебная утилита GOALcity Tweaker содержит различные настройки программы для администратора системы видеонаблюдения.

Изменяйте эти параметры только если Вы полностью уверены в том что делаете или по рекомендациям службы технической поддержки.

·"Порог сброса кэша (сервер/клиент)" - Включение автоматической системы отслеживания занимаемых ресурсов видеосервером. Во время своей работы система GOALcity активно использует оперативную память компьютера, и в случае, если расход превышает указанный в процентном соотношении предел (по умолчанию 80%), то происходит освобождение неиспользуемых ресурсов (сброс кэша). Для 32-х разрядной системы максимальный объем используемой оперативной памяти равен 2Gb. Для 64-х разрядной - 64Gb. Соответственно, 80% будут считаться исходя из выше указанных значений.

Не включайте данную опцию без дополнительной рекомендации нашей службы технической поддержки!

Обратите внимание! При активации данной настройки и наступления момента переполнения порога оперативной памяти система GOALcity автоматически перезапуститься. При этом, если включена и настроена запись в архив, в журнале GOALcity Вы можете найти сообщение об ошибках записи.

·"Количество часов в кэше записи архива" - чем выше значение, тем выше скорость чтения архива, но больше расход памяти. Рекомендуется оставлять значение по умолчанию, а при большом расходе памяти - уменьшить.

·"Отслеживать использование системных ресурсов" - при включении, в системный журнал добавляются процессы GOALcity.exe и slssh.exe.

·"Дефрагментация памяти" - данная опция предотвращает необоснованный расход памяти. Внимание! Данная настройка экспериментальная! Изменять без рекомендации не следует!

·"Защита памяти (сервер/клиент)" - активировать только при нестабильной работе приложения. При включении увеличивается шанс найти ошибку в программе, но при этом увеличится расход памяти и возрастает нагрузка на процессор. Внимание! Данная настройка экспериментальная! Изменять без рекомендации не следует!

·"Использовать кодек SpecLab S-JPEG HARD по умолчанию" - при активации данной опции включается кодек индивидуального сжатия видеоинформации каждому сетевому клиенту SpecLab S-JPEG HARD.

·"Права по умолчанию для неизвестного пользователя" - данная опция позволяет подключаться к серверу любым пользователи (которые не созданы на сервере). Для этого необходимо поставить отметку ("галку") напротив соответствующего пункта и в строку ввести имя пользователя и пароль следующим образом: пользователь\пароль, без пробелов. В нашем случае: unknown\1 (имя пользователя - unknown, пароль - 1). Затем необходимо создать такого же пользователя ("unknown") с таким же паролем ("1") на серверах и предоставить ему права, которые будут автоматически передаваться всем неизвестным пользователям, подключающимся к серверу.

·"Уникальная строка сервера" - здесь указывается уникальный идентификатор сервера GOALcity (типа MAC-адреса). К нему "привязываются" все настройки GOALcity. При изменении этого идентификатора все настройки собьются, поэтому необходимо его запомнить и записать.

·"Размер дампа памяти при сбое" - доступно четыре варианта - минимальный, средний, большой и полный. Для сбора всей необходимой информации рекомендуем оставлять значение "полный".

·"Максимальный таймаут соединения SLDCOM" - устанавливается время отсутствия соединения, в миллисекундах, по истечении которого программа решит, что удалённый компьютер не отвечает.

·"Максимальное количество открытых сокетов SLDCOM" - устанавливается максимальное количество сетевых соединений.

·"Максимальное количество потоков веб сервера" - регулирует использование ресурсов веб сервера. Внимание! Данная настройка экспериментальная! Изменять без рекомендации не следует!

·"Максимальное количество потоков в пуле процесса" - увеличение значения даст необходимый эффект только при конфигурациях клиента от 100 камер и выше. Внимание! Данная настройка экспериментальная! Изменять без рекомендации не следует!

·"Безопасный режим драйвера" - если активировать данную опцию, то кадры будут принудительно удаляться из буфера, но возможен эффект "старых кадров". Внимание! Данная настройка экспериментальная! Изменять без рекомендации не следует!

·"Язык интерфейса" - позволяет выбрать язык интерфейса программы.

·"Порт подключения сервера" - здесь можно задать порт для сетевых подключений, в том числе WEBCam (по умолчанию 3107).

·"Использование старой конфигурации" - включите данную опцию если Вы загружаете конфигурацию от более ранних версий системы (Cassandra, Instinct-2 и т.д.)

·"Использовать ProcDump для создания дампов" - опция используется для альтернативного способа сбора служебной информации. Важно! Включается только по рекомендации службы технической поддержки!


Создание дампов с помощью ProcDump

Navigation: Настройка >

Создание дампов с помощью ProcDump

Общие сведения

Бываю случаи, когда встроенный в GOALcity автоматический сборщик дампов не работает, или работает не корректно. При этом дампы могут либо вообще не создаваться, либо создаваться с ошибками. Чтобы исправить это, и при "падении" программы получить полноценную отладочную информацию в GOALcity был добавлен дополнительный инструмент отладки - ProcDump.

Важно! По умолчанию GOALcity использует встроенный сборщик дампов, которого, в большинстве случаев, хватает. Используйте ProcDump только по рекомендации службы технической поддержки.

Включение ProcDump

ProcDump включается с помощью служебной утилиты GOALcity, иначе - Tweak'eр. Чтобы его запустить, откройте меню "Пуск", далее "Все программы", SpecLab", "GOALcity" и выберите "GOALcity Tweak".

Откроется окно твикера с различными параметрами. Ни в коем случае не изменяйте их, если не знаете что делаете или Вам это не рекомендовала служба технической поддержки. Изменение параметров в твикере может повлечь за собой нестабильную работу системы или вообще её полный отказ.

·"Проскрольте" окно в самый низ, и найдите строчку "Использовать ProcDump для создания дампов".

·Активируйте этот пункт, поставив "птичку" перед ним.

·Переместите курсор мыши на надпись "Нет" справа, кликните левой кнопкой мыши и выберите пункт "Да".

·Внешний вид окна с включенным ProcDump будет следующий:

·Теперь все дампы будут создаваться используя ProcDump до выключения в твикере. Вместе с GOALcity запускается процесс procdump.exe, контролирует работу системы и завершается при выгрузке GOALcity. В случае непредвиденного завершения процессов клиента GOALcity (goalcity.exe) или службы (slssh.exe) - создает дампы памяти.

·Дампы сохраняются по пути "Системный диск:\Users\"Текущий пользователь"\AppData\Roaming\SpecLab\GOALcity\GOALcity\xml_log\ - от клиентской части GOALcity и по пути "Системный диск":\Users\All Users\SpecLab\GoalCity\Server Host\xml_log\" - от серверной части.


Работа под ограниченной учетной записью

Navigation: Настройка >

Работа под ограниченной учетной записью

GOALcity во время своей работы активно использует ресурсы ПК, доступные только учетным записям с правами администратора данного ПК. Чтобы создать ярлык программы и запускать её всегда с правами администратора из под любой учетной записи воспользуйтесь следующей инструкцией:

· Скачайте архив с дистрибутивами необходимых программ.

·"Залогиньтесь" на ПК под учетной записью администратора и установите программу AdmiLink.

Процесс установки

Запустите исполняемый файл installadmilink.exe. Откроется мастер установки программы.

Выберите необходимый язык программы и нажмите кнопку "Ок".

Согласитесь с лицензионным соглашением нажатием кнопки "Принимаю".

Выберите необходимые компоненты установки, рекомендуем оставить все "По умолчанию".

Выберите папку установки программы, нажатием кнопки "Обзор..." или оставьте путь предлагаемый мастером установки. Нажмите кнопку "Установить".

Начнется процесс копирования файлов. Нажмите кнопку "Закрыть" по окончании процесса записи файлов и закройте мастер установки.

·Выйдите из системы и "залогиньтесь" под пользователем, который будет работать с GOALcity.

·Запустите ранее установленную программу AdmiLink.

·В первой строке укажите путь к программе Elevate соблюдая разрядность операционной системы (входит в состав архива).

·Во второй - путь к исполняемому файлу GOALcity.exe.

·Перейдите на вкладку "Account", укажите данные учетной записи с правами администратора. Если используется локальная учетная запись, то в поле "Имя домена" выберите "localhost", если же используется доменная сеть, то выберите необходимый домен нажатием на кнопку ".....". Нажмите на кнопку "Сгенерировать ключ запуска AdmiRun".

·Перейдите на вкладку "LNK". Укажите имя создаваемого ярлыка в поле "Имя ярлыка" и путь, куда нужно сохранить созданный ярлык в поле "Каталог".

·В поле "Картинка" укажите путь к исполняемому файлу GOALcity.exe чтобы внешний вид ярлыка не отличался от "стандартного", хотя Вы можете выбрать любое другое изображение на Ваш вкус.

Важно! Измените путь сохранения нового ярлыка с установленного по умолчанию (рабочий стол) на "корень" любого из жестких дисков. Программа не всегда корректно создает ярлыки сразу на рабочем столе. Позже можно будет переместить созданный ярлык вручную.

·Нажмите кнопку "Сгенерировать командную строку" и затем "Создать ярлык сейчас!".

·Переместите ярлык из папки на рабочий стол и запускайте программу используя его.


Архивный сервер

Navigation: »No topics above this level«

Архивный сервер

"Архивный сервер" - менеджер записи, хранения и просмотра видео-, аудиоданных, а также истории событий системы в комплексе или индивидуально по каждому элементу безопасности.

Он разграничивает доступ большого числа пользователей как локально, так и по сети, обеспечивая контроль прав, перераспределение ресурсов, защиту данных.

Если Вы установили бесплатное ПО, а затем перешли на платное, но не приобрели архивный сервер, то его нужно удалить через "Программы и компоненты".

tipbulb Смотрите также:

· Установка Архивного сервера

· Создание или подключение архива

· Просмотр и фильтрация записей


Установка Архивного сервера

Navigation: Архивный сервер >

Установка Архивного сервера

Запустите исполняемый файл 3_Archive_Server_x64.exe (ранее файл назывался setupas_x64.exe). На мониторе Вы увидите окно "Установка Archive Server", в котором отображается версия программы и номер сборки.

Важно! Программа использует электронный аппаратный ключ защиты Guardant Sign или Guardant Stealth-II. Убедитесь, что Вы скопировали файл license.txt в корневой каталог диска, на который установлена операционная система перед запуском программы. Без файла-лицензии программа будет работать в демо-режиме. Если в системе используется ключ Stealth-II то необходимо дополнительно вручную установить драйвера на ключ защиты!

·Инсталляцию системы нужно проводить, загрузив ОС под именем пользователя, обладающего правами администратора этого ПК;

·Система GOALcity должна работать в сеансе того пользователя ОС, который производил инсталляцию системы

·Категорически запрещается работать одновременно под разными пользователями ОС, каждый из которых запускает свой сеанс GOALcity.

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена" (текст лицензионного соглашения будет показан только при "чистой" установке программы, если любой из компонентов уже установлен, то мастер автоматически пропустит этот шаг).

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции "Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск".

После этого мастер откроет окно "Опции повторной установки". Отметьте "птичками" необходимые действия: если нужно удалить все предыдущие настройки GOALcity - "Удалить файлы настроек". Если драйвера на ключ защиты Guardant уже установлены в системе, и переустанавливать их нет необходимости - "Не переустанавливать драйверы ключа защиты". Нажмите кнопку "Установить".

Начнется процесс записи файлов программы на ПК, ход которой отображается в окне "Копирование файлов", пожалуйста, немного подождите.

Завершите установку Архивного сервера GOALcity нажатием кнопки "Готово".


Создание или подключение архива

Navigation: Архивный сервер >

Создание или подключение архива

Установите дистрибутив "Архивного сервера" - 3_Archive_Server_x64.exe (ранее файл назывался setupas_x64.exe). Запустите клиентскую часть GOALcity и произведите поиск серверов GOALcity. Отметьте галочками все найденные серверы и добавьте их на Диаграмму подключений.

Откройте настройки "Архивного сервера", кликнув правой кнопкой мыши на прямоугольнике "Сервер архива" и в появившемся меню выберите "Настроить...", либо дважды кликните по "шапке" сервера архивов.

Откроется окно настроек, которое поделено на две части. Слева располагается список основных пунктов в виде дерева, справа - окно, в котором производятся те или иные настройки.

Нажмите кнопку "Добавить" и затем "Создать" (либо "Подключить" если хотите использовать ранее созданный архив).

Укажите путь к папке, в которой будет храниться архив и укажите ограничения архива по:

·максимальному размеру архива;

·минимальному свободному месту на жестком диске;

·времени записи.

Для создания архива на сетевом диске или сетевом хранилище следует вручную вписать путь к архиву в диалоге добавления архива, не используя встроенный диалог выбора папки.

Путь будет выглядеть примерно так: \\192.168.10.150\Arh, а не как на рисунке выше.

Важно! Для корректного подключения сетевого диска необходимо в настройках служб Windows изменить тип входа в систему для службы SpecLab Server Host (slssh.exe) с системной учетной записи на учетную записью администратора или любого другого пользователя обладающего этими правами! Так же, необходимо убедиться, что пользователь, от которого будет загружаться служба имеет доступ по локальной сети в "расшаренную" для архива папку.

В рамках Архивного сервера можно создать неограниченное количество сетевых архивов!

Преимущество "Архивного сервера" перед локальным архивом состоит еще и в том, что можно создать неограниченное количество архивов на разных дисках и в каждый вести запись информации с любого количества источников. Таким образом, можно настроить запись так, что с одной группы источников запись идет в один архив, который находится на одном жестком диске, а с другой группы - на другой диск и т.д.

При достижении любого порогового значения ограничений, место под новые записи будет освобождаться путем удаления старых, т.е. активируется механизм самостирания.

Обратите внимание! Если при настройке архива было указано одно значение минимального свободного места, а затем изменено на большее, то освобождение дискового пространства произойдет не мгновенно, а в течении 15-30 минут работы GOALcity. Например, архив занимал на жестком диске 1,5 ТБ, изменяем его параметры и ставим ограничение размера в 500 ГБ. Сохраняем настройки. "Свободное место" появится в течении 15-30 минут.

Сохраните изменения нажатием кнопки "Ок". При этом в окне настроек сервера появится архив, имя архива совпадает с именем указанной папки.

После выполнения всех настроек Архивного сервера нажмите кнопку "Ок" и перейдите на Диаграмму подключений. От созданного сетевого архива протяните связь в новое окно клиента GOALcity.

После этого нажмите в правом нижнем углу "Диаграммы подключений" кнопку "Ок". Откроется клиент GOALcity с окном созданного архива.

В примере рассмотрено создание одного архива, но можно создать и несколько, поочередно

добавляя их указанным способом!


Просмотр и фильтрация записей

Navigation: Архивный сервер >

Просмотр и фильтрация записей

Чтобы посмотреть записанную информацию в GOALcity существует несколько способов: кликом по кнопке archsrv-06 Главной панели управления можно открыть полностью весь архив и выбрать необходимую камеру (или камеры) либо открыть архив непосредственно из окна камеры, кликнув по всплывающей кнопке button-play, получив записи именно этого источника.

За частую используется именно второй способ, но первый способ пригодится для одновременного синхронного просмотра нескольких камер в одном окне.

Выбор камер и избыточности просмотра

Чтобы открыть архив, кликните по кнопке

"Архив" Главной панели управления. Откроется окно "Выберите записи для просмотра".

Выберите записи для просмотра с интересующих Вас камер, отметив соответствующие строчки флажками. Если в списке камер отсутствуют данные о дате записи, нажмите кнопку "Получить диапазон".

Если необходимо выбрать другие камеры для просмотра записей - нажмите кнопку "Снять выделение" и произведите выбор снова. Для каждой из камер можно настроить "Избыточность просмотра".

Избыточность

·Минимальная – выводятся только те кадры, в которых произошла сработка детекторов (движения, лиц, автономеров и т.д.) и алгоритмов Панели "Внимание!". Это может быть дерганый просмотр, т.к. видеодетекция неоднородна и не всегда отражает полную картину. Но это минимальная информация, которая передает сюжеты перед камерой, как видит их машина. Рекомендуется использовать при недостатке времени на просмотр.

·Средняя – выводятся все кадры, в которых произошла сработка алгоритмов и детекторов, а также те, которые были записаны до и после сработки. Проигрывание идет в однородной скорости. На просмотр выводятся даже те кадры, которые могли быть "не отмечены" детектором в силу незаметности движения (эмоции лица, движения глаз, разговорных мышц, легкие покачивания головой, конечностями и проч.) Выводятся также и промежутки между продетектированными движениями, например, тот период, пока человек стоял неподвижно. Кроме того, выдается некоторый период записи, предшествующей началу движения. Рекомендуется использовать при стандартном просмотре.

·Максимальная – самая большая плотность кадров, в которую входит вся записанная информация. Как правило, это страховочная запись, которая делается на случай, если видеодетекцию по каким-либо причинам удалось обойти, например, при сильных атмосферных помехах. Рекомендуется использовать в случае рассмотрения происшествия и выводить только ограниченный период самого происшествия, т.к. постоянный просмотр такого объема записи требует крайне много времени.

Аналитика

Если отмечена опция "Аналитика", то сюжеты, на которые среагировали алгоритмы аналитической системы "Внимание!" (Панель "Внимание!"), будут автоматически воспроизводиться плеером с максимальной избыточностью. Как правило, это новые события, нестандартное поведение или изменение обстановки в зоне обзора камеры.

На просмотр выводятся начальные моменты записанных сюжетов, а в окошке "Аналитика" выставляется интервал времени, который добавится при воспроизведении этих сюжетов. В полученных таким образом интервалах будут показаны все кадры без фильтрации. Рекомендуется использовать как основной тип просмотра в стандартном режиме постоянного контроля за объектом.

Завершив настройку, нажмите кнопку "Готово". Перед вами откроется окно архивного плеера.

Окно архивного плеера

"Окно плеера архива" визуально разделено на 2 части: верхняя – окна просмотра, нижняя – элементы управления плеером и панели с информацией.

Воспроизводит записи архива программный многофункциональный видео плеер, который может:

·Одновременно и синхронно демонстрировать записи с нескольких камер (каждую в отдельном окне);

·Отключать/подключать просмотр одной или нескольких камер "на ходу" без остановки воспроизведения;

·Переключать масштаб диапазона времени от 1 секунды до 4-х лет;

·Производить поиск и отображение информации по разным признакам (детекция движения, оставленные, унесённые предметы, номера автомобилей, лица);

·Графически отображать плотность записи;

·Графически отображать запись сработок детекторов, как в общем потоке информации, так и отдельно по каждой из подключенных камер;

·Пере подключаться к архиву по команде оператора;

·Производить экспорт информации в другой раздел ПК, на другие компьютеры, на другие носители: CD, DVD-диски и т.п.;

·Сохранять отдельные кадры в формате *.jpg;

·Изменять скорость воспроизведения в диапазоне от х0,10 (десятикратное замедление) до х64 (ускорение в 64 раза)

Раскраска интервалов записей на шкале времени плеера является неточным, исключительно оценочным инструментом. Алгоритм раскраски, при некоторых условиях, при наличии даже одного кадра с движением может привести к изменению цвета участка записи длительностью до нескольких минут и даже больше.

В верхней части отображается картинка, поступающая с архива записей камер. Наличие подписи под окном камеры и вид этой подписи переключается кнопкой arch-prosmotr-04. Каждый очередной клик по ней переключает вид подписи или совсем выключает её. Следующая кнопка arch-prosmotr-05 служит для переключения соотношения сторон кадра. В нажатом состоянии кадр в окне воспроизводится с реальным соотношением сторон. Если кнопка неактивна, кадр заполняет окно камеры полностью и может воспроизводиться с искажением размера кадра в зависимости от размера окна. Кнопка arch-prosmotr-06 переворачивает изображение на 180 градусов.

Кнопка arch-prosmotr-07 позволяет установить фильтры для отбора плеером соответствующей информации из архива. Подключив желаемые фильтры, нажмите кнопку "Ок".

Левее располагаются кнопки, отвечающие за включение/отключение от просмотра архива определённых камер. Например arch-prosmotr-09, – окно архива камеры 2 включено.

В нижней части окна плеера находится Панель управления. Линия, отделяющая эту область окна, может перемещаться, изменяя зону просмотра и зону управления плеером.

Ниже этой линии – кнопки выбора диапазона: крайняя справа позволяет выбрать диапазон непосредственно по датам, при этом можно воспользоваться встроенным календарём, открывающимся при клике по треугольнику в окошке "Годы".

Сама кнопка "Диапазон" является частью Селектора масштабирования диаграммы архива. Под селектором находится диаграмма архива, показывающая наличие записи и её плотность. Кнопки Селектора позволяют выбрать наиболее удобный масштаб диаграммы. Нажатие кнопки с названием соответствующего периода времени означает, что масштаб диаграммы будет соответствовать этому периоду.

Панель управления плеером видео архива

Большинство кнопок Панели управления плеером снабжены всплывающими подсказками, которые помогают быстро разобраться с их назначением. Тем не менее несколько пояснений не помешают. Итак, слева направо. Кнопка "Переподключение" – ей удобно воспользоваться, когда необходимо просмотреть записи с тех камер, которых сейчас в окне просмотра нет. Кликнув по ней, вы попадёте в меню выбора записей для просмотра, здесь, отметив соответствующие флажки, можно сменить просматриваемые камеры. Далее – кнопка "Настройки". При нажатии на нее открывается окно "Плеер – настройки", в котором можно установить некоторые опции плеера архивов.

Следующая кнопка позволяет сохранить фрагменты архивных видеозаписей как на жестком диске компьютера, так и на внешних носителях информации. После нажатия на неё откроется окно "Экспорт видео", в котором надо произвести соответствующие настройки: выбрать формат экспорта (SSDF или AVI), путь сохранения (раздел, каталог и название файла) и ввести, если необходимо, краткое описание.

С помощью следующей кнопки производится экспорт отдельного кадра. При нажатии её доступны следующие опции: сохранить в файле, скопировать в буфер обмена и печать. В случае выбора первой из них вы попадете в окно "Сохранение текущего кадра". Здесь нужно указать программе, куда записать снимок, и настроить с помощью ползунка качество записи изображения в формат *.jpeg. Чем более высокий процент вы выберете, тем лучше будет качество, но тем больше будет размер файла. Копирование в буфер обмена позволяет переместить кадр в другую программу или в документ, например, в MS Word при написании рапорта или объяснительной. Выбор опции "Печать" откроет диалог принтера, подключенного к компьютеру.

Чтобы автоматически перейти к следующему диапазону после окончания воспроизведения текущего нажмите на Панели управления плеером видео архива кнопку arch-prosmotr-15. Чтобы посмотреть все записи по текущей камере нажмите кнопку arch-prosmotr-16. Следующие две кнопки при воспроизведении архивных записей не активны. Воспользоваться ими можно только когда воспроизведение оставлено. Их назначение: помочь Вам в поиске нужных записей и их фрагментов.

arch-prosmotr-20 - Кнопки управления воспроизведением. Функции их разъясняются всплывающими подсказками. Далее на Панели управления плеером видео архива следуют две кнопки arch-prosmotr-21 с окошком между ними. Это регуляторы и индикатор скорости воспроизведения. С помощью стрелки влево можно замедлить воспроизведение до х0,10, т.е. в 10 раз, а стрелка вправо позволит ускорить его до х64, т.е. в 64 раза.

Поиск объектов и движения

Кнопка

откроет окно "Поиск объектов" в текущем диапазоне просмотра и в выбранной (или не выбранной) зоне. Если зона поиска не указана, то поиск будет производиться по всем кадру. Чтобы настроить фильтр объектов, нажмите кнопку "Настройки", Вы попадёте в таблицу, где расстановкой флажков-галочек в соответствующих клетках и установите цифровые значения нужных критериев поиска и нажмите кнопку "Готово", после чего, нажмите кнопку "Старт" и запустите поиск. Результаты поиска отобразятся в окне в виде кадров.

По умолчанию все категории открыты и активны. Вы можете отключить и свернуть "не нужные".

Контекстное меню окна управляет способом открытия-закрытия вкладок. Если активировать пункт "Раскрывать только один элемент", то на просмотр будет выводиться только один активный элемент, все остальные будут "спрятаны".

Поиск объектов можно производить и в определенной области видео. Для этого "наведите" курсор мыши на видео и в правом верхнем меню появится всплывающее меню, кликните по кнопке "Зоны поиска".

Выделите с помощью мыши необходимую зону для поиска.

Количество зон поиска не ограничено и Вы можете выделить сразу несколько. Чтобы удалить "ненужную" зону, "схватите" её левой кнопкой мыши и "утащите" за пределы окна архивного плеера.


Мультимедиа сервер

Navigation: »No topics above this level«

Мультимедиа сервер

Мультимедиа сервер представляет из себя комбайн источников для работы с различным оборудованием. В зависимости от установленных компонентов комплекса и компонентов в прошивке ключа защиты GOALcity в настройках мультимедиа сервера будут присутствовать следующие источники:

DeviceSource

DeviceSource - приемник для работы с виртуальными устройствами. Позволяет создавать виртуальные ключи. Требуется наличие в прошивке ключа защиты возможности работы с компонентом "Сервер устройств". Устанавливается вместе с мультимедиа сервером. Также через этот источник подключаются интегрированные датчики и ключи с системы ОПС "Багульник".

DirectShowSource

DirectShowSource - приемник для работы с устойствами DirectShow, такими как USB Web камеры и т. д. Является экпериментальной разработкой и присутствует только в аппаратном ключе защиты с прошивкой "Мастер ключ". Устанавливается вместе с мультимедиа сервером.

ExternalExtensionsSource

ExternalExtensionsSource - источник внешних расширений, используется для работы со специализированным оборудованием, например, для подключения IP оборудования производства Dallmeier. Требуется установка компонента ExternalExtensionsSource и наличие в прошивке ключа защиты возможности работы с данным компонентом. Устанавливается из файла ExtExSourceSetup.exe из комплекта ПО GOALcity.

FlirSource

FlirSource - источник для работы степловизорами от фирмы Flir. Термодетектор, разрабатываемый компанией СпецЛаб, на сегодняшний день идеальное средство для точного диагностирования целей и помех. Он, как и обычная видеокамера, может видеть на большие расстояния, и, в отличие от обычной, в густых кустах и лесных массивах. Пожалуй, это самый зоркий видеодетектор, а главное, самый точный помехоустойчивый. Ему не надо объяснять, что есть качающаяся ветка или крупный снег, он работает только по температурным объектам. Устанавливается из файла flirsource.exe комплекта ПО GOALcity.

CoxSource

CoxSource - источник для работы с тепловизорами немецкой фирмы Cox. Устанавливается из файла coxsource.exe комплекта ПО GOALcity.

EvsSource

EvsSource - источник для работы с камерами фирмы EVS отечественной разработки. Данные камеры работают по протоколу UDP и показывают довольно неплохие показатели, особенно по соотношению цена-качество. Устанавливается из файла evssource.exe комплекта ПО GOALcity.

Ретранслятор

GOALcity - приемник для работы с ретранслируемыми окнами видеоклиента GOALcity. Устанавливается вместе с мультимедиа сервером. Для работы с данным источником требуется прошивка компонента Ретранслятор.

IpSource

IpSource - приемник для работы с различным IP оборудованием (видеокамеры, видеосервера, мегапиксельные камеры). Для некоторых моделей оборудования дополнительно поддерживается работа со встроенными каналами звука (аудио), датчиками и реле. Устанавливается вместе с мультимедиа сервером. Для работы с данным источником требуется наличие в прошивке ключа защиты компонента "Сервер поддержки IP устройств".

RTPSource

RTPSource - приемник для работы с IP видеокамерами или серверами по RTP или RTSP протоколу передачи мультимедийных данных. Устанавливается вместе с мультимедиа сервером. Поддерживается работа и по протоколу ONVIF, имеется автоматический поиск поддерживаемых камер.

FFSource

FFSource - новая версия источника для работы с IP видео камерами через GOALcity и RTSP протокол передачи мультимедийных данных. В работе используются программные библиотеки ffdshow. Устанавливается вместе с Мультимедиа сервером GOALcity. Является заменой устаревшего источника VLCSource.

SLDASource

SLDASource - источник работы с устройствами, подключаемыми по протоколу RS-485 производства Спецлаб и ряда сторонних производителей. Также в этом источнике осуществляется подключение IP контроллера Телепатия производства Спецлаб. Требуется установка бесплатного драйвера SLDA и наличии в прошивке ключа защиты возможности работы с компонентом Сервер устройств. Устанавливается вместе с мультимедиа сервером.

Также через SLDASource подключаются устройства из интегрированных систем ОПС, таких как "Болид" и "Стрелец".

SLSource

SLSource - источник для работы с IP-видеосерверами и IP-Видеоблейзерами производства Спецлаб. Позволяет использовать все источники указанного оборудования (видео, датчики, реле и сигнализацию). Устанавливается вместе с мультимедиа сервером. Для работы с данным источником требуется наличие в прошивке ключа защиты компонента "Сервер поддержки IP устройств".

VlcSource

VlcSource - источник для внутренних (технологических) нужд. В большинстве случаев Вам он не понадобится, кроме как по рекомендации службы технической поддержки. Устанавливается из файла VlcSourceSetup.exe из комплекта дистрибутивов GOALcity.

С помощью этого источника можно проигрывать ролики в окнах GOALcity вместо "живого" видео с камер видеонаблюдения.

Амальгама

Amalgama - приемник для контроля действий оператора. Осуществляет захват и запись видео изображения рабочего стола ОС и всех действий оператора, включая захват нажимаемых клавиш, логирование запускаемых программ и открываемых файлов. Требуется установка компонента Amalgama и наличие в прошивке ключа защиты возможности работы с данным компонентом. Устанавливается из файла amalgama.exe из комплекта ПО GOALcity.

Обратите внимание, что данная система является экспериментальной разработкой и поставляется "как есть".


Установка мультимедиа сервера

Navigation: Мультимедиа сервер >

Установка мультимедиа сервера

Запустите исполняемый файл 2_IP_Server_x64.exe (ранее файл назывался setupvss_x64.exe). На мониторе Вы увидите окно "Установка Support Server", в котором отображается версия программы и номер сборки.

Важно! Программа использует электронный аппаратный ключ защиты Guardant Sign или Guardant Stealth-II. Убедитесь, что Вы скопировали файл license.txt в корневой каталог диска, на который установлена операционная система перед запуском программы. Без файла-лицензии программа будет работать в демо-режиме. Если в системе используется ключ Stealth-II то необходимо дополнительно вручную установить драйвера на ключ защиты!

·Инсталляцию системы нужно проводить, загрузив ОС под именем пользователя, обладающего правами администратора этого ПК;

·Система GOALcity должна работать в сеансе того пользователя ОС, который производил инсталляцию системы

·Категорически запрещается работать одновременно под разными пользователями ОС, каждый из которых запускает свой сеанс GOALcity.

Нажмите кнопку "Далее". Откроется окно с текстом лицензионного соглашения. Чтобы продолжить установку, необходимо принять условия соглашения. В противном случае следует отказаться от продолжения установки, нажав кнопку "Отмена" (текст лицензионного соглашения будет показан только при "чистой" установке программы, если любой из компонентов уже установлен, то мастер автоматически пропустит этот шаг).

Если инсталляция компонентов GOALcity выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции"Обзор".

Следующий шаг – выбор размещения папки программы в меню "Пуск".

После этого мастер откроет окно "Опции повторной установки". Отметьте "птичками" необходимые действия: если нужно удалить все предыдущие настройки GOALcity - "Удалить файлы настроек". Если драйвера на ключ защиты Guardant уже установлены в системе, и переустанавливать их нет необходимости - "Не переустанавливать драйверы ключа защиты". Нажмите кнопку "Установить".

Начнется процесс записи файлов программы на ПК, ход которой отображается в окне "Копирование файлов", пожалуйста, немного подождите.

Завершите установку Мультимедиа сервера нажатием кнопки "Готово".


Интерфейс и настройки

Интерфейс и настройки мультимедиа сервера

Navigation: Мультимедиа сервер >

Интерфейс и настройки мультимедиа сервера

Установите все необходимые компоненты GOALcity, откройте "Диаграмму подключений", добавьте на неё установленные сервера GOALcity и кликните правой кнопкой мыши по "шапке" "Мультимедиа сервера". Откроется контекстное меню.

GOALcity поддерживает захват звука с встроенной звуковой карты, если это разрешено прошивкой. Речь идет о источниках "Микрофон@ваша звуковая карта", "Первичный драйвер звука" и т.д. Количество может меняться в зависимости от особенностей звуковой карты.

Обратите внимание! Особенность Windows 10 заключается в том, что если устройство физически не подключено к аудио входу звуковой карты, то ОС не использует этот вход (отключает) и соответственно на Мультимедиа сервере Вы ничего не увидите. Для активизации необходимо физически подключить устройство к аудио входу и перезапустить программу и службу GOALcity.

Вкладка "Настройки"

Выберите пункт "Настроить...". Откроется окно "Настройки мультимедиа сервера". Также попасть в настройки можно двойным кликом левой кнопкой мыши в любом месте на пиктограмме мультимедиа сервера.

Окно настроек мультимедиа севера, условно разделено на две части - слева располагаются основные пункты меню, а справа их подпункты.

Мультимедиа сервер представляет из себя комбайн источников для работы с различным оборудованием. В зависимости от установленных компонентов комплекса GOALcity в настройках мультимедиа сервера будут присутствовать различные источники.

Чтобы перейти к конфигурации одного из источников, нажмите кнопку button-04 напротив необходимого источника.

Клик правой кнопкой мыши в правой части окна настроек раскроет контекстное меню.

·Пункт "Раскрывать элементы, имеющие возможность редактирования в отдельном окне" - активирует режим редактирования настроек источника в текущем окне. При задействовании перед источниками появится элемент "+", нажатие на который приведет к раскрытию списка элементов доступных для редактирования в данном источнике.

·Пункт "Раскрывать только один элемент" - при активации данного режима, возможно редактирование только одного источника в текущем окне. При раскрытии нового источника на редактирование, ранее редактируемый источник автоматически закроется.

Вкладка "Пользователи"

GOALcity многопользовательская система и каждому из пользователей можно разрешить определенные действия, например жена может смотреть только камеры установленные в детской, а муж имеет полный доступ ко всем камерам. Чтобы разршить\запретить доступ к определенным камерам мультимедиа сервера выполните следующие действия:

·Перейдите на вкладку "Пользователи" мультимедиа сервера, выберите пользователя, которому хотите изменить права и нажмите кнопку "Изменить". Создание новых пользователей производится через Основные настройки GOALcity на вкладке "Пользователи". Важно! Для изменения прав доступа пользователям необходимо обладать правами администратора GOALcity.

·Отметьте "птичками" необходимые разрешения пользователю.

Например, на рисунке выше, пользователю "Оператор 1" разрешено подключение к источнику "IP Source" и просмотр одной камеры "Улица".

Аналогично настраиваются права пользователей на просмотр архива, подключение к камерам видеосервера, аудиосерверу и т.д.

Вкладка "Фаервол"

GOALcity имеет встроенный внутренний фаервол, который может препятствовать несанкционированным подключениям "из вне" к вашей системе видеонаблюдения, ограничивать количество одновременных подключений и т.д.

В строке "Текущие подключения" отображается количество и IP адреса всех клиентов GOALcity, которые в данный момент подключены в Вашему Мультимедиа серверу.

·Строка "Фаервол" позволяет задать ограничения на подключения. Политикой предусмотрено 2 состояния "Разрешить все кроме" и "Запретить все кроме".

·В строке "Максимальное количество" задается максимальное одновременное количество разрешенных подключений.

·Чтобы задать новую маску IP адресов, которым Вы запрещаете или, наоборот, разрешаете подключение, нажмите на кнопку vss-22. Символом * обозначается целый диапазон адресов. В примере выше, к мультимедиа серверу разрешено 3 одновременных подключений с любых IP адресов кроме 192.168.10.* ("звездочка" обозначает диапазон от 1 до 225).

Аналогично настраиваются права пользователей на просмотр архива, подключение к камерам видеосервера, аудиосерверу и т.д.


Аппаратные источники

Аппаратные источники звука

Navigation: Мультимедиа сервер > Настройка компонентов >

Аппаратные источники звука

GOALcity поддерживает захват звука с встроенной звуковой карты, если это разрешено прошивкой. Речь идет о источниках "Микрофон@ваша звуковая карта", "Первичный драйвер звука", "Линейный вход" и т.д. Количество может меняться в зависимости от особенностей звуковой карты.

Обратите внимание! Особенность Windows 10 заключается в том, что если устройство физически не подключено к аудио входу звуковой карты, то ОС не использует этот вход (отключает) и соответственно на Мультимедиа сервере Вы ничего не увидите. Для активизации необходимо физически подключить устройство к аудио входу и перезапустить программу и службу GOALcity.


Источник RTPSource и FFSource

Источник RTPSource и FFSource. Подключение IP камер с использованием кодека h264.

Navigation: Мультимедиа сервер > Настройка компонентов >

Источник RTPSource и FFSource. Подключение IP камер с использованием кодека h264.

Общее описание

RTPSource - приемник для работы с IP видеокамерами или серверами по RTP или RTSP протоколу передачи мультимедийных данных. Устанавливается вместе с мультимедиа сервером. Поддерживается работа и по протоколу ONVIF, имеется автоматический поиск поддерживаемых камер.

FFSource - другая версия источника для работы с IP видео камерами через GOALcity и RTSP протокол передачи мультимедийных данных. В работе используются программные библиотеки ffdshow. Устанавливается вместе с Мультимедиа сервером GOALcity. Является заменой устаревшего источника VLCSource.

Разница между источниками

·RTSPSource получает и пишет видео кодеком H.264. Так как для записи используется потоковый кодек, то трафик и размер архива будет на порядок меньше, чем при использовании покадрового кодека. Однако при просмотре будет тратиться много процессорных ресурсов. Просмотреть синхронно несколько камер в полном формате практически невозможно. Из-за структуры потока проблематичен и покадровый просмотр назад.

·FFSource также получает видео в формате H.264, но запись на жесткий диск производится с использованием покадрового кодека mjpeg, т. е. записывается каждый кадр. Размер архива будет больше, чем при использовании потокового кодека, но ресурсов при просмотре будет тратиться намного меньше и просмотреть несколько камер синхронно не составит никакого труда. Покадровый просмотр назад также идет без проблем.

Рекомендации по подключению IP камер

Современные IP камеры могут "отдавать" сразу несколько видео потоков в разном разрешении и с использованием разных кодеков. Используя эту функцию камер, мы доработали наш RTSP источник тем самым, позволяя существенно снизить нагрузку на ЦП, путем вывода на просмотр в маленьком окне "небольшого" потока, но при "распахивании" окна GOALcity автоматически переключаться на "полный" поток. Другими словами, в маленьком окне Вы будете видеть "маленькую" картинку, но так как размер окна мал, то отличий от изображения в полном разрешении практически не будет. При максимизации окна Вы будете видеть изображение в полном разрешении.

Запись при этом ведется всегда "полного" потока в максимальном разрешении.

Чтобы настроить такой алгоритм работы, выполните следующие действия:

·Используйте RTSP источник для создания камер или мастер добавления IP камер GOALcity.

·"раскройте" созданный RTSP источник и введите необходимые данные в поля "URL для просмотра" и "URL для записи"

В поле "URL для просмотра" необходимо вводить ссылку на "маленький" видео поток с IP камеры, он будет отображаться в маленьком окне GOALcity. Рекомендуем использовать кодек jpeg и разрешение 640х480 или меньше в зависимости от размера окна. Рекомендуем устанавливать разрешение камеры с сохранением пропорций изображения!

В поле "URL для записи" необходимо вводить ссылку на "полный" видео поток с этой же IP камеры, он будет отображаться при распахивании окна GOALcity и постоянно записываться. Рекомендуем использовать кодек h264 и максимальное разрешение.

Создание источников

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке

напротив пункта "RTPSource" или "FFSource" и выберите строчку "Редактировать". Принцип создания источника очень похож на выше рассмотренный, только вместо IP адреса камеры используется rtsp ссылка на поток. Большое количество RTP ссылок для IP камер различных производителей Вы можете найти в интернете.

Нажатием кнопки button-04 вызовите всплывающее меню и выберите "Добавить видео источник". Откроется окно добавления нового источника.

Укажите все необходимые параметры и сохраните изменения. Аналогично прошлому примеру, созданный источник появиться в Мультимедиа сервере и останется только подключить его к окну GOALcity.

Чтобы повторно открыть настройки видео источника, достаточно щелкнуть по пиктограмме напротив необходимого источника. Удаление ненужных источников производится кликом по кнопке vss-19. Так же настройки подключения можно поменять непосредственно из окна камеры, зайдя в её настройки и перейдя на вкладку "Подключение". Настройки полностью аналогичны и могут быть изменены любым из доступных методов.

Клонирование источников

Функция клонирования используется для создания нескольких копий выбранного элемента (камера, микрофон, датчик, ключ). Копия может отличаться от оригинала несколькими параметрами (название, ip-адрес, и т. д.). При клонировании можно автоматически изменить числовые элементы в параметрах "Имя" и "Host" в сторону возрастания. Для этого надо сразу после числа, которое необходимо изменить, поставить два знака "+". Например, пусть элемент называется "video 1". Тогда, добавив в параметр "Название" два знака "+", получим "video 1++". При клонировании, к числу "1" будет добавлен порядковый номер создаваемой копии, и в результате будут созданы элементы с названиями "video 2", "video 3" и т. д.


Источник IPSource

Источник IPSource. Подключение IP камеры с использованием кодека mjpeg.

Navigation: Мультимедиа сервер > Настройка компонентов >

Источник IPSource. Подключение IP камеры с использованием кодека mjpeg.

Общее описание

IpSource - приемник для работы с различным IP оборудованием (видеокамеры, видеосервера, мегапиксельные камеры). Для некоторых моделей оборудования дополнительно поддерживается работа со встроенными каналами звука (аудио), датчиками и реле. Устанавливается вместе с мультимедиа сервером.

Создание источников

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке

напротив пункта "IP Source" и выберите строчку "Редактировать". Через этот источник можно подключить к GOALcity различные IP устройства: камеры, микрофоны, передатчики и т.д. Полный список интегрированных камер Вы всегда можете найти на нашем сайте технической поддержки.

Кликните по кнопке button-04 справа от пункта "Камеры", перед Вами откроется список всего оборудования, прошедшего расширенную интеграцию. Выберите источник "Axis-Video".

В окне настроек заполните необходимые поля соответсвующими данными:

·"Название" - введите название видео источника.

·"Хост" -введите IP адрес видео источника.

·"Пользователь" и "Пароль" - введите данные для аутентификации на устройстве.

·"Использовать прокси" - если Ваша сеть использует прокси-сервер, введите его параметры.

·"Время ожидания ответа" - укажите интервал времени в секундах, за которое должен быть получен ответ от камеры, если за это время камера не ответит, в окне вместо видео появится надпись "Нет сигнала".

·"Камера" - номер камеры (видео канала), укажите необходимый канал, при условии что подключаемся к видео серверу с несколькими каналами. Если это одиночная камера, оставьте значение "1".

·"Разрешение" - укажите разрешение камеры. Важно! Разрешение при подключении камеры в GOALcity и в веб интерфейсе камеры должны совпадать!

Нажмите кнопку "Ок" сохраните изменения и закройте настройки "Мультимедиа сервера".

Обратите внимание! Для каждого из источников набор параметров может отличаться: для каких-то камер можно указать разрешение, для каких-то - скорость просмотра и другие параметры. Но, зачастую, все необходимые настройки разрешения и скорость отображения видео нужно производить в веб интерфейсе IP камеры.

Теперь на Диаграмме подключений в "Мультимедиа сервере" Вы увидите созданную IP-камеру. Осталось только ее подключить к окну GOALcity.

Подключение микрофонов, датчиков, ключей и прочего оборудования выполняется идентично. Вся разница в выборе источника - Микрофоны, Устройства и прочее.

Клонирование источников

Функция клонирования используется для создания нескольких копий выбранного элемента (камера, микрофон, датчик, ключ). Копия может отличаться от оригинала несколькими параметрами (название, ip-адрес, и т. д.). При клонировании можно автоматически изменить числовые элементы в параметрах "Имя" и "Host" в сторону возрастания. Для этого надо сразу после числа, которое необходимо изменить, поставить два знака "+". Например, пусть элемент называется "video 1". Тогда, добавив в параметр "Название" два знака "+", получим "video 1++". При клонировании, к числу "1" будет добавлен порядковый номер создаваемой копии, и в результате будут созданы элементы с названиями "video 2", "video 3" и т. д.


Источник SLSource

Источник SLSource. Подключение устройств нашего производства.

Navigation: Мультимедиа сервер > Настройка компонентов >

Источник SLSource. Подключение устройств нашего производства.

Общее описание

SLSource - источник для работы с IP-видеосерверами и IP-Видеоблейзерами производства Спецлаб. Позволяет использовать все источники указанного оборудования (видео, датчики, реле и сигнализацию). Устанавливается вместе с мультимедиа сервером, но для работы с данным источником требуется наличие в прошивке ключа защиты компонента "Сервер поддержки IP устройств".

Создание источников

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке

напротив пункта "SL Source" и выберите строчку "Редактировать". Для примера добавим видео с второго Блейзера.

Кликните по кнопке button-04 справа от пункта "Камеры" и выберите источник "SL-Blazer-II Video".

В окне настроек заполните необходимые поля соответсвующими данными:

·"Название" - введите название видеоисточника.

·"Хост" -введите IP адрес видеоисточника.

·"Пользователь" и "Пароль" - введите данные для аутентификации на устройстве.

·"Использовать прокси" - если Ваша сеть использует прокси-сервер, введите его параметры.

·"Время ожидания ответа" - укажите интервал времени в секундах, за которое должен быть получен ответ от видеоблейзера, если за это время блейзер не ответит, в окне вместо видео появится надпись "Нет сигнала".

·"Камера" - устройство может поддерживать несколько каналов вывода видео, укажите необходимый.

Нажмите кнопку "Ок" сохраните изменения и закройте настройки "Мультимедиа сервера".

Создание и настройка параметров датчиков, ключей, передатчиков и прочего оборудования нашего производства выполняется аналогично. Вся разница в выбранном устройстве и источнике.

Обратите внимание! Параметры для настройки могут отличаться в зависимости от используемого источника!

Клонирование источников

Функция клонирования используется для создания нескольких копий выбранного элемента (камера, микрофон, датчик, ключ). Копия может отличаться от оригинала несколькими параметрами (название, ip-адрес, и т. д.). При клонировании можно автоматически изменить числовые элементы в параметрах "Имя" и "Host" в сторону возрастания. Для этого надо сразу после числа, которое необходимо изменить, поставить два знака "+". Например, пусть элемент называется "video 1". Тогда, добавив в параметр "Название" два знака "+", получим "video 1++". При клонировании, к числу "1" будет добавлен порядковый номер создаваемой копии, и в результате будут созданы элементы с названиями "video 2", "video 3" и т. д.


Источник SLDASource

Источник SLDASource. Установка и настройка.

Navigation: Мультимедиа сервер > Настройка компонентов >

Источник SLDASource. Установка и настройка.

Общее описание

SLDASource - источник работы с устройствами, подключаемыми по протоколу RS-485 производства Спецлаб и ряда сторонних производителей. Также в этом источнике осуществляется подключение IP контроллера "Телепатия" производства Спецлаб и других устройств нашего и не нашего производства. Требуется установка бесплатного драйвера SLDA и наличии в прошивке ключа защиты возможности работы с компонентом "Сервер устройств". Устанавливается вместе с мультимедиа сервером.

Также через SLDASource подключаются устройства из интегрированных систем ОПС, таких как "Болид" и "Стрелец".

Установка драйвера SLDA

Обязательно убедитесь в том, что клиент (GOALcity.exe) и служба (slssh.exe) GOALcity выключены. Также необходимо отключить Rotor-Net.

Запустите дистрибутив SLDAsetup.exe. Откроется окно мастера с выбором языка установки:

Выберите необходимый язык и нажмите кнопку "Ок".

Запустится мастер установки, в котором отображается версия драйвера.

Нажмите кнопку "Далее" и примите условия лицензионного соглашения с конечным пользователем.

После нажатия кнопки "Принимаю", выберите папку установки программы. По умолчанию это "Х:\Program Files (x86)\Speclab\SLDA" (где Х - диск, на котором установлена ОС Windows). Нажмите кнопку "Далее".

Выберите размещение папки программы в меню "Пуск". Нажмите кнопку "Далее".

Проверьте все данные установки и нажмите кнопку "Установить".

Драйвер SLDA установлен. На этом же этапе можно выполнить инсталляцию драйверов для USB HUB RS-485, к которому подключаются контроллеры датчиков - КД -16/485, контроллеры устройств - КВУ -8/485, блок приборов "Климат-контроль". Инсталляция необходима в случае, когда сервер устройств SLDA будет работать с данными контроллерами, в противном случае снимите "галку" и нажмите "Завершить".

Создание устройств

Рассмотрим добавление устройств на примере IP контроллера "Телепатия" нашего производства. Отметим, что устройства добавляются практически аналогично виртуальным, вся разница в параметрах этих устройств.

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке button-04 напротив пункта "SLDASource" и выберите строчку "Редактировать".

Кликните по кнопке button-04 справа от пункта "Датчики и ключи", перед Вами откроется список всего доступного для подключения оборудования. Выберите источник "Добавить Телепатия".

·"Название" - укажите имя создаваемого датчика/ключа.

·"Адрес" - укажите IP адрес контроллера "Телепатия".

·"Тип" - укажите, какой из элементов контроллера "Телепатия" создается - ключ или датчик.

·"Номер" - укажите номер элемента (датчика/ключа) на контроллере.

·"Пользователь" и "Пароль" - укажите данные для авторизации на IP контроллере.

Нажмите кнопку "Ок" и сохраните изменения. Теперь на Диаграмме подключений в "Мультимедиа сервере" Вы увидите созданный ключ. Подключите его к окну GOALcity.

Все параметры физических устройств практически полностью идентичны рассмотренным ранее виртуальных.


Источник VLCSource

Источник VLCSource. Установка и настройка.

Navigation: Мультимедиа сервер > Настройка компонентов >

Источник VLCSource. Установка и настройка.

Общее описание

VlcSource - источник для внутренних (технологических) нужд. В большинстве случаев Вам он не понадобится, кроме как по рекомендации службы технической поддержки. Устанавливается из файла 8_VLC_Source_x64.exe из комплекта дистрибутивов GOALcity.

С помощью этого источника можно проигрывать ролики в окнах GOALcity вместо "живого" видео с камер видеонаблюдения.

Установка компонента

Запустите исполняемый файл 8_VLC_Source_x64.exe. Откроется окно мастера установки "GOALcity VLC Source", в котором отображается версия программы и номер сборки.

В связи с тем, что система GOALcity продолжает активно развиваться, её компоненты постоянно дорабатываются и модифицируются. Не рекомендуется устанавливать на один сервер компоненты из сборок разных версий, если иное не оговорено разработчиком. Рекомендуем использовать последнюю релизную версию сборки.

Нажмите кнопку "Далее" и примите лицензионное соглашение с конечным пользователем.

После нажатия кнопки "Принимаю", выберите папку установки программы. По умолчанию это "Х:\Program Files\Speclab\VlcSource" (где Х - диск, на котором установлена ОС Windows). Нажмите кнопку "Установить".

Начнется процесс записи файлов программы на ПК. Закончив инсталляцию программы, Мастер установки предложит сразу же запустить службу. Запускайте.

Подключение видеоисточников

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке button-04 напротив пункта "VLCSource" и выберите строчку "Редактировать".

Укажите путь до установленного ранее в систему VLC Player'а в поле "Путь к VLC".

Обратите внимание! VLC плеер постоянно обновляется. Поэтому мы рекомендуем отключить в настройках плеера автоматическое обновление. Последняя стабильная версия VLC (протестированная с GOALcity) - 2.2.0. Скачать ее можно с сайта производителя.

Важно! Для GOALcity Vanga необходимо использовать 64-х разрядную версию плеера!

Кликните по кнопке button-03 справа от пункта "Камеры", снизу добавятся поля для ввода параметров нового видеоисточника.

·"Имя" - задайте новое имя видеоисточнику.

·"Url" -укажите rtsp ссылку на видео поток с камеры. Как правило данную ссылку нужно искать в web-интерфейсе настроек IP камеры или уточнять у производителя камер.

·"Аудио" - если в видео поток "примешивается" аудио сигнал, и Вам необходимо его получать, отметьте данный пункт.

·"Надежность" - отметьте "птичкой" это поле, если наблюдаются коротко временные или длительные "пропажи" видеосигнала в окне GOALcity.

Как проиграть видеоролик вместо "живого" видео

С помощью VLCSource можно проигрывать ролики в окнах GOALcity вместо "живого" видео с камер видеонаблюдения (практически любые видео файлы, поддерживаемые VLC Player'ом). Это довольно полезная функция, если Вы, например, хотите проанализировать Ваш видео ролик с помощью нашей видеоаналитики или видеосемантики. Посмотреть как наша система реагирует на те или иные события, и просто протестировать систему не имея ни одной камеры видеонаблюдения.

Чтобы открыть видеоролик, укажите в поле "Url" путь до видеоролика в формате:

file:///полный путь до Вашего видео ролика

Важно поставить именно три "слэша"! Это не опечатка! Например: "file:///d:\Кино\Лучшее\Аvatar.avi"


Источник DeviceSource

Источник DeviceSource. Работа с виртуальными устройствами.

Navigation: Мультимедиа сервер > Настройка компонентов >

Источник DeviceSource. Работа с виртуальными устройствами.

Общее описание

DeviceSource - источник работы с виртуальными устройствами. Позволяет создавать виртуальные ключи. Требуется наличии в прошивке ключа защиты возможности работы с компонентом "Сервер устройств". Устанавливается вместе с мультимедиа сервером. Также через этот источник подключаются интегрированные датчики и ключи с системы ОПС "Багульник".

Создание виртуальных устройств

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке button-04 напротив пункта "DeviceSource" и выберите строчку "Редактировать".

Для примера, рассмотрим процесс создания виртуального ключа.

Кликните по кнопке button-04 справа от пункта "Датчики и Ключи", перед Вами откроется список всех доступных для создания устройств.

Основные используемые элементы это виртуальный ключ, ключ с таймером. Разница между ними в том, что при использовании второго, пользователь может задать определенный промежуток времени через который нужно сменить состояние ключа. Параметры обоих ключей практически идентичны.

Выберите пункт "Добавить виртуальный ключ".

Укажите все необходимые данные:

·"Имя" - укажите имя создаваемого виртуального ключа.

·"Замкнут" - укажите состояние ключа, нормально замкнутый или нормально разомкнутый.

·"Поврежден" - если установить параметр в "Да", то ключ будет имитировать КЗ в сети.

Нажмите кнопку "Ок" и сохраните изменения. Теперь на Диаграмме подключений в "Мультимедиа сервере" Вы увидите созданный виртуальный ключ. Подключите его к окну GOALcity.

Каждому состоянию ключа соответствует своя пиктограмма в окне:

Настройка виртуальных устройств

Откройте настройки виртуального ключа нажатием на кнопку

.

Вкладка "Запись"

·На вкладке "Запись" настраивается выбирается архив, в который будут сохранятся данные о сработке данного ключа.

Вкладка "Контроль"

·"Ограничение времени подключения" - установите время, в течении которого GOALcity будет пытаться подключиться к ключу.

·"Интервал проверки связи" -установите периодичность проверки связи с ключом.

·Опция "Менять состояние по двойному щелчку" - регулирует каким способом производить переключение ключа с разомкнутого на замкнутое состояние и обратно.

·"Активизировать окно при сработке" - если ключ участвует в каком либо из алгоритмов и окно ключа скрыто с экрана, то установив данную птичку можно показывать окно в случае сработки ключа.

·"Звуковой сигнал при сработке" - если Вам требуется звуковое оповещение при сработке ключа, активизируйте данную опцию.

·"Отображать:" - выберите, какие элементы интерфейса отображать в окне ключа.

·"Журнал" - укажите, записывать ли в архив моменты сработки и время подключения и отключения ключа.

Вкладка "Визуальное представление"

Является одинаковой для датчиков и ключей и позволяет установить пользовательские изображения на любые из состояний виртуального устройства.

Укажите в поле "Путь к каталогу с файлами..." путь к каталогу, в котором должно лежать 5 файлов в формате EMF+. Файлы будут иллюстрировать состояния ключа/датчика в программе и должны иметь определенные названия:

·unknown.emf - неопределенное состояние;

·open.emf - разомкнут;

·close.emf - замкнут;

·short.emf - короткое замыкание;

·broken.emf - обрыв.

В окне "Изображение" Вы можете увидеть предпросмотр изображения.


Ретранслятор VSS-Retr

Navigation: Мультимедиа сервер > Настройка компонентов >

Ретранслятор VSS-Retr

Cхема работы ретранслятора

В ранее рассмотренных вариантах каждый клиент GOALcity должен был подключаться к каждому серверу. Т. е. к первому серверу три подключения (согласно схеме), ко второму три подключения и к третьему тоже три подключения. Если много клиентов, то каждое такое подключение значительно увеличивает нагрузку на сервер. Чтобы избежать этого, можно выполнить подключение всего одним клиентом GOALcity, на котором установлен VSS-Retr. Теперь все клиенты могут искать не сервера, а VSS-Retr и получать с него видео со всех серверов GOALcity.

Еще одна возможность VSS-Retr – это транслирование видео на клиентские ПК с меньшим разрешением.

К примеру, есть два офиса, объединенных по каналу Интернет. Схематично толстыми линиями показан широкий канал локальной сети, а тонкими линиями – сеть Интернет. Клиентские машины одного из офисов все так же подключаются в VSS-Retr, на котором выставлено меньшее разрешение для того, чтобы можно было передать весь необходимый видео трафик по каналу с ограниченной пропускной способностью.

Ретранслятор можно разместить и со стороны клиентских ПК. В этом случае видео передается с серверов на VSS-Retr. Пропускная способность канала Интернет подобрана соответствующим образом, а все клиенты, чтобы не загружать сервера и главное - чтобы не забивать Интернет канал - подключаются к VSS-Retr.

Схем реализации большое количество, что делает систему очень гибкой и распределено-сетевой.

Настройка трансляции

Кликните правой кнопкой мыши в окне любой камеры и вызовите контекстное меню. Выберите пункт "Транслировать" и активируйте ретранслятор (отметка напротив данного пункта указывает на то, что трансляция источника включена).

После активации ретранслятора станет доступен пункт "Настройки трансляции". Активируйте его.

·"Без изменений" - если активирован этот пункт, то кадр с источника передаётся без изменений: "каким пришёл - таким и ушёл".

·"Размеры выходного кадра" - задайте ширину и высоту в пикселах транслируемых (выходных) кадров.

·"Режим градации серого" - если активировать данную опцию, то транслируемый видеосигнал будет черно-белым.

После включения трансляции данного окна зайдите на Диаграмму подключений, кликните правой кнопкой мыши по Мультимедиа серверу, выберите опцию "Обновить" - появится еще один источник - "Окно1@GOALcity". Это и есть новое транслируемое окно с заданными выше параметрами.

Получение транслируемых данных

Подключитесь клиентом по IP адресу к серверу, на котором стоит VSS-ретранслятор источника и подключите с него транслируемый источник. Имя у транслируемого источника будет вида "Имя камеры"@GOALcity.


Амальгама

Navigation: Мультимедиа сервер >

Амальгама

Обратите внимание, что данная система является экспериментальной разработкой и поставляется "как есть".

В мире, где на каждого человека приходится по несколько компьютеров, когда электроника стала неотделима от замысла личности, гораздо больше информации можно почерпнуть, контролируя компьютеры, а не только людей.

·"Амальгама" – это профессиональная многоканальная видеозапись изображения экрана мониторов.

·"Амальгама" – это распределенный сетевой комплекс, способный собирать всю информацию с удаленных компьютеров, полностью документируя (как видеопоток) все действия пользователя.

·"Амальгама" – это многомерное зеркало, способное отображать экраны сотен компьютеров на мониторе хозяина как в реальном масштабе времени, так и в записи.

·"Амальгама" полностью поддерживает все протоколы видеозаписи GOALcity и по технологии почти ничем не отличается от обычной видеозаписи, только вместо видеокамер используется программа перехвата изображения с экрана.

·"Амальгама" имеет все сервисные функции обычной видеозаписи - от видеодетекции до видеоаналитики, что значительно сокращает поток лишней информации. Учитывая то, что на мониторе нет помех, эти технологии работают идеально - в прямом смысле данного слова.

Видеоаналитика помогает вычислять отличительные особенности той или иной деятельности: игры, финансовые документы, Интернет-браузеры, текстовые комбинации клавиш, даже направление перемещения курсора "мышки".


Установка и настройка

Navigation: Мультимедиа сервер > Амальгама >

Установка и настройка

Модуль "Амальгама" является дополнительным модулем Мультимедиа сервера и требует дополнительной установки. Инсталляция начинается с запуска исполняемого файла "amalgama_x64.exe".

Важно! "Амальгама" является отдельным продуктом, и, в случае деинсталляции, удалять её нужно так же отдельно! Если запускать общую деинсталляцию GOALcity, то все данные "Амальгамы" сохранятся!

Установка

Запустите исполняемый файл amalgama_x64.exe из комплекта дистрибутивов системы GOALcity. Выберите язык установки.

·Инсталляцию "Амальгамы" нужно проводить, загрузив ОС под именем пользователя, обладающего правами администратора этого ПК;

·Система GOALcity должна работать в сеансе того пользователя ОС, который производил инсталляцию системы

·Категорически запрещается работать одновременно под разными пользователями ОС, каждый из которых запускает свой сеанс GOALcity.

Откроется окно мастер установки "Амальгамы" в котором указана версия и сборка программного обеспечения

В настоящее время "Амальгама" работает только совместно со службой терминалов операционной системы. Поэтому служба терминалов должна быть активна. В связи с тем, что система GOALcity продолжает активно развиваться, её компоненты постоянно дорабатываются и модифицируются. Не рекомендуется устанавливать на один ПК компоненты из сборок разных версий, если иное не оговорено разработчиком. Рекомендуем использовать последнюю релизную версию сборки.

Затем откроется окно с текстом лицензионного соглашения. Примите условия соглашения нажатием кнопки "Принимаю".

Если инсталляция выполняется впервые, то после нажатия кнопки "Принимаю", будет предложено выбрать папку, куда Вы хотели бы установить программу. По умолчанию это "Х:\Program Files\Speclab\GOALcity" (где Х - диск, на котором установлена ОС Windows). Можно также указать любой другой путь, непосредственно набрав его с клавиатуры в окошке "Папка установки", либо выбрать с помощью функции"Обзор".

Укажите расположение ярлыков программы в меню "Пуск" и снова нажмите кнопку "Далее".

Затем мастер установки предложит ввести адрес сервера (верхняя строчка), с которого необходимо получать информацию и название окна (нижняя строчка).

Например: "Амальгама" устанавливается на компьютер с IP адресом 192.168.10.25, а видео нам нужно получать на сервере с адресом 192.168.10.30. Значит при установке в верхнее поле нужно вписать адрес сервера (192.168.10.30:3107), а в нижнее можно вписать любую информацию, по которой Вы затем поймете на каком компьютере установлена "Амальгама" и чей "рабочий стол" Вы "смотрите". То есть, на клиентском ПК (с которого нужно получать видео рабочего стола) и нужно устанавливать "Амальгаму", прописывая в настройках "куда вещать".

Таким образом, на контролируемом компьютере должен быть установлен только дистрибутив "Амальгамы", ни ключа защиты, ни какого либо дополнительного ПО устанавливать не нужно! На серверной же стороне минимально должен быть установлен Мультимедиа сервер и Клиент GOALcity.

Важно! При вводе IP адреса сервера (верхняя строчка) обязательно указывайте порт подключения (по умолчанию 3107).

"Амальгама" начнет копирование файлов на жесткий диск. Закончив инсталляцию программы нажмите кнопку "Готово" и перезагрузите ПК.

Настройка "Амальгамы"

Откройте "Диаграмму подключений", правым кликом по шапке сервера откройте контекстное меню и выберите пункт "Обновить". Появятся новые окна "Амальгамы". Можете подключить их к окну GOALcity и начать контроль.

Расширенная настройка

Перейдите к настройкам Мультимедиа сервера и найдите в списке источников найдите Вашу "Амальгаму" Название источника будет вида "Amalgama (имя, которое Вы задавали в настройках при установке в нижней строке)".

Кликните по кнопке button-04 справа от Вашей "Амальгамы" чтобы открыть её настройки. По умолчанию, все источники захвата, кроме видео, отключены.

Настройки отображения так же можно изменить на вкладке "Трансляция" настроек Амальгамы, вызываемых по клику на кнопку button-settings всплывающей панели.

Важно! Если на контролируемом ПК используется несколько мониторов, то и видеоисточников "Амальгамы" будет такое же количество (DISPLAY1, DISPLAY2 и т.д.)! Каждый из них имеет индивидуальные настройки!

Захват видеопотока

Настройки видеопотока находятся на вкладке "Трансляция" каждого из "мониторов"

·С помощью опции "Масштаб" - выберите разрешение транслируемого по сети рабочего стола в процентах от оригинального. Необходимо отметить, что чем больше разрешение, тем больший объем информации пойдет по сети и соответственно увеличится ее загрузка.

·"Скорость к/с" -укажите скорость просмотра транслируемого видеосигнала. Чем больше это значение - тем больше загрузка сети.

·"Захватывать курсор" - если Вам необходимо захватывать вместе с рабочим столом и курсор мыши, отметьте эту опцию.

·"Режим совместимости для интегрированных видео карт" - включите, если на контролируемом ПК установлена интегрированная в материнскую плату видеокарта.

Захват клавиатуры

Отметьте птичкой данную опцию, если необходимо использовать захват клавиатуры на контролируемом ПК. Укажите, после нажатия каких "горячих" клавиш клавиатуры отправлять информацию. Нажмите клавишу "Ок" и сохраните настройки. На Мультимедиа сервере появится еще один источник типа датчик с именем вида: "Keyboard@Amalgama(имя, которое Вы задавали в настройках при установке в нижней строке).

Подключите его к окну GOALcity. Теперь Вы будете видеть все что пользователь нажимает на клавиатуре в режиме реального времени. Отправка информации осуществляется после нажатия на одну из ранее настроенных горячих клавиш.


Основные настройки панели

Navigation: Панель "Внимание!" >

Основные настройки панели

Одним из нововведений, отличающих GOALcity от других систем безопасности, является панель последовательного видеонаблюдения "Внимание!". Её назначение активизировать группу аналитических алгоритмов, предназначенных для того, чтобы обратить внимание оператора на события, представляющие определённую опасность для объекта наблюдения.

Важно! По умолчанию Вы можете подключить до двух панелей "Внимание!", но каждая панель требует определенной мощности центрального процессора, т. к. все панели запускаются как отдельные потоки. Третья и последующие панели подключаются за дополнительную плату.

Общая информация

При первой установке программы Панель "Внимание!" включится по умолчанию. Если же Вы устанавливаете новую версию программы и при этом сохранили прежние её настройки, то потребуется включить и настроить Панель.

Включение и настройка Панели "Внимание!" производится через Главное меню программы нажатием левой кнопкой мыши по пункту "Настройка панели "Внимание!"...".

В открывшемся окне "Настройка панелей "Внимание!" отобразится список подключенных к системе панелей "Внимание". Можно удалить уже подключенные или добавить новые панели. Чтобы удалить не нужную панель, необходимо отметить ее флажком и нажать кнопку "Удалить". Если просто снять галочку и нажать кнопку "Закрыть", то выбранная панель пропадет с монитора, но не удалится из системы. Кнопка "Добавить" - добавляет новую панель сразу на монитор. Все действия с ней аналогичны ранее описанным.

Чтобы перейти к настройкам конкретной панели, выделите её и нажмите на кнопку "Настроить".

В поле "Корневая папка для сохранения видеороликов" укажите путь, по которому панель будет хранить ролики для последующей их передачи в GOALmobile 2. Убедитесь, что на диске достаточно свободного места для хранения роликов!

Общие настройки

Выделите одну из панелей и нажмите кнопку "Настроить", откроется окно настроек текущей панели.

Здесь перечислены все камеры по которым панель "Внимание!" может вести аналитический анализ. Клик левой кнопкой мыши по "строчке камеры" включает\выключает обработку камеры панелью, а клик правой кнопкой - открывает параметры текущей камеры.

В строке "Статус мобильного оповещения" задайте важность событий с текущей панели. Этот параметр будет влиять на настройки оповещений при связке GOALcity с GOALmobile 2.

Кнопка "Дополнительно" открывает расширенные настройки панели "Внимание!".

Чтобы переименовать панель, введите необходимое имя в строку "Наименование". Следующие два поля отвечают за расположение роликов на панели и соотношение сторон. Подстройте параметры под Ваши нужды.

Опция "Режим работы с подтверждением" активирует таймер панели "Внимание!" и "заставляет" охранников следить за тем, чтобы панель "Внимание!" оставалась чистой, иначе тревожные события будут автоматически передаваться в настроенный заранее центр мониторинга. Проще говоря, если охранник не отреагирует на событие (закроет его или закомментирует) то это событие автоматически будет отправлено по определенному, заранее настроенному, адресу.

Остальные параметры влияют на "косметические" настройки панели, поэксперементируйте с ними и подберите подходящий Вам вариант.

Опция "Не стирать файлы после перезагрузки" поможет в том случае, если необходимо чтобы не потерять текущие ролики при перезапуске программы или внезапной перезагрузке ПК.

Контекстное меню событий на панели "Внимание!"

att comon 12

Нажав правой кнопкой мыши по одному из "кадров" Панели "Внимание!" Вы вызовете контекстное меню.

·"Комментировать" - написать комментарий по данному событию.

·"Показать камеру" - разворачивает окно камеры с актуальным изображением, по которой сработал алгоритм.

·"Показать запись" - позволяет оперативно просмотреть фрагмент записи, выполненной по отображенному на Панели событию.

·"Показать историю" - отображает в выпадающей панели историю событий панели "Внимание!" по выбранной камере.

·"Настройки панели" - разворачивает окно с основными настройками отображения алгоритмов панели "Внимание!"

·"Настройки камеры" - позволяет перейти к настройке камеры, с которой полученно событие.

·"Запомнить" - сохраняет ролик на панели "Внимание!", защищая его от перезаписи (при превышении максимального количества роликов), и удаления после перезапуска ПО (если снята галка "Не очищать панель при завершении программы")

·"Удалить" - удаляет выбранное событие с панели.

Клик по кнопке att comon 13 вызовет всплывающее меню панели:

att comon 15

·"Развернуть" - пристыковывает панель к левому краю экрана и разворачивает её на всю высоту монитора.

·"Поверх других окон" - помещает панель над всеми остальными окнами.

·"Очистить" - очищает все события с панели.

·"Закрыть" - закрывает (не удаляет!) панель.

·"Окно статистики" - выводит окно с цифровым количеством событий на данной панели.

·"Транслировать" - включение трансляции панели - панель, как отдельная камера, появится в списке Мультимедиа сервера.

·"Прокручивать" - включение\отключение режима перехода к новому ролику. Например, вы прокрутили панель с роликами вниз и не видите последних (самых свежих) событий, если данная опция включена, то при появлении новых событий, панель будет автоматически прокручиваться к появившемуся событию. Соответственно при отключении, мы сможем "листать" панель свободно, перехода к новому событию не произойдет.

·"Закрепить" - позволяет настроить расположение и размер событий на панели при использовании нескольких столбцов или колонок. То есть, если Вы используете несколько столбцов или строк с событиями в рамках одной панели, и Вам не нравится что первая строка (столбец) слишком мала, активируйте данную опцию и "поправьте в ручную" ширину столбцов (колонок). После приведения панели "Внимание!" в необходимый вид активируйте опцию повторно. Тем самым Вы сохраните соотношение столбцов (колонок) внутри панели "Внимание!".

·"Настройки" - открывает настройки панели "Внимание!".


Настройка отображения алгоритмов

Navigation: Панель "Внимание!" >

Настройка отображения алгоритмов

Доступ к настройкам

Параметры отображения алгоритмов индивидуальны для каждой камеры на панели "Внимание!" и настраиваются исходя из требуемых задач. Чтобы открыть настройки текущей камеры кликните левой кнопкой мыши по кнопке "Настроить" или правой кнопкой мыши в любом месте "строки" камеры.

Основные настройки

Перед Вами откроется окно с основными настройками отображения алгоритмов панели "Внимание!" (вкладка "Отображение")

В левой части окна расположены основные параметры, в правой части окно с "живым" видео с текущей камеры с схематичным отображением визуальных параметров.

·Параметр "Увеличение области события" регулирует, на сколько сильно увеличивать область, в которой "произошло" какое-либо событие (область, в которой сработал какой-либо алгоритм). По умолчанию, установлена единица, т.е. область события не увеличивается. Установка "двойки" увеличит область события в 2 раза и т.д.

·Опция "От начала события проигрывать" устанавливает, какой промежуток времени выводить на панель "Внимание!" до сработки какого-либо из алгоритмов. Значение по умолчанию в 3 секунды позволяет выводить сам момент сработки алгоритма и 3 секунды после этой сработки. Эта настройка определяет лишь максимальное значение длительности ролика, а сам ролик формируется исходя из собственных алгоритмов, задача которых передать смысл изменений.

·"Коэффициент замедления" позволяет регулировать скорость отображения ролика на панели "Внимание!". Значение по умолчанию 2 - замедляет воспроизведение в 2 раза от оригинального. Таки образом, можно рассмотреть событие более детально.

·15 секундный "Интервал смежности" говорит о том, что сколько бы событий не обрабатывала панель "Внимание!" по текущей камере, периодичность их появления будет не менее чем 15 секунд. То есть, после сработки любого алгоритма должно пройти минимум 15 секунд до сработки следующего.

·События на панели "Внимание!" можно увеличивать двойным кликом для более детального просмотра. При этом они "разворачиваются" на всю область рабочего стола и автоматически закрываются через период времени, указанный в поле "Закрывать окно просмотра через".

Избыточность

·Минимальная – выводятся только те кадры, в которых произошла сработка детекторов (движения, лиц, автономеров и т.д.) и алгоритмов Панели "Внимание!". Это может быть дерганый просмотр, т.к. видеодетекция неоднородна и не всегда отражает полную картину. Но это минимальная информация, которая передает сюжеты перед камерой, как видит их машина. Рекомендуется использовать при недостатке времени на просмотр.

·Максимальная – самая большая плотность кадров, в которую входит вся записанная информация. Как правило, это страховочная запись, которая делается на случай, если видеодетекцию по каким-либо причинам удалось обойти, например, при сильных атмосферных помехах. Рекомендуется использовать в случае рассмотрения происшествия и выводить только ограниченный период самого происшествия, т.к. постоянный просмотр такого объема записи требует крайне много времени.

Внешний вид и надписи

Область с "птичками" далее позволяет настроить внешний вид камеры и событий исходя из Ваших требований. Можно включить отображение даты сработки алгоритма, его название, мигание рамки вокруг камеры, по которой произошла сработка и другие параметры.

·Кнопка "Настройка камеры" откроет параметры текущей камеры.

·Опция "Отображать надписи" и, соответственно, кнопка "Настроить" позволяет задать произвольные надписи поверх видео у всех видеороликов для текущей камеры и текущей панели "Внимание!".

Сам текст настраивается очень просто. Вы можете менять параметры и параллельно смотреть как они отображаются на внешнем виде роликов на панели "Внимание!".

Так же, вместо обычного текста Вы можете использовать переменные:

·%t - выведет текущее время поверх видеоизображения в формате Ч:М

·%T - вермя в формате Ч:М:С

·%d - выведет текущую дату, а %D текущую дату с указанием дня недели.


Алгоритм "Авария"

Navigation: Панель "Внимание!" >

Алгоритм "Авария"

Алгоритм панели "Внимание!" "Авария" служит для оперативного оповещения оператора о том, что с одной из видеокамер пропал видеосигнал. Даже если оператор отвлекся, он всегда увидит это оповещение на одной из панелей "Внимание!".

Чтобы настроить алгоритм, откройте настройки панели "Внимание!" и перейдите на вкладку "Авария". Настраивается алгоритм отдельно для каждой камеры.

Чтобы включить алгоритм, установите переключатель в положение "Activated". В поле "Допустимое время отсутствия видео" установите период, после которого выводить оповещение на панель "Внимание!". То есть, если видео "пропало" на 29 секунд и появилось на 30-ой - оповещения не будет.

В поле "Длительность ролика последних записанных в архив кадров" устанавливается длительность ролика, который будет выведен на панель "Внимание!".

Параметр "Реагировать на отсутствие записи" поможет Вам отслеживать моменты пропадания видеозаписи с текущей камеры в случае повреждения жесткого диска или каких либо других проблем. На панель внимание так же будет выведен ролик с последними секундами записи и иконкой перечеркнутого жесткого диска.

Обратите внимание! Для работы алгоритма необходимо, чтобы у камеры была настроена и включена запись в архив, т.к. ролики формируются именно из текущего архива камеры.


Алгоритм "Лица"

Navigation: Панель "Внимание!" >

Алгоритм "Лица"

Общее описание

Алгоритм панели "Внимание!" "Лица" служит для оперативного оповещения оператора о детекции лиц, и помогает ему отслеживать нежелательных личностей со своего рабочего места.

Обратите внимание! Для работы алгоритма необходимо, чтобы у камеры была настроена и включена запись в архив, т.к. ролики формируются именно из текущего архива камеры.

Трекер лиц

В новых версиях GOALcity добавлена возможность не только детектировать сам факт появления лица в кадре, но и использовать биометрический анализ с точным определением того, кто находится перед камерой.

Обратите внимание на наши рекомендации по установке камер для детекции лиц!

Чтобы включить трекер лиц, выполните следующие действия:

Откройте настройки камеры, на которой необходимо выполнять анализ и определение лиц, и активируйте на вкладке "Фильтры" параметр "Трекер лиц".

Важно! Для работы системы необходимо активировать именно Трекер лиц, стандартное определение лиц при этом должно быть выключено!

Для начала, другие настройки можете не изменять, они настраиваются "опытным" путем, в зависимости от расположения камеры, размера лица в кадре и других параметров, в большинстве случаев, значения "по умолчанию" должны подходить.

Затем откройте параметры панели "Внимание!" и перейдите к настройкам этой камеры. Выберите вкладку "Лица".

Если на камере трекер лиц включается впервые, и ни одного лица еще не было определено, то Вам нужно оставить систему немного поработать, чтобы можно было выбрать определенные лица и занести их в базу. Активируйте алгоритм, сохраните все параметры и немного подождите, пока система наработает хотя бы небольшую базу.

Кликните правой кнопкой мыши по одному из лиц, которые Вы хотите добавить в базу, и выберите пункт "Добавить лицо".

Система проанализирует всю базу данных и выведет все подходящие лица.

Введите имя этого человека или любую другую информацию, которая будет отображаться на панели "Внимание!" при обнаружении этого лица.

Теперь откройте настройки панели "Внимание!" и перейдите на вкладку "Лица". Изначально список лиц будет пуст, и Вы можете добавить туда определенных людей или всех сразу. При этом панель "Внимание!" может работать в двух режимах - выводить только людей из списка или наоборот выводить только неизвестных людей.


Рекомендации по установке

Navigation: Панель "Внимание!" >

Рекомендации по установке

Залог корректной работы распознавания лиц – правильная фотография в базе данных и качественная картинка с камеры.

Это не наши установки, мы их скопировали с официальных документов других компаний. Таким образом, мы имеем общую с другими систему предъявления претензий. В реальности наши алгоритмы распознавания лиц успешно работают на двойных превышениях этих значений. Но, конечно, уже возможны погрешности.

Дополнительно рекомендуем ознакомиться со статьей "Подбор и настройка камер для распознавания лиц".

Официальные требования к установке камеры для распознавания лиц и ее основным характеристикам

Камера должна быть установлена с отклонением центральной оси наблюдения не более 15 градусов к плоскости лица, как в горизонтальной, так и в вертикальной плоскости.

Для распознавания лиц требуется плотность пикселов не менее 500 pix/м во всей предполагаемой зоне распознавания. Это требование в конечном итоге определяет разрешение и угол обзора камеры

Глубина резкости должна покрывать всю зону контроля. Глубина резкости напрямую зависит от фокусного объектива и значения диафрагмы. То есть рекомендуется заранее просчитывать глубину резкости (особенно актуально для длиннофокусных объективов) выбирать камеру с возможностью управления диафрагмой. В идеале камера должна позволять задавать пределы открытия и закрытия диафрагмы объектива.

Для четкости получаемого кадра, рекомендация по значению времени накопления заряда (выдержки, shutter) – не менее 1/100 секунды.

Камеру рекомендуем выбрать с высокой светочувствительностью (матрица от 1/3“ и больше), использовать светосильный объектив (от F1,4 и лучше)

В зоне контроля необходимо обеспечить хорошее и ровное освещение (150 и более люкс).

Технические требования к организации системы распознавания лиц можно свести в таблицу:

ПАРАМЕТР | ТРЕБОВАНИЕ
Плотность пикселей | Не менее 500 пикс/м
Углы отклонения | Не более 15⁰ по вертикали и горизонтали
Диафрагма объектива | Регулируемая; с возможностью ручного управления
Светосила объектива | Не менее 1:1.4 (т.е., например, объектив 1:1.2 имеет бОльшую светосилу, чем 1.4)
Размер матрицы | Не менее 1/3”
Выдержка | Не более 1/100 с (т.е. с выдержкой, например, 1/25 с возможно появление смазывания движущихся объектов)
Освещенность | Не менее 150 лк; освещение лица должно быть равномерным
Требования к фото | Размер лица в кадре не менее 150px *150px

Условия распознавания лиц

Минимальные условия для детекции лиц и поиска их совпадений (распознавания):

·Наклон головы 30°

·Поворот головы менее ±30°

Для достижения максимально точных результатов рекомендуются следующие условия (в случае увеличения углов наклона/поворота точность уменьшается).

·Наклон головы 20°

·Поворот головы менее ±20°

Рекомендации по установке камеры

·Рекомендуется расположение при котором объект смотрит и движется вперед в направлении камеры

·Путь движения не должен блокироваться дисплеями, информационными стойками

·В случае широкого угла зрения минимальной шириной лица является его изображение в 125 пикселей.

1.Старайтесь устанавливать камеру как можно ниже используя кронштейн, чтобы лицо было расположено напротив камеры. Для работы с лицами детей, рекомендуется размещать камеру на высоте 1,4м от пола.

2.Угол наклона камеры в конце области определения лиц, должен быть в пределах примерно 12⁰ Идеальное условие высота камеры от пола 2.2m, желательно чтобы начало области определения лиц располагалось далее 8,5м.

3.В начальной позиции определения лиц, настройте камеру таким образом, чтобы размер лица взрослого человека составлял 150x150 пикселей. Поле зрения в ширину не более 2м.

4.От начальной позиции до конечной, в идеале, камера должна успеть захватить примерно 20 кадров на человека


Детектор помех

Navigation: Панель "Внимание!" >

Детектор помех

В GOALcity Vanga добавился детектор помех, позволяющий отсекать природные помехи, или хотя бы снижать активность панели на них. Другими словами, этот детектор позволяют уменьшить количество ложных срабатываний аналитики.

Посмотрите пример, как это работает на практике и какие рекомендации мы даем по использованию.

Чтобы активировать детектор помех, откройте настройки панели "Внимание!", перейдите к настройке камеры, для которой хотите включить детектор помех, и активируйте алгоритм.

Включить или выключить детектор помех можно сразу для всех камер с помощью кнопки "Помехи" над списком камер.

"Растения"

Этот детектор предназначен для отсечения помех, связанных с систематическим движением, например качающаяся в кадре ветка дерева. Активируйте его, переведя "ползунок" в "зеленое" положение.

Теперь детектор необходимо настроить.

Параметр "Уровень помех" отвечает за время "нереакции" на устойчивую помеху. То есть, если Вы получаете сообщение, например, о качающейся ветке, довольно часто, то уровень помех нужно поднять, переместив ползунок вправо или если Вы заметили что события практически перестали приходить, передвиньте ползунок влево, для уменьшения времени "нереакции". Для первой настройки можете оставить все "По умолчанию" система автоматически подстроиться под Ваш объект и будет менять этот параметр в зависимости от ситуации.

Опция "Проводить настройку при загрузке программы" позволит проводить подстройку алгоритма при каждом запуске GOALcity в автоматическом режиме. Система сама проанализирует видеопоток и "вычленит" проблемные места.

Следующая опция "Отображать карту уровня опасности в окне камеры" позволит включить цветовое наложение на видеопоток, на котором будут отмечены различными цветами зоны особого внимания и зоны с "пониженной чувствительностью". Данную опцию можете включить, если Вам интересно, в каком же месте кадра система определила помехи, и какие из зон кадра отметила, но для "бытового" использования рекомендуем не включать опцию, т.к. оператора могут "сбивать с толку" цветные карты в окне камеры.

Кнопка "Настройка зоны особого внимания" позволяет открыть редактор с видеокадром и вручную указать зоны, на появление в которых чего или кого либо система должна реагировать всегда, если в других частях кадра нет детекции. Такую маску надо накладывать в те места, где исключаются естественные помехи, и она не должна превышать 50% кадра.

С помощью "Толщины каймы опасной зоны" система пытается предугадать начальную стадию развития помехи. Например, ветер только начинается и качает лишь незначительно ветку. Следующий порыв ветра с более сильным колебанием ветки будет компенсирован этой каймой. И т.д.

Нажмите кнопку "Ок" и сохраните все изменения. Система перейдет в режим анализа движения по текущей камере.

Затем, если Вы активировали опцию "Отображать карту уровня опасности в окне камеры" и в кадре есть движение, видеоизображение постепенно окраситься разными цветами. Синим цветом выделена зона особого внимания.

Говоря коротко, суть алгоритма заключается в том, чтобы всегда держать Вас в курсе того что происходит в зоне особого внимания и периодически обращать Ваше внимание на другие, возможные угрозы в кадре, стараясь при этом не выдавать лишней, ненужной информации.

"Атмосфера"

Атмосфера - помехи, идущие одновременно по большой части кадра в своей общей площади

Данный фильтр предназначен для отсечения помех, связанных с природными явлениями такими как снег, град, дождь и другими, распространяющими своё действие по всему кадру. Активируйте его, переведя "ползунок" в "зеленое" положение.

Настройка детектора очень проста, постарайтесь, с помощью двух "ползунков", визуально "подогнать" площадь нарисованных на видеоизображении помех к тому, что Вы реально видите в кадре. Другими словами, выберите максимальную площадь детекции с помощью этого прямоугольника, если детекция будет больше указанной площади, то сработки алгоритмов не будет.

Нажмите "Ок" и сохраните изменения.

"Объекты"

Данный детектор предназначен для работы в паре с нейронной сетью и работает по индивидуальным ТЗ. Для более подробной информации рекомендуем Вам обратиться в наш отдел продаж.


Видеоаналитика

Navigation: Панель "Внимание!" >

Видеоаналитика

В отличие от самонастраивающейся видеосемантики, классическая видеоаналитика требует точной настройки на конкретный объект и иногда автоматического изменения этих настроек с учетом времени, новых условий освещения и влияния других факторов - все эти возможности представлены. Проще всего настраивать видеоаналитику для внутренних помещений, там происходят наименьшие фактурные изменения фона по сравнению с уличной обстановкой, но и в этом случае нужно учитывать динамику освещенности, а также других иногда встречающихся помех.

Аналитический видеодетектор объектов

Подробнее о видеоаналитике.


"Опасное направление"

Navigation: Панель "Внимание!" > Видеоаналитика >

"Опасное направление"

Алгоритм "Опасное направление" предупреждает, что какой-либо объект движется в сторону, запрещенную правилами. Представим себе парковочную станцию. И вот, один нарушитель, или неопытный водитель решил выехать через въезд, тем самым создавая потенциально аварийную ситуацию. Но сработавший вовремя алгоритм разбудит задремавшего охранника, включит сирену, активирует шлагбаум и т.д.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения. На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении. Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Опасное направление» предусмотрены следующие установки.

·"Активировать" - активирует/дезактивирует алгоритм.

По нажатию кнопки "Добавить" откроется окно "Настройка зоны".

Здесь задаются разрешенные и запрещенные направления.

Область, ограниченная периметром ABCD - зона. Все, что вне зоны - внешняя область.

Зону можно располагать как необходимо. Для этого указатель мыши подводим к краю с буквенным обозначением, зажимаем левую кнопку и перетаскиваем край, меняя положение границы.

Далее следуют настройки всех четырех границ (A-B, B-C, C-D, D-A).

·"Состояние" - может быть открыто - разрешено пересечение границы в любом направлении, закрыто - пересечение запрещено, только выход - пересечение границы при движении со стороны внешней области по направлению к зоне запрещено, только вход - пересечение границы при движении со стороны зоны по направлению к внешней области запрещено.

·"Длина в метрах" - здесь необходимо указать реальную длину границы, иначе алгоритм функционировать не будет.

·"Движение в сторону границы разрешено" - если убрать галочку из данного пункта, то любое движение в сторону границы, даже без ее пересечения, запрещено.

·"Начальная задержка" – устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и проч.

·"Длительность усреднения" - суть данного параметра заключается в следующем. В реальности объект движется неравномерно. Для математического анализа необходимо некая усредненная траектория движения, в рамках которой будут производиться расчеты. В данном пункте устанавливается, на протяжении скольких кадров будет производиться усреднение. Значение влияет на чувствительность алгоритма.

·"Продолжительность отслеживания" - здесь устанавливается время, в течении которого программа, не прекращая отслеживание, будет ожидать движения объекта при его исчезновении.

Для индикации сработки этого алгоритма можно назначить звуковой сигнал.


"Опасный поворот"

Navigation: Панель "Внимание!" > Видеоаналитика >

"Опасный поворот"

Алгоритм "Опасный поворот" выявляет резкие повороты. Как ни странно, большинство выбираемых людьми направлений основывается на совершенно конкретном математическом законе: из точки А в точку Б мы направляемся кратчайшим путем – по прямой. Согласитесь, довольно странно выглядит человек, идущий змейкой по просторной дороге. Еще более странным может быть резкий разворот назад.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения. На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении. Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Опасный поворот» предусмотрены следующие установки.

·"Активировать" - активирует/дезактивирует алгоритм.

·"Разрешенный левый поворот", "Разрешенный правый поворот" - позволяют установить, в градусах, значение максимального угла поворота объекта налево и направо соответственно, ниже которого сработка алгоритма не произойдет.

·"Начальная задержка" – устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и проч.

·"Длительность усреднения" - суть данного параметра заключается в следующем. В реальности объект движется неравномерно. Для математического анализа необходимо некая усредненная траектория движения, в рамках которой будут производиться расчеты. В данном пункте устанавливается, на протяжении скольких кадров будет производиться усреднение. Значение влияет на чувствительность алгоритма.

·"Продолжительность отслеживания" - здесь устанавливается время, в течении которого программа, не прекращая отслеживание, будет ожидать движения объекта при его исчезновении.

·"Отставание базового вектора" - суть этого параметра заключается в том, что аналитический аппарат в каждом новом кадре к траектории движущегося объекта строит касательную-вектор. Между последним таким вектором и предпоследним, который называется "базовым", рассчитывается угол, по которому и определяется на сколько "опасен" поворот. Значение, выставленное в данном пункте задает в каком кадре, относительно последнего, будет строиться базовый вектор. Меняя этот параметр, меняем чувствительность алгоритма.

Для индикации сработки можно назначить звуковой сигнал.

Для работы алгоритма "Опасное направление" необходимо активировать Детектор объектов (меню "Объекты" в настройках камеры).

Пример. Если человек не сразу выбрал кратчайший путь до входа в ваш офис, а, пытаясь не привлекать внимание, шел параллельно дороги, то резкий разворот у самого окна или двери можно считать опасным.


"Зона"

Navigation: Панель "Внимание!" > Видеоаналитика >

"Зона"

Алгоритм «Опасные зоны» – предупреждает, что в зонах контролируемых какой-то из камер, для которых он включен, и где не должно происходить никакого движения, неожиданно появились движущиеся объекты. С помощью его можно установить маршруты санкционированного движения и такие, где движение запрещено. Злоумышленник волей-неволей вынужден проникать туда, где обычно людей не бывает или они там появляются чрезвычайно редко.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения. На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении. Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Опасные зоны» предусмотрены следующие установки.

"Начальная задержка" – устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и проч.

Для индикации сработки этого алгоритма можно назначить звуковой сигнал.

Кликнув мышью по кнопке «Настройка зон», Вы попадете в окно, в котором можно выделить маску зон/зоны действия этого алгоритма.

В верхней части окна выбирается размер "кисти" и выполняемое действие (маскирование или стирание маски). Удерживая левую кнопку мыши и перемещая курсор по кадру Вы наносите или стираете маску. Сразу очистить замаскированную площадь можно, нажав кнопку «Очистить». Кнопка «Получить кадр» позволит Вам обновить картинку, отображаемую в окне.

Завершив маскирование зоны детекции, кликните по кнопке «Ок»


"Предмет"

Navigation: Панель "Внимание!" > Видеоаналитика >

"Предмет"

Алгоритм «Предметы» – осуществляет контроль за появлением/исчезновением предметов в поле наблюдения камеры. Если предмет исчез, то можно предположить, что он похищен, просмотр записи, предшествующей моменту сработки алгоритма поможет уточнить обстоятельства исчезновения. Внезапное появление нового предмета может представлять в наше время существенную опасность. Им может оказаться какое-либо "шпионское" устройство, либо даже взрывоопасный предмет.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются моменты появления или исчезновения в поле зрения камеры нового предмета. На панели крупным планом выводится сам предмет, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении. Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Предметы» предусмотрены всего две установки:

·"Время предпросмотра в архиве" - укажите, какой период времени должен анализироваться для сработки алгоритма. Другими словами, сколько должен находится предмет в кадре до сработки.

·"Продолжительность отслеживания после обнаружения" - укажите задержку на сработку алгоритма после обнаружения предмета в кадре за время, установленное в предыдущем поле.

Для индикации сработки этого алгоритма можно назначить звуковой сигнал. Также можно указать место в компьютере, куда программа будет сохранять записываемые кадры.

Чтобы алгоритм работал необходимо активировать фоновый детектор (детектор объектов в настройках камеры).


"Время"

Navigation: Панель "Внимание!" > Видеоаналитика >

"Время"

Алгоритм «Опасное время» предупреждает, что в зоне видимости какой-то из камер, для которых он включен, где, как правило люди долго не задерживаются, движущийся объект находится слишком долго. Применение его особенно эффективно, например, для камер, установленных в подъездах, перед входными дверями квартир и домов. Позволяет отследить деятельность лиц, готовящих несанкционированное проникновение.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения. На панели крупным планом выводится сам объект, по периметру окна камеры, передающей изображение с места события мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении. Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Опасное время» предусмотрены следующие установки.

·"Активировать" - активирует/дезактивирует данный алгоритм.

·"Период превышения" – рассчитывается исходя из того, сколько времени по максимуму требуется обычно, чтобы покинуть зону видимости камеры. Как правило, на проход по лестничной площадке требуется около 10 сек. Но для подготовки ограбления этого мало: нужно изучить замки, глазки, взломоустойчивость двери. Именно эта разница во времени нахождения в зоне наблюдения камеры и используется для распознавания "хороших" и "плохих".

·"Макс. время отсутствия движения" - задается время, по истечении которого, если не произошло ни одного движения, то алгоритм сработает.

Если, например, хозяин выйдет покурить на площадку, или кто-то из "своих", явившись навеселе, слишком долго добирается от лифта до двери, система обратит внимание оператора лишь на начало события, после чего все виды оповещения заблокируются до следующего события, определённого в настройках алгоритма Интервалом между событиями.


"Покой"

Navigation: Панель "Внимание!" > Видеоаналитика >

"Покой"

Алгоритм "Опасный покой" очень похож на алгоритм " Время ", только работает в "обратную сторону" Настройки аналогичны.

Разница заключается в том, что "Опасный покой" срабатывает тогда, когда какое-либо движение в поле обзора камеры прекращается совсем. Это полезно, например, в случае с конвеером, когда он останавливается.


"Количество"

Navigation: Панель "Внимание!" > Видеоаналитика >

"Количество"

Алгоритм «Опасное количество» предупреждает, что в зоне контролируемой какой-то из камер, для которых он включен, неожиданно скопилось слишком много или слишком мало движущихся объектов: людей, автотранспорта и т.п., большая часть которых находятся на расстоянии друг от друга. Применение его особенно эффективно для камер с широким углом обзора, способных зафиксировать одновременно большое количество самостоятельных объектов. Так неожиданное появление толпы на или возле охраняемого объекта может оказаться началом опасного события.

Если сработка системы по алгоритму «Опасное начало» предупреждает о том, что в зоне контроля камеры появился первый движущийся объект (объекты), то включение алгоритма «Опасное количество» означает, что количество таких объектов изменилось (увеличилось или уменьшилось).

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность(и) и оценить намерения. На панели крупным планом выводится сам движущийся объект(ы), по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении. Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Опасное количество» предусмотрены следующие установки.

"Разрешенное количество" - здесь выбирается какое число объектов одновременно может появиться в поле зрения камеры без сработки алгоритма (если количество объектов больше, то алгоритм сработает).

"Начальная задержка" – устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и проч.

"Минимальное расстояние между объектами" - позволяет установить предельное расстояние между детектируемыми объектами, до которого они могут сблизиться.

Для индикации сработки этого алгоритма можно назначить звуковой сигнал.

Непрерывное изменение количества объектов в кадре вследствие их неупорядоченного движения компенсируется Интервалом между событиями, алгоритм которого постоянно вычисляет среднее число объектов в зоне видимости. Если в поле зрения камеры появились, например, два человека, идущие навстречу друг другу, в тот момент, когда траектории их движения пересекутся, то, если этот момент не превысит время, установленное для Интервала между событиями, сработки не произойдёт. Если же они задержатся, чтобы побеседовать друг с другом, то сработает оповещение и событие будет зафиксировано. Что, в общем, и правильно: регистрация факта такой встречи может оказаться небесполезной с позиции безопасности охраняемого объекта.


"Площадь"

Navigation: Панель "Внимание!" > Видеоаналитика >

"Площадь"

Алгоритм «Опасная площадь» – комплексный. Он предупреждает сразу о нескольких признаках опасных проявлений. Например, если в большой аудитории среди сидящих кто-нибудь встанет, то алгоритм распознает это как новое событие, так как существенно изменится площадь детекции. Толпа людей тоже представляет собой по площади детекции один большой объект, потому любая его трансформация вызовет сработку. Это может быть поднятая рука, подобравшийся близко к камере злоумышленник и многое другое.

При инициализации этого алгоритма на «Панели "Внимание!"» отображаются и фиксируются последние события от начала их и в течение нескольких секунд после этого момента. Уже по первым кадрам можно квалифицировать личность и оценить намерения. На панели крупным планом выводится сам движущийся объект, по периметру окна камеры, передающей изображение с места события, мигает красная рамка, если настроен, то слышится звуковой сигнал. Оператор, даже если в момент события его не было на месте, спустя любое время может выбрать зафиксированное событие и просмотреть динамическую последовательность кадров, показывающую событие в движении. Также можно вызвать воспроизведение записи этого события из архива с его начала и по любое время. Для этого надо кликнуть правой кнопкой мыши по записанному кадру и выбрать "Показать запись". А выбор пункта "Комментировать..." вызовет окно, в котором можно записать текстовый комментарий к запечатленной последовательности кадров. Этот комментарий позволит Вам моментально отыскать запись этого события при просмотре архива.

В настройке алгоритма «Опасная площадь» предусмотрены следующие установки.

"Начальная задержка" – устраняет ложные сработки, вызываемые природными явлениями, животными, бликами, тенями и проч.

"Время усреднения" - период, на протяжение которого допускается кратковременное изменение площади с возвращением её в прежние пределы. Это время необходимо для того, чтобы избежать ложных сработок в случае кратковременного попадания в зону обзора посторонних предметов, не представляющих опасности, например, флагов, развеваемых порывом ветра.

"Соотношение" – вычисляется инсценированием событий перед камерой. "Актёрами" воспроизводятся сцены возможных несанкционированных действий и по результатам их анализа устанавливаются параметры изменения площади детекции.

Настройка "Реагировать на уменьшение площади движения" указывает алгоритму на необходимость сработки не только в случае увеличения площади движущихся объектов, но и в обратной ситуации – при ее уменьшении.

Для индикации сработки этого алгоритма можно назначить звуковой сигнал.

Алгоритм может вступать в коллизии с другими и дополнять их, потому рекомендуется применять для каждого конкретного объекта разные комбинации алгоритмов. Кроме того, имеется возможность настроить любую из камер на выдачу только одного сообщения при наступлении одновременно нескольких рассчётных событий.

Правильно установленный Интервал между событиями отсечёт ложные срабатывания при постоянно совершающемся движении. Так, если по объективу камеры ползает насекомое, то его движение вызовет только одну сработку алгоритма.


Видеосемантика

Navigation: Панель "Внимание!" >

Видеосемантика

Видеосемантика — краткое логическое изложение видеоинформации путём разложения ее на семантические единицы (видеосюжеты), каждый из которых имеет свой законченный смысл, отличающийся от предыдущего и последующего видеосегмента. Это особое направление видеоаналитики — так называемая гибкая видеоаналитика, не имеющая жестких параметров и точной формализации.

Видеосемантика отслеживает характерные черты видеоконтента в результате анализа статистических изменений, таким образом, осуществляется селекция видео-событий по их смысловому отличию. Семантика в языкознании изучает смысл единиц языка, а в видеоаналитике изучает смысл единиц видеособытий. И там, и там — это набор знаний, объединенных между собой определенными соотношениями.

Видеосемантика базируется на большом наборе различных типов видеодетекторов, изучающих свойства объекта (его размеры, соотношения сторон, цветовую гамму, направление движения, скорость, частоту движений, параметры изменений…). Все эти характеристики связаны между собой математическими соотношениями, основанными на закономерностях поведения различных типов объектов.

Отсутствие жестко заданных параметров и точной формализации защищает от помех, так как они включаются в общий анализ и вычитаются сами из себя в результате разности статистических изменений.

Видеосемантика позволяет разграничивать события по их отличительным признакам, что дает возможность автоматизировать многие процессы, связанные с поиском видеоконтента в длительных записях или в режиме реального видеонаблюдения.

Видеосемантика раскладывает видеопоследовательность на смысловые единицы. Дополнительные программы могут выделять ту часть смысловой единицы, который полностью характеризует весь фрагмент. И, в итоге, вместо монотонной видеозаписи получается разделенный на короткие фрагменты видеоряд, вмещающий в себе смысл всей записи в удобном для восприятия любым, даже неподготовленным человеком, виде.

Видеосемантика

tipbulb Смотрите также:

· Алгоритм "Новизна"

· Алгоритм "Поступательность"

· Алгоритм "Количество"

· Алгоритм "Пропорции"

· Алгоритм "Площадь"

· Алгоритм "Гамма"


"Новизна"

Navigation: Панель "Внимание!" > Видеосемантика >

"Новизна"

Является основным с особенно часто используемым из всего набора видеосематических алгоритмов. Принцип работы основан на сравнивании ключевых моментов видеоряда. Особенно хорошо алгоритм себя проявляет на "статических" камерах, другими словами, в том случае, когда движение в кадре не постоянно. Например, задний двор вашего дома. Как правило там редко кто-то появляется, но, если появится, вы получите мгновенное оповещение хоть на компьютер, хоть на мобильный телефон, о том, что Ваш ребенок, собака или, не дай Бог, злоумышленник "вышли погулять" на задний двор. Коротко говоря, алгоритм работает по принципу "Ничего нет - что-то появилось".

Как уже отмечалось ранее, особых настроек он не требует, и сам "подстроится" под реалии вашего объекта.


"Поступательность"

Navigation: Панель "Внимание!" > Видеосемантика >

"Поступательность"

Основан на анализе поступательного движения человека, машины, и т.д. Для примера возьмем проходную с одним входом и выходом расположенными в одном направлении. Алгоритм Новизна в этом случае нам особо не поможет, потому что движение в проходной практически постоянное, но вот Поступательность будет более чем кстати. Алгоритм анализирует траекторию движения людей по коридору и подстраивается под обстановку. Если большинство людей идет прямо к выходу, алгоритм запомнит это и не будет обращать Ваше внимание, но вот если один из них вдруг решит изменить свое направление и, например, зайти в подсобку справа, Вы тут же увидите об этом на панели "Внимание!", мобильном телефоне, планшете.

Или другой пример, автомобильная дорога. Установлен знак "Только прямо", но есть возможность повернуть в ту или иную сторону. Алгоритм подстроиться под прямолинейное движение автомобилей, а Вы увидите на панели "Внимание!" только злостных нарушителей.

Настроек алгоритм так же практически не требует, и сам подстроиться под Вашу ситуацию на объекте.


"Количество"

Navigation: Панель "Внимание!" > Видеосемантика >

"Количество"

В отличии от алгоритма Количество, применяемого в жесткой видеоаналитике, в "гибкой" видеосемантике алгоритм ведет себе совсем иначе. При использовании "жесткого" алгоритма, нам необходимо указывать количество объектов, их размер и прочую служебную информацию для отработки алгоритма. Здесь же ничего этого не требуется. Необходимо только указать, насколько широкий угол обзора у Вашей камеры, все остальные параметры алгоритм подберет "сам". Работа основана на "долгосрочном" анализе, другими словами алгоритм накапливает статистику по размещению объектов в поле зрения камеры. Например, мимо вашей камеры постоянно ходят люди, по 1-му, вдвоем. Алгоритм "привыкнет" к таким группам и не будет заострять Ваше внимание на эти события, но, если пойдет более большая группа людей Вы сразу же получите об этом сигнал.

Или, например, перекресток и стоп линия. Ширина проезжей части может "вместить" один автомобиль перед стоп линией. Алгоритм "привыкнет" что автомобиль там должен быть только один. И если кто-то захочет нарушить и "вылезет" вторым рядом, система мгновенно оповестит Вас об этом.

Из настроек, мы предлагаем Вам указать только насколько широкий угол обзора у Вашей камеры, остальное алгоритм все сделает "сам".


"Пропорции"

Navigation: Панель "Внимание!" > Видеосемантика >

"Пропорции"

Анализирует текущие пропорции объекта и их изменение с течением времени. Применение алгоритма довольно специфично, а требует грамотной установки камеры и четкого понимания того, что Вы хотите отслеживать. Один из простейших примеров работы алгоритма — это контролирование подходов к территории. На удалении силуэт (пропорции) объекта будут маленькими и по мере приближения к камере, соответственно, увеличатся. Система сразу же оповестит Вас о приближении того или иного объекта.


"Площадь"

Navigation: Панель "Внимание!" > Видеосемантика >

"Площадь"

Расширяет сферу применения жесткого видеоаналитического алгоритма «Площадь». Принцип работы схож с алгоритмом Количество, и работают они, как правило, в паре. Опять же, вся разница в том, что нам не нужно задавать конкретных параметров. Сработка алгоритма основана на накоплении видеостатистки. Например, мы смотрим на место для курения. Обычно покурить выходят 1-2 человека одновременно. Алгоритм "привыкнет" к этому. Если "курильщиков" выйдет больше, дружно сядут на лавочку и начнут мило беседовать, Вы получите об этом оповещение.

Настройка алгоритма так же сведена к минимуму, необходимо только указать насколько "широко" смотрит Ваша камера и примерное время сравнения изменений в видеоряде.


"Гамма"

Navigation: Панель "Внимание!" > Видеосемантика >

"Гамма"

Алгоритму Гамма можно найти огромное количество применений начиная от прямого назначения "Свет есть - свет погас" и заканчивая более изощренными, например, нахождение в темном потоке машин светлой или наоборот. Так же алгоритм мгновенно предупредит о перекрытии камеры, о сильной засветке или прочих "нештатных" ситуациях. Будет полезен практически в любой ситуации, и может обратить Ваше внимание на то, о чем Вы бы и не подумали. Прекрасно сигнализирует о возгораниях, задымлениях и т.д.

Настройка не прихотлива. Укажите только примерную разницу в освещении, которую Вам необходимо отслеживать. Остальную работу алгоритм сделает за Вас.


Farwit и GOALmobile-2

Navigation: Панель "Внимание!" >

Farwit и GOALmobile-2

Farwit (или "Далекий свидетель") и GOALmobile-2 являются дополнительными "помошниками" в обеспечении Вашей безопасности, но, в отличии от Вашего ПК, они могут быть всегда с Вами, в вашем смартфоне.

"Далекий свидетель" - облачный видеоархив на основе «коротких данных» Short Data. Работает с устройствами, поддерживающими технологию видеосемантики. Сюда могут входить как мощные корпоративные видеосервера, так и домашние видеодомофоны.

Такая технология не нагружает сеть тяжёлыми видеопотоками и удлиняет период хранения архивов на долгие годы. Вы сможете и через 10 лет вспомнить, кто приходил к вам домой на день рождения или какой номер был у автомобиля вашего знакомого 5 лет назад.

Но основной задачей этого сервиса является безопасность. Большинство систем видеонаблюдения лишь всё пишут – и всё стирают, это не самый эффективный способ использования информации.

Сейчас мало кто не знает назначение видеокамер, поэтому идти на криминал в открытую перед ними желающих уже нет, тех горе-преступников, которых иногда все-таки записывают камеры, можно поймать и без камер. Камера в сегодняшних условиях – лишь косвенный свидетель, который может отследить близ появляющихся людей, странности поведения, особые приметы. Однако по косвенным свидетельствам тоже можно вычислить подозреваемого, так же, как и по свидетельствам живых людей, собственно говоря, это основной путь любого следствия.

Но камера гораздо лучше справляется со своими задачами, чем люди. Никакая бабушка у подъезда не нарисует точную внешность подозреваемого, не покажет особенности поведения, не уточнит время действия, да и не сможет она сидеть 24 часа в сутки на лавочке в дождь и снег.

Так же, как и перед живым свидетелем, перед камерой тоже никто не будет совершать само преступление. Другое дело, что попасть на место совершения без попадания на камеру тоже проблематично. Да и злоумышленники не без головы, обычно преступления готовятся заранее, осматриваются пути доступа, изучается распорядок дня. Но подготовка может идти и месяцы, и годы. Сохранить архив большой длительности и позволяет "Далёкий свидетель".

Этот Интернет-сервис пишет не кино, а лишь короткие отрывки из событий, оставляя факты, лица и внешности людей, номера автомобилей, особенности поведения и другие приметы, по которым можно производить анализ как произошедшего, так и готовящихся проблем.

Любое видеозаписывающее устройство можно унести с собой вместе с записанными уликами, Далёкий свидетель надежно хранит эту информацию в удалённом от объекта месте, и несанкционированный доступ к нему невозможен даже при угрозе силой.

GOALmobile-2 – это универсальное решение для мониторинга и управления объектами, которое всегда с Вами. GOALmobile-2 функционально совершенствует Ваш сотовый телефон (планшет, КПК и т.п.). Теперь он становится еще и мобильным пультом охраны, и системой видеонаблюдения, и устройством оповещения, и защищенной базой данных, и неуничтожаемым архивом, и средством анализа - и не только.

Из любой точки мира Вы всегда сможете просматривать камеры, записи событий или управлять домом прямо с телефона, а главное - получать тревожные видеосообщения, информативно передающие проиcходящее.

GOALmobile-2 – система передачи ВИДЕО от видеокамер на мобильный телефон как в реальном времени, так и по более удобной технологии аналитической выдачи видеоданных. Не Вы постоянно проверяете объект на предмет происшествий, не Вы ищете камеру, в которой развиваются события, не Вы коннектитесь в надежде поймать нужный момент, а технология Gm2 сама постоянно запрашивает информацию о сработках, проверяет жизнеспособность, закачивает ключевые моменты, сообщает Вам о наступлении новых событий и показывает их Вам.

От человека ничего не требуется при будничном контроле, а при тревожном - только одно нажатие, чтобы увидеть сразу ВСЕ события.

GOALmobile-2 - это удобно, не надо постоянно смотреть в телефон, производить большое число нажатий для вывода видео, тратить много времени для поиска происходящего события в камерах. GOALmobile-2 анализирует ситуацию и автоматически выдает пользователю нужные видеосюжеты. Быстро и очень удобно!

Еще удобнее контролировать события и живое видео на умных часах!

Примечание. В связи с тем, что система постоянно совершенствуется и модернизируется, производитель оставляет за собой право вносить в нее изменения, не снижающие функциональность, без предварительного уведомления пользователей. Для получения консультации и дополнительной информации свяжитесь со специалистами Спецлаборатории.


Активация сервисов

Navigation: Панель "Внимание!" > Farwit и GOALmobile-2 >

Активация сервисов

Оба сервиса являются "условно бесплатными" и, на данный момент, Вы можете ими пользоваться без какой либо дополнительной платы, но с небольшими ограничениями. Все необходимые для работы программы и библиотеки уже установлены в системе и готовы к работе, нужно лишь их активировать.

Откройте настройки панели "Внимание!", выберите камеру с которой хотите получать события на мобильный телефон в приложении GOALmobile-2 или отправлять их в облачный сервис farwit.com, перейдите на вкладку "Оповещение" и включите необходимый Вам сервис.

·Чтобы использовать "Далекий свидетель" необходимо зарегистрироваться в системе. Нажмите на кнопку "Зарегистрироваться". Откроется веб сайт farwit.com где Вам и нужно указать все необходимые данные. Запомните их, они еще пригодятся.

·Чтобы использовать "GOALmobile-2" необходимо скачать клиент GM-2 себе на устройство. На данный момент поддерживаются практически любые Android устройства с версией 2.3 и выше. Нажмите на кнопку "Мобильное приложение" и перед Вами откроется магазин Google Play на страничке загрузки. Установите приложение себе на устройство. Более подробную информацию о загрузке и установке приложения Вы можете найти в инструкции к GOALmobile-2.


Настройка сервисов

Navigation: Панель "Внимание!" > Farwit и GOALmobile-2 >

Настройка сервисов

Оба сервиса настраиваются с помощью специального конфигуратора, который устанавливается вместе с GOALcity, если при установке выбрана опция "GOALmobile-2".

Нажмите кнопку "Настроить сервер событий".

Общее описание

Как таковой, конфигуратор не требует особой настройки и автоматически получает все данные о пользователях, камерах и панелях "Внимание!" из GOALcity. Подробнее остановимся только на сетевых настройках конфигуратора.

·Сервер событий - контролирует появление в папке новых видео роликов и перезаписывает самые старые ролики при достижении максимального количества. Также сервер событий отправляет сообщение брокеру о том, что появились новые события (ролики). Как правило, сервер событий устанавливают на один ПК совместно с GOALcity.

Почему их два? Данная настройка введена для экономии трафика и, соответственно, ваших денежных средств.

Например, Вы уехали в командировку но хотите продолжать контролировать Ваш объект. Указываете первичный адрес сервера событий который будет доступен из сети интернет. Подключаетесь к нему из любой точки земного шара и контролируете ситуацию на объекте. Но вот Вы вернулись и пришли на объект лично. На объекте имеется локальная сеть и wifi. Указав вторичным адресом внутренний адрес в локальной сети, Вы автоматически переключитесь с "интернета на локальную сеть" и за интернет трафик платить уже не нужно.

·Брокер событий - ведет учет подключенных мобильных устройств и сообщает им о том, что на одном из серверов событий появился новый ролик (новое событие) и видеоинформацию можно скачать. Может быть установлен как на одном компьютере с сервером событий, так и отдельно.

Вкладка "Сервер GOALcity"

На данной вкладке необходимо указать данные для авторизации на сервере GOALcity чтобы конфигуратор мог подключиться к нему и собрать данные о панелях "Внимание!", пользователях и камерах.

Остальные вкладки "Конфигуратора" заполняются автоматически, исходя из настроек клиентской части GOALcity.

Вкладка "Суперархив"

Эта вкладка отвечает за подключение GOALcity к облачному сервису farwit.com. Здесь необходимо ввести Ваши данные, которые Вы указывали при регистрации на сайте.


Пользователи GOALmobile-2

Navigation: Панель "Внимание!" > Farwit и GOALmobile-2 >

Пользователи GOALmobile-2

GOALmobile-2 многопользовательское приложение, таким образом Вы можете предоставить доступ к определенным камерам определенной группе лиц. Например, чтобы жена могла смотреть только камеры из детской, но "не залезала" к Вам в гараж. Все права настраиваются на базе клиента GOALcity, GOALmobile-2 же подхватывает их автоматически.

Настройка прав для "живого" просмотра камер и архива

Первое что нужно сделать, это создать необходимого Вам пользователя в системе GOALcity. Откройте основные настройки программы и перейдите на вкладку "Пользователи".

Нажмите кнопку "Добавить" внизу окна и введите необходимые данные нового пользователя. Сохраните все нажатием кнопки "Ок".

Новый пользователь отобразится в общем списке. Теперь нужно разрешить или запретить ему определенные функции работы с GOALcity. Выделите созданного пользователя в общем списке и нажмите кнопку "Изменить". Чтобы данный пользователь не мог вносить никакие изменения в GOALcity ему хватит прав только на "Просмотр записей". Сохраните все настройки нажатием кнопки "Ок".

Теперь нужно указать что пользователь может просматривать, а что нет. Откройте диаграмму подключений GOALcity, перейдите к настройкам необходимого сервера (Мультимедиа, Архивного или Видеосервера) и перейдите на вкладку "Пользователи". Как и в прошлый раз, выделите необходимого пользователя и нажмите кнопку "Изменить". Для примера рассмотрим Видеосервер.

Во первых, нужно разрешить пользователю подключаться к данному серверу GOALcity. Поставьте галочку в разделе "Видеосервер - Подключение". Затем, выберите те камеры, к которым хотите разрешить доступ пользователю. Разрешайте (отмечайте "птичками") по-парно к какой плате и какой камере дать доступ. Сохраните все изменения нажатием кнопки "Ок". На примере "Жене" разрешен доступ только к камере 1 видеосервера GOALcity. Все остальные камеры она не увидит.

Для других серверов GOALcity доступ выставляется аналогично. На мультмедиа сервере вместо плат видеозахвата будут источники (IPSource, RTPSource и т.д.), а на архивном сервере, соответственно - архивы.

После этих действий необходимо включить Оповещение для выбранных камер в настройках панели "Внимание!". Откройте настройки панели "Внимание!", и активируйте оповещение для выбранных камер, щелкнув левой кнопкой мыши по значку мобильного телефона справа от необходимой камеры. Не забудьте также активировать и саму камеру, чтобы она отрабатывала алгоритмы панели "Внимание!" иначе показывать Вам будет просто не чего. Вся "полоска" камеры при этом окрасится в зеленый цвет.

Если Вы все сделали правильно, то в настройках конфигуратора <%GM2%> отобразятся все созданные Вами пользователи.

На вкладке "Камеры" Вы сможете проверить верно ли Вы "выдали" права пользователям.


Экспорт событий для сервисов

Navigation: Панель "Внимание!" > Farwit и GOALmobile-2 >

Экспорт событий для сервисов

Основное назначение этих сервисов - это оповещение пользователя путем предоставление коротких видеофрагментов с охраняемого объекта. Разберемся как они настраиваются.

Настройка хранилища видеособытий

Для начала необходимо указать корневую папку для записи всех видеособытий с Ваших камер. Откройте главное меню GOALcity и выберите пункт "Настройка панелей Внимание!".

Перед Вами откроется окно параметров для всех панелей "Внимание!" в Вашей системе. Укажите в нижнем поле "Корневая папка для сохранения видеороликов" путь к папке. В неё и будут сохраняться все Ваши видеособытия со всех настроенных камер. Если в системе несколько панелей "Внимание!", то GOALcity создаст подпапки для каждой панели автоматически. В примере используется папка на диске "D" с именем "gm2". Сохраните параметры нажатием кнопки "Закрыть".

Настройка экспорта видеособытий

Перейдем непосредственно к настройке самих видеособытий. Все видеособытия получаются путем "отработки" аналитических алгоритмов панели "Внимание!" GOALcity. Для каждой из панели "Внимание!" можно задать "приоритет" поступаемых с неё событий - Экстренные события, Обратить внимание и Предупреждение о неисправностях. Каждый из приоритетов имеет отдельную настройку в мобильном приложении GOALmobile-2. Например, когда поступает событие с приоритетом "Экстренные события", мобильное устройство будет дрожать, оповещать звуком и всячески требовать обратить на себя внимание до тех пор, пока Вы это не сделаете. Но если поступило событие из разряда "Обратить внимание", то мобильное устройство может просто подать единовременнный сигнал и "успокоиться" на этом.

Приоритет событий задается в целом для всей панели "Внимание!"

Настройка контейнера и разрешения оповещений

Настройка контейнера и разрешения оповещений индивидуальна для каждой камеры. Чтобы открыть настройки, щелкните по кнопке "Настроить" button-11 и перейдите на вкладку "Оповещение" в раздел "Разрешение". Перед Вами откроется окно настроек оповещения для мобильного устройства.

Тип контейнера или другими словами формат "ролика" который будет передаваться на Ваше мобильное устройство. По умолчанию это видеоролики в формате mp4. Данный формат поддерживаю практически все Android устройства, но если у Вас возникли проблемы с воспроизведением ролика на мобильном устройстве, можете изменить контейнер на другой.

Настройте необходимые параметры видео оповещения под ваше мобильное устройство. Выберите разрешение создаваемого ролика, соотношение сторон и качество видео установив необходимый битрейт. Настройки по умолчанию подходят для подобающего большинства мобильных устройств на базе Android, но если Ваше устройство довольно "мощное", повысьте параметры для более "приятного" видео изображения. Все довольно просто.

Настроенные параметры видеособытий актуальны для обоих сервисов! То есть, и на мобильное приложение GOALmobile-2 и в облачное хранилище ролики будут уходить одинаковые!

Виджет GOALmobile-2

Мобильное приложение GOALmobile-2 имеет свой виджет для рабочего стола Android устройств. На вкладке "Виджет" настройте какой из кадров видео ролика будет "попадать" на данный виджет. Рекомендуем оставить значение по умолчанию - "Показывать наилучший кадр". Таким образом GOALcity в момент создания ролика будет создавать и один кадр для предпросмотра, который по "мнению" системы отражает всю суть происходящего в ролике. Этот кадр Вы и будете видеть на рабочем столе вашего Android устройства.

Аудио

Для еще большей информативности Вы можете активировать звуковой сигнал который будет подаваться при создании каждого ролика. Нужно это или нет, решать Вам, при большом объеме экспортированной информации компьютер может начать раздражать "пищанием" внутреннего динамика и наоборот может привлечь к себе внимание при редких видео событиях.


ОПС "Стрелец"

Navigation: Интеграция с системами ОПС >

ОПС "Стрелец"

Важно! Для корректной работы необходимо подключать пульт к ПК используя интерфейс RS232 и только через COM порт! Можно использовать преобразователи USB to Com, но в любом случае, подключение должно производиться через COM порт! Т.е. от устройства должен приходить провод с COM портом!

Подготовка ОПС "Стрелец"

Для начала необходимо установите на ПК программное обеспечение ОПС "Стрелец" и подключите к управляющему устройству все датчики и ключи. Про подключение и настройку устройств можно почитать здесь. Подключите РРОП через COM-порт (RS-232) к компьютеру, на который будет установлена система GOALcity. Подключение можно осуществлять через промышленные приемо-передатчики RS-232 либо через конвертор интерфейсов БПИ RS-И при значительном удалении РРОП и сервера системы друг от друга. В диспетчере устройств проверьте, что подключение прошло удачно и в разделе "Порты COM и LTP" у Вас появился нужный порт. Запомните номер СОМ-порта, он понадобится в дальнейшем для настройки. Устанавите программу WirelEx из комплекта ПО "Стрелец" и запустите ее.

Выберите опцию "Файл" -> "Новая система", откроется окно выбора типа системы, выберите Динамическую. В окне свойств новой системы выьберите Код системы и рабочую частоту, эти параметры должны быть указаны в документации к ОПС Стрелец.

Новая система создана, теперь необходимо добавить в нее управляющие и управляемые устройства. Перейдите на вкладку "Конфигурирование", в поле "Топология радиосети" кликните правой кнопкой мыши по заголовку и выберите строчку "Добавить КР".

В окне выбора типа управляющего устройства выберите необходимый. В примере это РРОП.

Откроется окно свойств управляющего устройства.

Важно! Для корректной работы необходимо присвоить расширителю нулевой адрес!

Остальные параметры можно оставить по умолчанию либо изменить их, руководствуясь документацией по управляющему устройству.

Вернитесь к вкладке "Конфигурирование" и увидите, что управляющее устройство добавилось. Кликните по нему правой кнопкой мыши и считайте с него параметры. В поле "Дочерние устройства" отобразится список устройств, уже подключенных к расширителю. Если Вы делаете все с нуля, то, соответственно, данное поле останется чистым.

Добавление нового устройства

Кликните правой кнопкой мыши по иконке расширителя и выберите пункт "Добавить дочернее устройство". Откроется список устройств, с которыми может работать данный расширитель.

Выберите необходимое Вам устройство и нажмите кнопку "Добавить". В примере рассмотрен охранный извещатель Икар-Р. Откроется окно свойств добавляемого устройства.

Управляющее устройство РРОП имеет 16 разделов. GOALcity работает с разделом целиком, т. е. если подключить несколько датчиков в один раздел, то постановка, снятие с охраны и тревога будут работать для всех устройств в данном разделе. Выберите номер раздела. В примере будет рассмотрен первый раздел и 4-ый адрес извещателя внутри раздела. Период передачи контрольных сигналов лучше поставить минимальный, чтобы извещатель как можно чаще сообщал о своем состоянии расширителю. Нажмите кнопку "Ок".

Дочернее устройство (Икар-Р) появится в списке, но для работы его необходимо запрограммировать в память расширителя. Кликните правой кнопкой мыши по устройству и выберите строчку "Программирование локальное (RS232)". Начнется процесс программирования, и его необходимо подтвердить переключением тумблера на самом устройстве. Как это сделать подробно описано в инструкции к данному устройству или вы можете посмотреть здесь.

Добавление других устройств происходит аналогично, различаются только параметры добавляемых устройств, про которые можно почитать в документации к этим устройствам. Главное - помнить, что работа будет происходить с целыми разделами, и подключайте устройства грамотно. Например, можно завести на первый раздел 5 датчиков движения в левом крыле здания, на второй раздел пожарные датчики в этом же крыле и т. д.

Настройка видеосистемы

Установите GOALcity, для чего запускайте поочередно следующие дистрибутивы программы из комплекта поставки: 1_GOALcity_Client_x64.exe – видео клиент системы, 2_IP_Server_x64.exee – мультимедиа сервер, 9_SLDA_Driver.exee – драйвер взаимодействия с устройствами. Если вы настраиваете подключение ОПС Стрелец в уже предустановленной системе GOALcity, то установите только необходимые модули. Перезагрузите ПК после установки всех элементов.

Откройте Диаграмму подключений GOALcity, выберите локальный мультимедиа сервер и откройте его настройки. Локальный мультимедиа сервер имеет в своем названии IP адрес 127.0.0.1.

Обратите внимание! Удаленный (установленный на другом компьютере) мультимедиа сервер не сможет работать с устройствами (COM-порт), физически к нему не подключенными.

Откройте настройки "Мультимедиа сервера" и выберите пункт "SLDA Source".

В пункте "Датчики и ключи" нажатием серой кнопки button-01 откройте меню добавления устройств. Выберите пункт "Добавить Стрелец".

В создавшемся элементе в обязательном порядке последовательно заполните все пункты.

·"Название" - укажите название, понятное для каждого, кто будет работать с системой.

·"СОМ порт" - укажите номер COM порта, запомненный ранее.

·"Код доступа" - укажите код доступа к РРОП, с которым осуществляется связь по COM порту (RS-232). При заводских настройках РРОП имеет код доступа 0х11112222. Если заводской код доступа не подходит, значит, он был изменен инсталлятором системы ОПС Стрелец. Обратитесь к нему за получением нового кода доступа.

·"Номер расширителя" - укажите номер РРОП в системе ОПС Стрелец, был ему присвоен при добавлении управляющего устройства в программе WirelEx из комплекта ПО Стрелец. По умолчанию это нулевой номер.

·"Номер локального раздела" - укажите номер локального раздела на выбранном РРОП в системе ОПС Стрелец. Это и есть те самые разделы, про которые писалось выше.

·"Частота обновления" - задайте частоту обновления. Данная частота обновления не связана с внутренним опросом устройств внутри системы Стрелец и отвечает только за частоту посылки запросов к РРОП на наличии в нем изменений.

Сохраните все настройки нажатием кнопки "Ок" во всех диалоговых окнах мультимедиа сервера. После применения всех настроек на мультимедиа сервер появится новое устройство. Соедините появившееся устройство с окном видео клиента и нажмите кнопку "Ок" для применения настроек.

В создавшемся окне Вы должны увидеть состояние раздела РРОП и можете управлять постановкой/снятием данного раздела с охраны.

В верхней части окна находится историю состояний текущего раздела. Размер поля истории можно изменить. В нижней части окна находится выпадающий список действий с текущим разделом. Вы можете выбрать снятие с охраны раздела, постановку на охрану или сброс тревог. Для подтверждения выбранной задачи необходимо сделать двойной щелчок левой кнопкой мыши по пиктограмме в центре окна.

При наступлении тревоги вокруг окна будет мигать красная рамка.

Расшифровка ошибок

· Неверный код доступа - неверный код доступа, по умолчанию - 0x11112222

·Не удается открыть COM порт - неверно указан COM порт

·Ошибка чтения-записи - устройства выключены

·Неизвестное состояние - состояние, при котором система опросила COM порт, сверила код, но не получила от Стрельца состояние раздела


ОПС "Болид"

Navigation: Интеграция с системами ОПС >

ОПС "Болид"

Необходимые компоненты

Минимальный набор компонентов GOALcity для работы с ОПС "Болид" это:

· Мультимедиа сервер (2_IP_Server_x64.exe),

· Клиент GOALcity (1_GOALcity_Client_x64.exe),

· SLDA драйвер для GOALcity (9_SLDA_Driver.exe),

· Архивный сервер (3_Archive_Server_x64.exe).

· "Модуль управления ИСО Орион";

·Пульт С2000М производства фирмы "Болид" и адресные датчики (ключи, считыватели).

Установка и первоначальная настройка программного обеспечения

Начните с установки компонентов GOALcity. Установите Мультимедиа сервер, SLDA драйвер, затем Клиент GOALcity и перезагрузите ПК.

После перезагрузки установите "Ядро опроса Орион Про" и снова перезагрузите ПК. Процесс установки всех вышеперечисленных компонентов довольно прост - просто следуйте подсказкам мастера установки.

Важно! "Ядро опроса Орион Про" может быть установлено и на другой ПК, который, в данном случае, будет выступать в качестве сервера ОПС "Болид".

Когда компьютер загрузиться, запустите клиентскую часть GOALcity и выполните следующие действия:

·Откройте Диаграмму подключений GOALcity и добавьте на неё все установленные ранее компоненты.

· Создайте архив на Архивном сервере GOALcity.

Создание датчика (ключа, считывателя) для ОПС Болид

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке button-01 напротив пункта "SLDASource" и выберите строчку "Редактировать".

Кликните по кнопке button-01 справа от пункта "Датчики и ключи", перед Вами откроется список всего доступного для подключения оборудования. Выберите источник "Добавить Болид".

·"Название" - укажите произвольное название будущего датчика (считывателя, ключа);

Важно! При установке "Ядра опроса Орион Про" Мастер установки не предлагает менять какие либо настройки и все порты, логины и пароли – остаются стандартными для программного обеспечения ОПС Болид. Все данные о логинах-паролях, портах подключения и т.д. хранятся в реестре Windows по пути HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\BOLID\ORION_PRO\ORICORE для 64-х разрядной системы Windows, либо по пути HKEY_LOCAL_MACHINE\SOFTWARE\BOLID\ORION_PRO\ORICORE для 32-ух разрядной системы. При желании изменить эти параметры можно там же.

·"Адрес" - укажите сетевой адрес компьютера, на котором установлено "Ядро опроса Орион Про" и к которому подключен пульт С2000М. Если все сделано на базе одного ПК, то укажите локальный адрес (127.0.0.1), если же на другом ПК - соответственно адрес этого ПК. Адрес обязательно нужно указывать вместе с портом подключения! По умолчанию это порт 8080 (ключ "XMLIPPORT" в реестре);

·"Пользователь" - по умолчанию ADMINISTRATOR (ключ "LOGIN" в реестре);

·"Пароль" - по умолчанию ORION (ключ "Password" в реестре);

·"Тип" - выберите тип подключаемого устройства (охранно-пожарный датчик, ключ или считыватель);

·"СОМ порт" - номер СОМ порта, по которому подключен пульт С2000М к ПК;

·"Адрес RS-485" - укажите адрес контроллеров типа Сигнал 20М, КДЛ и т.п. Адрес самого пульта не вписывается не при каких обстоятельствах.

·"Номер" - укажите номер шлейфа (если используются аналоговые датчики) либо адрес датчика, в том случае, если датчик адресный и подключен к КДЛ.

·"Добавлять код состояния" - если Вы отметите данную опцию, то ко всем состояния датчика в окне будет добавляться его код.

Нажмите кнопку "Ок" и сохраните изменения. Теперь на Диаграмме подключений в "Мультимедиа сервере" Вы увидите созданный датчик. Подключите его к окну GOALcity.

Примеры подключений

В этом примере сервер GOALcity обменивается данными с пультом С2000М. К пульту подключен адресный контроллер двухпроводной линии (1), а к контроллеру, в свою очередь, подключены адресный извещатель "ДИП-34А" (6) и адресный пожарный извещатель (7).

Также к пульту С2000М подключен приемно-контрольный прибор Сигнал 20М (2). К Сигналу 20М (2), в свою очередь, подключены 3 безадресных датчика (3-5).

Важно! Все адреса устройств даны для примера. Для того чтобы назначить вашим устройствам нужные вам адреса, пожалуйста, обратитесь к документации по данным устройствам.

Соответственно, чтобы подключить к GOALcity, например, адресный извещатель (7), настройки должны выглядеть так:

Адрес | 192.168.10.158:8080
Пользователь | ADMINISTRATOR
Пароль | ORION
Тип | Охранно-пожарный датчик
СОМ Порт | 1
Адрес RS-485 | 1
Номер | 7

Так как извещатель адресный и подключается к контроллеру двухпроводной линии, то в строку "Адрес RS-485" нужно вводить адрес контроллера двухпроводной линии (1), а в строку "Номер" – адрес датчика, подключенного к этому контроллеру.

Если нужно подключить один из безадресных датчиков, например (4), то настройки будут выглядеть немного иначе:

Адрес | 192.168.10.158:8080
Пользователь | ADMINISTRATOR
Пароль | ORION
Тип | Охранно-пожарный датчик
СОМ Порт | 1
Адрес RS-485 | 2
Номер | 4

При таком типе подключения данные "забираются" с четвертого раздела приемно-контрольного прибора Сигнал 20М (2).

Настройка "Модуля управления ИСО Орион"

Запустите программу "Модуль управления ИСО Орион" из меню "Пуск" или сделав двойной клик по ярлыку на рабочем столе.

Важно! При работе GOALcity совместно с ОПС "Болид" данный модуль должен быть всегда включен.

Откроется окно настроек модуля управления. Раскройте "дерево устройств", выберите поле "Последовательные порты" и справа выберите тот, к которому подключен пульт С2000М.

Переместитесь на следующую строчку. Включите опрос СОМ порта, поставив "птичку" напротив "Порт активен".

Выберите устройство С2000М и настройте способ соединения с ПК и тип опроса.

·"Тип ПИ" - если пульт С2000М подключен напрямую к COM порту, то выберите "С2000М". Если же используется преобразователь интерфейса "RS232 to USB", то выберите "ПИ".

·"Опрос" - если пульт переключен в режим "Компьютер", то выберите "ПКУ обмен с приборами". Если же пульт в режиме "ПИ/РЕЗЕРВ" - выберите "Обмен с приборами".

Процесс настройки на этом можно считать законченным. В окне GOALcity Вы должны увидеть примерно следующую картину:


ОПС "Багульник"

Navigation: Интеграция с системами ОПС >

ОПС "Багульник"

Общее описание

ОПС "Багульник" это очередная система, интегрированная в GOALcity. Интеграция позволяет задействовать датчики и ключи, используемые аппаратными контроллерами "Багульника" и вывести их в интерфейсе GOALcity для дальнейшего программирования событий и действий.

Датчики подключаются через источник DeviceSource Мультимедиа сервера GOALcity.

Создание датчика

Откройте настройки "Мультимедиа сервера", кликните левой кнопкой мыши по кнопке

напротив пункта "DeviceSource" и выберите строчку "Редактировать".

Кликните по кнопке button-01 справа от пункта "Датчики и Ключи", перед Вами откроется список всех доступных для создания устройств.

Выберите пункт "Добавить Багульник".

·"Имя" - укажите имя создаваемого устройства;

·"Хост" - укажите IP адрес ПК, на котором установлено "родное" программное обеспечение ОПС "Багульник";

·"Порт" - укажите порт подключения к "Багульнику", по умолчанию 7998;

·"Имя сегмента" - в данном поле указывается название участка из "родного" ПО "Багульника". У Выходов его можно скопировать из свойств, в которые можно попасть кликнув колесиком на нужном сегменте.

·"Тип сегмента" - параметр "Устройство" обозначает непосредственно само устройство (контроллер) Багульника к которому подключаются шлейфы и реле, "Вход" - охранный шлейф, "Выход" - Исполнительное реле.

Нажмите кнопку "Ок" и сохраните изменения. Теперь на Диаграмме подключений в "Мультимедиа сервере" Вы увидите созданный виртуальный ключ. Подключите его к окну GOALcity.